Problem on jomla 1.5 with mootools 1.2 and modal.js

This forum is for reporting bugs in Joomla!. Please don't report problems with extensions in here.
Forum rules
Forum Rules
Forum Post Assistant - If you are serious about wanting help, you will use this tool to help you post.
sbruhat
Joomla! Fledgling
Joomla! Fledgling
Posts: 1
Joined: Wed Sep 28, 2011 11:18 am

Problem on jomla 1.5 with mootools 1.2 and modal.js

Postby sbruhat » Wed Sep 28, 2011 11:27 am

Hi,
a few months ago, I upgraded mootools with the extension : mtupgrade.
So i'm now using mootools 1.2 on my frontend.
The issue is that I can't use modal popups (JHTML::_('behavior.modal'); ).

here is my code :
<?php
defined("_JEXEC") or die("Restricted area");
JHTML::_('behavior.modal');
?>
<a href="index.php?option=com_popup&controller=popup" class="modal" target="_blank" rel="{handler: 'iframe', size: {x: 680, y: 370}}" >TEST POPUP</a>

here is the error :
Class is not defined onOpen: Class.empty,modal.js (ligne 32)

it seems that the modal.js is not compatible with the mootools 1.2

Does anyone already encountered this issue ?

Thank you

Return to “Joomla! 1.5 Bug Reporting”

Who is online

Users browsing this forum: No registered users and 9 guests