The Joomla! Forum ™



Forum rules


Forum Rules
Absolute Beginner's Guide to Joomla! <-- please read before posting, this means YOU.
Forum Post Assistant - If you are serious about wanting help, you will use this tool to help you post.



Post new topic Reply to topic  [ 17 posts ] 
Author Message
PostPosted: Mon Feb 25, 2008 1:24 pm 
User avatar
Joomla! Guru
Joomla! Guru

Joined: Wed Feb 20, 2008 6:50 am
Posts: 632
Location: Canada, Montreal
I try everything.
• Change permissions
• Create a new params.ini (true or false/ if the params.ini is blank, the prefererence of the used template will be written to the file)
• When I change the permission to all files in the Joomla folder it work until I make a change in the template editor to revert to unwritable.
• if I change the permission only to the param.ini file it don’t work, meaning that’s another file that have is permission change, but what files????
ª What other file params.ini is related to?
• In Safari, when param.ini is unwritable no change possible in the template editor but in Firefox, even if unwritable, change occurs.

I can see that this problem is widespread to Joomla user...
Anybody with a final clear fix to a serious drawback of Joomla usability?????

_________________
Can God help us!
Marketing, SEO, Web development - Powered by Joomla!
http://www.grafcomm.ca/


Top
 Profile  
 
PostPosted: Mon Feb 25, 2008 1:56 pm 
Joomla! Enthusiast
Joomla! Enthusiast

Joined: Wed Feb 20, 2008 8:59 am
Posts: 234
Chacapamac wrote:
I can see that this problem is widespread to Joomla user...
Anybody with a final clear fix to a serious drawback of Joomla usability?????

Yes. Simple solution: Don't care!
"Params.ini unwritable" (in RED) is the "everything is ok situation!
viewtopic.php?f=431&t=267250

ONLY if you press "apply" and there is a "real" error message (like write failed, or whatever) you have a problem (wrong folder permisson?). As long as the setup screen of the template simply says, "unwritable" everything is GREEN ... though it's RED.

Let's all vote for the 1.5.2 release: pls make the message ... GREEN ;)


Top
 Profile  
 
PostPosted: Mon Apr 28, 2008 10:03 pm 
Joomla! Enthusiast
Joomla! Enthusiast

Joined: Mon May 29, 2006 7:11 am
Posts: 108
Hi guys,

Does anybody know if this was fixed in 1.5.3?


Top
 Profile  
 
PostPosted: Mon Jun 30, 2008 11:02 pm 
Joomla! Fledgling
Joomla! Fledgling

Joined: Mon Jun 30, 2008 2:18 am
Posts: 4
Location: Kumeu, New Zealand.
Doesn't seem to have been fixed because I am running 1.5.3 and it is happening to me. And when I try to change the 555 write permission it won't let me. But having read the replies, I'll now go ahead and see what happens when I press "apply". I have tried it with "save" which doesn't work for me.
My hosting support says that it is because I used the "install" function to upload the zip packaged Epic template which had the effect of making the user into "nobody" and that you cannot use this function to upload templates in 1.5.3.
That is the only way Epic can be installed so I'll have to see.

_________________
If a thing's worth doing, it's worth having a go at.


Top
 Profile  
 
PostPosted: Tue Jul 01, 2008 3:07 pm 
Joomla! Apprentice
Joomla! Apprentice

Joined: Sat Jun 28, 2008 10:14 am
Posts: 37
I just have encountered this error in 1.5.3.

Is there now an available fix for this?


Top
 Profile  
 
PostPosted: Wed Jul 02, 2008 12:16 am 
Joomla! Fledgling
Joomla! Fledgling

Joined: Mon Jun 30, 2008 2:18 am
Posts: 4
Location: Kumeu, New Zealand.
I may be getting close to an answer to this one.
According to other forums, it has a lot to do with the setup of the FTP layer in Joomla 1.5.
I have found a video on setting up the layer by a fellow called Alex West at
http://video.google.com/videoplay?docid ... la+hosting
The FTP opening directory in configuration.php MUST be set to the directory where Joomla is located.
You may be able to do this through the Joomla admin panel but if you get error messages must go to the file through Cpanel.
In my case, configuration.php is set at 644 and I have asked my hosting company to change it so that it is writable.
I will keep you up to date with the results.

_________________
If a thing's worth doing, it's worth having a go at.


Top
 Profile  
 
PostPosted: Wed Jul 02, 2008 3:21 am 
Joomla! Apprentice
Joomla! Apprentice

Joined: Sat Jun 28, 2008 10:14 am
Posts: 37
Thanks judy2...

Will wait for your update...


Top
 Profile  
 
PostPosted: Tue Nov 04, 2008 2:33 am 
Joomla! Fledgling
Joomla! Fledgling

Joined: Wed Dec 26, 2007 6:04 pm
Posts: 4
Judy2

It is ages since you posted, so this may not be relvant anymore. I followed your link to the tutorial and it worked.

I had had the same related issue with the permissions not wanting to change and I fixed that too with a work-around using joomlaXplorer.

Here is the link for my post
viewtopic.php?f=469&t=232568&p=1470325#p1470325

Craig
P.S.
My version at time of writing is 1.5.6


Top
 Profile  
 
PostPosted: Fri Nov 07, 2008 8:53 pm 
Joomla! Intern
Joomla! Intern

Joined: Tue Oct 28, 2008 4:20 pm
Posts: 61
I too had the same problem.

In the template parameters it would state that params.ini is unwritable.
When I downloaded the file via Dreamweaver, I was unable to upload it back with a report of unable to upload file.

MY FIX

I log in to cPanel, visit File Manager and navigate to the location of my params.ini, in the root of my chosen template. Simply changed Permissions as write was not set. The Write option was not set, so changed permissions to 0755.
It worked!!!
params.ini is now writable

I use the following:
Joomla 1.5.7
cPanel X (SiteBuilder.com)
Dreamweaver CS3

Hope this helps someone.

Simon


Top
 Profile  
 
PostPosted: Mon Feb 23, 2009 3:11 am 
Joomla! Fledgling
Joomla! Fledgling

Joined: Mon Feb 23, 2009 2:58 am
Posts: 1
I had the same problem.

After looking around for a "conventional" solution, I've just changed the owner of the file, so no process can change the permissions anymore.

If you're a Mac OS user, you have to activate root user first (Finder->Go->Utilities->Directory Utility then activate root user in the menu)

0. Open Terminal. (for Mac OS users : Finder -> Go -> Utilities -> Terminal)
1. su
(enter root password)
2. cd path_to_your_site/templates/your_template
3 chown nobody params.ini
4. chmod 777 params.ini
5. exit



Done !


Top
 Profile  
 
PostPosted: Wed May 20, 2009 4:03 pm 
Joomla! Fledgling
Joomla! Fledgling

Joined: Tue May 19, 2009 10:48 pm
Posts: 1
SIMON FIXED MY PROBLEM!!!

YAY! hallelujah! WooHoo!!! Friggen finally!

Thanks Simon!
Jamie :eek: :D


Top
 Profile  
 
PostPosted: Wed Nov 11, 2009 9:41 am 
Joomla! Fledgling
Joomla! Fledgling

Joined: Tue Nov 10, 2009 7:07 pm
Posts: 3
alexeipolozov wrote:
I had the same problem.

After looking around for a "conventional" solution, I've just changed the owner of the file, so no process can change the permissions anymore.

If you're a Mac OS user, you have to activate root user first (Finder->Go->Utilities->Directory Utility then activate root user in the menu)

0. Open Terminal. (for Mac OS users : Finder -> Go -> Utilities -> Terminal)
1. su
(enter root password)
2. cd path_to_your_site/templates/your_template
3 chown nobody params.ini
4. chmod 777 params.ini
5. exit

Done !


After hours of struggling (Joomla newbie) this brought the solution! Thanks a lot. Hope that Joomla does not have more of these stupid issues in mind for me!!
Worst of all: there are soooooooo many posts on this topic, why does not address Joomla this in a clear way and avoid all the frustation with their users?


Top
 Profile  
 
PostPosted: Fri Apr 23, 2010 11:02 am 
Joomla! Fledgling
Joomla! Fledgling

Joined: Fri Apr 23, 2010 10:51 am
Posts: 2
A quick fix to this problem is to use FileZilla. Locate configuration.php, right-click on properties, change value to 777. Do the same for template.css or any other file you want to make writable.


Top
 Profile  
 
PostPosted: Tue May 25, 2010 6:50 pm 
Joomla! Apprentice
Joomla! Apprentice

Joined: Mon Feb 15, 2010 4:34 pm
Posts: 14
Does changing the owner really work? I'm tired of changing permissions over and over. How does one do that?


Top
 Profile  
 
PostPosted: Wed Mar 30, 2011 6:05 pm 
User avatar
Joomla! Hero
Joomla! Hero

Joined: Fri Sep 22, 2006 6:21 pm
Posts: 2511
Location: Orlando, FL
Changing the files permissions is a quick fix but it appears the controller.php file in Joomla is the cause. It changes the permissions to 555 when you save template changes from the back-end. Not sure why Joomla would do this... perhaps to lock the file down from future edits as a security measure.

If you don't want this to keep happening change all instances of 0555 to 0644 within the file at /administrator/components/com_templates/controller.php

Also if the ownership of the file is user "nobody" then this means your hosting provider is not using suPHP. I'd suggest transferring to a host that does. Using suPHP keeps all of your files owned by your default user on the site.

_________________
CPanel Web Hosting Services http://interactiveonline.com/shared-web-hosting
Follow us on Twitter @interactiveo


Top
 Profile  
 
PostPosted: Mon Apr 11, 2011 11:38 pm 
Joomla! Intern
Joomla! Intern

Joined: Mon Nov 01, 2010 9:23 pm
Posts: 60
Help???

Why is this so complicated? Why is there not a simple way of setting the write permissions to the best recommended fit for administering Joomla? I have been working on a few templates recently and over the duration of each project, the write options within the templates section of the back end change to unwriteable as I work through customising the template. Why is this? Can anyone shed some light on this?

Alex


Top
 Profile  
 
PostPosted: Mon Apr 11, 2011 11:54 pm 
User avatar
Joomla! Master
Joomla! Master

Joined: Sat Apr 05, 2008 9:58 pm
Posts: 25005
Location: @Webdongle
Joomla deletes the file and saves it chmod 555
Nothing can write to a file 555 that's why after the first save it shows unwriteable.
But that does not bother Joomla because the file Owner can delete a file whatever the permissions.

So long as Joomla has Ownership of the files it can still save because it does not save to the file. It deletes it then saves with a file of the same name. If at a later time you wish to edit the file with an editor then chmod it 644 and you can edit it.

_________________
'When I'm right nobody remembers when I'm wrong nobody forgets.'

http://weblinksonline.co.uk/joomla-faq.html


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 17 posts ] 



Who is online

Users browsing this forum: No registered users and 29 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Jump to:  
Powered by phpBB® Forum Software © phpBB Group