WAMP-MySQL-Joomla database connect problem

Need help installing Joomla! 1.5? For all Joomla! 1.5 installation issues please use this forum.

Moderator: General Support Moderators

Forum rules
Forum Rules
Absolute Beginner's Guide to Joomla! <-- please read before posting, this means YOU.
Forum Post Assistant - If you are serious about wanting help, you will use this tool to help you post.
jumla15_guy
Joomla! Apprentice
Joomla! Apprentice
Posts: 36
Joined: Thu Sep 25, 2008 9:26 pm

WAMP-MySQL-Joomla database connect problem

Postby jumla15_guy » Fri Sep 26, 2008 12:29 am

Hi

This started with trying Joomla 1.5.7(a newbie). I followed a Lynda.com tutorial which used WampServer. Changed privileges in PhpMyAdmin and config.inc.php and off I went. I LOVE JOOMLA! Reminds me of the StoresOnline interface but vastly superior!!

After finishing the tutorial I deleted that installation and copied over a fresh Joomla install package to start my test site. Did everything the same but Joomla would not connect to the database.
So here is my pre-install setup:

Release version.............: 1.5.7
Localhost....................: WAMPSERVER 2c
System Information.......: PHP Version 5.2.6
.................................Apache/2.2.8 (Win32)
.................................MySQL 5.0.51a
My OS........................: Windows XP SP2 build 2600
PhpMyAdmin privileges...: localhost username = root
................................: localhost password = iforgot
config.inc.php..............: $cfg['Servers'][$i]['password'] = 'iforgot';

Reading the 1.5 Installation Manual for Joomla I see it says "Warning! By default the standard installation of MySQL does not use a password - it is blank. This will not be accepted by Joomla! and it is not a particularly wise security habit to get into in any case. You should ensure that you have set a password up within the my.ini file which is the configuration file of MySQL."

When I look at the my.ini file in the MySQL folder of WAMP there is no text whatsover as referring to a password?
So I opened 'my.ini' and inserted the line "password=iforgot" in the client section.
I can access the database, named 'joomla150' through the MySQL console. But when I reach the Joomla installation 'Database Configuration' screen and set:

Database Type
'mysql'

Host Name
'localhost'

Username
'root'

Password
'iforgot'

Database Name
'joomla150'

Pressing Next gets me:

An error has occurred.: Unable to connect to the database:Could not connect to MySQL.

I searched through the forum but couldn't find a solution that has resolved my problem.

Thanks, help would really be appreciated.
Last edited by jumla15_guy on Sat Sep 27, 2008 5:37 pm, edited 1 time in total.

User avatar
brad
Joomla! Master
Joomla! Master
Posts: 13408
Joined: Fri Aug 12, 2005 12:38 am
Location: Sydney - Australia
Contact:

Re: WAMP-MySQL-Joomla database connect problem

Postby brad » Fri Sep 26, 2008 12:31 am

Brad Baker
http://www.rochen.com - Joomla! Hosting, the correct way.
https://www.joomlatutorials.com <-- Joomla Help & Tutorials
^Now with Joomla 2.5 and Joomla 3.0 Tutorials

jumla15_guy
Joomla! Apprentice
Joomla! Apprentice
Posts: 36
Joined: Thu Sep 25, 2008 9:26 pm

Re: WAMP-MySQL-Joomla database connect problem

Postby jumla15_guy » Fri Sep 26, 2008 12:37 am

brad wrote:http://docs.joomla.org/Beginners


Yes I've tried that, thats where I found Andy Wallaces Installation Manual which I adhered to during this unsuccessful installation. Trying the blank password in PhpMyAdmin and config.inc.php, as in the Quick Guide got me the same error message.

Thanks for the prompt response though.

User avatar
linuxwild
Joomla! Apprentice
Joomla! Apprentice
Posts: 38
Joined: Sat Sep 23, 2006 1:45 pm
Location: Nairobi, Kenya

Re: WAMP-MySQL-Joomla database connect problem

Postby linuxwild » Fri Sep 26, 2008 2:52 pm

I've tried using the Joomla 1.5 installation manual to install Joomla 1.5 on my computer
and the only problem is I'm having a problem with the mysql password field. I'm using the Wamp5 server on windows XP. I can create the database but what do i fill in for the mysql password since when I installed the Wamp5 server I wasn't asked to input any password for the mysql database. I understand the username is root but what about the password. In Wamp5 the password is blank but if I leave the field blank while trying to install Joomla i get a Mysql error. Could someone who has installed Joomla on Windows using Wamp5 please assist me on the fields because I can't get past that. I'd greatly appreciate.
"Success is not the measure of a man but a triumph over those who choose to hold him back". -Bill Clinton

jumla15_guy
Joomla! Apprentice
Joomla! Apprentice
Posts: 36
Joined: Thu Sep 25, 2008 9:26 pm

Re: WAMP-MySQL-Joomla database connect problem

Postby jumla15_guy » Sat Sep 27, 2008 2:43 am

Well I got it working??????? Don't know how - one of those mysteries of life ???

Removed WampServer 2c, then reinstalled it. Once started went to PhpMyAdmin - then Privileges - made sure root/localhost user had no password set - copied this user to user 'admin' (just for the heck of it) again no password and saved.

Extracted my 1.5.7 into a subdirectory of Wamps 'www' folder. Restarted Wamps and on homepage selected my project - this started the installation - at the dreaded Step 4 I put in [MySql] [localhost] [admin] [no password] [database.name] and away it went. 2 days later and not a clue to what I did.

Anyway thanks for the help guys ;) (though I never did get that JTS post assistant PHP script to work :( )

dhuumketu
Joomla! Fledgling
Joomla! Fledgling
Posts: 2
Joined: Sat Sep 27, 2008 2:07 pm

Re: WAMP-MySQL-Joomla database connect problem

Postby dhuumketu » Sat Sep 27, 2008 2:29 pm

brad wrote:http://docs.joomla.org/Beginners


nice reply, for a single question u gave us the whole book :D
. A lot of confusions here about the database connection error, and no one tells the ....

nice forum :D


Return to “Installation 1.5”

Who is online

Users browsing this forum: No registered users and 10 guests