The Joomla! Forum ™



Forum rules


Forum Rules
Absolute Beginner's Guide to Joomla! <-- please read before posting, this means YOU.
Forum Post Assistant - If you are serious about wanting help, you will use this tool to help you post.



Post new topic Reply to topic  [ 6 posts ] 
Author Message
PostPosted: Sat Jan 03, 2009 2:16 am 
User avatar
Joomla! Guru
Joomla! Guru

Joined: Fri Nov 10, 2006 7:05 pm
Posts: 572
Location: Detroit, Michigan, USA
Parse error: syntax error, unexpected T_STRING in /home/jeffp/public_html/bigo/configuration.php on line 1

This is the first couple of lines.. what would cause this ?

Code:
<?phpclass JConfig {/* Site Settings */var $offline = '0';var $offline_message = 'This site is down for maintenance.<br /> Please check back again soon.';var $sitename = 'test';var $editor = 'tinymce';var $list_limit = '20';var $legacy = '0';/* Debug Settings */var $debug = '0';var $debug_lang = '0';/* Database Settings */var $dbtype = 'mysql';var $host = 'localhost';


Top
 Profile  
 
PostPosted: Sat Jan 03, 2009 3:24 am 
User avatar
Joomla! Master
Joomla! Master
Online

Joined: Sun Oct 02, 2005 12:50 am
Posts: 17643
Location: Omaha, NE
start here:
Code:
<?phpclass

_________________
Regards, Dave
http://www.kiwaniswest.org


Top
 Profile  
 
PostPosted: Sat Jan 03, 2009 6:28 am 
User avatar
Joomla! Guru
Joomla! Guru

Joined: Fri Nov 10, 2006 7:05 pm
Posts: 572
Location: Detroit, Michigan, USA
start there with what ?


Top
 Profile  
 
PostPosted: Sat Jan 03, 2009 3:02 pm 
User avatar
Joomla! Master
Joomla! Master
Online

Joined: Sun Oct 02, 2005 12:50 am
Posts: 17643
Location: Omaha, NE
pmcnamara wrote:
start there with what ?


If you presented the file as it looks to you then there is no such operative in php as
Code:
<?phpclass
instead, it should look like the following:
Code:
<?php
class JConfig {
   var $offline = '0';
   var $editor = 'none';
   var $list_limit = '50';

Otherwise, try to use an editor that can present the file with the linefeeds.

_________________
Regards, Dave
http://www.kiwaniswest.org


Top
 Profile  
 
PostPosted: Sat Jan 03, 2009 4:12 pm 
User avatar
Joomla! Guru
Joomla! Guru

Joined: Fri Nov 10, 2006 7:05 pm
Posts: 572
Location: Detroit, Michigan, USA
That was embarrassing on my part.. I missed a simple space.

Thank you.. I'm going to crawl back under my rock now.


Top
 Profile  
 
PostPosted: Mon Aug 19, 2013 10:41 am 
Joomla! Apprentice
Joomla! Apprentice

Joined: Fri May 28, 2010 7:44 am
Posts: 8
Hi,
I know that this is old topic but I take my chances. I get the same error when transferring site to the production server:
Parse error: syntax error, unexpected T_STRING in /public_html/configuration.php on line 1
As I can see there is no error in line 1.
Code:
<?php
class JConfig {
   public $offline = '1';
   public $offline_message = '';
   public $display_offline_message = '1';
   public $offline_image = '';


Any advice what could cose this error. :(
Regards
David


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 6 posts ] 



Who is online

Users browsing this forum: No registered users and 16 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Jump to:  
Powered by phpBB® Forum Software © phpBB Group