PHP Warning: Parameter 3 to mb_videobot()

Need help with the Administration of your Joomla! 1.5 site? This is the spot for you.

Moderator: General Support Moderators

Forum rules
Forum Rules
Absolute Beginner's Guide to Joomla! <-- please read before posting, this means YOU.
Forum Post Assistant - If you are serious about wanting help, you will use this tool to help you post.
jamalqc
Joomla! Apprentice
Joomla! Apprentice
Posts: 14
Joined: Thu Feb 18, 2010 6:21 am

PHP Warning: Parameter 3 to mb_videobot()

Postby jamalqc » Wed Mar 24, 2010 2:03 am

Hi,

I Changed the host, and on my log i see the warning :
PHP Warning: Parameter 3 to mb_videobot() expected to be a reference, value given in /home/user1/public_html/libraries/joomla/event/dispatcher.php on line 136

Thankyou

cesarel
Joomla! Fledgling
Joomla! Fledgling
Posts: 1
Joined: Thu Apr 01, 2010 3:51 am

Re: PHP Warning: Parameter 3 to mb_videobot()

Postby cesarel » Thu Apr 01, 2010 3:53 am

Warning: Parameter 3 to mb_videobot() expected to be a reference, value given in /home/MYSITE/public_html/libraries/joomla/event/dispatcher.php on line 136

Having same problem, did you fixed it? anybody? ... please :)

if you have the solution please pm ;)

ayursuman
Joomla! Apprentice
Joomla! Apprentice
Posts: 5
Joined: Fri Dec 04, 2009 11:20 am

Re: PHP Warning: Parameter 3 to mb_videobot()

Postby ayursuman » Thu Apr 22, 2010 12:37 am

i had the similar problem of such errror message after changing the hosting of my website
its great trouble some for me due to such error

please anyone write teh solution for this

waiting the support from jooomla experts

KVS
Joomla! Fledgling
Joomla! Fledgling
Posts: 2
Joined: Sun Nov 30, 2008 11:00 pm

Re: PHP Warning: Parameter 3 to mb_videobot()

Postby KVS » Tue Jun 08, 2010 9:45 pm

Hi all, this is my first post here, and I really hope for some help from you, thanks...

I have the same problem as mentioned above. I've googled the problem and from what I can see this is a problem all over on many Joomla! sites.

My error reads;
Warning: Parameter 3 to mb_videobot() expected to be a reference, value given in /home/myroooxa/public_html/libraries/joomla/event/dispatcher.php on line 136

You'll find it on http://www.myroots.no/index.php?option= ... 1&Itemid=2
It's in norwegian, but you will maybe be able to see the problem anyway

I'm running Joomla! 1.5.18, fresh install

KVS
Joomla! Fledgling
Joomla! Fledgling
Posts: 2
Joined: Sun Nov 30, 2008 11:00 pm

Re: PHP Warning: Parameter 3 to mb_videobot()

Postby KVS » Thu Jun 10, 2010 6:39 pm

Ah, finally, found the solution.

There's a plugin that comes with either Jom Social of My Blog called Azrul Video Mambot ver 0.1. Just unpublish this plugin and the error should disappear.

roncse29
Joomla! Fledgling
Joomla! Fledgling
Posts: 3
Joined: Thu Oct 22, 2009 7:54 am

Re: PHP Warning: Parameter 3 to mb_videobot()

Postby roncse29 » Tue Mar 01, 2011 9:32 am

KVS wrote:Ah, finally, found the solution.

There's a plugin that comes with either Jom Social of My Blog called Azrul Video Mambot ver 0.1. Just unpublish this plugin and the error should disappear.


Yes. This is the cause of the problem. But what is the solution?

But, I need the plugin, working on my site. Then, what can I do? How can I solve the problem? Please, anyone help me... :'(

stavroch
Joomla! Intern
Joomla! Intern
Posts: 68
Joined: Wed Feb 15, 2006 10:23 pm

Re: PHP Warning: Parameter 3 to mb_videobot()

Postby stavroch » Fri May 13, 2011 2:22 pm

Any solution of this error?

sumanguj
Joomla! Enthusiast
Joomla! Enthusiast
Posts: 106
Joined: Mon Feb 22, 2010 12:35 pm

Re: PHP Warning: Parameter 3 to mb_videobot()

Postby sumanguj » Sat Jun 11, 2011 6:17 pm

i unpublished that azrul plugin and it worked. thanx

diverso
Joomla! Enthusiast
Joomla! Enthusiast
Posts: 105
Joined: Tue Jun 14, 2011 3:40 pm
Contact:

Re: PHP Warning: Parameter 3 to mb_videobot()

Postby diverso » Mon Nov 07, 2011 1:19 pm

roncse29 wrote:
KVS wrote:Ah, finally, found the solution.

There's a plugin that comes with either Jom Social of My Blog called Azrul Video Mambot ver 0.1. Just unpublish this plugin and the error should disappear.


Yes. This is the cause of the problem. But what is the solution?

But, I need the plugin, working on my site. Then, what can I do? How can I solve the problem? Please, anyone help me... :'(




Hi,

having same issue here, any solutions to this? I'd really need the plug in to work I want my users to be able to upload videos..

massivescale
Joomla! Apprentice
Joomla! Apprentice
Posts: 31
Joined: Wed Jul 13, 2011 10:15 pm
Contact:

Re: PHP Warning: Parameter 3 to mb_videobot()

Postby massivescale » Mon Mar 12, 2012 2:08 pm

Edit plugins/content/azvideobot.php

Change line 8 from
function mb_videobot($published, & $row, & $params, $page=0 ){

to

function mb_videobot($published, & $row, $params, $page=0 ){

(remove ampersand before $params)

Hope it helps. Also, likely there's an update from Azrul, check it out.
http://massivescale.net/ - website performance optimization
http://twitter.com/massivescale

ThePiston
Joomla! Guru
Joomla! Guru
Posts: 623
Joined: Mon Nov 07, 2005 3:45 am
Contact:

Re: PHP Warning: Parameter 3 to mb_videobot()

Postby ThePiston » Wed Apr 25, 2012 4:15 pm

had to disable the plugin in Joomla plugins, not just myblog plugins. I emailed this page to Azrul support

stevebower
Joomla! Apprentice
Joomla! Apprentice
Posts: 36
Joined: Thu May 03, 2012 3:35 pm

Re: PHP Warning: Parameter 3 to mb_videobot()

Postby stevebower » Sun Jul 29, 2012 5:13 pm

I get this too, moving sites from Windows to Linux hosting. I don't have the Azrul plugin though!

kenvac
Joomla! Fledgling
Joomla! Fledgling
Posts: 1
Joined: Wed May 02, 2012 8:43 am

Re: PHP Warning: Parameter 3 to mb_videobot()

Postby kenvac » Sun Aug 05, 2012 12:15 pm

massivescale wrote:Edit plugins/content/azvideobot.php

Change line 8 from
function mb_videobot($published, & $row, & $params, $page=0 ){

to

function mb_videobot($published, & $row, $params, $page=0 ){

(remove ampersand before $params)

Hope it helps. Also, likely there's an update from Azrul, check it out.


It worked for me.. Thanks Dude. Appreciated 8)

User avatar
dlm
Joomla! Enthusiast
Joomla! Enthusiast
Posts: 164
Joined: Wed Mar 26, 2008 7:56 pm
Location: Twin Bridges, Montana
Contact:

Re: PHP Warning: Parameter 3 to mb_videobot()

Postby dlm » Thu Sep 13, 2012 9:45 pm

Changing line 8 worked for me too!! Thanks massivescale!

ironlion37
Joomla! Apprentice
Joomla! Apprentice
Posts: 37
Joined: Sun Nov 30, 2008 9:22 pm

Re: PHP Warning: Parameter 3 to mb_videobot()

Postby ironlion37 » Fri Jan 11, 2013 10:19 pm

KVS wrote:Ah, finally, found the solution.

There's a plugin that comes with either Jom Social of My Blog called Azrul Video Mambot ver 0.1. Just unpublish this plugin and the error should disappear.


THANK YOU!!! :D


Return to “Administration 1.5”

Who is online

Users browsing this forum: No registered users and 17 guests