Illegal variable _files or _env or _get or _post or _cookie

Discussion regarding Joomla! 1.5 Performance issues.

Moderator: General Support Moderators

Forum rules
Forum Rules
Absolute Beginner's Guide to Joomla! <-- please read before posting, this means YOU.
Security and Performance FAQs
Forum Post Assistant - If you are serious about wanting help, you will use this tool to help you post.
hungreemon
Joomla! Apprentice
Joomla! Apprentice
Posts: 16
Joined: Fri Mar 12, 2010 5:43 pm

Illegal variable _files or _env or _get or _post or _cookie

Postby hungreemon » Wed Nov 17, 2010 9:33 pm

I've been working on this site for a few days now. Suddenly I keep getting the following error:

Illegal variable _files or _env or _get or _post or _cookie or _server or _session or globals passed to script.

I did install JConnect to deal with Facebook connect integration but it does seem to work and produces this error everytime I try to use it. Any ideas? Any Facebook connect solutions that work for Joomla?

HiRavi
Joomla! Fledgling
Joomla! Fledgling
Posts: 1
Joined: Sat Nov 27, 2010 1:38 pm

Re: Illegal variable _files or _env or _get or _post or _coo

Postby HiRavi » Sat Nov 27, 2010 1:53 pm

Dude! Did you copy the API key correctly in the JConnector module page ?

Even i got this error. But later i found that i have copied the application id instead of API key.

Hope this works for you :)

hungreemon
Joomla! Apprentice
Joomla! Apprentice
Posts: 16
Joined: Fri Mar 12, 2010 5:43 pm

Re: Illegal variable _files or _env or _get or _post or _coo

Postby hungreemon » Wed Dec 01, 2010 4:36 pm

ha i believe that was it although its still not behaving 100% correctly... now its opening a connect window with my own site in it instead of the typical login to facebook window... thinking maybe it has to do with the fact that this is a demo site and its at an IP address rather than a proper domain... not sure

talkbizzy
Joomla! Fledgling
Joomla! Fledgling
Posts: 1
Joined: Thu Apr 14, 2011 1:06 pm

Re: Illegal variable _files or _env or _get or _post or _coo

Postby talkbizzy » Thu Apr 14, 2011 1:24 pm

I found that i have copied the application id instead of API key, too. I couldn't get access of my site from both back and front ends since I installed Jconnector and created facebook application. I thought deleting this application would be the solution and finally I did it. But it kept erroring "Illegal variable _files or _env or _get or _post or _cookie" every time I refreshed any windows previously opened. Any one who could help me in recovering my site!

sandyordonez
Joomla! Fledgling
Joomla! Fledgling
Posts: 2
Joined: Tue May 10, 2011 7:48 pm

Re: Illegal variable _files or _env or _get or _post or _coo

Postby sandyordonez » Tue May 10, 2011 7:54 pm

clear the cookies. this should fix it.

sandy

thrasher11
Joomla! Fledgling
Joomla! Fledgling
Posts: 1
Joined: Thu Jun 09, 2011 8:03 pm

Re: Illegal variable _files or _env or _get or _post or _coo

Postby thrasher11 » Thu Jun 09, 2011 8:11 pm

Similar problem for my only in firefox. Here's what I've done:
1. Fixed the API Key
2. Cleared the cache

Still getting the error message in firefox.

Any more suggestions would be greatly appreciated.

mikozen
Joomla! Apprentice
Joomla! Apprentice
Posts: 7
Joined: Sat Nov 26, 2011 6:00 pm

Re: Illegal variable _files or _env or _get or _post or _coo

Postby mikozen » Sun Nov 27, 2011 9:22 pm

this module / script ( jconnector ) is REALLY creepy - it crashed my site (from Safari) , fortunately firefox allowed me to enter and unpublish it.

After clearing Safari's cache, the 'crash' symptom (that error 'Illegal variable _files or _env or _get or _post or _cookie' seemed to go away -

But then it came back 4 more times.

This is really bothering me, as the module was 1st, turned off, then completely removed - But Safari's still occasionally showing up the crashed symptom. I haven't tested this in other browsers, frankly because I don't have all day to sit around trying to duplicate the symptoms.

Does anyone know how to completely insure that this script/module is removed PERMANENTLY ?

I can't believe that the JED still allows this module to be published. Something that crashes sites should be completely removed. Very eery, creepy - And the fact that the makers of this module just drop the forum threads displays an utter lack of responsibility on their part. Free is even worse, because that means that they're not liable for legal damage should their sloppy code ruin someone's ability to represent their online work, or worse, lose valuable business, reputation, and time because their site suddenly shows an error message.

FAIL!

Anyone with any advice or symptom observations on this ridiculous and evil script, PLEASE post what you have discovered to rid your site of it.

And please - Whomever said 'App ID vs. Key' - FAIL #2! They're the SAME THING! You're thinking of the 'App Secret vs. API key.' (At least from my quadruple-checking on my FB's APP screen. I see NOWHERE three numbers, just 2 - the API key and the Secret #.

Back to original request: Symptoms or Ways to Completely remove it. PLEASE. PLEASE. PLEASE. :)

And thank you :))))))

Mklgiht
Joomla! Apprentice
Joomla! Apprentice
Posts: 11
Joined: Wed Apr 25, 2012 11:34 am

Re: Illegal variable _files or _env or _get or _post or _coo

Postby Mklgiht » Wed Apr 25, 2012 2:11 pm

don know... i am having the same problem....
and i dont think it's regarding to some module... i have to special modules
and still i have this problem


Return to “Performance - Joomla! 1.5”

Who is online

Users browsing this forum: No registered users and 6 guests