The Joomla! Forum ™



Forum rules


Forum Rules
Absolute Beginner's Guide to Joomla! <-- please read before posting, this means YOU.
Forum Post Assistant - If you are serious about wanting help, you will use this tool to help you post.



Post new topic Reply to topic  [ 1805 posts ]  Go to page Previous  1 ... 54, 55, 56, 57, 58, 59, 60, 61  Next
Author Message
PostPosted: Tue Aug 02, 2011 9:35 am 
Joomla! Fledgling
Joomla! Fledgling

Joined: Tue Aug 02, 2011 9:18 am
Posts: 3
hi joomla community!

first i want to say that your yvComment extension is awesome and thank you for making it free for everyone.

So after a few time of probing different configurations i have a special problem and thought you could help me.

My Problem is everytime i try to post a comment without filling the required fields for the Emailadress / name, the extension will link to the standard preview which is loading the articles wrong (showing intro text, hidden readmore-links..., most of my articles are displayed in blog layout). thats why i want to ask if i can do something like an overwrite do strip the preview and simply show the error messages on the same site under the associated textfield(name, email).

I hope you can help me.

Also i hope you understand the problem i tried to describe above^^ because my english isnt good at all

with best regards

tilt32


Top
 Profile  
 
PostPosted: Thu Aug 04, 2011 6:20 pm 
Joomla! Apprentice
Joomla! Apprentice

Joined: Wed Jul 06, 2011 7:40 pm
Posts: 6
I'm not sure if yvComment can do this, but maybe someone can help.

My site has 3 access levels: unregistered, registered, and unlimited. I would like to have unregistered and registered be able to view article comments (works fine now), but I would like to specify that only unlimited users can POST comments. Currently I am only able to specify that registered users can post (which includes unlimited).

Changing the access level of the plugin to unlimited would prevent unregistered and registered from viewing comments.

Thanks!


Top
 Profile  
 
PostPosted: Fri Aug 05, 2011 9:57 am 
Joomla! Fledgling
Joomla! Fledgling

Joined: Thu Nov 19, 2009 9:22 am
Posts: 1
I am using this component with Joomla 1.6.3 and I am really satisfied (even I'm pretty much beginner)
I have just one question. Is there any chance to include the count of comments in my latestnews modul (not yvComment module)?
Thanks in advance.

P.S. Great extension, Yuri.


Top
 Profile  
 
PostPosted: Mon Aug 08, 2011 12:22 am 
User avatar
Joomla! Fledgling
Joomla! Fledgling

Joined: Mon Aug 08, 2011 12:06 am
Posts: 2
Location: ALCAMPELL, Spain
Great extension --thanks Yuri!-- but I am facing a weird issue.

After successfully installing other yvComment langpacks, spanish language pack installation fails with message:
Error! Could not find a Joomla! XML setup file in the package.
But spanish language for Admin IS installed.

Joomla! Version: Joomla! 1.5.18 Stable [ wojmamni ama wojnaiki ] 27-May-2010 18:00 GMT
Installed: Spanish (es-ES) Admin 1.5.23 5-4-2011 Spanish translation team: Comunidad Joomla
Installed: yvComment 1.25.003
Failing language pack: yvCommentLanguagePack_es-ES-2.00.001.zip (downloaded from http://joomlacode.org/gf/project/yvcomm ... tion=index 2011-08-07)

What could be the problem?


Last edited by esljf on Wed Aug 10, 2011 12:06 am, edited 1 time in total.

Top
 Profile  
 
PostPosted: Mon Aug 08, 2011 6:46 am 
Joomla! Fledgling
Joomla! Fledgling

Joined: Wed Mar 10, 2010 7:13 pm
Posts: 4
http://www.knock-out.dk/index.php/news/ ... omment1744

joomla 1.5, artisteer template - all plugins installed, key capchta etc with code etc. Enable the right places - BUT CAPTCHA DOES NOT APPEAR? I have tried searching forum etc. didnt find any specific explanation.. any help from the oracle? the master? the king?


Top
 Profile  
 
PostPosted: Tue Aug 09, 2011 8:39 pm 
User avatar
Joomla! Apprentice
Joomla! Apprentice

Joined: Fri Jun 27, 2008 1:30 pm
Posts: 30
After much hair pulling and gnashing of teeth, I managed to install yvcomment into joomla 1.7.0.

I found I had to extract and edit install.yvcomment.php then re-insert it into yvCommentComponent-2.00.003.zip.

FIND
Code:
$db = & JFactory :: getDBO();
$TableName = $db->replacePrefix('#__yvcomment');
CHANGE TO
Code:
$db = & JFactory :: getDBO();
$TableName = '#__yvcomment';

Probably need to do the same with uninstall.yvcomment.php, but I haven't tried uninstalling yet.

The only problem I have found since, is this: I created several threaded comments and replies to one article and then tried deleting them. They all deleted OK except for the initial comment that give me the error
Quote:
Could not delete: comments on this Comment are present
, but there aren't any - so I can't delete the last comment by conventional means.

Any advice please?

Edit: Sorted - had to deleted the trashed comments from the bin.

_________________
I don't code - I just butcher that of others'.


Top
 Profile  
 
PostPosted: Wed Aug 10, 2011 4:48 am 
User avatar
Joomla! Guru
Joomla! Guru

Joined: Thu Jun 01, 2006 1:52 pm
Posts: 979
Location: Moscow, Russia
fade2gray wrote:
After much hair pulling and gnashing of teeth, I managed to install yvcomment into joomla 1.7.0.

I found I had to extract and edit install.yvcomment.php then re-insert it into yvCommentComponent-2.00.003.zip.

FIND
Code:
$db = & JFactory :: getDBO();
$TableName = $db->replacePrefix('#__yvcomment');
CHANGE TO
Code:
$db = & JFactory :: getDBO();
$TableName = '#__yvcomment';

Probably need to do the same with uninstall.yvcomment.php, but I haven't tried uninstalling yet.

Thank you fade2gray,
I've debugged this and found that Joomla! 1.7.0 has a bug:
Code:
$db = & JFactory :: getDBO();
$TableName = $db->replacePrefix('#__yvcomment');

sets $TableName to the empty string :(

I filed a bug report to Joomla! Tracker:
http://joomlacode.org/gf/project/joomla/tracker/?action=TrackerItemEdit&tracker_item_id=26617

BTW, I found this version of Joomla! doesn't work with MSIE 9 also...

_________________
Text of all my messages is available under the terms of the GNU Free Documentation License: http://www.gnu.org/copyleft/fdl.html


Top
 Profile  
 
PostPosted: Wed Aug 10, 2011 9:59 am 
User avatar
Joomla! Apprentice
Joomla! Apprentice

Joined: Fri Jun 27, 2008 1:30 pm
Posts: 30
Hi yvolk,
yvolk wrote:
Thank you fade2gray,
I've debugged this and found that Joomla! 1.7.0 has a bug:
Code:
$db = & JFactory :: getDBO();
$TableName = $db->replacePrefix('#__yvcomment');

sets $TableName to the empty string :(

I filed a bug report to Joomla! Tracker:
http://joomlacode.org/gf/project/joomla/tracker/?action=TrackerItemEdit&tracker_item_id=26617

My bad :-[

I found this in joomla google groups.

Temporary workaround:- edit /libraries/joomla/database/database.php

FIND
Code:
protected function replacePrefix($sql, $prefix='#__')
CHANGE TO
Code:
public function replacePrefix($sql, $prefix='#__')

_________________
I don't code - I just butcher that of others'.


Top
 Profile  
 
PostPosted: Wed Aug 10, 2011 10:19 am 
User avatar
Joomla! Guru
Joomla! Guru

Joined: Thu Jun 01, 2006 1:52 pm
Posts: 979
Location: Moscow, Russia
esljf wrote:
Great extension --thanks Yuri!-- but I am facing a weird issue.

After successfully installing other yvComment langpacks, spanish language pack installation fails with message:
Error! Could not find a Joomla! XML setup file in the package.
But spanish language for Admin IS installed.

Joomla! Version: Joomla! 1.5.18 Stable [ wojmamni ama wojnaiki ] 27-May-2010 18:00 GMT
Installed: Spanish (es-ES) Admin 1.5.23 5-4-2011 Spanish translation team: Comunidad Joomla
Installed: yvComment 1.25.003
Failing language pack: yvCommentLanguagePack_es-ES-2.00.001.zip (downloaded from http://joomlacode.org/gf/project/yvcomm ... tion=index 2011-08-07)

What could be the problem?


Hi!
Language packs v.2.xx are for yvComment v.2.xx only!
So you should install language pack v.1.xx for yvComment 1.25.003
(e.g. yvCommentLanguagePack_es-ES_1.21.001.zip for Spanish)

_________________
Text of all my messages is available under the terms of the GNU Free Documentation License: http://www.gnu.org/copyleft/fdl.html


Top
 Profile  
 
PostPosted: Wed Aug 10, 2011 10:54 am 
User avatar
Joomla! Apprentice
Joomla! Apprentice

Joined: Fri Jun 27, 2008 1:30 pm
Posts: 30
After building the packages from the svn, immediately after installing I see what's shown in the images below - I don't understand the difference in module status and id number, also the module version number is shown as 2.00.0 and not 2.00.3 like the other components.
Attachment:
extension.png
Attachment:
module.png
Attachment:
plugin.png


You do not have the required permissions to view the files attached to this post.

_________________
I don't code - I just butcher that of others'.


Top
 Profile  
 
PostPosted: Wed Aug 10, 2011 11:23 am 
User avatar
Joomla! Guru
Joomla! Guru

Joined: Thu Jun 01, 2006 1:52 pm
Posts: 979
Location: Moscow, Russia
fade2gray wrote:
After building the packages from the svn, immediately after installing I see what's shown in the images below - I don't understand the difference in module status and id number, also the module version number is shown as 2.00.0 and not 2.00.3 like the other components.

Different statuses and IDs may mean bugs/inconsistencies of Joomla! ...
Module didn't change since v.2.00.0. So it's version number wasn't changed.

_________________
Text of all my messages is available under the terms of the GNU Free Documentation License: http://www.gnu.org/copyleft/fdl.html


Top
 Profile  
 
PostPosted: Wed Aug 10, 2011 2:45 pm 
User avatar
Joomla! Guru
Joomla! Guru

Joined: Thu Jun 01, 2006 1:52 pm
Posts: 979
Location: Moscow, Russia
tilt32 wrote:
hi joomla community!

first i want to say that your yvComment extension is awesome and thank you for making it free for everyone.

So after a few time of probing different configurations i have a special problem and thought you could help me.

My Problem is everytime i try to post a comment without filling the required fields for the Emailadress / name, the extension will link to the standard preview which is loading the articles wrong (showing intro text, hidden readmore-links..., most of my articles are displayed in blog layout). thats why i want to ask if i can do something like an overwrite do strip the preview and simply show the error messages on the same site under the associated textfield(name, email).

I hope you can help me.

Also i hope you understand the problem i tried to describe above^^ because my english isnt good at all

with best regards

tilt32

Hi Tilt, you need to override the "layout": /components/com_yvcomment/views/comment/tmpl/default.php
You may simply delete something|everything from the block:
Code:
<div class='Article'> ...

_________________
Text of all my messages is available under the terms of the GNU Free Documentation License: http://www.gnu.org/copyleft/fdl.html


Top
 Profile  
 
PostPosted: Wed Aug 10, 2011 5:45 pm 
User avatar
Joomla! Fledgling
Joomla! Fledgling

Joined: Mon Aug 08, 2011 12:06 am
Posts: 2
Location: ALCAMPELL, Spain
yvolk wrote:
Hi!
Language packs v.2.xx are for yvComment v.2.xx only!
So you should install language pack v.1.xx for yvComment 1.25.003
(e.g. yvCommentLanguagePack_es-ES_1.21.001.zip for Spanish)

Thank you very much. Obviously this works.

Please notice that yvComment for Joomla! v.1.5 homepage:
http://yurivolkov.com/Joomla/yvComment/ ... -5_en.html
refers to this donwnload links page for additional languages:
http://joomlacode.org/gf/project/yvcomm ... tion=index
and looking there for spanish langpacks, I could only find the v.2.0.0. This seems to be the case with other languages too.

Thanks again!


Last edited by esljf on Thu Aug 11, 2011 3:17 am, edited 2 times in total.

Top
 Profile  
 
PostPosted: Wed Aug 10, 2011 7:00 pm 
User avatar
Joomla! Guru
Joomla! Guru

Joined: Thu Jun 01, 2006 1:52 pm
Posts: 979
Location: Moscow, Russia
ivaana wrote:
I am using this component with Joomla 1.6.3 and I am really satisfied (even I'm pretty much beginner)
I have just one question. Is there any chance to include the count of comments in my latestnews modul (not yvComment module)?
Thanks in advance.

P.S. Great extension, Yuri.

Hi ivaana,
yvComment has "View name" = "Most commented" +
"Layout name" = "003 (Like 'Latest News')".
This is close to what you want:
it lists articles + number of comments, not "Latest" but "Most commented".

In the MVC (Model-View-Controller) pattern this means that yvComment needs another model to retrieve articles by other criteria... You may see and try to hack '\components\com_yvcomment\models\mostcommented.php' file to work as you wish...

_________________
Text of all my messages is available under the terms of the GNU Free Documentation License: http://www.gnu.org/copyleft/fdl.html


Top
 Profile  
 
PostPosted: Sat Aug 13, 2011 4:19 pm 
Joomla! Fledgling
Joomla! Fledgling

Joined: Tue Aug 02, 2011 9:18 am
Posts: 3
Thank you very much for your answer yuri!
this is exactly what i needed.


Top
 Profile  
 
PostPosted: Sat Aug 20, 2011 11:18 am 
User avatar
Joomla! Guru
Joomla! Guru

Joined: Thu Jun 01, 2006 1:52 pm
Posts: 979
Location: Moscow, Russia
yvComment v.2.0.4 released, see the JED.

What's new:
+ Tested to be compatible: with Joomla! 1.7.0 and with Community Builder 1.7
# Small fix improving Comment preview page (got rid of additional linebreaks in the parent Article). Thanks to Carlo for the tip.
# Workaround for the Joomla! 1.7.0 bug: JDatabase->replacePrefix() function returns empty string.

_________________
Text of all my messages is available under the terms of the GNU Free Documentation License: http://www.gnu.org/copyleft/fdl.html


Top
 Profile  
 
PostPosted: Wed Aug 31, 2011 1:26 pm 
Joomla! Fledgling
Joomla! Fledgling

Joined: Mon Aug 29, 2011 6:05 am
Posts: 1
Dear Yuri,
1st of all my heartiest welcome for the the grt commenting plugin/module u have created.I had used it for Joomla 1.5and it had worked perfectly.Now in a test site where joomla 1.7 is the cms,urs latest ver2.00.4 doesnt seem to get installed. the problem is occuring with yvcommentcomponent2.00.004.zip(filesize 136kb).On starting it to install, from the backend,withen a short time, the admin login screen is appearing. When logged in half display vanishing----again after logout and again logging in display returning but found this component not installed.Screenshots have been sent----If u plz do the needfull,i will be obliged.My email:[email protected]
Regards,
Jayanta


You do not have the required permissions to view the files attached to this post.


Top
 Profile  
 
PostPosted: Thu Sep 08, 2011 4:06 pm 
Joomla! Apprentice
Joomla! Apprentice

Joined: Sat May 07, 2011 11:40 pm
Posts: 13
Hi mate,

I wanted to ask you if there is any chance this component/plugin can be implemented in other component.
For instance I'm using joomsport component and would like to use your comments on matches from Joomsport etc. They have some sort of commenting system but it doesn't work.

Any advise is appreciated.

Thank you for your time.


Top
 Profile  
 
PostPosted: Sun Sep 11, 2011 9:19 pm 
Joomla! Fledgling
Joomla! Fledgling

Joined: Sat Sep 10, 2011 7:30 pm
Posts: 1
Hi, I am desperated. I tried every instruction i found about yvcomment but still nothing shows up. Just article as it is. Not a single evidence in front end that yvcomment exists.
please can you help me some way?
webpage is : en-stav.cz and in it top menu link called : Diskuze
There should be a comments.
Iam using last joomla 1.5 (.22 i gues) and meet all requirements for proper working of copmonent.
Thanks a lot
[email protected]


Top
 Profile  
 
PostPosted: Mon Sep 12, 2011 11:53 pm 
Joomla! Fledgling
Joomla! Fledgling

Joined: Mon Sep 12, 2011 7:44 pm
Posts: 1
Hi, I have succesful installed yvComment,

I can see the yvComment component in the front end, Not registed users are allowed to make comments. I'm the administrator and I see also the list of comment from the users in the back-end. I set up " allow comments on comment - Administrator's reply only" because I want to be the only person who replies comments, but I dont see any "REPLY" button in the list of comment (back-end). Honestly I don't find an answer to my question. I would like to receive any help. If you need more information about my configuration, just ask me.

SOS.
Thanks in advance.


Top
 Profile  
 
 Post subject: vComment - aceSEF
PostPosted: Sat Sep 17, 2011 8:18 pm 
Joomla! Fledgling
Joomla! Fledgling

Joined: Sat Sep 17, 2011 8:13 pm
Posts: 1
I use aceSEF and the only way I could get these two plugins to work together is if I disable aceSEF for yvComments. Is there a better way?


Top
 Profile  
 
PostPosted: Sun Sep 18, 2011 6:16 am 
I've been banned!

Joined: Sat Sep 17, 2011 4:05 pm
Posts: 21
esljf wrote:
yvolk wrote:
Hi!
Language packs v.2.xx are for yvComment v.2.xx only!
So you should install language pack v.1.xx for yvComment 1.25.003
(e.g. yvCommentLanguagePack_es-ES_1.21.001.zip for Spanish)

Thank you very much. Obviously this works.

Please notice that yvComment for Joomla! v.1.5 homepage:
http://yurivolkov.com/Joomla/yvComment/ ... -5_en.html
refers to this donwnload links page for additional languages:
http://joomlacode.org/gf/project/yvcomm ... tion=index
and looking there for spanish langpacks, I could only find the v.2.0.0. This seems to be the case with other languages too.

Thanks again!


thanks esljf i do this structure too and its work for me too
and thanks yvolk for this solution

_________________
http://[spam].ir
http://www.[spam].ir


Top
 Profile  
 
PostPosted: Thu Sep 22, 2011 7:45 am 
Joomla! Fledgling
Joomla! Fledgling

Joined: Thu Sep 22, 2011 7:37 am
Posts: 1
1. I use plugin yvcoment. In "use content table" I choice YES.
after that, I try to write comment, and then in comment SHOW button EDIT and DELETE.

2. In "use content table" I choice NO.
after that, I try to write comment, and then in comment NOT SHOW button EDIT and DELETE. so I cant delete/edit my comment :(

I want to use NO but in comment show button edit and delete. any advice ? please help me
sorry my english so worst :(


Top
 Profile  
 
PostPosted: Thu Sep 22, 2011 5:32 pm 
User avatar
Joomla! Apprentice
Joomla! Apprentice

Joined: Fri Jan 15, 2010 2:14 pm
Posts: 15
Location: Hamburg
Joomla 1.7:

"Allow comments on comment-->Threaded comments" does not work. It is not possible to reply to comments.

Regards
Joe

_________________
Lernen ist wie Rudern gegen den Strom; sobald man aufhört, treibt man zurück.
Chinesisches Sprichwort.


Top
 Profile  
 
PostPosted: Thu Sep 22, 2011 6:06 pm 
Joomla! Apprentice
Joomla! Apprentice

Joined: Sun Jun 19, 2011 11:44 am
Posts: 47
Hi,

I've installed yvComment component and plugin in a joomla 1.7 site, but the extension is not working.
I explain:
only the "Please register or login to add your comments to this article" message is displayed and nothing else.
How can I fix it?
the URL is
http://www.alliotiko.gr/testa/index.php ... 7-37%CE%B2 (Sorry for the long address, its in Greek)

Pls advise
Chris


Top
 Profile  
 
PostPosted: Thu Sep 22, 2011 6:30 pm 
User avatar
Joomla! Apprentice
Joomla! Apprentice

Joined: Fri Jan 15, 2010 2:14 pm
Posts: 15
Location: Hamburg
@cvrak

Still, the extension is working.

Read this, but everything: yvComment

_________________
Lernen ist wie Rudern gegen den Strom; sobald man aufhört, treibt man zurück.
Chinesisches Sprichwort.


Top
 Profile  
 
PostPosted: Thu Sep 22, 2011 9:14 pm 
Joomla! Apprentice
Joomla! Apprentice

Joined: Sun Jun 19, 2011 11:44 am
Posts: 47
Joenet wrote:
@cvrak

Still, the extension is working.

Read this, but everything: yvComment


Hi,

I uninstalled yvcomment, installed greek language pack for administrator, re-installed yvcomment component & plugin, but the problem isn't changed. I haven't installed any language package for yvcomment, because the Greek one is still in version 1.8.xx

Any suggestions?

Regards
Chris


Top
 Profile  
 
PostPosted: Thu Sep 22, 2011 9:54 pm 
User avatar
Joomla! Apprentice
Joomla! Apprentice

Joined: Fri Jan 15, 2010 2:14 pm
Posts: 15
Location: Hamburg
@cvrak

Yes, Suggestions are in my previous post that you quote.

_________________
Lernen ist wie Rudern gegen den Strom; sobald man aufhört, treibt man zurück.
Chinesisches Sprichwort.


Top
 Profile  
 
PostPosted: Thu Sep 22, 2011 11:18 pm 
Joomla! Apprentice
Joomla! Apprentice

Joined: Sun Jun 19, 2011 11:44 am
Posts: 47
Joenet wrote:
@cvrak

Yes, Suggestions are in my previous post that you quote.



I've read the instructions many times and I've followed every step.
Can you be more specific?


Top
 Profile  
 
PostPosted: Fri Sep 23, 2011 12:16 pm 
User avatar
Joomla! Apprentice
Joomla! Apprentice

Joined: Fri Jan 15, 2010 2:14 pm
Posts: 15
Location: Hamburg
No, seems you have not read everything. Otherwise you would have seen this
(3. Preparing for configuration):

Quote:
2. If you plan to enable guests (visitors, unregistered users...) to post comments:

  • Create special 'Guest user', who will become (from Joomla's point of view) Author of all comments, created by different guests (guests are not themselves registered users of Joomla!). Joomla! doesn't have built-in 'Guest user account' (Guest user) to impersonate guests, so you have to create such user yourself:
    e.g. (in the backend menu->'Site'->'User Manager'->Click 'New' button) create user with 'Name'='Guest user' and 'Username'='guest'.
  • Guest user has to be in the Author group.
  • If you plan to edit comments with Joomla! built-in editor, this 'Guest user' should be enabled.

_________________
Lernen ist wie Rudern gegen den Strom; sobald man aufhört, treibt man zurück.
Chinesisches Sprichwort.


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 1805 posts ]  Go to page Previous  1 ... 54, 55, 56, 57, 58, 59, 60, 61  Next



Who is online

Users browsing this forum: No registered users and 21 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Jump to:  
Powered by phpBB® Forum Software © phpBB Group