The Joomla! Forum ™



Forum rules


Forum Rules
Absolute Beginner's Guide to Joomla! <-- please read before posting, this means YOU.



Post new topic Reply to topic  [ 43 posts ]  Go to page 1, 2  Next
Author Message
PostPosted: Thu Mar 20, 2008 11:12 am 
Joomla! Apprentice
Joomla! Apprentice

Joined: Tue Mar 18, 2008 6:46 pm
Posts: 15
Hello,

I'm trying to make the template madeyourweb, one of
the two defoult template in Joomla 1.0, working under
Joomla 1.5.

In your opinion, is this attempt without hope?

The first thing I would like to fix is the visualization
of the menus, wich are not embedded in the fancy "metal box"
provided by the template, as you can see in the attached
screenshot.

Any hint?

Regards,
Giovanni Gherdovich


You do not have the required permissions to view the files attached to this post.


Top
 Profile  
 
PostPosted: Tue Apr 22, 2008 6:21 pm 
Joomla! Apprentice
Joomla! Apprentice

Joined: Wed Feb 13, 2008 9:05 am
Posts: 44
Location: Denmark
Good question.

I'd also like to know, if people have any hints for this...


Top
 Profile  
 
PostPosted: Wed May 21, 2008 2:56 am 
Joomla! Fledgling
Joomla! Fledgling

Joined: Wed May 21, 2008 2:52 am
Posts: 1
Hi,
Go to module manager, edit Main Menu, select Menu Style 'Legacy - Vertical' and remove suffix '_menu' in advanced paramters.
Hey, I have a problem, the content area is not shown. When I click on a link to a content page, the content area is blank.
Thanks,
Shameer.


Top
 Profile  
 
PostPosted: Wed Dec 17, 2008 12:09 pm 
Joomla! Apprentice
Joomla! Apprentice

Joined: Wed Dec 17, 2008 11:44 am
Posts: 8
Hi,
I am new new to this forum and saw your question. I do not know if you had any success, but just selecting "vertical legacy" in the main menu module does not help very well.
The problem is you have to adapt the index.php file to the Joomla 1.5 system first. The template_css.css file is fine and only a small change is needed which has to do with the alteration of the index.php file.
I made a succesful conversion. If more members are interested I can provide the details.

Transes


Top
 Profile  
 
PostPosted: Wed Dec 17, 2008 12:35 pm 
Joomla! Apprentice
Joomla! Apprentice

Joined: Wed Feb 13, 2008 9:05 am
Posts: 44
Location: Denmark
That would be so cool :)


Top
 Profile  
 
PostPosted: Thu Dec 18, 2008 3:00 am 
Joomla! Apprentice
Joomla! Apprentice

Joined: Wed Dec 17, 2008 11:44 am
Posts: 8
Alteration madeyourweb template to Joomla 1.5 template

Three files must be changed:
1. index.php
All standard code until body tag to be replacd by the standard joomla 1.5 template code. Specific code $usera etc. to be replaced by new code.
Body part:
All modules and formats to be replaced by joomla 1.5 modules and codes (jdoc:include type= .... and ($this->countModules.....)
Change of code under id="top-bottom"
Change of code under id="footer ..."
Important: style of the left and right module positions must be "rounded", otherwise the menu and module graphics do not work!
Most "if" statements to be closed by "end if" (PHP)
2. Small changes in the template_css.css file due to some changes in the index.php file
3. templateDetails.xml file adapted to standard file for joomla 1.5

User instructions:
After changing the files (validate first!) install the new template madeyourweb_15
For the main menu (mod_mainmenu) use menu style legacy-vertical (no suffixes);
for the top-menu use legacy-horizontal and menu class suffix -nav

It is not too complicated but you need to know something about the template structures and php.

I have made a zip file - madeyourweb_15.zip (5kb) - only including the 3 files changed. After unzipping you only have to add the two sub-directories (css and images) to the madeyourweb_1.5 directory and replace the 3 old files with the news ones. Zip it again and install it in Joomla 1.5. Ready.

The file can be freely shared by the members, but I do not know how.

Transes


Top
 Profile  
 
PostPosted: Thu Dec 18, 2008 7:33 am 
Joomla! Apprentice
Joomla! Apprentice

Joined: Wed Feb 13, 2008 9:05 am
Posts: 44
Location: Denmark
Nicely done!

This will come in handy when I upgrade my 1.0 sites - without having to mess around to much with alternative templates.

I'm not sure where to put the files. Anyone?


Top
 Profile  
 
PostPosted: Wed Jan 07, 2009 2:22 pm 
Joomla! Fledgling
Joomla! Fledgling

Joined: Tue Jan 06, 2009 1:24 pm
Posts: 1
Anyone have seen the files that transes done?


Top
 Profile  
 
PostPosted: Mon Jan 12, 2009 1:56 pm 
Joomla! Apprentice
Joomla! Apprentice

Joined: Tue Sep 11, 2007 2:34 am
Posts: 8
I'd wish he'd posted them too.


Top
 Profile  
 
PostPosted: Thu Jan 22, 2009 1:04 am 
Joomla! Fledgling
Joomla! Fledgling

Joined: Thu Jan 22, 2009 1:00 am
Posts: 2
Has this (the zipped file) been posted?


Top
 Profile  
 
PostPosted: Thu Jan 22, 2009 2:46 am 
Joomla! Apprentice
Joomla! Apprentice

Joined: Tue Sep 11, 2007 2:34 am
Posts: 8
Unfortunately not. I've moved on and found a new template :-)


Top
 Profile  
 
PostPosted: Thu Jan 22, 2009 10:41 am 
Joomla! Apprentice
Joomla! Apprentice

Joined: Wed Dec 17, 2008 11:44 am
Posts: 8
So far I have send the file to everyone who has asked for it via the Forum. The Forum has send me the request plus the email address. So I do not understand all this commotion.
Of course it would be better if the forum had a download place, where I could place the file available for everyone.

Transes


Top
 Profile  
 
PostPosted: Fri Jan 23, 2009 7:42 am 
Joomla! Fledgling
Joomla! Fledgling

Joined: Thu Jan 22, 2009 10:16 pm
Posts: 2
Hi Transes,

Just post it as an attachment when you post here. The "upload attachment" form is below the textarea you write in when posting.

~Spiralis


Top
 Profile  
 
PostPosted: Fri Jan 23, 2009 9:17 am 
Joomla! Apprentice
Joomla! Apprentice

Joined: Wed Dec 17, 2008 11:44 am
Posts: 8
Enclosed as an attachment you will find the file including the conversion of the madeyourweb template from Joomla 1.0 to 1.5.

The file includes all sub-files but not the image directory. The new template-thumbnail is included.

User Instructions:
Unzip this file first and read the instructions put in the read-me-first text file.

The file is free for distribution to the members of this forum.

Let me know if everything is okay this way

Transes


Top
 Profile  
 
PostPosted: Fri Jan 23, 2009 10:04 am 
Joomla! Fledgling
Joomla! Fledgling

Joined: Thu Jan 22, 2009 10:16 pm
Posts: 2
Big thanks :). I will try these shortly.

When I installed the madeyourweb templates in 1.5 I was asked to enable the legacy mode plugin. Is this still needed after these changes?

~Spiralis


Top
 Profile  
 
PostPosted: Fri Jan 23, 2009 7:36 pm 
Joomla! Apprentice
Joomla! Apprentice

Joined: Wed Dec 17, 2008 11:44 am
Posts: 8
No, in principal not. It runs the with the system legacy plugin off.

But it will also work with the system legacy plugin on.

No difference at all. Do what you like

Transes


Top
 Profile  
 
PostPosted: Mon Feb 02, 2009 11:10 pm 
Joomla! Fledgling
Joomla! Fledgling

Joined: Mon Feb 02, 2009 10:53 pm
Posts: 1
Hi
i used the zip provided by transes but when installing the template i get :
JInstaller::install: File '/home/concepts/public_html/sijny/tmp/install_49877c9151cc7/madeyourweb_15/madeyourweb_15/images/back_all1024.gif' does not exist.

pls help...thanks


Top
 Profile  
 
PostPosted: Mon Feb 02, 2009 11:20 pm 
Joomla! Apprentice
Joomla! Apprentice

Joined: Tue Sep 11, 2007 2:34 am
Posts: 8
Yes I got that as well and in the end could never really make it work. I know its me, but is there any chance someone knows of a complete template zip file that could be used as a normal install template file for Joomla 1.5 (I used the blue theme) for us relative novices :-)??

It would be hugely appreciated.


Top
 Profile  
 
PostPosted: Tue Feb 03, 2009 9:50 am 
Joomla! Apprentice
Joomla! Apprentice

Joined: Wed Dec 17, 2008 11:44 am
Posts: 8
Sometimes you have to do something yourselve. You must add the image directory including all images you want to use. See instructions
You have to check if all image files included in the templateDetails.xml file are present in your image directory and vice versa. If you are missing one or more files in your image directory, you get this error.!

By the way the back_all1024.gif is a regular file of the madeyourweb template. If you are not using it, remove this image file from templateDetails.xml file (using a text editor, e.g. wordpad) and your problem is solved.

Transes


Top
 Profile  
 
PostPosted: Tue Feb 03, 2009 10:59 am 
Joomla! Apprentice
Joomla! Apprentice

Joined: Tue Sep 11, 2007 2:34 am
Posts: 8
I know - thanks transes. I've moved on from this now so as I mentioned, I did appreciate you posting the instructions in the first place.


Top
 Profile  
 
PostPosted: Thu Feb 05, 2009 9:46 pm 
Joomla! Intern
Joomla! Intern

Joined: Wed May 24, 2006 1:51 pm
Posts: 63
Thanks for this upgrade! It made things a ton easier for me to finally upgrade to joomla 1.5!

One thing, just in case anyone has trouble. If you use some sort of drop down menu (I am using PraiseMenu) you might have trouble with it appearing behind an element on the front page (such as a slideshow of some sort - I use PraiseSlides).

What needs to be added is in the template css
Look for #leftcol
and add the property: z-index: 100;

And you should be golden.

Thanks again,
Nathan


Last edited by pe7er on Fri Feb 20, 2009 11:32 pm, edited 1 time in total.
Manual signature removed. Please use signature in Forum Profile instead.


Top
 Profile  
 
PostPosted: Tue Feb 17, 2009 11:02 pm 
Joomla! Apprentice
Joomla! Apprentice

Joined: Mon Feb 09, 2009 12:14 am
Posts: 7
Thank you, transes, for re-doing this template! :D It's a good one, and it would have been a shame to lose it.

I am having one problem with it, though - I copied the images directory over, as per your instructions, and everything looks great on the home page and content items on my test site. But when I go to the register page or a CB profile, none of the images show up - I just get a white background with plain text in a single column. And this only happens with SEF enabled. When I turn off SEF, everything seems to work fine.

Has anyone else noticed this, or did I do something wrong?


Top
 Profile  
 
PostPosted: Tue Feb 24, 2009 2:36 pm 
Joomla! Apprentice
Joomla! Apprentice

Joined: Mon Feb 23, 2009 10:47 pm
Posts: 5
Under Joomla! 1.5 "navigation" not show above Mainmenu . Can you help me?



madeyourweb under joomla 1.0
Attachment:
joomla10.gif


madeyourweb 1.5 under joomla 1.5
Attachment:
joomla15.gif


You do not have the required permissions to view the files attached to this post.


Top
 Profile  
 
PostPosted: Wed Feb 25, 2009 12:42 am 
Joomla! Apprentice
Joomla! Apprentice

Joined: Wed Dec 17, 2008 11:44 am
Posts: 8
This error has nothing to do with the template.
You must activate the module "breadcrumbs" and check the specification of the parameters (module manager)

Transes


Top
 Profile  
 
PostPosted: Sat Mar 14, 2009 1:15 am 
Joomla! Apprentice
Joomla! Apprentice

Joined: Mon Feb 09, 2009 12:14 am
Posts: 7
Silly me, I forgot to activate the SEF links plugin. For some reason, other templates seemed to be working without it. This one is working fine now, though. Thanks again! :D


Top
 Profile  
 
PostPosted: Sun Mar 15, 2009 1:11 pm 
Joomla! Apprentice
Joomla! Apprentice

Joined: Wed Apr 19, 2006 7:03 pm
Posts: 45
Hiya,

I tried to download the attached file (madeyourweb_15.zip), but get the message "Unable to deliver file". Could somebody, please, upload the file again.

Thx,

Mike


Top
 Profile  
 
PostPosted: Mon Mar 16, 2009 10:45 am 
Joomla! Apprentice
Joomla! Apprentice

Joined: Tue Nov 01, 2005 4:51 pm
Posts: 15
I have the same problem as Mike, cannot download the file.
Can somebody please upload.

Thanks
Paul


Top
 Profile  
 
PostPosted: Mon Mar 16, 2009 9:27 pm 
Joomla! Apprentice
Joomla! Apprentice

Joined: Wed Dec 17, 2008 11:44 am
Posts: 8
Okay, I will upload the file again and hope it will be active for some time again
See for instructions my previous upload

Transes


You do not have the required permissions to view the files attached to this post.


Top
 Profile  
 
PostPosted: Tue Mar 17, 2009 9:03 pm 
Joomla! Apprentice
Joomla! Apprentice

Joined: Wed Apr 19, 2006 7:03 pm
Posts: 45
Thx a lot, buddy, everything is fine now!

Cheers,

Mike


Top
 Profile  
 
PostPosted: Fri Mar 20, 2009 3:27 pm 
Joomla! Apprentice
Joomla! Apprentice

Joined: Tue Nov 01, 2005 4:51 pm
Posts: 15
Thank you.
Paul


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 43 posts ]  Go to page 1, 2  Next



Who is online

Users browsing this forum: No registered users and 22 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Jump to:  
Powered by phpBB® Forum Software © phpBB Group