The Joomla! Forum ™



Forum rules


Forum Rules
Absolute Beginner's Guide to Joomla! <-- please read before posting, this means YOU.
Forum Post Assistant - If you are serious about wanting help, you will use this tool to help you post.



Post new topic Reply to topic  [ 656 posts ]  Go to page Previous  1 ... 6, 7, 8, 9, 10, 11, 12 ... 22  Next
Author Message
PostPosted: Fri Jan 16, 2009 10:37 am 
Joomla! Ace
Joomla! Ace

Joined: Wed Nov 05, 2008 11:28 pm
Posts: 1231
hello Friends,

This is a very long thread. It has more than 240 postings so far. It is quite amazing to see such a bulk of postings here. This is open-source at its best, at its veryvery best. I think that problem solving capabilities are at a very very high level.
I thought that i have tracked down the issue with the folder with some rough methods. I set all the folder-permissions recursively to 777: now the hackers are invited to hack the page.

but without no success: i allways get the errors: JFolder::create: Could not create directory

We need a better solution. Many guys here talk bout suPHP. suPHP is the only thing I really know of that would do what many guys are looking for. Well - what does suPHP? It allows php to run as your account user that it's setup on instead of apache so that files/folders created by php are still owned by your account user instead of apache. You could try this and see if it helps:

I'm on a Apache-Server. From what I can gather, I need to [list=]
upgrade to a new server-configuration,
then set up ISPConfig,
then install PHP as Cgi,
then install suPHP,
then configure suPHP,
then rebuild my vhost config files so suPHP will work.
[/list]
Cripes! :eek: All this just so I can enjoy the added security of Joomla 1.5.9

Still waiting for a good solve.. or a sticky of the solves... nothing I have tried on here will work.
PLZ advice. Do not let my out in the dark.

Joo_jesus

_________________
regards un-leash,
a big fan for ++ 8 years now: With Joomla you can easily create and extend your website: see the site, that offers you ideas & modules - extensions.joomla.org - it lists over 4000 extensions


Top
 Profile  
 
PostPosted: Fri Jan 16, 2009 7:59 pm 
Joomla! Enthusiast
Joomla! Enthusiast

Joined: Thu Aug 21, 2008 3:38 pm
Posts: 135
hello dear friends,

well - i had serious issues - with the topic. But i guess that i am lucky. ifound out that the server runs in different conditions...

i compared two sites of mine... The rootserver that is adminstered by a friend of mine has different conditions and settings. In a directory (of the server) wich is able to run every extension i have the safe_mode switched to off and on the "bad" site - where nothing is possible - no extensions at all - the safe_mode is set to on!!!

so i ask my admin to set the server according you advice. What do you think about this idea? Let me know this.

many many thanks in advance!

best regards
[drive] :)


Actions Taken To Resolve so far:
Attempted altering permissions, tried uploading in different ways. Attempted chown but doesn't work, no permissions. Tried with and without FTP layer enabled. Tried [de]enabling GZIP. Tried manually altering paths in configuration.php file. Setting the UID and GID flags don't appear to make a difference. If I unzip and then upload instead I get:

Quote:
* It was not possible to copy the selected file.


Last edited by joodriver on Fri Jan 16, 2009 11:47 pm, edited 1 time in total.

Top
 Profile  
 
PostPosted: Fri Jan 16, 2009 10:33 pm 
Joomla! Intern
Joomla! Intern

Joined: Fri Dec 02, 2005 3:52 am
Posts: 82
/tmp just worked for me too - thanks


Top
 Profile  
 
PostPosted: Fri Jan 16, 2009 11:43 pm 
Joomla! Enthusiast
Joomla! Enthusiast

Joined: Thu Aug 21, 2008 3:38 pm
Posts: 135
hello dear friend, hello dear pbhj

if you still try to get the thing up and running - do just one thing: Set the php-configuration straight:

You write: safe_mode: Enabled
i am pretty sure that you get the thing up and running within only 2 mins: switch off or disable the safe_mode: just switch it to off! And you will be more than happy. You get the thing running.

pbhj wrote:
[size=90]Problem Description:
I've this same issue. I too have my joomla site in a non-doc-root folder but it doesn't appear to be that that is the cause of this. I've tried with a few things but currently attempting to upload a template ... Note that I have a Wordpress install under the same server conditions with absolutely no problems uploading, auto-updating, etc..
Quote:
* JFolder::create: Could not create directory
* Unable to create destination

The problem appears to be that uploaded files get "apache:apache" as their permissions whilst I'm on a vhost with username (like) "creative:psac" - all the default install files have that and those are the credentials I get from whoami and groups via SSH. Uploading this theme pack it gets placed in /joomla/tmp and a temporary /joomla/tmp/installXXXXX folder is created but the error above prevents anything else from happening.

Actions Taken To Resolve:
Attempted altering permissions, tried uploading in different ways. Attempted chown but doesn't work, no permissions. Tried with and without FTP layer enabled. Tried [de]enabling GZIP. Tried manually altering paths in configuration.php file. Setting the UID and GID flags don't appear to make a difference. If I unzip and then upload instead I get:

Quote:
* It was not possible to copy the selected file.
* JInstaller::install: Failed to copy file: /var/www/vhosts/divers.org.uk/httpdocs/joomla/tmp/js_jamba/index.php to /var/www/vhosts/divers.org.uk/httpdocs/joomla/templates/js_jamba/index.php


Whouuhh, pbhj you did a lot of action to resolve the issues. Are you still waiting for a good solve? Well my dear: do me one favour: set the safe_mode: disabled

I am pretty sure that you get the thing up and running within only 2 mins: switch off or disable the safe_mode: just switch it to off! And you will be more than happy. You get the thing running.


best regards
[drive] :)


Top
 Profile  
 
PostPosted: Tue Jan 20, 2009 1:47 am 
Joomla! Enthusiast
Joomla! Enthusiast

Joined: Sat Oct 25, 2008 7:13 pm
Posts: 116
Location: Sheridan Wyoming
If you've moved the site, You need to make sure you've updated

var $log_path = '/logs';
var $tmp_path = '/tmp';

so it corresponds with your hosting or it will not work.

You will get the Jfolder error

That is located in your configuration.php file

Brandon Barclay


[mod note: please add signatures to your profile and not to each post]

_________________
If you have more questions PM me or
Need Support Call 307-461-0220
http://101online.org


Top
 Profile  
 
PostPosted: Tue Jan 20, 2009 9:18 pm 
Joomla! Intern
Joomla! Intern

Joined: Wed Dec 24, 2008 5:24 pm
Posts: 56
I know most users are using apache servers for there installations, but there are a few of us who are using Windows and have the same problem:-

* JFolder::create: Path not in open_basedir paths
* Unable to create destination

So, any idea's on a Windows platform would be great!!

Thanks


Top
 Profile  
 
PostPosted: Fri Jan 30, 2009 9:08 am 
Joomla! Fledgling
Joomla! Fledgling

Joined: Fri Jan 30, 2009 9:01 am
Posts: 2
My host uses windows and I had to put the full windows path (including the [drive] letter).

I found this info by going to the media manager and figuring out what the path to the tmp directory is.

After I updated the global configuration, the component install worked for me.

Good luck.


Top
 Profile  
 
PostPosted: Fri Jan 30, 2009 3:35 pm 
Joomla! Fledgling
Joomla! Fledgling

Joined: Wed Dec 17, 2008 1:57 pm
Posts: 1
What is confusing is I am working on Joomla 1.5.8, I am getting the error (not changed permissions yet..will check Google). The odd thing is...I have a half dozen plugins that DID install, then last night I tried to install Communicator Newsletter, it failed and now I cannot install a simple mod plugin.

I could see the google/permissions solutions IF I was not able to install ANY plugins but that is not what is happening.

Just FYI.


Top
 Profile  
 
PostPosted: Thu Feb 05, 2009 12:17 am 
Joomla! Apprentice
Joomla! Apprentice

Joined: Mon Feb 18, 2008 7:53 pm
Posts: 5
I have been dealing with this issue for 2 weeks with no luck. I suspect it is may be caused by the fact that my "current path" and "document root" settings are different.
Current Path /mnt/oldvar/www/vhosts/myhome.com/httpdocs
Document Root /var/www/vhosts/myhome.com/httpdocs
Can anyone advise?



Diagnostic Information
Joomla! Version: Joomla! 1.5.9 Production/Stable [ Vatani ] 9-January-2009 23:00 GMT
configuration.php: Not Writable (Mode: 444 ) | RG_EMULATION: N/A
Architecture/Platform: Linux 2.6.18-53.1.14.el5 ( i686) | Web Server: Apache ( myhome.com ) | PHP Version: 5.2.5
PHP Requirements: register_globals: Disabled | magic_quotes_gpc: Disabled | safe_mode: Disabled | MySQL Support: Yes | XML Support: Yes | zlib Support: Yes
mbstring Support (1.5): Yes | iconv Support (1.5): Yes | save.session_path: Writable | Max.Execution Time: 30 seconds | File Uploads: Enabled
MySQL Version: 5.0.22 ( Localhost via UNIX socket )


Top
 Profile  
 
PostPosted: Thu Feb 05, 2009 4:16 pm 
Joomla! Fledgling
Joomla! Fledgling

Joined: Thu Feb 05, 2009 4:06 pm
Posts: 1
Hi everyone !

I was also stuck with this error, the FTP layer being enabled or not.
The "./tmp" tip did it for me (I could change it without issue through the admin panel).

Thanks a lot ! Hope I will help back one day.

-Mato


Top
 Profile  
 
PostPosted: Thu Feb 05, 2009 6:41 pm 
Joomla! Enthusiast
Joomla! Enthusiast

Joined: Mon Mar 19, 2007 8:29 am
Posts: 171
Hi all.

I have the same issue.

* JFolder::create: Could not create directory
* Component Install: Failed to create directory.: "/home/mysite/public_html/components/com_sh404sef"

I have been reading and searching the forums now for 2 days. I think I have tried everything and I am literally at the point where I am considering scrapping the project.

Its a J1.5.9 site and I cant install anything.

Someone shoot me.


Top
 Profile  
 
PostPosted: Thu Feb 05, 2009 7:54 pm 
User avatar
Joomla! Exemplar
Joomla! Exemplar

Joined: Thu Aug 18, 2005 8:43 pm
Posts: 7986
Location: New York
You haven't said what your enviornment is, what you have tried and if you tookd out sh404. Frustration is hard, but if you wnat help you need to give people information.

Fight at the top is the forum post assistent, you need to start with that.

_________________
So we must fix our vision not merely on the negative expulsion of war, but upon the positive affirmation of peace. MLK 1964.
http://officialjoomlabook.com Get it at http://www.joomla.org/joomla-press-official-books.html Buy a book, support Joomla!.


Top
 Profile  
 
PostPosted: Fri Feb 06, 2009 11:03 am 
Joomla! Enthusiast
Joomla! Enthusiast

Joined: Mon Mar 19, 2007 8:29 am
Posts: 171
With my situation i have plenty of joomla sites on this server and only this one is having trouble.

Sorry but where is the post assistant? I cant seem to find it?

Many Thanks

Gary


Top
 Profile  
 
PostPosted: Fri Feb 06, 2009 11:20 pm 
Joomla! Apprentice
Joomla! Apprentice

Joined: Mon Feb 18, 2008 7:53 pm
Posts: 5
I tried all the various suggestions that are related to this problem that I could find in the forums, all to no avail.
The only fix for me was to contact my host and tell them my problem and 20 minutes later 'presto' all my extensions install with no problem.
I strongly suggest to everyone having this problem to contact their hosting tech support as I did and put an end to all the frustration. After all that is one of the services you pay for.
:-)


Top
 Profile  
 
PostPosted: Sat Feb 07, 2009 2:21 am 
User avatar
Joomla! Exemplar
Joomla! Exemplar

Joined: Thu Aug 18, 2005 8:43 pm
Posts: 7986
Location: New York
sitewonders wrote:
With my situation i have plenty of joomla sites on this server and only this one is having trouble.

Sorry but where is the post assistant? I cant seem to find it?

Many Thanks

Gary


At the top in the same box as forum rules.

_________________
So we must fix our vision not merely on the negative expulsion of war, but upon the positive affirmation of peace. MLK 1964.
http://officialjoomlabook.com Get it at http://www.joomla.org/joomla-press-official-books.html Buy a book, support Joomla!.


Top
 Profile  
 
PostPosted: Sat Feb 07, 2009 9:42 am 
Joomla! Enthusiast
Joomla! Enthusiast

Joined: Mon Mar 19, 2007 8:29 am
Posts: 171
Diagnostic Information
Joomla! Version: Joomla! 1.5.9 Production/Stable [ Vatani ] 9-January-2009 23:00 GMT
configuration.php: Writable (Mode: 777 ) | RG_EMULATION: N/A
Architecture/Platform: Linux 2.6.18-92.1.18.el5 ( i686) | Web Server: Apache/2.0.63 (Unix) mod_ssl/2.0.63 OpenSSL/0.9.8b mod_auth_passthrough/2.1 mod_bwlimited/1.4 FrontPage/5.0.2.2635 PHP/5.2.6 ( http://www.kentsmallbusiness.co.uk ) | PHP Version: 5.2.6
PHP Requirements: register_globals: Disabled | magic_quotes_gpc: Enabled | safe_mode: Disabled | MySQL Support: Yes | XML Support: Yes | zlib Support: Yes
mbstring Support (1.5): Yes | iconv Support (1.5): Yes | save.session_path: Writable | Max.Execution Time: 30 seconds | File Uploads: Enabled
MySQL Version: 5.0.67-community ( Localhost via UNIX socket )


Many Thanks Guys, I really need to sort this :)

Gary


Top
 Profile  
 
PostPosted: Sat Feb 07, 2009 1:57 pm 
Joomla! Fledgling
Joomla! Fledgling

Joined: Sat Feb 07, 2009 1:54 pm
Posts: 1
Pro just solved, i read the posts and then changed my /tmp to /temp, and it works! I dont know y i have to do it backward like other people did. But glad to see it works. cheers.


Top
 Profile  
 
PostPosted: Mon Feb 09, 2009 1:37 pm 
Joomla! Apprentice
Joomla! Apprentice

Joined: Fri Jan 30, 2009 12:10 am
Posts: 9
Hello
I am new for Joomla and I have the same problem .

but I couldn't understand what I should do to solve the problem.

should I upload the files of the component or template to " /tmp dir."

please help me


Top
 Profile  
 
PostPosted: Mon Feb 09, 2009 3:17 pm 
User avatar
Joomla! Intern
Joomla! Intern

Joined: Sat May 31, 2008 6:15 pm
Posts: 93
Location: South Africa
In my case it was permission related. I asked my Host to activate CU PHP on this domain giving super admin rights to over the folders/files. Remember that this could create problems with your links, if "search engine friendly" option is selected in the configuration.

I don't know why, but sometimes the server takes ownership of folders and files thus causing the listed error.

Hope it all makes sense.


Top
 Profile  
 
PostPosted: Wed Feb 11, 2009 1:42 am 
Joomla! Apprentice
Joomla! Apprentice

Joined: Wed Jan 07, 2009 5:16 pm
Posts: 5
just wanted to comment on my experience for others who may be like me. the community generally seems supportive enough and I find them a little on edge about helping. I have been on many forums and there is a angst here toward new people, "volunteers" might want to tone it down a bit. Also Joomla is not for you if you don't know how to change file permissions. I know its easy to do but if you have never done it you will end up just trying anything (like giving 777 to everyone... yeah!) to get your site just to install just one component. Don't do it. You risk security nightmares down the road. Just walk away.

The software looks fantastic (it's shiny) and has great promise but you will be better served paying someone to install in and showing you the tweaks needed to get going. This includes security. Once you are up and running things seem easier from there. Make sure you pay attention so you can replicate the process and be a setup guru too!

For me, I give up. I will go the pay route if I even attempt this CMS again. Its not the software's fault its me. I want to be able to install something and have it work without picking apart permissions on this or that or changing temp directories or ssh'ing to chmod anything. The FTP layer promise is what kept me going for weeks... but I have to get on with life.


Top
 Profile  
 
PostPosted: Wed Feb 11, 2009 5:18 am 
User avatar
Joomla! Intern
Joomla! Intern

Joined: Sat May 31, 2008 6:15 pm
Posts: 93
Location: South Africa
Never underestimate the importance of persistence! I learned all i know from this Forum and the peoples contribution. It does not come over night, like everything else. So i want to give thanks to the Joomla community for teaching me Joomla, and I'm still learning, what a JOY when stuff works!


Top
 Profile  
 
PostPosted: Wed Feb 18, 2009 1:49 am 
Joomla! Enthusiast
Joomla! Enthusiast

Joined: Tue Dec 23, 2008 11:04 pm
Posts: 112
THIS HAS TO DO WITH YOUR JOOMLA ACCESSING YOUR FOLDERS.

I am on a windows server oh yay, right yeh right, okay so i get the same error.

WINDOWS
Right click your folder and go to properties, then security. Set your IIS server to have full control over your folder. Click all the little boxes under IIS.

UNIX
you need to do a change mod on certain folders, or change the permission to that folder. See above for which folders.

It is all about access. Mine works great now..


Top
 Profile  
 
PostPosted: Thu Feb 19, 2009 1:24 am 
Joomla! Fledgling
Joomla! Fledgling

Joined: Thu Feb 19, 2009 12:16 am
Posts: 2
I've had the same Issues with windows and linux servers.
JFolder::create 'Path not in open_basedir paths'

For Linux 99% of cases are wrong permissions or the tmp and log directories with the wrong path.
The path could be totally wrong because of a migration from a server to another, rarely by default.
It could also happen that have been set /tmp instead of /path/to/joomla/tmp and the path is not specified in the open basedir.

After all the permissions discussions I've noticed that joomla have a simple bug checking the paths on windows servers.




For checking if I have the permissions to create a folder with the actual limitations of open_basedir
I just try to create a folder.

(ex. myfolder.php in the joomla folder)
Code:
<?php
$path = getcwd();
mkdir($path . '\tmp\alfa');
?>


If the folder can be created it means that probably you've encountered this small bug.

The bug happens because joomla converts all the '/' to '\' for windows while could happen the server administrator uses the / instead of the '\' (ex. c:/domains) in the php.ini.
I personally suggest to the joomla team to use only the / for anything and avoid the windows \ for the paths.

I've printed the relevant data to get the culprit of the error
The file is - \libraries\joomla\filesystem\folder.php -
The loop starts at line 208

An example of the data checked by joomla is
Array ( [0] => c:/domains )
C:\domains\yoursite.com\wwwroot\tmp\install_499ca9ec02e7a

Note that in the configuration I've also tried to add the path with / but they are all converted to \
and the C (of c:) is always uppercase.


Another problem is that uppercase C that even if is not really a bug for windows machines should be better to have a conversion of the data in the right manner with stripos instead of strpos (strpos is the optimal for unix systems).


To be Brief after making sure that your folders have the correct permissions just see if the basedir is correct in the php.ini and in your joomla configuration (for the actual joomla they MUST be with \ for windows servers) and that the first letter of the paths (the [drive] letter) is Uppercase (windows servers) because in most cases in the env variables is Uppercase and joomla checks with Case sentivity (strpos).

Joomla reports always the same errors even if they are different, developers please add some codes. I personally added an error number for each similar error that applies to different things. Maybe joomla needs to send to the joomla system debug more informations about the paths used and checked (I've used the worst manner with the print_r and echoes to debug).

I'm sorry for my poor english and bad explanations.
I hope that in any case you all can solve your problems :)


Last edited by trueliar on Mon Feb 23, 2009 1:37 am, edited 1 time in total.

Top
 Profile  
 
PostPosted: Thu Feb 19, 2009 9:21 am 
User avatar
Joomla! Exemplar
Joomla! Exemplar

Joined: Thu Aug 18, 2005 8:43 pm
Posts: 7986
Location: New York
@trueliar

Would you see if that issue is already in the issue tracker and if not, please post a copy of what you put here as a new issue.
http://joomlacode.org/gf/project/joomla ... cker_id=32

If you don't have a joomlacode account you will need to create one.


Thanks!

_________________
So we must fix our vision not merely on the negative expulsion of war, but upon the positive affirmation of peace. MLK 1964.
http://officialjoomlabook.com Get it at http://www.joomla.org/joomla-press-official-books.html Buy a book, support Joomla!.


Top
 Profile  
 
PostPosted: Thu Feb 19, 2009 12:32 pm 
User avatar
Joomla! Guru
Joomla! Guru

Joined: Thu Jul 06, 2006 12:57 pm
Posts: 702
Location: Stockholm Sweden
trueliar wrote:
I've had the same Issues with windows and linux servers.
JFolder::create 'Path not in open_basedir paths'

For Linux 99% of cases are wrong permissions or the tmp and log directories with the wrong path.
The path could be totally wrong because of a migration from a server to another, rarely by default.
It could also happen that have been set /tmp instead of /path/to/joomla/tmp and the path is not specified in the open basedir.

After all the permissions discussions I've noticed that joomla have a simple bug checking the paths on windows servers....


Well this is very important bcs this is really a problem for many hosting on shared webhosting..Pls report this and also see if this is problems for unix hosts.

_________________
Success in the long run Its not about the code its about the people and community that's make it!
Its not what you say its what you do that matters!

Darb - aka ssnobben


Top
 Profile  
 
PostPosted: Mon Feb 23, 2009 2:34 am 
Joomla! Fledgling
Joomla! Fledgling

Joined: Thu Feb 19, 2009 12:16 am
Posts: 2
darb wrote:
Well this is very important bcs this is really a problem for many hosting on shared webhosting..Pls report this and also see if this is problems for unix hosts.

No, it's not a problem related to *nix hosts.
On *nix systems in most cases it's a permissions problem, a server misconfiguration, a joomla configuration problem (ex. wrong log or tmp folders set).


Top
 Profile  
 
PostPosted: Sat Feb 28, 2009 8:11 pm 
Joomla! Apprentice
Joomla! Apprentice

Joined: Thu Jul 24, 2008 7:17 pm
Posts: 9
I tried everything listed and all failed.

I tried changing my temp directory to
var $tmp_path = '/tmp';

This did not work however I then noticed that the path was incorrect and set to
var $tmp_path = '/home/xxxxx/public_html/tmp';

xxxxx being the name of the hosting reseller I use and not my subfolder on his server, I changed this to my share name and it now works. Seems my install had picked up the hosts name and not my share.

Hope this helps someone!


Top
 Profile  
 
PostPosted: Sat Mar 07, 2009 11:24 am 
Joomla! Apprentice
Joomla! Apprentice

Joined: Sun Feb 01, 2009 3:56 am
Posts: 33
I've been running a 1.5.9 site on Godaddy Linux hosting for about a month with no problems - finally managed to access the site via my FTP client (after Godaddy eventually gave me an answer last night why I couldn't login to it since I opened my acount) so I could bulk upload some photos to my morfeoshow galleries and now suddenly every time I access a page on the site I'm getting JFolder::create: Could not create directory !! Have no clue why it's suddenly started as I haven't changed anything. It doesn't look great for my visitors though when they get the pink bar with the message at the top of all the pages and think they've done something wrong. I checked my config using phpinfo and noticed that open_basedir doesn't appear to be set - could this have any bearing on it and could anyone advise what I can do to get rid of the problem. As far as Joomla system info is concerned all my directories are writable and I have the FTP layer switched off. I'm wondering if accessing the site via FTP has changed the ownership permissions or something like that but I have no idea how to change them back.


Top
 Profile  
 
PostPosted: Sat Mar 07, 2009 5:16 pm 
Joomla! Ace
Joomla! Ace

Joined: Wed Nov 05, 2008 11:28 pm
Posts: 1231
hello dear Folks

Believe it or not - i wanted to throw the computer out of the window!!

I tried all the various suggestions that are related to this problem that I could find in the forums, all to no avail. I did a lot of action to resolve the issues. Finally i did the last thing: set the
safe_mode: disabled

Well - yes to be honest - i also had to put all the folders to 7777 - A big big security hole you may think. Yes, pretty sure but i had no chance... All failed.

If there is anyone still waiting for a good solve? Well my dear: do me one favour: set the safe_mode: disabled
I am pretty sure that you get the thing up and running within only 2 mins: switch off or disable the safe_mode: just switch it to off! And you will be more than happy. You get the thing running.


joo

_________________
regards un-leash,
a big fan for ++ 8 years now: With Joomla you can easily create and extend your website: see the site, that offers you ideas & modules - extensions.joomla.org - it lists over 4000 extensions


Top
 Profile  
 
PostPosted: Sat Mar 07, 2009 5:55 pm 
Joomla! Apprentice
Joomla! Apprentice

Joined: Sun Feb 01, 2009 3:56 am
Posts: 33
Safe mode is already disabled on my server and I still get the error !


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 656 posts ]  Go to page Previous  1 ... 6, 7, 8, 9, 10, 11, 12 ... 22  Next



Who is online

Users browsing this forum: Yahoo [Bot] and 22 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Jump to:  
Powered by phpBB® Forum Software © phpBB Group