Tinymce and 1.5.14

This forum is for general questions about extensions for Joomla! version 1.5.x.

Moderator: General Support Moderators

Forum rules
Forum Rules
Absolute Beginner's Guide to Joomla! <-- please read before posting, this means YOU.
Forum Post Assistant - If you are serious about wanting help, you will use this tool to help you post.
williamstdd
Joomla! Intern
Joomla! Intern
Posts: 61
Joined: Wed May 27, 2009 3:06 am
Location: Camas, WA
Contact:

Tinymce and 1.5.14

Postby williamstdd » Fri Jul 31, 2009 4:11 pm

I just installed and tested 1.5.14 on my test site (using 1.5.10 to 1.5.14 zip) and all went well. After testing, I installed on my production (using the 1.5.11 to 1.5.14 zip) system and tinymce is not working. I have checked the global config, plugin settings and the files that were uploaded and all seems to be in order. Any suggestions?

BTW, the reason for using different upgrade packages was at a different base (for embarrassing reasons I do not want to mention) :-)

Todd
Cheers,
Todd

User avatar
webrp
Joomla! Guru
Joomla! Guru
Posts: 853
Joined: Sat Oct 28, 2006 9:10 pm
Location: Lisbon, Portugal

Re: Tinymce and 1.5.14

Postby webrp » Fri Jul 31, 2009 5:10 pm

I had many poroblems with editor after upgrade from 159 to 1513
I could only solve ALL problems, restoring my previous 159 version...

User avatar
Gotmian
Joomla! Fledgling
Joomla! Fledgling
Posts: 4
Joined: Wed Sep 10, 2008 10:28 am
Contact:

Re: Tinymce and 1.5.14

Postby Gotmian » Fri Jul 31, 2009 11:19 pm

Same problem here...

I upgraded from 1.5.10 to 1.5.13 (and now 1.5.14) and since the first upgrade, the TinyMCE is not working properly.
More than half of the icons on the editor are not visible, and some of the functions are disabled. For example, when i try to make a pic go left of the text, whilst it goes there, after hitting apply or save, the change is reversed and changes are lost.

There are other minor problems with formatting the text too...

Any ideas how to fix this, and WHY a "security" upgrade messed it all? :(

mysuedonym
Joomla! Fledgling
Joomla! Fledgling
Posts: 2
Joined: Sat Aug 01, 2009 1:10 am
Location: Brooklyn, NY
Contact:

Re: Tinymce and 1.5.14

Postby mysuedonym » Sat Aug 01, 2009 1:41 am

I'm having the same problem with tinymce after upgrading from 1.5.10 to 1.5.14. I also noticed that global config shows tinymce version 2.0, not 3.0 (the latest?).

I saw that there's a patch to address some (other?) issues with the editor, but it's related to the 1.5.13 upgrade.
http://joomlacode.org/gf/project/joomla ... m_id=17058

My site is live and I don't have a local version to test the patch out. Can someone let me know if the patch would be useful in this situation?

williamstdd
Joomla! Intern
Joomla! Intern
Posts: 61
Joined: Wed May 27, 2009 3:06 am
Location: Camas, WA
Contact:

Re: Tinymce and 1.5.14

Postby williamstdd » Sat Aug 01, 2009 2:31 am

Good spot to find this. However it did not help.

I also did not notice that only about half of the icons that I should have are on my "good" test site. The test site will allow me to use the editor and save an article, but my live site does not. I have switched to "no editor" and use straight HTML. This is an okay workaround, at this point, since I post everything.

BTW, I also tried re-installing and that did not help either. I thought maybe I screwed something up. Not so lucky.
Cheers,
Todd

User avatar
Gotmian
Joomla! Fledgling
Joomla! Fledgling
Posts: 4
Joined: Wed Sep 10, 2008 10:28 am
Contact:

Re: Tinymce and 1.5.14

Postby Gotmian » Sat Aug 01, 2009 10:06 am

mysuedonym wrote:I'm having the same problem with tinymce after upgrading from 1.5.10 to 1.5.14. I also noticed that global config shows tinymce version 2.0, not 3.0 (the latest?).

I saw that there's a patch to address some (other?) issues with the editor, but it's related to the 1.5.13 upgrade.
http://joomlacode.org/gf/project/joomla ... m_id=17058

My site is live and I don't have a local version to test the patch out. Can someone let me know if the patch would be useful in this situation?

So, now what? Is there a way for us to install and overwrite the current version to the latest one, or in any other way fix the issue? :(

williamstdd
Joomla! Intern
Joomla! Intern
Posts: 61
Joined: Wed May 27, 2009 3:06 am
Location: Camas, WA
Contact:

Re: Tinymce and 1.5.14

Postby williamstdd » Sat Aug 01, 2009 1:00 pm

So, now what? Is there a way for us to install and overwrite the current version to the latest one, or in any other way fix the issue?

Try another editor (i.e. XStandard Lite 2.0), use HTML or do a restore to your previous version. you can also try to determine where the problem is and suggest/create a fix for the problem.
Cheers,
Todd

rongdhonu
Joomla! Apprentice
Joomla! Apprentice
Posts: 7
Joined: Wed Jul 29, 2009 1:45 pm

Re: Tinymce and 1.5.14

Postby rongdhonu » Sat Aug 01, 2009 3:57 pm

I had same problem and i only restored tinymce pluing folder

williamstdd
Joomla! Intern
Joomla! Intern
Posts: 61
Joined: Wed May 27, 2009 3:06 am
Location: Camas, WA
Contact:

Re: Tinymce and 1.5.14

Postby williamstdd » Sat Aug 01, 2009 4:52 pm

That worked on my test site...after I remember to copy the two tinymce files in the editor directory.
Cheers,
Todd

User avatar
Hils
Joomla! Enthusiast
Joomla! Enthusiast
Posts: 181
Joined: Mon Aug 22, 2005 3:31 pm
Location: Norfolk, UK
Contact:

Re: Tinymce and 1.5.14

Postby Hils » Sat Aug 01, 2009 6:28 pm

Just an observation: these were, amongst other things, security updates. The security vulnerabilities have been published for all to see (including hackers). Reverting to older Joomla! versions because of a WYSIWYG editor seems perhaps foolish? JCE Editor never stopped working and it's free.

Hils
Member of the OpenTranslators Team
http://opentranslators.org

elmagistral
Joomla! Apprentice
Joomla! Apprentice
Posts: 11
Joined: Fri Mar 14, 2008 7:07 pm

Re: Tinymce and 1.5.14

Postby elmagistral » Sun Aug 02, 2009 3:36 am

This has been answered in this post, and a way to correct it and to all icons to appear is:

You may want to check here:

Extensions > Plugin Manager > Editor - TinyMCE 2.0 > Parameters > Plugin Parameters > Functionality: change to Extended from Simple or Advanced > Save :)

User avatar
Gotmian
Joomla! Fledgling
Joomla! Fledgling
Posts: 4
Joined: Wed Sep 10, 2008 10:28 am
Contact:

Re: Tinymce and 1.5.14

Postby Gotmian » Mon Aug 03, 2009 10:11 pm

elmagistral wrote:This has been answered in this post, and a way to correct it and to all icons to appear is:

You may want to check here:

Extensions > Plugin Manager > Editor - TinyMCE 2.0 > Parameters > Plugin Parameters > Functionality: change to Extended from Simple or Advanced > Save :)

Wow NICE :)

Thanks for the tip!!!! :)

User avatar
imanickam
Joomla! Master
Joomla! Master
Posts: 24553
Joined: Wed Aug 13, 2008 2:57 am
Location: Chennai, India

Re: Tinymce and 1.5.14

Postby imanickam » Mon Aug 03, 2009 10:43 pm

One more setting may help you in terms of code in the content. Look at the discussion http://forum.joomla.org/viewtopic.php?f=431&t=426904.
- Ilagnayeru (MIG) Manickam
http://www.eegan.org - helping the poor and underprivileged
educate. empower. enrich.
Support the poor and underprivileged

Ace_ov_Spade
Joomla! Apprentice
Joomla! Apprentice
Posts: 9
Joined: Fri Aug 15, 2008 2:42 am

Re: Tinymce and 1.5.14

Postby Ace_ov_Spade » Sat Aug 15, 2009 4:25 am

I tried to change the functionality to extended did not work. looks to be the file not found.. and got error like:
Probable reasons are:

* You sent a plain HTTP request to an SSL-enabled server port. Instead please use the HTTPS protocol to access this URL, like this: https://example.com:8443/
* You made a typo in the request, e.g., typed a comma instead of a colon. Please re-check the URL.


then I changed the params of tinymce[plugin table] theme=extended [from theme=advanced] but did not work.

does anyone have any idea?

brolzy
Joomla! Fledgling
Joomla! Fledgling
Posts: 3
Joined: Wed Feb 25, 2009 9:17 pm

Re: Tinymce and 1.5.14

Postby brolzy » Sat Aug 29, 2009 3:21 am

elmagistral wrote:This has been answered in this post, and a way to correct it and to all icons to appear is:

You may want to check here:

Extensions > Plugin Manager > Editor - TinyMCE 2.0 > Parameters > Plugin Parameters > Functionality: change to Extended from Simple or Advanced > Save :)


Thank you so much for that...I was going nuts trying to solve this myself. :)

kb1lqd
Joomla! Apprentice
Joomla! Apprentice
Posts: 8
Joined: Mon Jun 22, 2009 8:34 pm

Re: Tinymce and 1.5.14

Postby kb1lqd » Sun Aug 30, 2009 6:25 pm

Hmmm I have been having the same issues. No one can edit from the front end or back end and when you open the editor the cursor in center aligned for some weird reason and when you submit the article is just sits there. I do have the firefox web developer toolbar and get the following error when clicking the submit button:

Javascript error TinyMCE.activeEditor is undefined

I resolved this issue while we were still writing the website by reverting back to 1.5.12 but I really want to avoid that now that it is open. If needed the website is question is www.collegearc.com

I hope this information helps find a solution as it seems many people are seeing the same error!

baparks
Joomla! Intern
Joomla! Intern
Posts: 89
Joined: Fri Mar 09, 2007 5:13 pm

Re: Tinymce and 1.5.14

Postby baparks » Mon Sep 07, 2009 2:22 pm

Hils wrote:Just an observation: these were, amongst other things, security updates. The security vulnerabilities have been published for all to see (including hackers). Reverting to older Joomla! versions because of a WYSIWYG editor seems perhaps foolish? JCE Editor never stopped working and it's free.

Hils


Tried replacing with JCE. Still not working. ANy other suggestion?

tantosolo
Joomla! Fledgling
Joomla! Fledgling
Posts: 1
Joined: Sat Jan 10, 2009 3:36 pm

Re: Tinymce and 1.5.14

Postby tantosolo » Mon Oct 19, 2009 4:22 am

Thank you very very much...

frisbee
Joomla! Fledgling
Joomla! Fledgling
Posts: 2
Joined: Wed Jan 28, 2009 7:08 pm

Re: Tinymce and 1.5.14

Postby frisbee » Tue Oct 20, 2009 1:58 pm

elmagistral wrote:This has been answered in this post, and a way to correct it and to all icons to appear is:

You may want to check here:

Extensions > Plugin Manager > Editor - TinyMCE 2.0 > Parameters > Plugin Parameters > Functionality: change to Extended from Simple or Advanced > Save :)



Thank you soooooooo much!!!!!


Return to “Extensions for Joomla! 1.5”

Who is online

Users browsing this forum: No registered users and 11 guests