Why H1 tag not recognized in logo image?

Discuss Search Engine Optimization in relation to Joomla!. This forum will also have discussions on SEF/SEO Joomla! extensions.

Moderator: General Support Moderators

nic2009
Joomla! Enthusiast
Joomla! Enthusiast
Posts: 104
Joined: Thu Mar 19, 2009 11:51 am

Re: Why H1 tag not recognized in logo image?

Postby nic2009 » Wed Jan 25, 2012 12:29 pm

Ok, done... H1 tag is recognized, h1 tag text visible in black and logo disappeared... ;-)

And now...?

Harvey51
Joomla! Explorer
Joomla! Explorer
Posts: 295
Joined: Tue Feb 23, 2010 8:16 pm
Location: Lancaster UK
Contact:

Re: Why H1 tag not recognized in logo image?

Postby Harvey51 » Wed Jan 25, 2012 12:41 pm

I can see, you need to reduce the h1 slightly and put this html tag before the image:

<br />

here's the code with the break added, but you still need to reduce the h1 to one line.

<div id="logo"><h1>Fkk und Saunaclubs in Deutschland, Österreich und der Schweiz<br />
<a title="Fkk und Saunaclubs in Deutschland, Österreich und der Schweiz" href="/index.php">
<img title="FKK und Saunaclubs in Deutschland, Österreich und der Schweiz" alt="FKK und Saunaclubs in Deutschland, Österreich und der Schweiz" src="http://www.saunaclub.info/templates/ict_sunset/images/logo.png" /></a></h1>
</div>
Joomla Expert http://www.deanmarshall.co.uk/joomla-expert.html Expert Joomla Development and Support
Music For Schools http://www.musicforschoolsltd.co.uk/ Primary Schools Summer Musicals

nic2009
Joomla! Enthusiast
Joomla! Enthusiast
Posts: 104
Joined: Thu Mar 19, 2009 11:51 am

Re: Why H1 tag not recognized in logo image?

Postby nic2009 » Wed Jan 25, 2012 12:50 pm

Ok, I placed the amended code, but nothing changed...

What do you mean with 'reducing the h1 to one line'? If this would mean to have the whole code in one line, I did this also... same result...

Please advice.

Harvey51
Joomla! Explorer
Joomla! Explorer
Posts: 295
Joined: Tue Feb 23, 2010 8:16 pm
Location: Lancaster UK
Contact:

Re: Why H1 tag not recognized in logo image?

Postby Harvey51 » Wed Jan 25, 2012 12:53 pm

A slight change to the CSS provided:

From this:

#logo h1 a {
display: block;
text-indent: -5000px;
text-decoration: none;
}

To this:

#logo h1 {
display: block;
text-indent: -5000px;
text-decoration: none;
}
Joomla Expert http://www.deanmarshall.co.uk/joomla-expert.html Expert Joomla Development and Support
Music For Schools http://www.musicforschoolsltd.co.uk/ Primary Schools Summer Musicals

Harvey51
Joomla! Explorer
Joomla! Explorer
Posts: 295
Joined: Tue Feb 23, 2010 8:16 pm
Location: Lancaster UK
Contact:

Re: Why H1 tag not recognized in logo image?

Postby Harvey51 » Wed Jan 25, 2012 12:59 pm

Change one line of CSS and it's fixed

template_css.css (line 466)

From this

#logo, img#logo {
border: 0 none;
left: 0;
position: absolute;
top: 5px;
z-index: 9;
}

To this

#logo, img#logo {
border: 0 none;
left: 0;
position: absolute;
top: -38px;
z-index: 9;
}

Done!

Their is a slight display glitch, the CSS to correct this could be better, I will have a look and hopefully come back with a better answer, but for now it works.
Joomla Expert http://www.deanmarshall.co.uk/joomla-expert.html Expert Joomla Development and Support
Music For Schools http://www.musicforschoolsltd.co.uk/ Primary Schools Summer Musicals

nic2009
Joomla! Enthusiast
Joomla! Enthusiast
Posts: 104
Joined: Thu Mar 19, 2009 11:51 am

Re: Why H1 tag not recognized in logo image?

Postby nic2009 » Wed Jan 25, 2012 1:04 pm

Ok, h1 tag text is recognized and not displayed, but logo is not visible...

Seems we are close... ;-)

Harvey51
Joomla! Explorer
Joomla! Explorer
Posts: 295
Joined: Tue Feb 23, 2010 8:16 pm
Location: Lancaster UK
Contact:

Re: Why H1 tag not recognized in logo image?

Postby Harvey51 » Wed Jan 25, 2012 1:19 pm

You just need to remove the 'a' in the snippet of CSS I gave you.

From this:

#logo h1 a

To this:

#logo h1
Joomla Expert http://www.deanmarshall.co.uk/joomla-expert.html Expert Joomla Development and Support
Music For Schools http://www.musicforschoolsltd.co.uk/ Primary Schools Summer Musicals

nic2009
Joomla! Enthusiast
Joomla! Enthusiast
Posts: 104
Joined: Thu Mar 19, 2009 11:51 am

Re: Why H1 tag not recognized in logo image?

Postby nic2009 » Wed Jan 25, 2012 1:22 pm

I did change it back... no change.

Harvey51
Joomla! Explorer
Joomla! Explorer
Posts: 295
Joined: Tue Feb 23, 2010 8:16 pm
Location: Lancaster UK
Contact:

Re: Why H1 tag not recognized in logo image?

Postby Harvey51 » Wed Jan 25, 2012 1:33 pm

When I look in Firebug, I see this:

template_css.css (line 68)
#logo h1 a {
display: block;
text-indent: -5000px;
text-decoration: none;
}

If you've removed the 'a' and it's still showing, which it shouldn't, try clearing the cache in the backend of the site.

Administrator > Tools > Clean Cache > check all and delete.

This should not be the issue, but give it ago.

Just to reiterate, when I use Firebug I see the CSS attached to the anchor not the h1.
Joomla Expert http://www.deanmarshall.co.uk/joomla-expert.html Expert Joomla Development and Support
Music For Schools http://www.musicforschoolsltd.co.uk/ Primary Schools Summer Musicals

nic2009
Joomla! Enthusiast
Joomla! Enthusiast
Posts: 104
Joined: Thu Mar 19, 2009 11:51 am

Re: Why H1 tag not recognized in logo image?

Postby nic2009 » Wed Jan 25, 2012 1:47 pm

Ok, sorry, changed the wrong one. Now h1 tag is recognized and the logo is visible...

Could it be that there is still a slight glitch as I see a fine line just above the logo... or is it the logo Jpeg?

Anyway, your support in this issue was much appreciated and I would like to say again a thousand thanks...

Harvey51
Joomla! Explorer
Joomla! Explorer
Posts: 295
Joined: Tue Feb 23, 2010 8:16 pm
Location: Lancaster UK
Contact:

Re: Why H1 tag not recognized in logo image?

Postby Harvey51 » Wed Jan 25, 2012 1:57 pm

Not a problem.

The display glitch is your image, you could crop the top one or two pixels off the image, this might then require a slight change to your CSS (top: -38px;), this amount might require a tweak.

Good luck.
Joomla Expert http://www.deanmarshall.co.uk/joomla-expert.html Expert Joomla Development and Support
Music For Schools http://www.musicforschoolsltd.co.uk/ Primary Schools Summer Musicals

CarolWales
Joomla! Apprentice
Joomla! Apprentice
Posts: 13
Joined: Thu Oct 06, 2011 8:12 am

Re: Why H1 tag not recognized in logo image?

Postby CarolWales » Mon Jan 30, 2012 1:29 pm

Along with adding the H1 tag, it is also important to chek all the attributes of the on page optimization of your website in order to get the best results through online marketing strategies.


Return to “Search Engine Optimization (Joomla! SEO) in Joomla! 1.5”

Who is online

Users browsing this forum: No registered users and 7 guests