module not shown at all when using rtl template

General questions regarding the use of languages in Joomla! 2.5.

Moderators: infograf768, General Support Moderators

Forum rules
Forum Rules
Absolute Beginner's Guide to Joomla! <-- please read before posting, this means YOU.
Forum Post Assistant - If you are serious about wanting help, you will use this tool to help you post.
lord alaa
Joomla! Apprentice
Joomla! Apprentice
Posts: 26
Joined: Tue Sep 20, 2011 11:07 am
Contact:

module not shown at all when using rtl template

Postby lord alaa » Sat Apr 07, 2012 8:32 am

Hi, I hope I posted in the right place.

After I made my site a multilingual site, all languages worked fine.

But I had a problem with the "rtl direction" language;which is: The slideshow module not shown at all when using rtl template

the firebug console debugger shows this message:

Code: Select all

Script suspended on line 1 in anonymous, file "module_name".js
detailed error: 
JCaption is not defined
onClick()                                                                                  /altai...php/ar/ (line 1)
d()                                                                                      mootools-core.js (line 367)
   k = Object { event=Event load, $extended=true, type="load", more...}
e()                                                                                      mootools-core.js (line 368)
   k = Object { event=Event load, $extended=true, type="load", more...}



note: that the slideshow flashes at first then disappear; and when I change the live css to left or right or so....; it comes and goes but not in any acceptable way.

I surfed the internet looking for solution; I didn't find even a tiny clue.

any replays would be appreciated.
great thanks in advance.

User avatar
infograf768
Joomla! Master
Joomla! Master
Posts: 17988
Joined: Fri Aug 12, 2005 3:47 pm
Location: **Translation Matters**

Re: module not shown at all when using rtl template

Postby infograf768 » Sat Apr 07, 2012 8:55 am

1. Which version of Joomla are you using?
2. Which template ?
Jean-Marie Simonet / infograf · http://www.info-graf.fr
Multilanguage in 2.5: http://help.joomla.org/files/EN-GB_multilang_tutorial.pdf
---------------------------------
ex-Joomla Translation Coordination Team • ex-Joomla! Production Working Group

lord alaa
Joomla! Apprentice
Joomla! Apprentice
Posts: 26
Joined: Tue Sep 20, 2011 11:07 am
Contact:

Re: module not shown at all when using rtl template

Postby lord alaa » Sat Apr 07, 2012 8:59 am

joomla version: 2.5
template: zt_hemi

lord alaa
Joomla! Apprentice
Joomla! Apprentice
Posts: 26
Joined: Tue Sep 20, 2011 11:07 am
Contact:

Re: module not shown at all when using rtl template

Postby lord alaa » Sat Apr 07, 2012 9:05 am


lord alaa
Joomla! Apprentice
Joomla! Apprentice
Posts: 26
Joined: Tue Sep 20, 2011 11:07 am
Contact:

Re: module not shown at all when using rtl template

Postby lord alaa » Sat Apr 07, 2012 9:27 am

Hope you take a look a look at the demo.
note that the RTL language works Correctly.

As I think it's a JavaScript thing.
or the module just need to be adjusted for RTL direction.

Any suggestions would be very appreciated :).

User avatar
infograf768
Joomla! Master
Joomla! Master
Posts: 17988
Joined: Fri Aug 12, 2005 3:47 pm
Location: **Translation Matters**

Re: module not shown at all when using rtl template

Postby infograf768 » Sat Apr 07, 2012 1:08 pm

Last Joomla version is 2.5.4
Please update first and test.
Jean-Marie Simonet / infograf · http://www.info-graf.fr
Multilanguage in 2.5: http://help.joomla.org/files/EN-GB_multilang_tutorial.pdf
---------------------------------
ex-Joomla Translation Coordination Team • ex-Joomla! Production Working Group

lord alaa
Joomla! Apprentice
Joomla! Apprentice
Posts: 26
Joined: Tue Sep 20, 2011 11:07 am
Contact:

Re: module not shown at all when using rtl template

Postby lord alaa » Sat Apr 07, 2012 1:42 pm

infograf768 wrote:Last Joomla version is 2.5.4
Please update first and test.


Code: Select all

No updates available

You already have the latest Joomla! version, 2.5.4.


my joomla version up to date.

it looks like a blocked way.
I tried almost every thing

I neeed a solution

the disappoint point here is that this kind problems Appears at last.

I'll keep looking and predicting a clue here.

thnks for your concern ,
waiting & working

oc666
Joomla! Enthusiast
Joomla! Enthusiast
Posts: 215
Joined: Wed Oct 10, 2007 9:46 am
Location: Israel, TA
Contact:

Re: module not shown at all when using rtl template

Postby oc666 » Sat Apr 07, 2012 8:53 pm

Can I see it in action for debugging purpose?
http://www.embad.com - new way to insert ads to your website

lord alaa
Joomla! Apprentice
Joomla! Apprentice
Posts: 26
Joined: Tue Sep 20, 2011 11:07 am
Contact:

Re: module not shown at all when using rtl template

Postby lord alaa » Sun Apr 08, 2012 7:22 am

bad lock, nothing available online for the meantime.

MR. infograf768 I have a question if you may

my problem is a template supports the RTL languages have a mdule _which I added_ not supporting the RTL Direction

I think I need a tow lines of php code will be added to the module which checks the page direction and do the right CSS & JS reassignments, relocation, right to left and Vice versa

may be other possibility which is more common that the positions Conflict with the slideshow, so I need to disable the RTL direction for the slideshow position.

Any help,_even a clue_ would be highly appreciated.

User avatar
infograf768
Joomla! Master
Joomla! Master
Posts: 17988
Joined: Fri Aug 12, 2005 3:47 pm
Location: **Translation Matters**

Re: module not shown at all when using rtl template

Postby infograf768 » Mon Apr 09, 2012 10:23 am

If you follow the API and install your css and js files in media/mod_mymodule/...,

Basic code to integrate is something like:

Code: Select all

$lang = JFactory::getLanguage();
if ($lang->isRTL()) {
JHtml::_('stylesheet', 'mod_mymodule/css/mycss.css', array(), true);
JHtml::_('script', mod_mymodule/js/myjs.js', true, true);
}
Jean-Marie Simonet / infograf · http://www.info-graf.fr
Multilanguage in 2.5: http://help.joomla.org/files/EN-GB_multilang_tutorial.pdf
---------------------------------
ex-Joomla Translation Coordination Team • ex-Joomla! Production Working Group

ced1870
Joomla! Enthusiast
Joomla! Enthusiast
Posts: 126
Joined: Sun Oct 19, 2008 10:18 am
Location: Alsace
Contact:

Re: module not shown at all when using rtl template

Postby ced1870 » Mon Apr 09, 2012 2:33 pm

Hi
I had the same issue with my slideshow module, I had to remove the text-align:left; in the css to display the images with RTL
Hope it helps
CEd
Tutorials, extensions, design and template for Joomla!
http://www.joomlack.fr
Maximenu_CK for drop-down, multicolumn, link description, module loading, and documentation
Template Creator CK - the Joomla! component to create your own templates

lord alaa
Joomla! Apprentice
Joomla! Apprentice
Posts: 26
Joined: Tue Sep 20, 2011 11:07 am
Contact:

Re: module not shown at all when using rtl template

Postby lord alaa » Tue Apr 10, 2012 6:45 pm

thank you all for your help.
infograf768, I used the first two lines of your code, it worked perfectly
I just needed a clue, and you gave me that.

great thanks.

lord alaa
Joomla! Apprentice
Joomla! Apprentice
Posts: 26
Joined: Tue Sep 20, 2011 11:07 am
Contact:

Re: module not shown at all when using rtl template

Postby lord alaa » Tue Apr 10, 2012 6:54 pm

ced1870, my site is more complicated than just remove a "text-align" :D
even though i tried :),
thank you very much for your replay, it meant a lot.

kind regards.

telme
Joomla! Apprentice
Joomla! Apprentice
Posts: 32
Joined: Tue Apr 16, 2013 6:06 am

Re: module not shown at all when using rtl template

Postby telme » Sat Sep 14, 2013 8:00 pm

lord alaa wrote:But I had a problem with the "rtl direction" language;which is: The slideshow module not shown at all when using rtl template
Hello!
Which templates are now RTL compatible?


Return to “Language - Joomla! 2.5”

Who is online

Users browsing this forum: No registered users and 2 guests