The Joomla! Forum ™



Forum rules


Forum Rules
Absolute Beginner's Guide to Joomla! <-- please read before posting, this means YOU.
Forum Post Assistant - If you are serious about wanting help, you will use this tool to help you post.



Post new topic Reply to topic  [ 2 posts ] 
Author Message
PostPosted: Sun Jul 24, 2011 6:01 pm 
Joomla! Enthusiast
Joomla! Enthusiast

Joined: Thu Oct 04, 2007 5:32 am
Posts: 237
Hi there. I'm currently taking a VERY old/mature travel site and turning it into a Joomla 1.7. It's currently just static. In an effort to not lose my SEO and the existing names of the pages, I'm trying to duplicate the exact page names into my Joomla. However, almost all of my page names have an underscore (_) in the names as to separate names, rather than a dash (-). So when creating my pages and using the alias it simply removes the underscore and places the words together. It does not allow me to use underscore in my alias. Is there anyway at all to get around this? I really don't want to lose all my pages in the search engines. Many of these individual pages are ranked well. Thanks for any advice! :-[


Top
 Profile  
 
PostPosted: Wed Sep 21, 2011 2:06 am 
Joomla! Apprentice
Joomla! Apprentice

Joined: Mon Mar 16, 2009 6:00 am
Posts: 6
Hi,

I encounted the same problem but found a solution.

When creating article titles i set the alias as per previous page name e.g "travel_event"
Now Joomla will rewrite this as "travel-event" This is fine.
Then i installed sh404SEF and in the "basic configuration" tab of the "sh404SEF configuration" i used the "character replacements list to add " -|_ ", this replaced all - with _.
Then set the "file suffix" to .html which gave my old site page name "travel_event.html"

N.B. If you change the character replace setting first you will need to make you article alias with a dash eg. travel-event. Otherwise the replace setting will replace that - with the _ in alias field which will then cause Joomla alias system to strip the _ again. So create alias with - and this will work. Or create all you alias before installing and setting up sh404SEF and that will work too.

I hope this helps.

I found a few posts looking for this solution, so hopefully they find it.


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 2 posts ] 



Who is online

Users browsing this forum: No registered users and 10 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Jump to:  
Powered by phpBB® Forum Software © phpBB Group