The Joomla! Forum ™



Forum rules


Forum Rules
Absolute Beginner's Guide to Joomla! <-- please read before posting, this means YOU.
Forum Post Assistant - If you are serious about wanting help, you will use this tool to help you post.



Post new topic Reply to topic  [ 3 posts ] 
Author Message
PostPosted: Thu Aug 11, 2011 12:25 pm 
Joomla! Intern
Joomla! Intern

Joined: Thu Jun 18, 2009 5:03 pm
Posts: 98
Hi there, I'm not sure if this is the right forum for my question, but I saw none that fitted better.

I want to include an editor (TinyMCE, CodeMirror, ...) in my (self-developed) component; I followed the guide from the docs for this, but instead of a nice editor, I just get a blank space where it should be; there seems to be some kind of textarea - because I can enter text there, but all the formatting stuff is missing; i do however see the "buttons" below the editor, but just as text; see the attached screenshot. Firebug shows an iframe, but I can't view its content below the <html> tag...

Anybodoy got an idea what's wrong here? Am I maybe missing some more script inclusions (I do have the 'includes/js/joomla.javascript.js' included)?


You do not have the required permissions to view the files attached to this post.


Top
 Profile  
 
PostPosted: Thu Sep 01, 2011 8:34 pm 
Joomla! Intern
Joomla! Intern

Joined: Thu Jun 18, 2009 5:03 pm
Posts: 98
Must have confused something, now it works.
What I still can't get to work though are the buttons below the editor, I guess those are intended for the backend only?
I'll just hide them for the moment.


Top
 Profile  
 
PostPosted: Fri Sep 02, 2011 11:42 am 
Joomla! Intern
Joomla! Intern

Joined: Thu Jun 18, 2009 5:03 pm
Posts: 98
One other thing: 'description' doesn't seem to work as editor name; this results in an javascript error (tinymce.get('description') is not defined). Either the name's too long, or description is some kind of reserved word...
And I now found the reason why the editor was empty: For the user I checked with the first time, CodeMirror was configured as default editor - that editor doesn't seem to work in the frontend.


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 3 posts ] 



Who is online

Users browsing this forum: No registered users and 19 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Jump to:  
Powered by phpBB® Forum Software © phpBB Group