The Joomla! Forum ™



Forum rules


Forum Rules
Absolute Beginner's Guide to Joomla! <-- please read before posting, this means YOU.
Forum Post Assistant / FPA - If you are serious about wanting help, you will use this tool to help you post.



Post new topic Reply to topic  [ 3 posts ] 
Author Message
PostPosted: Fri Apr 06, 2012 1:17 pm 
Joomla! Fledgling
Joomla! Fledgling

Joined: Fri Apr 06, 2012 12:56 pm
Posts: 3
Hello, I assist someone in running multiple joomla sites. that unfortunately are in in old versions and not upgraded yet. All these site are production sites for businesses so downtime is not an option if something goes wrong.

One site is running 1.7.3. About a month ago we tried to upgrade it to 2.5, and it seemed like it worked, but it was a disaster the next day. Clients could not login, do to what looked like a compatibility problem with "Admin Tools", so we had to roll the site back to 1.7.3. Obviously this has made us extremely gun shy about upgrading.

one question I have is I see all the high security alerts for 2.5, and i'm still sitting at 1.7.3. They are High severity, but not deemed as critical. Obviously, i need to help in upgrading this eventually again, but the owner does not have a lot $ to pay for time to do the upgrade right now and test it. How hard should i push to get these upgraded to 2.5.

The owner also has some older sites running 1.5.21. The tricky part of this is that it is running Joomla Multi Site. So upgrading this is even more trickier. These sites have been running fine for 2 years, and I really don't want to touch them, as there is a large number based here. Is 1.5.21 a safe version to stay at, even though I have seen couple of security alerts.

thanks for the information, I love joomla, but I do not enjoy the complexity with the spider of compatibility issues that arrise with security updates and component versions. It is complicated.


Top
 Profile  
 
PostPosted: Mon Apr 09, 2012 2:53 am 
User avatar
Joomla! Master
Joomla! Master

Joined: Mon Aug 29, 2005 10:17 am
Posts: 13811
Location: Netherlands/ UK/ S'pore/Jakarta/ North America
Well you have little choice. Your Joomla 1.5.21 websites are extremely vulnerable since all upgrades from Joomla 1.5.15 onwards have been security updates. This means that your site(s) is having huge security risks and one of these days you are going to be in deep, deep trouble and than $ are going to be a lot more! So like it or not but you need to upgrade to Joomla 1.5.26 (!!!)

Re your Joomla 1.7.3 same issue.... Joomla 1.7 is End of Life, is known to be full of security issues and you are playing with 'your life' of the site! And I do not understand your hesitation. Upgrade from m1.7 to 2.5 goes with a cick on a button and if you follow the guide I have written in the migration forum (first sticky) it is not a big deal.. Couple of clicks of your mouse. Extensions not compatible with Joomla 2.5? Good reason to get rid of them!

So your choice: Stand still or get whacked, hacked and loose your sites OR have a secure environment and migrate 1.5 to 2.5 and upgrade your Joomla sites

Leo 8)

_________________
-- Joomla Professional Support Services : http://gws-desk.com --
-- Good & Cheap Joomla Sites Ready To Roll : http://gws-deals.today --
-- Joomla Specialized Hosting Solutions : www.gws-host.com --
-- Member Joomla Bug Squad --


Top
 Profile  
 
PostPosted: Mon Apr 09, 2012 10:35 am 
Joomla! Fledgling
Joomla! Fledgling

Joined: Fri Apr 06, 2012 12:56 pm
Posts: 3
Thanks for the feedback. That is what I feared.


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 3 posts ] 



Who is online

Users browsing this forum: No registered users and 24 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Jump to:  
Powered by phpBB® Forum Software © phpBB Group