The Joomla! Forum ™



Forum rules


Forum Rules
Absolute Beginner's Guide to Joomla! <-- please read before posting, this means YOU.
Forum Post Assistant - If you are serious about wanting help, you will use this tool to help you post.



Post new topic Reply to topic  [ 12 posts ] 
Author Message
PostPosted: Tue Nov 13, 2012 9:38 pm 
Joomla! Apprentice
Joomla! Apprentice

Joined: Tue Nov 13, 2012 2:47 pm
Posts: 9
Hello,

I just deployed Joomla via the Web Platform Installer (Command Line) and when browsing to the site it just displays the error below. This is definitely a Joomla error page and not just the standard IIS 500 error. I've re-installed but the results are the same.

Some research leads me to believe the template it is trying to use is not compatible with the version installed?

Is anyone else able to install Joomla via the WebPi with success?

Quote:
Error: 500
You may not be able to visit this page because of:

an out-of-date bookmark/favourite
a search engine that has an out-of-date listing for this site
a mistyped address
you have no access to this page
The requested resource was not found.
An error has occurred while processing your request.
Please try one of the following pages:

Home Page
Search this site
If difficulties persist, please contact the System Administrator of this site and report the error below..

JHtml: :behavior not supported. File not found.


Top
 Profile  
 
PostPosted: Wed Nov 14, 2012 3:47 pm 
Joomla! Apprentice
Joomla! Apprentice

Joined: Tue Nov 13, 2012 2:47 pm
Posts: 9
Is there any more detailed Joomla error logging I can look into why this is failing to load after deployment?

How can I see what version of Joomla is being installed and the version of templates it is trying to use?


Top
 Profile  
 
PostPosted: Wed Nov 14, 2012 6:35 pm 
User avatar
Joomla! Master
Joomla! Master

Joined: Wed Aug 17, 2005 10:27 pm
Posts: 14715
Location: Kent, England
[Mod Note: Your duplicate topics have been merged. Do not simply multiple post your issues. Whilst you noticed your mistake you compounded it by reposting to the correct forum on top of what you had already written! ;)]

awoms wrote:
Is there any more detailed Joomla error logging I can look into why this is failing to load after deployment?

How can I see what version of Joomla is being installed and the version of templates it is trying to use?


Please run the Forum Post Assistant to provide the information to help us try and resolve the issue.
Just in case this throws up anything specific and therefore useful from the server configuration.
Please follow the instructions in the post and the program pack closely.


Top
 Profile  
 
PostPosted: Wed Nov 14, 2012 7:01 pm 
Joomla! Apprentice
Joomla! Apprentice

Joined: Tue Nov 13, 2012 2:47 pm
Posts: 9
Hello,

The 2 posts were separate, unrelated issues, thus the separate postings.

Issue #1 is WebPiCmd detecting SQL mode instead of MySQL mode - which appears to be an issue with WebPi itself as I posted.

Issue #2 is Joomla displaying a custom 500 error once a deployment is successful.


Top
 Profile  
 
PostPosted: Wed Nov 14, 2012 8:03 pm 
User avatar
Joomla! Master
Joomla! Master

Joined: Wed Aug 17, 2005 10:27 pm
Posts: 14715
Location: Kent, England
Apologies for the confusion so I assume your other thread is resolved then if you have completed the installation?


Top
 Profile  
 
PostPosted: Wed Nov 14, 2012 8:42 pm 
Joomla! Apprentice
Joomla! Apprentice

Joined: Tue Nov 13, 2012 2:47 pm
Posts: 9
The cmdline parameter answer file issue is being addressed with Microsoft.

The 500 error issue is still present when we deploy without using an answer file.

I'm beginning to think it's an issue with the PHP version or config on this environment...

Forum Post Assistant (v1.2.3) : 14th November 2012 wrote:
Basic Environment :: wrote:
Joomla! Instance :: Joomla! 2.5.6-Stable (Ember) 19-June-2012
Joomla! Platform :: Joomla Platform 11.4.0-Stable (Brian Kernighan) 03-Jan-2012
Joomla! Configured :: Yes | Writable (666) | Owner: 0 (uid: /gid: ) | Group: 0 (gid: ) | Valid For: 1.5
Configuration Options :: Offline: 0 | SEF: 0 | SEF Suffix: 0 | SEF ReWrite: 0 | .htaccess/web.config: Yes | GZip: 0 | Cache: 0 | FTP Layer: 0 | SSL: N/A | Error Reporting: -1 | Site Debug: 0 | Language Debug: 0 | Default Access: N/A | Unicode Slugs: N/A | Database Credentials Present: Yes

Host Configuration :: OS: Windows NT | OS Version: 6.1 | Technology: i586 | Web Server: Microsoft-IIS/7.5 | Encoding: gzip,deflate,sdch | Doc Root: //FSC01-S06/WWWROOT$/test.com/wwwroot | System TMP Writable: Yes

PHP Configuration :: Version: 5.3.18 | PHP API: cgi-fcgi | Session Path Writable: Unknown | Display Errors: | Error Reporting: 30719 | Log Errors To: C:\WINDOWS\Temp\php_errors.log | Last Known Error: 14th November 2012 14:38:14. | Register Globals: | Magic Quotes: | Safe Mode: | Open Base: | Uploads: 1 | Max. Upload Size: 28M | Max. POST Size: 28M | Max. Input Time: 120 | Max. Execution Time: 120 | Memory Limit: 256M

MySQL Configuration :: Version: 5.5.28 (Client:mysqlnd 5.0.8-dev - 20102224 - $Id: 65fe78e70ce53d27a6cd578597722950e490b0d0 $) | Host: --protected-- (--protected--) | Collation: utf8_general_ci (Character Set: utf8) | Database Size: 3.58 MiB | #of Tables:  61
Detailed Environment :: wrote:
PHP Extensions :: Core (5.3.18) | bcmath () | calendar () | ctype () | date (5.3.18) | ereg () | filter (0.11.0) | ftp () | hash (1.0) | iconv () | json (1.2.1) | mcrypt () | SPL (0.2) | odbc (1.0) | pcre () | Reflection ($Id: 593a0506b01337cfaf9f63ebc12cd60523fc2c41 $) | session () | standard (5.3.18) | mysqlnd (mysqlnd 5.0.8-dev - 20102224 - $Id: 65fe78e70ce53d27a6cd578597722950e490b0d0 $) | tokenizer (0.1) | zip (1.11.0) | zlib (1.1) | libxml () | dom (20031129) | PDO (1.0.4dev) | bz2 () | SimpleXML (0.1) | wddx () | xml () | xmlreader (0.1) | xmlwriter (0.1) | cgi-fcgi () | pdo_sqlsrv (3.0.3421.0) | sqlsrv (3.0.3421.0) | openssl () | curl () | fileinfo (1.0.5-dev) | gd () | gmp () | mbstring () | mysql (1.0) | mysqli (0.1) | Phar (2.0.1) | pdo_mysql (1.0.2) | pdo_pgsql (1.0.2) | pdo_sqlite (1.0.1) | pgsql () | SQLite (2.0-dev) | sqlite3 (0.7-dev) | tidy (2.0) | xmlrpc (0.51) | xsl (0.1) | wincache (1.1.0630.0) | mhash () | Zend Engine (2.3.0) |
Potential Missing Extensions :: suhosin |

Switch User Environment (Experimental) :: PHP CGI: Yes | Server SU: No | PHP SU: Yes | Custom SU (LiteSpeed/Cloud/Grid): Yes
Potential Ownership Issues: No
Folder Permissions :: wrote:
Core Folders :: --protected-- (777) | --protected-- (777) | --protected-- (777) | --protected-- (777) | --protected-- (777) | --protected-- (777) | --protected-- (777) | --protected-- (777) | --protected-- (777) | --protected-- (777) | --protected-- (777) | --protected-- (777) | --protected-- (777) |

Elevated Permissions (First 10) :: --protected-- (777) | --protected-- (777) | --protected-- (777) | --protected-- (777) | --protected-- (777) | --protected-- (777) | --protected-- (777) | --protected-- (777) | --protected-- (777) | --protected-- (777) |
Extensions Discovered :: wrote:
Strict Information Privacy was selected. Nothing to display.
Templates Discovered :: wrote:
_FPA_STRICT Information Privacy Nothing to display.


Top
 Profile  
 
PostPosted: Thu Nov 15, 2012 4:12 pm 
User avatar
Joomla! Master
Joomla! Master

Joined: Wed Aug 17, 2005 10:27 pm
Posts: 14715
Location: Kent, England
The overall validation for Joomla use on the server configuration is stating it is only valid for Joomla 1.5.

There is nothing immediately apparent from the FPA that would suggest any issue (other than the usual Windows annihilation of permissions!) that could cause a problem. So it may therefore be underlying settings/configuration that are not picked up within the FPA.

In theory with the main components you have installed you should be able to install Joomla 3.0 too!

I do not know for sure but try the installation with the 2.5.8 version of Joomla and it might make a difference (probably it will not).

What template are you using for this site? Are you getting the same result for both front and back end of Joomla?

Your second post asked about error logging you can check the joomla_root/logs/ directory and also the server logs themselves. C:\WINDOWS\Temp\php_errors.log and a separate IIS server log if it has one.


Top
 Profile  
 
PostPosted: Mon Nov 19, 2012 3:04 pm 
Joomla! Apprentice
Joomla! Apprentice

Joined: Tue Nov 13, 2012 2:47 pm
Posts: 9
Hello,

This was being caused by the files being hosted on a remote fileshare apparently...

Go to /libraries/joomla/filesystem/path.php

Work around by editing the file above and making the following change:

function clean($path, $ds=DS)
{
$path = trim($path);

return $path; // <-- Fixes issue with UNC paths

if (empty($path)) {
$path = JPATH_ROOT;
} else {
// Remove double slashes and backslahses and convert all slashes andbackslashes to DS
$path = preg_replace('#[/\\\\]+#', $ds, $path);
}
return $path;
}


Top
 Profile  
 
PostPosted: Mon Nov 19, 2012 4:15 pm 
User avatar
Joomla! Master
Joomla! Master

Joined: Wed Aug 17, 2005 10:27 pm
Posts: 14715
Location: Kent, England
Ermm, not too sure about that to be honest!

That might (I stress might) be something you could handle within the web.config file.
Editing the core Joomla files is never recommended as you never know what knock on effect it might have elsewhere and you potentially could overwrite that change every time Joomla is updated - which is fine if you are the Administrator of the site etc, but would be a major issue for a client not knowing their way around the site/issue.


Top
 Profile  
 
PostPosted: Mon Nov 19, 2012 4:42 pm 
User avatar
Joomla! Master
Joomla! Master

Joined: Wed Aug 17, 2005 10:27 pm
Posts: 14715
Location: Kent, England
Just as a complete shot in the dark error_reporting is set to -1 which means everything is reported. Try setting this in Joomla Global Configuration ⇒ Server ⇒ Error reporting to Maximum, Simple or Ultimately None. and see if this makes any difference. This obviously only affects this one site.
Or
Alternatively set it in the php.ini file on the server to
Code:
 error_reporting = E_ALL & ~E_NOTICE & ~E_STRICT
OR
Code:
display_errors = Off


Top
 Profile  
 
PostPosted: Wed Nov 21, 2012 6:21 pm 
User avatar
Joomla! Master
Joomla! Master

Joined: Wed Aug 17, 2005 10:27 pm
Posts: 14715
Location: Kent, England
I have referred the issue to the developers/bug squad to see if someone more used to these issues could provide comment and Sam Moffat replied
Sam Moffat wrote:
Looks like they're running Joomla on a UNC path. There was a commit somewhere a while back to fix that up in a few different places, perhaps this is just one more place it needs to be fixed. Perhaps ask them to check with 3.0 and see if that changes anything. This isn't an IIS or PHP specific issue but a file pathing issue. The same path on Apache would likely trigger similar problems. The usual work around is to either assign the UNC path a [drive] allocation or mount it on an existing NTFS file system (similar to how UNIX OS's mount different [drive]/network shares). (Note: I'm assuming that this feature hasn't been removed by Microsoft. They do that from time to time).


Top
 Profile  
 
PostPosted: Sat Nov 24, 2012 10:26 am 
Joomla! Apprentice
Joomla! Apprentice

Joined: Thu Dec 27, 2007 8:37 am
Posts: 32
Hi,

i have a site hosted on Webcentral whio runs IIS andrun in to this problem. I amended my path.php as above and the site now works.

Thanks,

johk


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 12 posts ] 



Who is online

Users browsing this forum: No registered users and 5 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Jump to:  
Powered by phpBB® Forum Software © phpBB Group