The Joomla! Forum ™



Forum rules


Forum Rules
Absolute Beginner's Guide to Joomla! <-- please read before posting, this means YOU.
Forum Post Assistant - If you are serious about wanting help, you will use this tool to help you post.



Post new topic Reply to topic  [ 5 posts ] 
Author Message
PostPosted: Mon Feb 27, 2012 6:50 am 
User avatar
Joomla! Guru
Joomla! Guru

Joined: Sun Aug 28, 2005 11:23 am
Posts: 958
Location: New York
hello,

i have just installed ssl certificate on a site running joomla 2.5.1.

can anyone please tell me what steps need to be taken now within joomla?

thank you!


Top
 Profile  
 
PostPosted: Mon Feb 27, 2012 7:15 am 
User avatar
Joomla! Master
Joomla! Master

Joined: Mon Aug 29, 2005 10:17 am
Posts: 13796
Location: Netherlands/ UK/ S'pore/Jakarta/ North America
Does the entire site need SSL or only parts?

Leo 8)

_________________
-- Joomla Professional Support Services : http://gws-desk.com --
-- Good & Cheap Joomla Sites Ready To Roll : http://gws-deals.today --
-- Joomla Specialized Hosting Solutions : www.gws-host.com --
-- Member Joomla Bug Squad --


Top
 Profile  
 
PostPosted: Mon Feb 27, 2012 7:23 am 
User avatar
Joomla! Guru
Joomla! Guru

Joined: Sun Aug 28, 2005 11:23 am
Posts: 958
Location: New York
thank you for your reply.

i think i am going to go with 'entire site' if there are no significant drawbacks to this.

i have set global config > server > server settings >force ssl > entire site and now going to www.mysite.com redirects to https://www.mysite.com which is great.

just getting a 'other resources are not secure' message in chrome which i think is mainly relating to template elements.

in firebug, clicking on the 'net' tab and hovering over the rows there are a number of template elements that are using http:// instead of https://.

not sure if these can be automatically converted to https:// or all have to be manually changed.

any advice would be appreciated.

thanks!


Top
 Profile  
 
PostPosted: Mon Feb 27, 2012 8:01 am 
User avatar
Joomla! Guru
Joomla! Guru

Joined: Sun Aug 28, 2005 11:23 am
Posts: 958
Location: New York
was able to fix insecure items (as revealed in firebug) with one setting in the template ie just defining the sites template as https://www.mysite.com, as opposed to http://www.mysite.com. The link to http://fonts.googleapis.com was also hardcoded into the website, so i changed that to https://. still getting a 'other resources are not secure' message in chrome, but i cannot see any http:// references in firebug or the source of the page (only http:// links in comments regarding software developers etc - do these need to be changed/removed?)


Top
 Profile  
 
PostPosted: Mon Feb 27, 2012 8:07 am 
User avatar
Joomla! Guru
Joomla! Guru

Joined: Sun Aug 28, 2005 11:23 am
Posts: 958
Location: New York
gosh, had to open page in new tab to clear cache!

see:

http://stackoverflow.com/questions/3920 ... warn-about


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 5 posts ] 



Who is online

Users browsing this forum: No registered users and 22 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Jump to:  
Powered by phpBB® Forum Software © phpBB Group