The Joomla! Forum ™



Forum rules


Forum Rules
Absolute Beginner's Guide to Joomla! <-- please read before posting, this means YOU.
Forum Post Assistant - If you are serious about wanting help, you will use this tool to help you post.



Post new topic Reply to topic  [ 6 posts ] 
Author Message
PostPosted: Tue Feb 28, 2012 6:53 pm 
User avatar
Joomla! Apprentice
Joomla! Apprentice

Joined: Sat Dec 11, 2010 8:12 pm
Posts: 7
Location: South Africa
Hello All,

I am trying to upgrade a Joomla! 1.7.5 Stable to 2.5.1 without success.

In -- admin - extension manager - update

I click Find Update which returns none

I then click Purge Cache and get the following error message.
"Failed to purge updates, failed to enable updates"

I have searched and search and cannot find any posts related to this topic.

Any suggestions?

_________________
Mark Brindley
2Large Networks
http://www.2large.co.za


Top
 Profile  
 
PostPosted: Tue Feb 28, 2012 7:36 pm 
User avatar
Joomla! Champion
Joomla! Champion

Joined: Fri Aug 19, 2005 10:46 am
Posts: 5722
Location: Roma
have read this guide
http://docs.joomla.org/Upgrading_from_an_existing_version

_________________
Nicola Galgano
i know that i don't know
www.alikonweb.it


Top
 Profile  
 
PostPosted: Tue Feb 28, 2012 7:55 pm 
User avatar
Joomla! Apprentice
Joomla! Apprentice

Joined: Sat Dec 11, 2010 8:12 pm
Posts: 7
Location: South Africa
@alikon - Thanks,

Yes I have read throught that doc.

I have updated quite a few sites to J2.5!
These range from 1.5 -- 2.5 & 1.7 -- 2.5
Have never seen this particular error before.

I FTP'd a full 1.7.5 , overwriting all the files on the server, just incase something was corrupted. Sadly that did not help.

--Quick Test--
I just set up a test site with 1.7.0
Ran the updater and Purge Cache without any problems.

--Further Info--

Checked Permissions
Checked CPU Load
Checked DB

_________________
Mark Brindley
2Large Networks
http://www.2large.co.za


Top
 Profile  
 
PostPosted: Fri Apr 27, 2012 12:03 pm 
Joomla! Fledgling
Joomla! Fledgling

Joined: Tue May 30, 2006 9:19 am
Posts: 1
Location: Warsaw, Poland
I came across the same problem.

In my case granting additional privileges for the user to the site's database helped.

I had: ALTER, CREATE, DELETE, EXECUTE, INSERT, LOCK TABLES, SELECT, UPDATE
I've added: CREATE_TEMPORARY_TABLES, DROP

I'm not sure which one of the two above helped, because the updates got purged right after the first shot.


Top
 Profile  
 
PostPosted: Fri Jun 08, 2012 1:58 am 
Joomla! Fledgling
Joomla! Fledgling

Joined: Fri Jun 08, 2012 1:49 am
Posts: 1
Hi,
I am having the same problem. Trying to upgrade from 1.7 to 2.5. My database permissions include CREATE_TEMPORARY_TABLES, DROP.

Any other suggestions?

Thanks,
Dina


Top
 Profile  
 
PostPosted: Thu Aug 02, 2012 1:52 am 
Joomla! Fledgling
Joomla! Fledgling

Joined: Fri Aug 06, 2010 4:36 am
Posts: 1
I am having the same issue. How do I change my database permissions? ver 1.7.3, and trying to upgrade to 2.5.


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 6 posts ] 



Who is online

Users browsing this forum: No registered users and 20 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Jump to:  
Powered by phpBB® Forum Software © phpBB Group