Update broke our site...Please help!

Need help upgrading your Joomla! website or converting to Joomla! 2.5?
Note: All 1.6 and 1.7 releases have reached end of life and should be updated to 2.5.

Moderator: General Support Moderators

Forum rules
Forum Rules
Absolute Beginner's Guide to Joomla! <-- please read before posting, this means YOU.
Forum Post Assistant - If you are serious about wanting help, you will use this tool to help you post.
WSA
Joomla! Fledgling
Joomla! Fledgling
Posts: 4
Joined: Wed Apr 04, 2012 10:46 pm

Update broke our site...Please help!

Postby WSA » Wed Apr 04, 2012 10:53 pm

Hi All,

We are really new to Joomla. One of our admins did the upgrades through the automatic upgrader in the admin area last night and now we can't get into either the front end or admin area of the site. All we get when we try is this:

Warning: fopen(/logs/rokcommon.php) [function.fopen]: failed to open stream: No such file or directory in /home/whatt071/public_html/libraries/joomla/log/loggers/formattedtext.php on line 248

Warning: fputs() expects parameter 1 to be resource, boolean given in /home/whatt071/public_html/libraries/joomla/log/loggers/formattedtext.php on line 254

Fatal error: Uncaught exception 'LogException' in /home/whatt071/public_html/libraries/joomla/log/loggers/formattedtext.php:256 Stack trace: #0 /home/whatt071/public_html/libraries/joomla/log/loggers/formattedtext.php(137): JLoggerFormattedText->initFile() #1 /home/whatt071/public_html/libraries/joomla/log/log.php(382): JLoggerFormattedText->addEntry(Object(JLogEntry)) #2 /home/whatt071/public_html/libraries/joomla/log/log.php(171): JLog->addLogEntry(Object(JLogEntry)) #3 /home/whatt071/public_html/libraries/rokcommon/RokCommon/Logger/Joomla17.php(91): JLog::add('Directory /home...', 32, 'RokCommon') #4 /home/whatt071/public_html/plugins/system/rokcommon/rokcommon.php(152): RokCommon_Logger_Joomla17->notice('Directory /home...') #5 /home/whatt071/public_html/plugins/system/rokcommon/rokcommon.php(133): plgSystemRokCommon->registerLibraries(Array) #6 /home/whatt071/public_html/plugins/system/rokcommon/rokcommon.php(78): plgSystemRokCommon->processRegisteredConfigs() #7 /home/whatt071/public_html/libraries/joomla/plugin/hel in /home/whatt071/public_html/libraries/joomla/log/loggers/formattedtext.php on line 256


I have absolutely no idea what we did wrong or what to do from here to repair it. If someone can point us in the right direction to get my site back up and running I would really appreciate it.

Thank you in advance.
WSA

WSA
Joomla! Fledgling
Joomla! Fledgling
Posts: 4
Joined: Wed Apr 04, 2012 10:46 pm

Re: Update broke our site...Please help!

Postby WSA » Thu Apr 05, 2012 1:38 am

I'm wondering if at the very least someone can assist me in getting back into the admin area of the site so that I can maybe find a backup and try to restore to before anything was done last night.

I really am desperate to get this resolved as quickly as possible and appreciate any help at all. Even just an explanation of what the above stuff means might help.

Thank you again.

User avatar
leolam
Joomla! Master
Joomla! Master
Posts: 16072
Joined: Mon Aug 29, 2005 10:17 am
Location: Netherlands/ UK/ S'pore/Jakarta/ North America
Contact:

Re: Update broke our site...Please help!

Postby leolam » Thu Apr 05, 2012 7:39 am

Have a look here:
https://www.rockettheme.com/forum/index ... ic#p796895

This is caused by not following the steps as outlined for the RT-upgrade when moving to 2.5.4. Rokcommon etc is throwing your site stress. Follow the steps the poster did in the link I gave you and you should be ok quickly

Oh and for real! http://www.tfd.com/backup Never upgrade without making a full backup first!

Leo 8)
-- Joomla Professional Support Services : https://gws-desk.com --
-- Joomla Specialized Hosting Solutions: https://gws-host.com --
-- Joomla Professional Web Development & Design :www.gws-studio.com
-- Member Joomla Bug Squad --

WSA
Joomla! Fledgling
Joomla! Fledgling
Posts: 4
Joined: Wed Apr 04, 2012 10:46 pm

Re: Update broke our site...Please help!

Postby WSA » Thu Apr 05, 2012 9:44 am

Thank you for your help leolam. I am very new to this stuff and have been relying on a couple of other relative newbies as well to get this going. We are all learning as we go. I am not sure I even know where to look to follow what that guy did to manually delete files and such to be honest.

I do have backups of the site including one taken right before the updates/installs that seem to have caused the problems. The trouble is that I need access to the admin area to get to them though.

WSA
Joomla! Fledgling
Joomla! Fledgling
Posts: 4
Joined: Wed Apr 04, 2012 10:46 pm

Re: Update broke our site...Please help!

Postby WSA » Thu Apr 05, 2012 10:47 am

Thank you for your help. I managed to get into my admin (by disabling the rokcommon plugin in mysql). I then restored my site to a backup from before the updates/uploads that caused the problem. I still have to test it out but it seems it is all working correctly now.


Return to “Migrating and Upgrading to Joomla! 2.5”

Who is online

Users browsing this forum: No registered users and 7 guests