The Joomla! Forum ™



Forum rules


Forum Rules
Absolute Beginner's Guide to Joomla! <-- please read before posting, this means YOU.
Forum Post Assistant - If you are serious about wanting help, you will use this tool to help you post.



Post new topic Reply to topic  [ 7 posts ] 
Author Message
PostPosted: Fri Apr 06, 2012 8:39 pm 
User avatar
Joomla! Enthusiast
Joomla! Enthusiast

Joined: Fri Apr 06, 2007 12:23 am
Posts: 236
Location: Boise, ID
Hello everyone,

What are some common reasons that would keep a language file from working, the component just displays the tags like so LABEL NAME, or LABEL EMAIL, etc. I noticed it in Joomla 2.5.4, I have never had a problem getting them to load in any of my custom Joomla 1.5.x to 2.5.3 components in the past, I am stumped.

So I'm just wondering what some of the common causes are that would affect the language file from loading.

Thanks everyone, please leave your thoughts below.


Top
 Profile  
 
PostPosted: Fri Apr 06, 2012 8:43 pm 
Joomla! Master
Joomla! Master

Joined: Mon Oct 27, 2008 9:27 pm
Posts: 17998
Location: Akershus, Norway
There is difference in the 2.5 and 1.5 format.

The file is not stored as UTF8 without BOM.


Top
 Profile  
 
PostPosted: Fri Apr 06, 2012 8:49 pm 
User avatar
Joomla! Enthusiast
Joomla! Enthusiast

Joined: Fri Apr 06, 2007 12:23 am
Posts: 236
Location: Boise, ID
yup in Joomla 1.5.x you did not need quotes around the text so it would look like:

Code:
LABEL NAME=Your Name


And in Joomla 1.6.x+ you needed to wrap the text in quotes like so:

Code:
LABEL NAME="Your Name"


Correct?

I was unaware of
Quote:
The file is not stored as UTF8 without BOM


Top
 Profile  
 
PostPosted: Fri Apr 06, 2012 8:54 pm 
Joomla! Master
Joomla! Master

Joined: Mon Oct 27, 2008 9:27 pm
Posts: 17998
Location: Akershus, Norway
Space is not allowed 1.6+ use LABEL_NAME="Your Name"


Top
 Profile  
 
PostPosted: Fri Apr 06, 2012 8:59 pm 
User avatar
Joomla! Enthusiast
Joomla! Enthusiast

Joined: Fri Apr 06, 2007 12:23 am
Posts: 236
Location: Boise, ID
Per Yngve Berg wrote:
Space is not allowed 1.6+ use LABEL_NAME="Your Name"

that's good to know to, I did test it by renaming the labels with underscores and then also added the component name at the start like so:
Code:
COM_MYCOM_LABEL_NAME="Your Name"

That did not fix it ether, I will give the UTF8 thing a shot.


Top
 Profile  
 
PostPosted: Fri Apr 06, 2012 9:02 pm 
Joomla! Master
Joomla! Master

Joined: Mon Oct 27, 2008 9:27 pm
Posts: 17998
Location: Akershus, Norway
Have you enabled Debug and Language Debug on the site?


Top
 Profile  
 
PostPosted: Fri Apr 06, 2012 9:37 pm 
User avatar
Joomla! Enthusiast
Joomla! Enthusiast

Joined: Fri Apr 06, 2007 12:23 am
Posts: 236
Location: Boise, ID
Ok so I turned on the language debug, and made sure that all of the language file spaces where removed from the labels and it seems to work now, that's good to know.

Code:
COM_YOURCOMPONENT_LABEL_NAME="Your Name"


Thanks for the help Per Yngve Berg


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 7 posts ] 



Who is online

Users browsing this forum: strumjan and 29 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Jump to:  
Powered by phpBB® Forum Software © phpBB Group