The Joomla! Forum ™



Forum rules


Forum Rules
Absolute Beginner's Guide to Joomla! <-- please read before posting, this means YOU.
Forum Post Assistant - If you are serious about wanting help, you will use this tool to help you post.



Post new topic Reply to topic  [ 2 posts ] 
Author Message
PostPosted: Thu Nov 29, 2012 9:26 pm 
Joomla! Fledgling
Joomla! Fledgling

Joined: Thu Nov 29, 2012 9:10 pm
Posts: 2
I am writing a plugin for Joomla! 2.5. Once installed, the plugin works perfectly and flawlessly. Good on me as i only started working with Joomla yesterday. However, one issue related to plugin installation. I will be distributing this plugin, and need to resolve the installation part. As part of installation, subdirectory is created in existing /plugins/authentication/ directory, and files uploaded to existing /administrator/language/en-GB/ directory. On my server, this did not work. I had to chmod each directory as 777. But, before that, the plugin was already "seen" as installed even though directories not installed, and files not uploaded. Became a mess. Had to uninstall by deleting from database via phpMyAdmin. Then, do the chmodding via FTP. Is there a better way? Or just, include readme doc that explains that they might have to chmod first?


Top
 Profile  
 
PostPosted: Thu Dec 27, 2012 2:50 am 
Joomla! Fledgling
Joomla! Fledgling

Joined: Thu Nov 29, 2012 9:10 pm
Posts: 2
Hopefully someone more experienced with this will ring in.


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 2 posts ] 



Who is online

Users browsing this forum: No registered users and 8 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Jump to:  
Powered by phpBB® Forum Software © phpBB Group