News feed works in 1.5 fails in 3.2

Need help upgrading your Joomla! website or converting to Joomla! 3.x? Please consider the availability of third-party templates and extensions when deciding which Joomla version to use.

Moderator: General Support Moderators

Forum rules
Forum Rules
Absolute Beginner's Guide to Joomla! <-- please read before posting, this means YOU.
Forum Post Assistant - If you are serious about wanting help, you will use this tool to help you post.
donporter
Joomla! Apprentice
Joomla! Apprentice
Posts: 30
Joined: Thu Jun 05, 2008 9:01 pm

News feed works in 1.5 fails in 3.2

Postby donporter » Fri Nov 15, 2013 12:30 am

I am converting a 1.5.20 site to 3.2.0. On the 1.5 site I have a menu item NewsFeeds>Single News Feed, pointing to a feed listed in the News Feed Manager with address http://abcde.[URL banned].com . All working fine. In the 3.2.0 test site, I have the same setup: news feed manager has the feed, with “link” field http://abcde.[URL banned].com and a menu item type single news feed pointing to that feed. But going to the menu item in the front end produces “0 Error” – “No registered feed parser for type html.” What am I missing?

User avatar
ozneilau
Joomla! Guru
Joomla! Guru
Posts: 830
Joined: Tue Aug 04, 2009 9:05 am
Location: Tasmania, Australia
Contact:

Re: News feed works in 1.5 fails in 3.2

Postby ozneilau » Tue Nov 19, 2013 8:04 am

I have the exact same problem.

Appending "/feeds/posts/default?alt=rss" to the url helps a little bit but it's still not working like it did in Joomla 1.5.

Neil.
Please request help via the forums rather than by PM so everyone can benefit from the conversation.
NEIL ROBERTSON
Webilicious Web Design and Development
http://webilicious.com.au

donporter
Joomla! Apprentice
Joomla! Apprentice
Posts: 30
Joined: Thu Jun 05, 2008 9:01 pm

Re: News feed works in 1.5 fails in 3.2

Postby donporter » Tue Nov 19, 2013 11:34 am

Thanks, ozneilau, but that makes no difference for me: still a blank white window.

User avatar
ozneilau
Joomla! Guru
Joomla! Guru
Posts: 830
Joined: Tue Aug 04, 2009 9:05 am
Location: Tasmania, Australia
Contact:

Re: News feed works in 1.5 fails in 3.2

Postby ozneilau » Tue Nov 19, 2013 11:46 am

Your milage may vary but I think supplying a link to an RSS feed works better than a link to a html page.

I think I'll try a third party extension instead.

Neil.
Please request help via the forums rather than by PM so everyone can benefit from the conversation.
NEIL ROBERTSON
Webilicious Web Design and Development
http://webilicious.com.au

User avatar
ozneilau
Joomla! Guru
Joomla! Guru
Posts: 830
Joined: Tue Aug 04, 2009 9:05 am
Location: Tasmania, Australia
Contact:

Re: News feed works in 1.5 fails in 3.2

Postby ozneilau » Wed Nov 20, 2013 3:29 am

I also tried the "Feed Display" module but still didn't get what I wanted.

I tested a few third party extensions and the best one I found is the free Simple RSS Feed Reader module which you can find at:

http://extensions.joomla.org/extensions ... aders/1723

Neil.
Please request help via the forums rather than by PM so everyone can benefit from the conversation.
NEIL ROBERTSON
Webilicious Web Design and Development
http://webilicious.com.au

User avatar
twhcreations
Joomla! Apprentice
Joomla! Apprentice
Posts: 33
Joined: Wed Nov 18, 2009 12:50 pm
Location: Hunter Valley NSW Australia
Contact:

Re: News feed works in 1.5 fails in 3.2

Postby twhcreations » Thu Jan 02, 2014 12:36 am

In the past i have used this module, which was great, but its not working in 3.x

http://extensions.joomla.org/extensions ... c3MiO30%3D
Here we go again...
Wally's Back

trebenath
Joomla! Fledgling
Joomla! Fledgling
Posts: 3
Joined: Sat Apr 27, 2013 8:14 am

Re: News feed works in 1.5 fails in 3.2

Postby trebenath » Thu Jan 01, 2015 8:32 pm

I had the same problem and found a workaround using an aggregator - I think this should be raised as a bug as it was working fine in 2.5, but not 3.3. See http://forum.joomla.org/viewtopic.php?f=706&t=869750


Return to “Migrating and Upgrading to Joomla! 3.x”

Who is online

Users browsing this forum: No registered users and 11 guests