Component doesn't save, delete or edit correctly

This forum is for general questions about extensions for Joomla! 3.x.

Moderators: pe7er, General Support Moderators

Forum rules
Forum Rules
Absolute Beginner's Guide to Joomla! <-- please read before posting, this means YOU.
Forum Post Assistant - If you are serious about wanting help, you will use this tool to help you post.
StefanKlokkie
Joomla! Fledgling
Joomla! Fledgling
Posts: 4
Joined: Fri Jan 11, 2013 12:12 am

Component doesn't save, delete or edit correctly

Postby StefanKlokkie » Fri Jan 11, 2013 12:28 am

Hi everyone,
I am very new to Joomla (3.0) extension development so I am still learning. I am making my own component which has the purpose to show images with some additionel information connected to categories.

The component installs correctly and displays everything correctly, the only problem(s) that I have are:
1. In my first view the delete button doesnt work like it should. It performs my query but doesnt delete my item(s)
2. In my second view where I can add and/ or edit my items none of my buttons work. After weeks of searching and comparing I still can't see what I am doing wrong. It is getting really annoying because I can't figure out what I am doing wrong.

I think that both my problems have the same cause but i'm not sure.
So my question is that if somebody can help me. I really want to learn how to create my own basic component so every help is welcome. I would really appreciate it if someone would help me! In the attachment is my .zip file.

Excuse me for my faulty English if there is any, i'm from Holland so I have a good excuse. :P

Yours sincerely,
Stefan
You do not have the required permissions to view the files attached to this post.

StefanKlokkie
Joomla! Fledgling
Joomla! Fledgling
Posts: 4
Joined: Fri Jan 11, 2013 12:12 am

Re: Component doesn't save, delete or edit correctly

Postby StefanKlokkie » Sat Jan 12, 2013 8:57 pm

Anyone? :)

StefanKlokkie
Joomla! Fledgling
Joomla! Fledgling
Posts: 4
Joined: Fri Jan 11, 2013 12:12 am

Re: Component doesn't save, delete or edit correctly

Postby StefanKlokkie » Fri Jan 18, 2013 7:37 pm

I am really stuck at the moment, any help would be very appreciated :)

sovainfo
Joomla! Exemplar
Joomla! Exemplar
Posts: 7676
Joined: Sat Oct 01, 2011 7:06 pm

Re: Component doesn't save, delete or edit correctly

Postby sovainfo » Fri Jan 18, 2013 9:17 pm

You might want to reconsider my advice given on joomlacommunity.eu.
Or visit the developers lists
Issue with migrating? Include logs/joomla_update.php in your report!
Blank screen? Verify pagesource for HTML code (javascript error)
Installation failing on populating database? Install with set_time_limit(0)
Document your customizations!

StefanKlokkie
Joomla! Fledgling
Joomla! Fledgling
Posts: 4
Joined: Fri Jan 11, 2013 12:12 am

Re: Component doesn't save, delete or edit correctly

Postby StefanKlokkie » Fri Jan 18, 2013 9:24 pm

Which advice? You only told to look at other component on how they do the submit. After days of trying I still cant manage to achieve this. I would appreciate it if you could help me out but only advice hasn't helped me out so far.


Return to “Extensions for Joomla! 3.x”

Who is online

Users browsing this forum: jaman_vvip and 11 guests