The Joomla! Forum ™



Forum rules


Forum Rules
Absolute Beginner's Guide to Joomla! <-- please read before posting, this means YOU.
Forum Post Assistant - If you are serious about wanting help, you will use this tool to help you post.



Post new topic Reply to topic  [ 1805 posts ]  Go to page Previous  1 ... 5, 6, 7, 8, 9, 10, 11 ... 61  Next
Author Message
PostPosted: Tue Dec 18, 2007 6:28 pm 
User avatar
Joomla! Hero
Joomla! Hero

Joined: Thu Aug 18, 2005 11:10 am
Posts: 2237
Location: Floripa, Brazil
just would like to warn future users that installing yvComment 1.11 in a Joomla! 1.5 (rev. 9666) will rise some errors:
Quote:

        * JInstaller::install: The language file 'www/language/da-DK/da-DK.com_yvcomment.ini' could not be installed because the Administrator language package for 'da-DK' has not been installed or does not exist.
        * JInstaller::install: The language file 'www/language/de-DE/de-DE.com_yvcomment.ini' could not be installed because the Administrator language package for 'de-DE' has not been installed or does not exist.
        * JInstaller::install: The language file 'www/language/es-ES/es-ES.com_yvcomment.ini' could not be installed because the Administrator language package for 'es-ES' has not been installed or does not exist.
        * JInstaller::install: The language file 'www/language/fa-IR/fa-IR.com_yvcomment.ini' could not be installed because the Administrator language package for 'fa-IR' has not been installed or does not exist.
        * JInstaller::install: The language file 'www/language/nl-NL/nl-NL.com_yvcomment.ini' could not be installed because the Administrator language package for 'nl-NL' has not been installed or does not exist.
        * JInstaller::install: The language file 'www/language/ru-RU/ru-RU.com_yvcomment.ini' could not be installed because the Administrator language package for 'ru-RU' has not been installed or does not exist.
        * JInstaller::install: The language file 'www/language/sv-SE/sv-SE.com_yvcomment.ini' could not be installed because the Administrator language package for 'sv-SE' has not been installed or does not exist.
        * JInstaller::install: The language file 'www/language/tr-TR/tr-TR.com_yvcomment.ini' could not be installed because the Administrator language package for 'tr-TR' has not been installed or does not exist.
        * JInstaller::install: The language file 'www/administrator/language/de-DE/de-DE.com_yvcomment.ini' could not be installed because the Administrator language package for 'de-DE' has not been installed or does not exist.
        * JInstaller::install: The language file 'www/administrator/language/es-ES/es-ES.com_yvcomment.ini' could not be installed because the Administrator language package for 'es-ES' has not been installed or does not exist.
        * JInstaller::install: The language file 'www/administrator/language/fa-IR/fa-IR.com_yvcomment.ini' could not be installed because the Administrator language package for 'fa-IR' has not been installed or does not exist.
        * JInstaller::install: The language file 'www/administrator/language/nl-NL/nl-NL.com_yvcomment.ini' could not be installed because the Administrator language package for 'nl-NL' has not been installed or does not exist.
        * JInstaller::install: The language file 'www/administrator/language/ru-RU/ru-RU.com_yvcomment.ini' could not be installed because the Administrator language package for 'ru-RU' has not been installed or does not exist.
        * JInstaller::install: The language file 'www/administrator/language/sv-SE/sv-SE.com_yvcomment.ini' could not be installed because the Administrator language package for 'sv-SE' has not been installed or does not exist.
        * JInstaller::install: The language file 'www/administrator/language/tr-TR/tr-TR.com_yvcomment.ini' could not be installed because the Administrator language package for 'tr-TR' has not been installed or does not exist.


I guess this is due to the removal of several language files from the /installation directory that happened today (they're probably packing rc4 and these translation teams are late... too bad).

Despite these errors, the component seems to be working well. (thanks for adding the mail notification feature yuri!)

_________________
Matheus Teixeira Mendes
http://www.bigodines.com/blog || http://www.joomla.com.br/


Top
 Profile  
 
PostPosted: Thu Dec 20, 2007 10:07 am 
User avatar
Joomla! Guru
Joomla! Guru

Joined: Thu Jun 01, 2006 1:52 pm
Posts: 979
Location: Moscow, Russia
I've just tested yvComment with RC4 and found 4 bugs in Joomla! core, that I submitted to the bugtrakker:
Edited:
Luckily, none of these bugs prevent from using yvComment with RC4
I mean: do use yvComment with Joomla! RC4
Unfortunately, I was too quick to write: above mentioned bug #8712 affects too much code of yvComment  :(
Please, don't be hurry to upgrade while this bug is not fixed  :'(

_________________
Text of all my messages is available under the terms of the GNU Free Documentation License: http://www.gnu.org/copyleft/fdl.html


Last edited by yvolk on Fri Dec 21, 2007 7:08 am, edited 1 time in total.

Top
 Profile  
 
PostPosted: Thu Dec 20, 2007 10:24 am 
User avatar
Joomla! Master
Joomla! Master

Joined: Thu Aug 18, 2005 10:41 am
Posts: 15753
Thanks for posting the bug reports  ;)

_________________
Regards Robin

http://www.linkedin.com/in/robinmuilwijk - http://twitter.com/i_robin


Top
 Profile  
 
PostPosted: Thu Dec 20, 2007 3:55 pm 
User avatar
Joomla! Guru
Joomla! Guru

Joined: Sun Feb 18, 2007 6:40 pm
Posts: 994
Location: Constantine, Algeria
yvolk wrote:
dzed wrote:
2 - try to install yvCommentComponent1.11.000.zip i got this error
Code:
JFolder::create: Path not in open_basedir paths
Component Install: Failed to create directory: "/home2/********/public_html/rencontre/components/com_yvcomment"

Code:
Install Component error


This is the only real error. Other "errors" are "features" of Joomla! (and of cause, yvComment.zip is not what to install  :) ).
I think, I know your problem:
your provider (or you?) set wrong value for 'PHP configuration directive' called 'open_basedir'.
You may check it with ini_get('open_basedir').
Is it "/home/********" ?  ;) (I had just this problem with one free provider, so I had to patch Joomla! don't check this directive...)


thanks for reply

-  my host its not free service
-  my problem is solved with replacing
this
"/home2/********/public_html/rencontre/"
be this
"/home2/********/rencontre/

_________________
Saber Bousba - صابر بوصبع
Member of the Arabic [ar-DZ] Joomla Translation Team :  http://joomlacode.org/gf/project/ardz/


Top
 Profile  
 
PostPosted: Thu Dec 20, 2007 4:02 pm 
User avatar
Joomla! Guru
Joomla! Guru

Joined: Sun Feb 18, 2007 6:40 pm
Posts: 994
Location: Constantine, Algeria
i use Joomla v1.5 RC4 Build-9671 2007-12-19, and i get
8710 - JInstaller generates error messages while installing language files of multilingual extension, if corresponding Joomla language packs don't exist
in installation of
yvCommentComponent1.11.000.zip
&
yvCommentPlugin1.11.000.zip
&
yvBBCodePlugin1.01.002.zip
&
yvSmileyPlugin1.02.001.zip

_________________
Saber Bousba - صابر بوصبع
Member of the Arabic [ar-DZ] Joomla Translation Team :  http://joomlacode.org/gf/project/ardz/


Last edited by dzed on Thu Dec 20, 2007 4:29 pm, edited 1 time in total.

Top
 Profile  
 
PostPosted: Thu Dec 20, 2007 10:42 pm 
Joomla! Apprentice
Joomla! Apprentice

Joined: Sun May 21, 2006 5:54 pm
Posts: 19
Hi Yuri,

thanks for component.

I use J 1.5  9682 , PHP 5.1.2, MySQL 5, Apache2, yv 1.11

Captcha is enabled in your component, I tried and installed both Bigo and OSTWigits. But no captcha image is shown in the comments-form.

The first two SEO options in Joomla are activated; the source code I get in the yv-form looks like:
Code:
                   </td>
                   <td>
                      <img src='/?task=displaycaptcha'
                        alt='Bild, welches das geheime Wort enthält' />
                      <br />
                   </td>


Any hints?

Also, when I get yvComment to work, it would be great to be able to show the add-comment-form only on demand; e.g. when the user clicks some link to make the form appear. Otherwise, being there all the time, the comments-form feels somehow disturbing to me.

Thanks,
zarkon


Top
 Profile  
 
 Post subject: Re: yvComment - RC4
PostPosted: Thu Dec 20, 2007 11:28 pm 
Joomla! Apprentice
Joomla! Apprentice

Joined: Thu Dec 20, 2007 11:24 pm
Posts: 7
So I upgraded today to Karibu and I tried to install yvComment and got a mess of errors...


JInstaller::install: The language file 'www/language/da-DK/da-DK.com_yvcomment.ini' could not be installed because the Administrator language package for 'da-DK' has not been installed or does not exist.
JInstaller::install: The language file 'www/language/de-DE/de-DE.com_yvcomment.ini' could not be installed because the Administrator language package for 'de-DE' has not been installed or does not exist.
JInstaller::install: The language file 'www/language/es-ES/es-ES.com_yvcomment.ini' could not be installed because the Administrator language package for 'es-ES' has not been installed or does not exist.
JInstaller::install: The language file 'www/language/fa-IR/fa-IR.com_yvcomment.ini' could not be installed because the Administrator language package for 'fa-IR' has not been installed or does not exist.
JInstaller::install: The language file 'www/language/nl-NL/nl-NL.com_yvcomment.ini' could not be installed because the Administrator language package for 'nl-NL' has not been installed or does not exist.
JInstaller::install: The language file 'www/language/ru-RU/ru-RU.com_yvcomment.ini' could not be installed because the Administrator language package for 'ru-RU' has not been installed or does not exist.
JInstaller::install: The language file 'www/language/sv-SE/sv-SE.com_yvcomment.ini' could not be installed because the Administrator language package for 'sv-SE' has not been installed or does not exist.
JInstaller::install: The language file 'www/language/tr-TR/tr-TR.com_yvcomment.ini' could not be installed because the Administrator language package for 'tr-TR' has not been installed or does not exist.
JInstaller::install: There is already a folder called '/home//public_html/new-main/language/en-GB/en-GB.com_yvcomment.ini' - Please initially check whether:
• the Extension is already installed
• the file names in the XML file are spelled correctly
• there are no XML files listed inside the extension.xml file
• all of the files (not including XML files) are correctly listed in the extension.xml file and there are no duplicate entries
• there is an empty folder listed from a previous installation attempt

JInstaller::install: The language file 'www/administrator/language/de-DE/de-DE.com_yvcomment.ini' could not be installed because the Administrator language package for 'de-DE' has not been installed or does not exist.
JInstaller::install: The language file 'www/administrator/language/es-ES/es-ES.com_yvcomment.ini' could not be installed because the Administrator language package for 'es-ES' has not been installed or does not exist.
JInstaller::install: The language file 'www/administrator/language/fa-IR/fa-IR.com_yvcomment.ini' could not be installed because the Administrator language package for 'fa-IR' has not been installed or does not exist.
JInstaller::install: The language file 'www/administrator/language/nl-NL/nl-NL.com_yvcomment.ini' could not be installed because the Administrator language package for 'nl-NL' has not been installed or does not exist.
JInstaller::install: The language file 'www/administrator/language/ru-RU/ru-RU.com_yvcomment.ini' could not be installed because the Administrator language package for 'ru-RU' has not been installed or does not exist.
JInstaller::install: The language file 'www/administrator/language/sv-SE/sv-SE.com_yvcomment.ini' could not be installed because the Administrator language package for 'sv-SE' has not been installed or does not exist.
JInstaller::install: The language file 'www/administrator/language/tr-TR/tr-TR.com_yvcomment.ini' could not be installed because the Administrator language package for 'tr-TR' has not been installed or does not exist.
JInstaller::install: There is already a folder called '/home//public_html/new-main/administrator/language/en-GB/en-GB.com_yvcomment.ini' - Please initially check whether:
• the Extension is already installed
• the file names in the XML file are spelled correctly
• there are no XML files listed inside the extension.xml file
• all of the files (not including XML files) are correctly listed in the extension.xml file and there are no duplicate entries
• there is an empty folder listed from a previous installation attempt

Database errors:
Error message: "You have an error in your SQL syntax. Check the manual that corresponds to your MySQL server version for the right syntax to use near 'LIKE jos_content)' at line 1 SQL=CREATE TABLE jos_yvcomment (LIKE jos_content)"
SQL="CREATE TABLE jos_yvcomment (LIKE jos_content)"



--------------------------------------------------------------------------------


Component Install: Custom install routine failure





--
Any help would be appreciated, I did try to install the table "jos_yvcomment" but I dont know sql that well and I was not sure for some of the fields...


Top
 Profile  
 
PostPosted: Fri Dec 21, 2007 4:15 am 
User avatar
Joomla! Guru
Joomla! Guru

Joined: Thu Jun 01, 2006 1:52 pm
Posts: 979
Location: Moscow, Russia
zarkon wrote:
The first two SEO options in Joomla are activated; the source code I get in the yv-form looks like:
Code:
                   </td>
                   <td>
                      <img src='/?task=displaycaptcha'
                        alt='Bild, welches das geheime Wort enthält' />
                      <br />
                   </td>



'components/com_yvcomment/views/comment/tmpl/default.php' file has this line:
Code:
  <img src='<?php echo JRoute::_('&option=com_yvcomment&task=displaycaptcha'); ?>'

Seems like JRoute doesn't work  :(. You may manually fix this, changing to static link, something like this:
Code:
  <img src='/?option=com_yvcomment&task=displaycaptcha' />

... and wait for Joomla! fix in SVN (nightly build)...
Edited: or better turn SEF URLs off - without them it's Ok without any hacks!
See my BUG Report:
8732 - [url=http://joomlacode.org/gf/project/joomla/tracker/?action=TrackerItemEdit&tracker_item_id=8732]With SEF turned on JRouter looses 'option' in URL.

zarkon wrote:
Also, when I get yvComment to work, it would be great to be able to show the add-comment-form only on demand; e.g. when the user clicks some link to make the form appear. Otherwise, being there all the time, the comments-form feels somehow disturbing to me.

Ok, I'll add this to my TODO list

timeshadowrider wrote:
So I upgraded today to Karibu and I tried to install yvComment and got a mess of errors...

JInstaller::install: The language file 'www/language/da-DK/da-DK.com_yvcomment.ini' could not be installed because the Administrator language package for 'da-DK' has not been installed or does not exist.
...

This Joomla! bug is already reported... you may ignore these messages now.

timeshadowrider wrote:
Database errors:
Error message: "You have an error in your SQL syntax. Check the manual that corresponds to your MySQL server version for the right syntax to use near 'LIKE jos_content)' at line 1 SQL=CREATE TABLE jos_yvcomment (LIKE jos_content)"
SQL="CREATE TABLE jos_yvcomment (LIKE jos_content)"

Looks like you have MySQL v.4: It is not compatible with such 'LIKE' usage.
Better move to MySql 5 ... or patch yvComment to avoid usage of this keyword.
BTW, jos_yvcomment is not necessary (and you don't have to create it), if you "Use content table" (see more info on the homepage)
... I'll add words about incompatibility with MySQL4 there too...

_________________
Text of all my messages is available under the terms of the GNU Free Documentation License: http://www.gnu.org/copyleft/fdl.html


Last edited by yvolk on Fri Dec 21, 2007 7:10 am, edited 1 time in total.

Top
 Profile  
 
PostPosted: Fri Dec 21, 2007 12:03 pm 
Joomla! Apprentice
Joomla! Apprentice

Joined: Sun May 21, 2006 5:54 pm
Posts: 19
Thanks for the quick answer.

Turning off SEO is not an option anymore; I got used to it, and I'm refering to SEO URLs from within some of my articles.

But I changed the scr to static (in line 302), and it works if I use full URL:

Code:
<img src='http://www.myhost.de/index.php?option=com_yvcomment&task=displaycaptcha'

Looking forward to the further development of yv-components :-)


Top
 Profile  
 
PostPosted: Fri Dec 21, 2007 2:33 pm 
User avatar
Joomla! Guru
Joomla! Guru

Joined: Thu Jun 01, 2006 1:52 pm
Posts: 979
Location: Moscow, Russia
zarkon wrote:
Turning off SEO is not an option anymore; I got used to it, and I'm refering to SEO URLs from within some of my articles.

Please note, that yvBBCode has unique feature, that enables you to create references between articles in the form:
[contentid=1]Welcome to Joomla![/contentid]
- and yvBBCode would convert them to real URLs on the fly: when user requests this page!

So, these links are not dependent on SEF (SEO) setting of your site: they would be built according to your settings (including security settings!) in the moment, when page is displayed to the user.

_________________
Text of all my messages is available under the terms of the GNU Free Documentation License: http://www.gnu.org/copyleft/fdl.html


Top
 Profile  
 
PostPosted: Sat Dec 22, 2007 11:36 am 
Joomla! Apprentice
Joomla! Apprentice

Joined: Fri Sep 28, 2007 11:44 pm
Posts: 37
I using this extension and i have few ideas.
I read yout Future plans nad thought

Quote:
"Bad words" option to stop people posting swear words etc...
]
I ques my first request/idead fit here. I have one stupitt bot who post same comment in my page every day ot twice a day.0
I ams sure This is only because i use 30 s between comments. And it always write same text. It would be very great if it could be filtered as spam.

Subject in most cases is unnescary field. I understand that your comments are treated as atricles and they must have title. But option to have default title "Reply to [Articel title]" would be great.


Top
 Profile  
 
PostPosted: Sat Dec 22, 2007 1:11 pm 
User avatar
Joomla! Guru
Joomla! Guru

Joined: Thu Jun 01, 2006 1:52 pm
Posts: 979
Location: Moscow, Russia
dArt85 wrote:
Quote:
"Bad words" option to stop people posting swear words etc...

I guess my first request/idea fit here. I have one stupid bot who post same comment in my page every day or twice a day.0
I am sure This is only because i use 30 s between comments. And it always write same text. It would be very great if it could be filtered as spam.

"Badwords" should be separate, site-wide extension, that may be used to "filter" any spam... If think about this deeper, this extension should be VERY intelligent AND language-aware...
So, the task is to create good "badwords" extension. Integration with yvComment would be easy. Some months ago CoolAcid started such work, but I don't like interface of his extension AND the implementation is TOO simple...
Does anybody want to start the "Badwords" project?

dArt85 wrote:
Subject in most cases is unnecessary field. I understand that your comments are treated as articles and they must have title. But option to have default title "Reply to [Articel title]" would be great.

I think, that "default subject", as in this forum - is bad decision: nobody looks at them, even if you try to write something meaningful :(. if you don't want to have subject, I think it's better make it invisible... and put some first words from message itself to the title (automatically while saving comment).

What do you think?

_________________
Text of all my messages is available under the terms of the GNU Free Documentation License: http://www.gnu.org/copyleft/fdl.html


Top
 Profile  
 
PostPosted: Sat Dec 22, 2007 1:59 pm 
User avatar
Joomla! Apprentice
Joomla! Apprentice

Joined: Sat Dec 22, 2007 1:40 pm
Posts: 5
hi everyone
This is my first post in joomla.org
i've installed joomla 1.5  i want to install comment component
i wanted to install this component But When i go to This URL : http://yurivolkov.com/Joomla/yvComment/index_en.html i receive an error :

[color=black]The connection has timed out


The server at yurivolkov.com is taking too long to respond.

   

    *  The site could be temporarily unavailable or too busy. Try again in a few
          moments.

    *  If you are unable to load any pages, check your computer's network
          connection.

    *  If your computer or network is protected by a firewall or proxy, make sure
          that Firefox is permitted to access the Web.

Website Is down or not ? have you any other download link ? Please Guide me  :(
[/color]


Last edited by feelkosh on Sat Dec 22, 2007 2:00 pm, edited 1 time in total.

Top
 Profile  
 
PostPosted: Sat Dec 22, 2007 2:51 pm 
User avatar
Joomla! Guru
Joomla! Guru

Joined: Thu Jun 01, 2006 1:52 pm
Posts: 979
Location: Moscow, Russia
feelkosh wrote:
hi everyone
i wanted to install this component But When i go to This URL : http://yurivolkov.com/Joomla/yvComment/index_en.html i receive an error :
The connection has timed out...

Everything works... in a case, you have connection problems, I've attached yvComment v.1.11.0 to that message: Re: yvComment v.1.11 released

_________________
Text of all my messages is available under the terms of the GNU Free Documentation License: http://www.gnu.org/copyleft/fdl.html


Top
 Profile  
 
PostPosted: Sat Dec 22, 2007 3:42 pm 
User avatar
Joomla! Apprentice
Joomla! Apprentice

Joined: Sat Dec 22, 2007 1:40 pm
Posts: 5
thanks i've downloaded install package from You attachment  But :
dzed wrote:
Error! Could not find an XML setup file in the package.



i received this error too .

* Error! Could not find an XML setup file in the package.

Unable to find install package 


Last edited by feelkosh on Sat Dec 22, 2007 3:47 pm, edited 1 time in total.

Top
 Profile  
 
PostPosted: Sat Dec 22, 2007 4:14 pm 
User avatar
Joomla! Guru
Joomla! Guru

Joined: Thu Jun 01, 2006 1:52 pm
Posts: 979
Location: Moscow, Russia
feelkosh wrote:
thanks i've downloaded install package from You attachment  But :
dzed wrote:
Error! Could not find an XML setup file in the package.


Please read instructions on the homepage:
Main site
Mirror in Geocities (I've updated it now)

_________________
Text of all my messages is available under the terms of the GNU Free Documentation License: http://www.gnu.org/copyleft/fdl.html


Top
 Profile  
 
PostPosted: Sat Dec 22, 2007 10:37 pm 
User avatar
Joomla! Guru
Joomla! Guru

Joined: Sun Feb 18, 2007 6:40 pm
Posts: 994
Location: Constantine, Algeria
yvolk wrote:
Looks like you have MySQL v.4: It is not compatible with such 'LIKE' usage.
Better move to MySql 5 ... or patch yvComment to avoid usage of this keyword.
BTW, jos_yvcomment is not necessary (and you don't have to create it), if you "Use content table" (see more info on the homepage)
... I'll add words about incompatibility with MySQL4 there too...


and from your web site
Quote:
Attention! It appears, that yvComment is not compatible with MySQL v.4 , because it uses 'LIKE ' keyword. So MySQL v.5 is required!


i have

- Server : Apache/1.3.37 (Unix)
- MySQL : 4.1.22-standard
- PHP : 4.4.6

and no problem ???

_________________
Saber Bousba - صابر بوصبع
Member of the Arabic [ar-DZ] Joomla Translation Team :  http://joomlacode.org/gf/project/ardz/


Top
 Profile  
 
PostPosted: Sat Dec 22, 2007 10:52 pm 
Joomla! Intern
Joomla! Intern

Joined: Fri Aug 17, 2007 11:18 pm
Posts: 84
Great stuff!  It essentiall turns articles into blogs.

I read through all of these comments quickly and if I'm understanding this correctly, someone wants guests to have the ability to post comments, but then you get into the spam-flooding problem. Instead of writing code to deal with this, why not just only permit registered users to post comments?  If they want to comment, then they can take a moment and register. Besides, as an admin, I might want to mine those registered users for, say a newsletter, announcement, etc. If someone is making a comment on my website i want to be able to contact them.

Regards, Dan


Top
 Profile  
 
PostPosted: Sun Dec 23, 2007 6:14 am 
User avatar
Joomla! Guru
Joomla! Guru

Joined: Thu Jun 01, 2006 1:52 pm
Posts: 979
Location: Moscow, Russia
dzed wrote:
yvolk wrote:
Looks like you have MySQL v.4: It is not compatible with such 'LIKE' usage.
Better move to MySql 5 ... or patch yvComment to avoid usage of this keyword.
BTW, jos_yvcomment is not necessary (and you don't have to create it), if you "Use content table" (see more info on the homepage)
... I'll add words about incompatibility with MySQL4 there too...


and from your web site
Quote:
Attention! It appears, that yvComment is not compatible with MySQL v.4 , because it uses 'LIKE ' keyword. So MySQL v.5 is required!


i have

- Server : Apache/1.3.37 (Unix)
- MySQL : 4.1.22-standard
- PHP : 4.4.6

and no problem ???

Thank you, dzed, for your observation. I updated documentation on the homepage to state this:
Quote:
Attention! It appears, that yvComment is not compatible with MySQL v.4 , because it uses 'LIKE ' keyword. So MySQL v.5 is required! Although, MySQL documentation says, that:
"In MySQL 4.1, you can also use LIKE to create an empty table based on the definition of another table, including any column attributes and indexes the original table has: CREATE TABLE new_tbl LIKE orig_tbl;".
There are reports also, that this works. So, maybe, MySQL v.4 will work for you.

_________________
Text of all my messages is available under the terms of the GNU Free Documentation License: http://www.gnu.org/copyleft/fdl.html


Top
 Profile  
 
PostPosted: Sun Dec 23, 2007 6:18 am 
User avatar
Joomla! Guru
Joomla! Guru

Joined: Thu Jun 01, 2006 1:52 pm
Posts: 979
Location: Moscow, Russia
DanBollinger wrote:
Great stuff!  It essentially turns articles into blogs.

I read through all of these comments quickly and if I'm understanding this correctly, someone wants guests to have the ability to post comments, but then you get into the spam-flooding problem. Instead of writing code to deal with this, why not just only permit registered users to post comments?  If they want to comment, then they can take a moment and register. Besides, as an admin, I might want to mine those registered users for, say a newsletter, announcement, etc. If someone is making a comment on my website i want to be able to contact them.

Regards, Dan

Thank you Dan, for your reply. yvComment MAY be configured to allow Registered users only to add comments. Moreover, these are default settings (i.e. adding comments by guests is disabled by default for security reasons).

I agree with your position, but, as I understand, some Admins are frightened, that site visitors would be too lazy to register and so, they won't add some comments  :).

_________________
Text of all my messages is available under the terms of the GNU Free Documentation License: http://www.gnu.org/copyleft/fdl.html


Last edited by yvolk on Sun Dec 23, 2007 6:29 am, edited 1 time in total.

Top
 Profile  
 
PostPosted: Sun Dec 23, 2007 11:17 am 
User avatar
Joomla! Apprentice
Joomla! Apprentice

Joined: Sat Dec 22, 2007 1:40 pm
Posts: 5
hi
thanks .
i could install your component.
i have questions :  1 - how i can show comments in article page ? now i can see comments in admin interface only
                          2 - how i can add features suh as ( smilies , word filtering,...) to this component ?is it possible or not ?

Thanks lot


Top
 Profile  
 
PostPosted: Sun Dec 23, 2007 12:16 pm 
Joomla! Apprentice
Joomla! Apprentice

Joined: Fri Sep 28, 2007 11:44 pm
Posts: 37
yvolk wrote:
dArt85 wrote:
Subject in most cases is unnecessary field. I understand that your comments are treated as articles and they must have title. But option to have default title "Reply to [Articel title]" would be great.

I think, that "default subject", as in this forum - is bad decision: nobody looks at them, even if you try to write something meaningful :(. if you don't want to have subject, I think it's better make it invisible... and put some first words from message itself to the title (automatically while saving comment).
What do you think?


Thats perhaps even better idea. Sometimes you just want to write comment and it is dificult to think suitable  title (subject) for your comment.
I also thought about posibility to hide subject field.

P.S Oh forum  has subjectfor replies  first time i noticed it.  :)


Top
 Profile  
 
PostPosted: Sun Dec 23, 2007 12:24 pm 
Joomla! Apprentice
Joomla! Apprentice

Joined: Fri Sep 28, 2007 11:44 pm
Posts: 37
feelkosh wrote:
hi
thanks .
i could install your component.
i have questions :  1 - how i can show comments in article page ? now i can see comments in admin interface only
                          2 - how i can add features suh as ( smilies , word filtering,...) to this component ?is it possible or not ?

Thanks lot


1. Perhaps you do not set some rules correctly. Maybe you still have to aprove comments. (Components/plugins/Ycvomment Immediately publish guest comments)

2. You have to install aditional components  smilies BBcode or Captcha.
I think there no component for world filtering yet/


Top
 Profile  
 
PostPosted: Sun Dec 23, 2007 8:28 pm 
User avatar
Joomla! Apprentice
Joomla! Apprentice

Joined: Sat Dec 22, 2007 1:40 pm
Posts: 5
i have error in using this component .i got this error :

Image

Server info :

MySQL Version
5.0.45
Perl Version
5.8.8
PHP Version
4.4.7


Setting of yvcomment is :
Image

what's the problem ?


Last edited by feelkosh on Sun Dec 23, 2007 8:31 pm, edited 1 time in total.

Top
 Profile  
 
PostPosted: Mon Dec 24, 2007 3:41 am 
User avatar
Joomla! Guru
Joomla! Guru

Joined: Thu Jun 01, 2006 1:52 pm
Posts: 979
Location: Moscow, Russia
feelkosh wrote:
i have error in using this component .i got this error :
what's the problem ?

This is result of Joomla! bug 8712 'JRoute doesn't handle fragments correctly', see this message above: yvComment and Joomla! 1.5 RC4

As a temporary workaround, you may make a patch:
file: components/com_yvcomment/views/comment/view.html.php
function: display()
change:
Code:
$linkOn = JRoute::_("&option=com_yvcomment&view=comment&ArticleID=".$article->id .  '#yvComment');

to
Code:
$linkOn = JRoute::_("&option=com_yvcomment&view=comment&ArticleID=".$article->id) . '#yvComment';

_________________
Text of all my messages is available under the terms of the GNU Free Documentation License: http://www.gnu.org/copyleft/fdl.html


Last edited by yvolk on Mon Dec 24, 2007 4:17 am, edited 1 time in total.

Top
 Profile  
 
PostPosted: Mon Dec 24, 2007 12:48 pm 
User avatar
Joomla! Guru
Joomla! Guru

Joined: Sun Feb 18, 2007 6:40 pm
Posts: 994
Location: Constantine, Algeria
i have change my user name from "ADMIN" to "OTHER_USER_NAME"
i have this error
Code:
yvComment mail notification: Username "admin" was not found
  ???

but the comment was successfully added

_________________
Saber Bousba - صابر بوصبع
Member of the Arabic [ar-DZ] Joomla Translation Team :  http://joomlacode.org/gf/project/ardz/


Top
 Profile  
 
PostPosted: Mon Dec 24, 2007 1:02 pm 
User avatar
Joomla! Apprentice
Joomla! Apprentice

Joined: Sat Dec 22, 2007 1:40 pm
Posts: 5
yvolk wrote:
change:
Code:
$linkOn = JRoute::_("&option=com_yvcomment&view=comment&ArticleID=".$article->id .  '#yvComment');

to
Code:
$linkOn = JRoute::_("&option=com_yvcomment&view=comment&ArticleID=".$article->id) . '#yvComment';


Nice it's ok . now how i can change interface (colors ,... ) ? (to set with my theme)  which file i should edit ?


Last edited by feelkosh on Mon Dec 24, 2007 1:05 pm, edited 1 time in total.

Top
 Profile  
 
PostPosted: Mon Dec 24, 2007 1:43 pm 
User avatar
Joomla! Guru
Joomla! Guru

Joined: Thu Jun 01, 2006 1:52 pm
Posts: 979
Location: Moscow, Russia
dzed wrote:
i have change my user name from "ADMIN" to "OTHER_USER_NAME"
i have this error
Code:
yvComment mail notification: Username "admin" was not found
  ???

but the comment was successfully added

This is expected behaviour, if you didn't change "ADMIN" to "OTHER_USER_NAME" in yvComment parameter with the list of Usernames.
Or do you propose not to add comment, if notification failed? I think, this is not good  :(

_________________
Text of all my messages is available under the terms of the GNU Free Documentation License: http://www.gnu.org/copyleft/fdl.html


Top
 Profile  
 
PostPosted: Mon Dec 24, 2007 1:48 pm 
User avatar
Joomla! Guru
Joomla! Guru

Joined: Thu Jun 01, 2006 1:52 pm
Posts: 979
Location: Moscow, Russia
feelkosh wrote:
Nice it's ok . now how i can change interface (colors ,... ) ? (to set with my theme)  which file i should edit ?

Hey, feelkosh! Are you testing me for patience  ;) or is documentation on the yvComment's homepage unclear?
Please, see http://yurivolkov.com/Joomla/yvComment/index_en.html#Styles
BTW, 'CSS' is about colors  :), 'template' is about 'interface'...

_________________
Text of all my messages is available under the terms of the GNU Free Documentation License: http://www.gnu.org/copyleft/fdl.html


Top
 Profile  
 
PostPosted: Mon Dec 24, 2007 2:27 pm 
User avatar
Joomla! Guru
Joomla! Guru

Joined: Sun Feb 18, 2007 6:40 pm
Posts: 994
Location: Constantine, Algeria
yvolk wrote:
This is expected behaviour, if you didn't change "ADMIN" to "OTHER_USER_NAME" in yvComment parameter with the list of Usernames.
Or do you propose not to add comment, if notification failed? I think, this is not good  :(


sorry for Inconvenience, I was wrong .
new work great

_________________
Saber Bousba - صابر بوصبع
Member of the Arabic [ar-DZ] Joomla Translation Team :  http://joomlacode.org/gf/project/ardz/


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 1805 posts ]  Go to page Previous  1 ... 5, 6, 7, 8, 9, 10, 11 ... 61  Next



Who is online

Users browsing this forum: No registered users and 14 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Jump to:  
Powered by phpBB® Forum Software © phpBB Group