Cannot upload images

This forum is for reporting bugs in Joomla!. Please don't report problems with extensions in here.
Forum rules
Forum Rules
Forum Post Assistant - If you are serious about wanting help, you will use this tool to help you post.
charlot
Joomla! Apprentice
Joomla! Apprentice
Posts: 7
Joined: Sun Jan 06, 2008 8:13 pm

Re: Cannot upload images

Postby charlot » Mon Jan 21, 2008 8:34 pm

Hi

still not working with rel 9954

at which rel. level does it work ?

Many thanks and 'bravo' for your job !


charlot

Stasys
Joomla! Ace
Joomla! Ace
Posts: 1318
Joined: Wed Aug 17, 2005 11:06 pm
Location: Lithuania
Contact:

Re: Cannot upload images

Postby Stasys » Mon Jan 21, 2008 9:26 pm

you should try rev. 9962
Lithuanian Joomla! Community http://www.lithuanianjoomla.com
lietuviškas Joomla! puslapis, naujienos, straipsniai, forumas, vertimai
always be open source, and be free as freedom

RonVA
Joomla! Apprentice
Joomla! Apprentice
Posts: 34
Joined: Wed Sep 05, 2007 4:22 pm

Re: Cannot upload images

Postby RonVA » Tue Jan 22, 2008 8:21 am

for us this is NOT FIXED IN THE SVN at least not with svn 9954!
after upload we still get the access forbidden message and have to login again.
Ron

charlot
Joomla! Apprentice
Joomla! Apprentice
Posts: 7
Joined: Sun Jan 06, 2008 8:13 pm

Re: Cannot upload images

Postby charlot » Tue Jan 22, 2008 6:01 pm

Hi
:'(
not better with 1.5Stable  :( :(

Where did I miss something ??

Many thanks

charlot

Stasys
Joomla! Ace
Joomla! Ace
Posts: 1318
Joined: Wed Aug 17, 2005 11:06 pm
Location: Lithuania
Contact:

Re: Cannot upload images

Postby Stasys » Thu Feb 07, 2008 12:09 pm

what permissions do you use?
Lithuanian Joomla! Community http://www.lithuanianjoomla.com
lietuviškas Joomla! puslapis, naujienos, straipsniai, forumas, vertimai
always be open source, and be free as freedom

charlot
Joomla! Apprentice
Joomla! Apprentice
Posts: 7
Joined: Sun Jan 06, 2008 8:13 pm

Re: Cannot upload images

Postby charlot » Fri Feb 08, 2008 5:55 pm

Hi

for me, same problem even with stable.
all directory permissions are  writable

Thanks

CHarlot

charlot
Joomla! Apprentice
Joomla! Apprentice
Posts: 7
Joined: Sun Jan 06, 2008 8:13 pm

Re: Cannot upload images

Postby charlot » Sat Feb 09, 2008 6:02 pm

:D
Great !!!!!

It's work now since I just move to 1.5.1

Your are the best !


Many thanks !
Charlot

jmeyerdo
Joomla! Apprentice
Joomla! Apprentice
Posts: 16
Joined: Thu Sep 15, 2005 3:25 pm

Re: Cannot upload images

Postby jmeyerdo » Thu Feb 14, 2008 9:10 pm

Hi!

Hmm, problem (uploading with flash-uploader shows completed - but no images uploaded) still occurs with Joomla 1.5.1 and Firefox 2.0.0.12. With IE7 everything works fine.

Depends this error on server + client or only on client-side?

Kind regards, Jens

User avatar
mcsmom
Joomla! Exemplar
Joomla! Exemplar
Posts: 7985
Joined: Thu Aug 18, 2005 8:43 pm
Location: New York
Contact:

Re: Cannot upload images

Postby mcsmom » Fri Feb 15, 2008 2:44 am

Please turn on debug in global configuration and then try an upload.
Paste the memory and the queries. Also state what browsers you have tried.
So we must fix our vision not merely on the negative expulsion of war, but upon the positive affirmation of peace. MLK 1964.
http://officialjoomlabook.com Get it at http://www.joomla.org/joomla-press-official-books.html Buy a book, support Joomla!.

andreagabellini
Joomla! Fledgling
Joomla! Fledgling
Posts: 1
Joined: Mon Feb 18, 2008 11:28 am

Re: Cannot upload images

Postby andreagabellini » Mon Feb 18, 2008 12:28 pm

Hi,

I have the same problem. IE7 works fine, but Firefox 2.0.0.12 no. I tried to apply the debug, and I noticed that the form and the buttons for the upload appears different than without debug. In this case the upload works fine (firefox + debug).

If I scroll down the page, and then scroll up the page, the form and buttons appears as before, and the upload doesn't occour. Always with firefox and debug.

Thanks,
Andrea

Stasys
Joomla! Ace
Joomla! Ace
Posts: 1318
Joined: Wed Aug 17, 2005 11:06 pm
Location: Lithuania
Contact:

Re: Cannot upload images

Postby Stasys » Mon Feb 25, 2008 8:41 pm

you still can't upload using Firefox 2.0.0.12 ?
Lithuanian Joomla! Community http://www.lithuanianjoomla.com
lietuviškas Joomla! puslapis, naujienos, straipsniai, forumas, vertimai
always be open source, and be free as freedom

murphy46
Joomla! Apprentice
Joomla! Apprentice
Posts: 6
Joined: Thu Dec 20, 2007 6:37 pm

Re: Cannot upload images

Postby murphy46 » Sat Mar 01, 2008 11:35 am

I can confirm the upload problem using Firefox 2.0.0.12
Also, I don't get a chance to decide which upload type to use, it always ends up with flash. So I can't even test if it would work via html upload.

An other problem is the different appearance of the popup window in front- and backside upload (see attachments). The fontsize of the frontside upload destroys the layout completely and makes it hardly usable. The layout and fontsize of the backside upload is fine.

PHP built On: Linux za12 2.6.9-041214 #1 SMP Tue Dec 14 01:56:52 CET 2004 i686
Datenbank-Version: 4.1.10a
Datenbank-Kodierung: utf8_general_ci
PHP-Version: 4.3.10
Webserver: Apache/2.0.53 (Linux/SUSE)
PHP-Anbindung an den Webserver: apache2handler
Joomla!-Version: Joomla! 1.5.1 Production/Stable [ Seenu ] 8-February-2008 22:00 GMT
Benutzer-Agent: Mozilla/5.0 (X11; U; Linux i686; de; rv:1.8.1.12) Gecko/20080203 SUSE/2.0.0.12-5.1 Firefox/2.0.0.12
Template used: JA_purity

I hope someone will find a solution other than using IE :)
murphy46
You do not have the required permissions to view the files attached to this post.

Stasys
Joomla! Ace
Joomla! Ace
Posts: 1318
Joined: Wed Aug 17, 2005 11:06 pm
Location: Lithuania
Contact:

Re: Cannot upload images

Postby Stasys » Sat Mar 01, 2008 12:20 pm

try to test svn 10093

your problem is frontend or backend?
Lithuanian Joomla! Community http://www.lithuanianjoomla.com
lietuviškas Joomla! puslapis, naujienos, straipsniai, forumas, vertimai
always be open source, and be free as freedom

murphy46
Joomla! Apprentice
Joomla! Apprentice
Posts: 6
Joined: Thu Dec 20, 2007 6:37 pm

Re: Cannot upload images

Postby murphy46 » Sat Mar 01, 2008 5:55 pm

Stasys wrote:try to test svn 10093

your problem is frontend or backend?


Both! I have not been able to upload a single picture yet, either way.
As long as FTP is working... But this is not a solution for authors or editors.

Murphy46

Stasys
Joomla! Ace
Joomla! Ace
Posts: 1318
Joined: Wed Aug 17, 2005 11:06 pm
Location: Lithuania
Contact:

Re: Cannot upload images

Postby Stasys » Sat Mar 01, 2008 9:22 pm

what permissions do you use?
Lithuanian Joomla! Community http://www.lithuanianjoomla.com
lietuviškas Joomla! puslapis, naujienos, straipsniai, forumas, vertimai
always be open source, and be free as freedom

ndee_at
Joomla! Apprentice
Joomla! Apprentice
Posts: 37
Joined: Sun Aug 21, 2005 10:24 am

Re: Cannot upload images

Postby ndee_at » Sat Mar 01, 2008 9:46 pm

Hi Guys,

I also still have this issue. It has become better. I do not get logged out automatically after hitting the upload button. But the progress bar still says "completed" and the file is NOT visible and NOT uploaded.

Error logs don't give hints due to permission problem. Component, plugin and module install is working with the same permissions without any problems. I don't think permissions are the problem:

permissions of images/stories

Code: Select all

-rw-r--r-- 1 s2web8 s2web8  4995 Feb  8 22:37 clock.jpg
-rw-r--r-- 1 s2web8 s2web8   251 Feb  8 22:37 ext_com.png
-rw-r--r-- 1 s2web8 s2web8   215 Feb  8 22:37 ext_lang.png
-rw-r--r-- 1 s2web8 s2web8   244 Feb  8 22:37 ext_mod.png
-rw-r--r-- 1 s2web8 s2web8   261 Feb  8 22:37 ext_plugin.png
drwxr-xr-x 2 s2web8 s2web8   192 Feb  8 22:38 food


permissions of modules (where I successfully installed modules)

Code: Select all

-rw-r--r--  1 s2web8 s2web8  44 Feb  8 22:38 index.html
drwxr-xr-x  3 s2web8 s2web8 200 Feb  8 22:39 mod_archive
drwxr-xr-x  3 s2web8 s2web8 200 Feb  8 22:39 mod_banners
drwxr-xr-x  3 s2web8 s2web8 216 Feb  8 22:39 mod_breadcrumbs


J! 1.5.1
PHP 5.2.5
Apache 2.2.x (suexec with suphp)

Please give us an option to switch on/off the flash uploader until this is resolved.

*Edit:
Tested with Firefox 2.0.0.12 + Opera 9.26 on Linux

brunsona
Joomla! Apprentice
Joomla! Apprentice
Posts: 24
Joined: Thu Jan 04, 2007 12:52 am

Re: Cannot upload images

Postby brunsona » Sat Mar 01, 2008 9:54 pm

I've been using the FCK editor with good results. The single image upload works great even when the Joomla image or the Media Manager don't work at all. I use ftp for upload of image groups but my users work in the FCK editor and upload files, configure image parameters, search directories on the server, etc.

Search for it in the extensions area.
-a-

murphy46
Joomla! Apprentice
Joomla! Apprentice
Posts: 6
Joined: Thu Dec 20, 2007 6:37 pm

Re: Cannot upload images

Postby murphy46 » Sun Mar 02, 2008 3:29 pm

Stasys wrote:what permissions do you use?


777 on directory 'images' and all subdirs
644 on all files

But I doubt it has to do with permissions. I have tested for a while with everything set to 777. Same result.

The thing is, when the popup is loaded I can see the html-type mask for about a second or two, but then it changes to flash-type. No way to keep the initial uploadscreen :(

mouki
Joomla! Fledgling
Joomla! Fledgling
Posts: 1
Joined: Mon Mar 03, 2008 12:28 am

Re: Cannot upload images

Postby mouki » Mon Mar 03, 2008 12:50 am

Same problem here. Everything's 664, also tried 777 for images. Sometimes i can successfully upload images with one user. When switching to another user (with same permissions) it fails again. Another time it works fine when logging in with the latter user. Also sometimes after it just worked with one user, it fails when trying the same user with the other browser. Happened with Managers and Super Admins. Tried FF 2.0.0.12 and IE 7.0.6001 on Vista here.

Some server details below.

Code: Select all

PHP built On:       Linux s15263944 2.6.9-023stab044.11-smp #1 SMP Sat Sep 29 13:36:25 MSD 2007 i686
Datenbank-Version:    4.1.10a
Datenbank-Kodierung:    utf8_general_ci
PHP-Version:    4.3.10
Webserver:    Apache/2.0.53 (Linux/SUSE)
PHP-Anbindung an den Webserver:    apache2handler
Joomla!-Version:    Joomla! 1.5.1 Production/Stable [ Seenu ] 8-February-2008 22:00 GMT
Benutzer-Agent:    Mozilla/5.0 (Windows; U; Windows NT 6.0; de; rv:1.8.1.12) Gecko/20080201 Firefox/2.0.0.12


Code: Select all

System    Linux s15263944 2.6.9-023stab044.11-smp #1 SMP Sat Sep 29 13:36:25 MSD 2007 i686
Build Date    Sep 24 2005 08:00:17
Configure Command    './configure' '--prefix=/usr' '--datadir=/usr/share/php' '--mandir=/usr/share/man' '--bindir=/usr/bin' '--libdir=/usr/share' '--includedir=/usr/include' '--sysconfdir=/etc' '--with-_lib=lib' '--with-config-file-path=/etc' '--with-exec-dir=/usr/lib/php/bin' '--disable-debug' '--enable-inline-optimization' '--enable-memory-limit' '--enable-magic-quotes' '--enable-safe-mode' '--enable-sigchild' '--disable-ctype' '--disable-session' '--without-mysql' '--disable-cli' '--without-pear' '--with-openssl' '--with-apxs2=/usr/sbin/apxs2-prefork' 'i586-suse-linux'
Server API    Apache 2.0 Handler
Virtual Directory Support    disabled
Configuration File (php.ini) Path    /etc/php.ini
PHP API    20020918
PHP Extension    20020429
Zend Extension    20021010
Debug Build    no
Thread Safety    disabled
Registered PHP Streams    php, http, ftp, https, ftps, compress.bzip2, compress.zlib


Safe Mode is off, Magic Quotes on, Register Globals Off.

It seems to be harder to repro when debugging is On. It happened in Debug 5mins ago, but i didn't save the output then and since then i've been failing to repro another time..

ndee_at
Joomla! Apprentice
Joomla! Apprentice
Posts: 37
Joined: Sun Aug 21, 2005 10:24 am

Re: Cannot upload images

Postby ndee_at » Mon Mar 03, 2008 8:13 pm

Additional Info:

Tried a fresh J! 1.5.1 install on another server with mod_php and I got logged out after uploading the second picture (see image). Does the media manger work for somebody? This issue was not solved for a long time now. Devs should fix it or disable the flash upload or give us an option to switch flash upload off. Imho the media manager is a key feature of a cms and that really should work painless.

Seems that many german speaking people have this issue. But I can not imagine how the language files could affect this. Hm...

PHP 5.2.5 (mod_php)
Apache.2.2.x
Safe Mode: off
Tested with FF 2.0.0.12 / linux
You do not have the required permissions to view the files attached to this post.

RonVA
Joomla! Apprentice
Joomla! Apprentice
Posts: 34
Joined: Wed Sep 05, 2007 4:22 pm

Re: Cannot upload images

Postby RonVA » Tue Mar 04, 2008 8:02 am

We had exactly the same problems (in Holland with a Dutch Joomla installation). Uploads disappearing and/or being logged out after the upload. We came to the conclusion that these problems are related to the server settings of our hosting provider. This provider has installed a third party security app called Suhosin which limits several php functions. Although this provider (denit.nl, a major provider in Holland) was unable (unwilling?) to trace the problem my guess is that a Suhosin setting is somehow interfering with the joomla php upload code.
We simply solved these issues by swithing to another hosting provider who doesn't use Suhosin or a similar php limiting app.

Nevertheless Joomla falls short in error handling. After 20 years of development experience I have learned that programming has to be defensive. In other words, the programmer has to anthicipate most error situations and has to code quite some error handling to gracefully deal with those errors. Apparently this is not 'hot'. I found very little error handling code in Joomla 1.5. Setting up a fancy framework is a bigger chalenge. Writing documentation is similar, not cool. So we have now a 1.5 code base which is 'lean and mean' and can surly win the 'who can code the most design patterns in as few lines as possible' contest. We users end up with an applicatioin that is difficult to understand (fancy constructions), difiicult to learn (very bad documentation) and hard to use if somehting deviates from the ordinary. Ok, a bit off topic but i have spend many more hours on creating a joomla 1.5 site with some custom code then that I estimated. This 'unable to upload images' issue was one of the major frustrations.

ndee_at
Joomla! Apprentice
Joomla! Apprentice
Posts: 37
Joined: Sun Aug 21, 2005 10:24 am

Re: Cannot upload images

Postby ndee_at » Tue Mar 04, 2008 9:23 am

Hi RonVA,

this is really a good hint. I have patched php with suhosin on both boxes. It successfully protected my joomla installations from existing vulnerabilities. None of my sites have been hacked starting from Mambo 4.5.0. Therefore for me it is a no go to disable it.

But on a first review i did not see any suhosin logs on both boxes. I will look into it more precisely and figure out if it is causing the error.

murphy46
Joomla! Apprentice
Joomla! Apprentice
Posts: 6
Joined: Thu Dec 20, 2007 6:37 pm

Re: Cannot upload images

Postby murphy46 » Tue Mar 04, 2008 10:48 am

ndee_at wrote:... Imho the media manager is a key feature of a cms and that really should work painless...


That's the point! It is of no use if the admin can't delegate the daily work to authors / editors who depend upon a fully functioning frontend!

An other thing I noticed: This button
upload_butt.jpg
has been removed from the iconmenu of the editor in 1.5.1. That button did work, but it's gone now... :(

Murphy46
You do not have the required permissions to view the files attached to this post.

User avatar
mcsmom
Joomla! Exemplar
Joomla! Exemplar
Posts: 7985
Joined: Thu Aug 18, 2005 8:43 pm
Location: New York
Contact:

Re: Cannot upload images

Postby mcsmom » Tue Mar 04, 2008 1:22 pm

I do not believe TInyMCE ever had that button. There is an image button that looks like a tree. This is the same one that has always been in TinyMCE.

You may have been using JCE in your old site; it has a button that looks like that.
So we must fix our vision not merely on the negative expulsion of war, but upon the positive affirmation of peace. MLK 1964.
http://officialjoomlabook.com Get it at http://www.joomla.org/joomla-press-official-books.html Buy a book, support Joomla!.

janno
Joomla! Fledgling
Joomla! Fledgling
Posts: 4
Joined: Thu Dec 22, 2005 3:16 am

Re: Cannot upload images

Postby janno » Tue Mar 04, 2008 10:15 pm

My temporary solution was this...

In file
libraries/joomla/html/html/behavior.php

Commented this line 221 (approx.)...
// $document->addScriptDeclaration($uploaderInit);

Regards

ndee_at
Joomla! Apprentice
Joomla! Apprentice
Posts: 37
Joined: Sun Aug 21, 2005 10:24 am

Re: Cannot upload images

Postby ndee_at » Wed Mar 05, 2008 11:20 pm

janno wrote:My temporary solution was this...

In file
libraries/joomla/html/html/behavior.php

Commented this line 221 (approx.)...
// $document->addScriptDeclaration($uploaderInit);

Regards


Hi janno!

Great! Thank you very much, it seems to be a really good temporary fix for this issue - it works for me. Our on/off switch :)

@all
You were right guys - it seems that suhosin is causing this error. I disabled the extension / patch and the media manager worked as it should. But the problem is really that suhosin does not log the alert. So I can not figure out which option of suhosin is causing this. I already posted in the suhosin forum to figure this issue out. I think really a suhosin limit is causing this - but I will update you if I found out more.

diri
Joomla! Guru
Joomla! Guru
Posts: 702
Joined: Wed Sep 21, 2005 9:27 am
Location: Somewhere

Re: Cannot upload images

Postby diri » Thu Mar 06, 2008 8:31 am

I see it like RonVa:

There is a fancy framework. It's fine and works well in standard environments. But, it's not defensive. It does not give any glue in case there is something not being expected by devs.

For this I have one server where I have to exclude /administrator from .htaccess to be able to say http://site/administrator in browser and to get login screen whenever any kind of SEF is enabled.

Not excluding this directory results in frontpage without content (duh!). I'm not the only one with this problem (it has been mentioned by multiple users in this forum) but, there is no idea to solve it.

And - there are other real trouble causing issues in backend which cause mod_php to be blocking (PHP5 in multiple incarnations)! I spend a lot of time trying to track this down because it's kind of business case for me - Joomla! 1.5 either works in this environment or customer uses another product. I wrote about this problem multiple times since August / September 2007 but, it didn't become better. The opposit applies - more platform dependancies where introduced without giving chance to get away from this. This is a showstopper for me while trying to change J!1.5 to work with AdoDB (I'm almost ready with J! 1.0). :(

ndee_at
Joomla! Apprentice
Joomla! Apprentice
Posts: 37
Joined: Sun Aug 21, 2005 10:24 am

Re: Cannot upload images

Postby ndee_at » Thu Mar 06, 2008 12:28 pm

Hi,

don't get me wrong. I can understand if you are confused by how things have changed and I agree with you, but this is a different topic and it is better to start a new thread.

We really should find a solution for this image/media upload problem.

Greets,
ndee

User avatar
infograf768
Joomla! Master
Joomla! Master
Posts: 18017
Joined: Fri Aug 12, 2005 3:47 pm
Location: **Translation Matters**

Re: Cannot upload images

Postby infograf768 » Thu Mar 06, 2008 12:57 pm

Jumping in on that one.
Bugsquad would like to know what's remaining about this issue as of last svn/nightly.

I have the feeling the only remaining issue is the use of Suhosin.
I am right?
If yes, how exactly have you solved it and how does it impact normal 1.5.x behaviour on other platforms?
Jean-Marie Simonet / infograf · http://www.info-graf.fr
Multilanguage in 2.5: http://help.joomla.org/files/EN-GB_multilang_tutorial.pdf
---------------------------------
ex-Joomla Translation Coordination Team • ex-Joomla! Production Working Group

ndee_at
Joomla! Apprentice
Joomla! Apprentice
Posts: 37
Joined: Sun Aug 21, 2005 10:24 am

Re: Cannot upload images

Postby ndee_at » Thu Mar 06, 2008 1:47 pm

Hi infograf768,

the problem is temporarily solved by disabling the flash uploader (see jannos solution: viewtopic.php?f=199&t=243392&p=1228001#p1226322 ). As mentioned before an option in the backend would be great. So that users with flash uploader problems are able to switch it of and use the html-uploader.

The html-uploader is then working although suhosin patch is installed. So, it seems that the flash-uploader violates the security restrictions of suhosin. Maybe one dev is able to figure it out and get it working. I am a little bit paranoid and I certanly do not uninstall suhosin. It has protected me from many open vulns in joomla and other webapps. I can run (e.g) J! 1.0.4 without being hacked on this server. Therefore please fix the flash-uploader.

The problem with suhosin is that it does not log the violation. Therefore admins have no clue what is causing the violation. So at least I can not give you a hint if the flash uploader violates array, memory, string, url, .. restrictions. But I posted the issue of not logging violations to suhosin forums. Maybe we can get it logging and find out what is causing this behaviour.

Beside that, an option to switch the flash-uploader on/off would make sense anyway?

Greets
ndee

EDIT: I have tested only with J! 1.5.1. Maybe on weekend I find a minute to test it with svn/nightly.


Return to “Joomla! 1.5 Bug Reporting”

Who is online

Users browsing this forum: No registered users and 2 guests