Cache - Character Set Problem

General questions regarding the use of languages in Joomla! 1.5.

Moderator: General Support Moderators

rsteiner
Joomla! Fledgling
Joomla! Fledgling
Posts: 3
Joined: Tue Sep 18, 2007 9:33 pm

Cache - Character Set Problem

Postby rsteiner » Wed Mar 05, 2008 9:08 pm

Hi all

when I use german umlauts öäüß in the text or in article name - they will be displayed correctly but just once. When I reload the page the text is crippled!
As soon as I delete the cache... display is correct ... after reaload is displays garbage again.

There seems to be a code page problem with the cache ... (or my configuration...)

Any suggestions what to change? Can anybody help.
Thank you.

RS

User avatar
infograf768
Joomla! Master
Joomla! Master
Posts: 17953
Joined: Fri Aug 12, 2005 3:47 pm
Location: **Translation Matters**

Re: Cache - Character Set Problem

Postby infograf768 » Tue Mar 11, 2008 3:25 pm

Do you have an url we could check?
What is your system info?
Which version of Joomal do you use?

Please give some information...
Jean-Marie Simonet / infograf · http://www.info-graf.fr
Multilanguage in 2.5: http://help.joomla.org/files/EN-GB_multilang_tutorial.pdf
---------------------------------
ex-Joomla Translation Coordination Team • ex-Joomla! Production Working Group

FunkyMonkey
Joomla! Apprentice
Joomla! Apprentice
Posts: 8
Joined: Tue Mar 04, 2008 2:47 pm

Re: Cache - Character Set Problem

Postby FunkyMonkey » Wed Mar 12, 2008 1:22 pm

I have the same problem. I'm making a bilingual site with finnish and english.
The following finnish article does not show correctly after reload
http://www.funkymonkey.fi/Joomla/index. ... ?task=view
--
Tero Pernu

rsteiner
Joomla! Fledgling
Joomla! Fledgling
Posts: 3
Joined: Tue Sep 18, 2007 9:33 pm

Re: Cache - Character Set Problem

Postby rsteiner » Wed Mar 12, 2008 9:41 pm

Thanks for your replies.

I ran 2 installation one with a clean 1.5 in wiampplite on my local windows machine and one on my website. Since it looked sooo obviously buggy, but nobody else ran into this problem before, I checked into code pages.

Some of them had been altered "mysteriously" to swedish_ci (just a guess: i think one component caused that problem) after manually changing collations in mysql back to UTF8_general_ci it works well and the caracter set problems are gone in the live system.

All right this does not explain any problems with a fresh & clean 1.5 installation in winampplite. I deleted the database, created a new one - making sure to select utf8_general_ci collation (probably finnish could use the same one - but swedish and estonian seems to be different) and reistalled joomla 1.5 stable.
What can I say - if you do it right it works. :laugh:

Hope this helps a little.
cu
rs

User avatar
infograf768
Joomla! Master
Joomla! Master
Posts: 17953
Joined: Fri Aug 12, 2005 3:47 pm
Location: **Translation Matters**

Re: Cache - Character Set Problem

Postby infograf768 » Thu Mar 13, 2008 6:52 am

utf8_general_ci collation works for all languages as far as I know.
You are all advised to upgrade your installs.
1.5.1 has been available for a while and 1.5.2 should be released quite soon.
Jean-Marie Simonet / infograf · http://www.info-graf.fr
Multilanguage in 2.5: http://help.joomla.org/files/EN-GB_multilang_tutorial.pdf
---------------------------------
ex-Joomla Translation Coordination Team • ex-Joomla! Production Working Group

FunkyMonkey
Joomla! Apprentice
Joomla! Apprentice
Posts: 8
Joined: Tue Mar 04, 2008 2:47 pm

Re: Cache - Character Set Problem

Postby FunkyMonkey » Thu Mar 13, 2008 7:19 am

My problem is solved.

The service provider checked the problem and said it was caused by an charset of iso-8859-15 in the php settings. So my page's meta tag send a different, utf8, charset to the server and the problem appeared. The service provider disabled the charset feature all together and no the browser is only reading my meta tag of utf-8.

Work fine. ... for now :)

ps. i have the 1.5.1 Looking forward to the 1.5.2

--
Tero

User avatar
rufuz
Joomla! Explorer
Joomla! Explorer
Posts: 303
Joined: Wed May 09, 2007 10:07 am
Location: Rome
Contact:

Re: Cache - Character Set Problem

Postby rufuz » Thu May 08, 2008 1:01 pm

I found 2 solutions to the problem:

1. changed default charset in php.ini to utf8_general_ci , then added

Code: Select all

<head>
   <meta http-equiv="Content-Type" content="text/html; charset=utf-8">
</head>

in index.php of your template

2. the other solution is a hack, but could be useful I guess if you cannot modify php.ini

add this as first line in index.php in main dir:

Code: Select all

<?php header("Content-Type: text/html; charset=UTF-8", true); ?>


reference: viewtopic.php?f=428&t=284028&p=1292426#p1292426


I'm testing, but it seems to me both solutions work

bye

ricc.

satzdom
Joomla! Apprentice
Joomla! Apprentice
Posts: 29
Joined: Mon Aug 24, 2009 6:22 am

Re: Cache - Character Set Problem

Postby satzdom » Tue Nov 03, 2009 6:10 am

I've got a solution:

just add the following line to the .htaccess file

Code: Select all

AddDefaultCharset utf-8


This solved my problem! :geek:
Warm Regards,
Satheesh K Dominic

http://www.tutorials2learn.com

UYGHURMEN
Joomla! Enthusiast
Joomla! Enthusiast
Posts: 124
Joined: Mon Jan 18, 2010 12:43 am

Re: Cache - Character Set Problem

Postby UYGHURMEN » Mon Jan 18, 2010 4:44 pm

rufuz wrote:I found 2 solutions to the problem:

1. changed default charset in php.ini to utf8_general_ci , then added

Code: Select all

<head>
   <meta http-equiv="Content-Type" content="text/html; charset=utf-8">
</head>

in index.php of your template

2. the other solution is a hack, but could be useful I guess if you cannot modify php.ini

add this as first line in index.php in main dir:

Code: Select all

<?php header("Content-Type: text/html; charset=UTF-8", true); ?>


reference: viewtopic.php?f=428&t=284028&p=1292426#p1292426


I'm testing, but it seems to me both solutions work

bye

ricc.

I did, but page couldn't open, after deleted.

batteringram
Joomla! Apprentice
Joomla! Apprentice
Posts: 12
Joined: Tue Aug 03, 2010 11:49 am

Re: Cache - Character Set Problem

Postby batteringram » Thu Aug 05, 2010 1:58 am

Hi

I tried all abow except changing the php.ini since we rent webspace at a web host, so tht is not an option.

We still have problems showing Eutopeans characters especially åäö and ÅÄÖ. The problem seam to be when we read data from the data base. Everything else seem to use &xxxx; HTML characters for åäö. The problem begin after reuploading the site after making changes due to a fishing attack we had. Some php scripts was changed and added that we had to remove. Bu tto my knowledge I can't imagine I changed any thing with the language. That is unless the hacker removed it. BTW there was no backup when I strated to work on the problem.


Ony other suggestion.

rtozzi
Joomla! Fledgling
Joomla! Fledgling
Posts: 3
Joined: Tue Dec 09, 2008 12:38 am

Re: Cache - Character Set Problem

Postby rtozzi » Sun Dec 11, 2011 12:19 am

satzdom wrote:I've got a solution:

just add the following line to the .htaccess file

Code: Select all

AddDefaultCharset utf-8


This solved my problem! :geek:


This worked for me too... I love a one line / one file fix. Good Work! :geek:


Return to “Language - Joomla! 1.5”

Who is online

Users browsing this forum: No registered users and 5 guests