how remove border in link image?

General questions relating to Joomla! There are other boards for more specific help on Joomla! features and extensions.

Moderator: General Support Moderators

Forum rules
Forum Rules
Absolute Beginner's Guide to Joomla! <-- please read before posting, this means YOU.
Forum Post Assistant - If you are serious about wanting help, you will use this tool to help you post.
faberga
Joomla! Apprentice
Joomla! Apprentice
Posts: 14
Joined: Mon Jan 08, 2007 10:42 pm

how remove border in link image?

Postby faberga » Fri Aug 29, 2008 2:07 pm

Hello to everyone!
I'd like to know if there is a simple way to remove the border around an image with hiperlink in content.
For example I've an image in the frontpage which link me to another page. With firefox the border has a color, with IE7 another color and with Oper there is no border. I'd like that every browser hide the border around the picture..there is a way to set it in the window I use in the back-ent to upload picture? I don't know a lot about css.. There is a simple way?
Thanks to everyone!
fab

I attached how the picture looks like with different browser
You do not have the required permissions to view the files attached to this post.

User avatar
pxforti
Joomla! Hero
Joomla! Hero
Posts: 2755
Joined: Wed Apr 04, 2007 8:54 pm
Location: Driggs, Idaho

Re: how remove border in link image?

Postby pxforti » Fri Aug 29, 2008 2:48 pm

Hi,

Try this

a:link img {border:none;}
or
a img {border:none;}
Joomla Website Design / CS-Cart Website Design
http://writenowdesign.com

faberga
Joomla! Apprentice
Joomla! Apprentice
Posts: 14
Joined: Mon Jan 08, 2007 10:42 pm

Re: how remove border in link image?

Postby faberga » Fri Aug 29, 2008 3:52 pm

thanks a lot, but where have I to insert this code?

User avatar
pxforti
Joomla! Hero
Joomla! Hero
Posts: 2755
Joined: Wed Apr 04, 2007 8:54 pm
Location: Driggs, Idaho

Re: how remove border in link image?

Postby pxforti » Fri Aug 29, 2008 5:33 pm

Hi,

Insert the code into /templates/your-template/css/template_css.css

Also, you might want to look for a:link and see if there is a rule for border in there.
Joomla Website Design / CS-Cart Website Design
http://writenowdesign.com

User avatar
techWild
Joomla! Intern
Joomla! Intern
Posts: 60
Joined: Mon Oct 01, 2007 7:54 pm
Location: USA, Michigan

Just set the image boarder to zero

Postby techWild » Fri Aug 29, 2008 6:15 pm

As a quick, individual basis solution, set the boarder of the image to 0 (zero) when inserting it on your page. If you leave the boarder value blank, it will still add a 1 pixel boarder around the image sometimes. And sometimes you won't see a boarder until you do add a link to it. The code would look similar to this

Code: Select all

<img src="sample.jpg" width="180" height="180" border="0" />
~~~TechWild~~~

faberga
Joomla! Apprentice
Joomla! Apprentice
Posts: 14
Joined: Mon Jan 08, 2007 10:42 pm

Solved!

Postby faberga » Sat Aug 30, 2008 8:14 am

Thanks a lot! It was easier than I thought!
Before change the code I tried to set border value to 0 in the "insert/edit image" window of joomla. The border disappeared!
Thanks a lot
Fab

User avatar
b.sanjay
Joomla! Enthusiast
Joomla! Enthusiast
Posts: 235
Joined: Wed May 09, 2007 7:53 am
Location: Bangalore, Karnataka, India
Contact:

Re: how remove border in link image?

Postby b.sanjay » Mon Sep 01, 2008 11:51 am

in CSS file add "template_css.css"

img{
border-width:0px;
}

then therez no need to add again and again
Thank you.

Regards,
Sanjay Beedi
Senior Software Engineer,
Construe Solutions, Hyderabad, AP, India
http://www.construesol.com/

potongsaga
Joomla! Fledgling
Joomla! Fledgling
Posts: 3
Joined: Thu Jul 28, 2011 8:40 am

Re: how remove border in link image?

Postby potongsaga » Thu Jul 28, 2011 8:54 am

hi, i know this thread has been years ago..

but im having the same problem with my joomla 1.7 that i just downloaded. in the template, there's 2 css files. one is template.css and another is template_rtl.css for the default beez_20 template.

i have tried to find and insert the codes, and tried to edit borders to 0 but i still get the annoying border on the top menu link image that i have been testing on my site. can anyone help?

www.scruffiez.com

im just playing with different options so i can get my site running.


Return to “General Questions - 1.0.x”

Who is online

Users browsing this forum: No registered users and 4 guests