The Joomla! Forum ™



Forum rules


Forum Rules
Absolute Beginner's Guide to Joomla! <-- please read before posting, this means YOU.
Forum Post Assistant - If you are serious about wanting help, you will use this tool to help you post.



Post new topic Reply to topic  [ 1800 posts ]  Go to page Previous  1 ... 22, 23, 24, 25, 26, 27, 28 ... 60  Next
Author Message
PostPosted: Fri Oct 24, 2008 7:37 pm 
User avatar
Joomla! Guru
Joomla! Guru

Joined: Thu Jun 01, 2006 1:52 pm
Posts: 978
Location: Moscow, Russia
Chris wrote:
I read some amazing reviews about your component and decided it would make a great addition to our site, so I installed the component, module and plugin step-by-step like your documented on your site, but when I open an article I get this error:

The comment was not found.: ArticleID=0; (Child ArticleID=125)
This means, that you opened an Article (with ID=125) that is not a Comment (so it has no "Parent article" with ID=0), but yvComment thinks, that it IS a Comment.
This may be due to the fact, that Section of this Article is the same as "Section for comments", configured in yvComment plugin parameters.

Am I right?
Why did this happen, how can I improve documentation? ...


Top
 Profile  
 
PostPosted: Fri Oct 24, 2008 9:15 pm 
Joomla! Apprentice
Joomla! Apprentice

Joined: Sun Oct 12, 2008 10:01 pm
Posts: 14
Can I align the comment box to the left?


Top
 Profile  
 
PostPosted: Wed Oct 29, 2008 11:19 pm 
User avatar
Joomla! Fledgling
Joomla! Fledgling

Joined: Wed Jun 21, 2006 1:30 pm
Posts: 3
Hi Yuri,

I'm using your great component and let me tell you is the best solution I found for my comments web site, now I was asking if you could include an option for a admin replay only and date filter for administration list page, so we can control comments reception for day or week.

Greetings, Raul


Top
 Profile  
 
PostPosted: Thu Oct 30, 2008 1:46 am 
Joomla! Fledgling
Joomla! Fledgling

Joined: Sun Aug 24, 2008 5:17 pm
Posts: 3
Hello!

This is really great component, and it worked just fine for some time, but now I have this problem:
Every time I comment the article, the comment doesn't show up! However, the comment appears in my articles (meaning backend, in a separate section and category, both only for comments, as asked in installation). So, the comments are there, they just don't show up! Furthermore, only "strange" thing that I've noticed is that all new articles have "order" value of 1. When I change this, all of the comments for that specific article appears!

When I first installed yvcomment, I used Joomla! 1.5.5 and yvcomment 1.18, and It worked perfectly. The problem occurred shortly after I upgraded my Joomla! to 1.5.6.
I tried to install latest version of yvcomment, to change user, to change section and category, to upgrade to Joomla! 1.5.7, but nothing happend...

I saw someone here had similar problem as I do, and you said that probably "Auto close comments" is turned on, but that's not case here. I even tried to give it a large value, but no success whatsoever...

I think that it has to do something whit that article ordering, but again, I'm no expert for these things...

Hope to see you write something about this, preferably the solution :)


Top
 Profile  
 
PostPosted: Thu Oct 30, 2008 6:23 am 
User avatar
Joomla! Guru
Joomla! Guru

Joined: Thu Jun 01, 2006 1:52 pm
Posts: 978
Location: Moscow, Russia
KrusevacOpen wrote:
Every time I comment the article, the comment doesn't show up! However, the comment appears in my articles (meaning backend, in a separate section and category, both only for comments, as asked in installation). So, the comments are there, they just don't show up! Furthermore, only "strange" thing that I've noticed is that all new articles have "order" value of 1. When I change this, all of the comments for that specific article appears!

Maybe comments are unpublished? (And after you change something, e.g. order, they become published).
I will guess better, if you give us _exact_ contents of jos_content table record (of this comment) before and after modification...


Top
 Profile  
 
PostPosted: Thu Oct 30, 2008 6:29 am 
User avatar
Joomla! Guru
Joomla! Guru

Joined: Thu Jun 01, 2006 1:52 pm
Posts: 978
Location: Moscow, Russia
woody_sud wrote:
Hi Yuri,

I'm using your great component and let me tell you is the best solution I found for my comments web site, now I was asking if you could include an option for a admin replay only and date filter for administration list page, so we can control comments reception for day or week.

Greetings, Raul

Hi, Raul!
As I understood you, you ask to add 'filter by date' (e.g. last day, last week...) to the admin page (List of comments view...).
But I didn't get what you mean by 'option for a admin replay only' :(


Top
 Profile  
 
PostPosted: Fri Oct 31, 2008 6:10 pm 
User avatar
Joomla! Fledgling
Joomla! Fledgling

Joined: Wed Jun 21, 2006 1:30 pm
Posts: 3
yvolk wrote:
Hi, Raul!
As I understood you, you ask to add 'filter by date' (e.g. last day, last week...) to the admin page (List of comments view...).
But I didn't get what you mean by 'option for a admin replay only' :(


Ok, thats a minor issue just for my own site, look, I need a reply only from any admin, and option in "allow_comment_on_comment" plugin parameter have "owner_reply_only", "one_level_deep" and "threaded_comments", so an option "admin_only" would be great.
I already made a little patch in "/components/com_yvcomments/helpers.php", hopping you dont mind so much:

line 920|
Code:
static $ArticleID = null;

changed to
Code:
global $mainframe; static $ArticleID = null;

just adding global $mainframe var to the function ambit.

line 1010|
Code:
if ( $user->get('id') != $ArticleAuthorID ) {

changed to
Code:
if ( ($user->get('id') != $ArticleAuthorID) || !$framework->isAdmin() ) {

adding an admin validation so only admin can reply comments.

Just waitting your approvation, and sorry for my poor english I'm from Mexico.

This is my website
http://www.tapachula.gob.mx

Thanks, Raul


Top
 Profile  
 
PostPosted: Sat Nov 01, 2008 5:22 am 
User avatar
Joomla! Guru
Joomla! Guru

Joined: Thu Jun 01, 2006 1:52 pm
Posts: 978
Location: Moscow, Russia
woody_sud wrote:
I need a reply only from any admin, and option in "allow_comment_on_comment" plugin parameter have "owner_reply_only", "one_level_deep" and "threaded_comments", so an option "admin_only" would be great.

Ok, I'll add this to the next version of yvcomment:
---
Add new value to "Allow comments on comment" option: "Administrator's reply only". - Same as "Owner's reply only", but only Administrators (or users, who have all rights to edit comments) are allowed to add comment on Comment.
---

_________________
Text of all my messages is available under the terms of the GNU Free Documentation License: http://www.gnu.org/copyleft/fdl.html


Top
 Profile  
 
PostPosted: Mon Nov 03, 2008 11:16 am 
Joomla! Apprentice
Joomla! Apprentice

Joined: Wed Jan 10, 2007 2:21 pm
Posts: 20
Is there any simple way to make the ymComment module hide article author information when listing new comments? Is it possible to make it display comment and details about comment, but not to show the name of the author whose article is commented?

Thanks in advance.


Top
 Profile  
 
PostPosted: Tue Nov 04, 2008 2:05 pm 
Joomla! Fledgling
Joomla! Fledgling

Joined: Tue Nov 04, 2008 12:35 pm
Posts: 2
Could you add a button Report abouse - like they have : http://www.azrul.com/articles/happy_hal ... l#comments

with box: "Comment reported to site administrator " [x]


Top
 Profile  
 
PostPosted: Wed Nov 05, 2008 6:42 am 
User avatar
Joomla! Guru
Joomla! Guru

Joined: Thu Jun 01, 2006 1:52 pm
Posts: 978
Location: Moscow, Russia
Vigilante wrote:
Is there any simple way to make the ymComment module hide article author information when listing new comments? Is it possible to make it display comment and details about comment, but not to show the name of the author whose article is commented?

Thanks in advance.

Hi! Out of the box, in the yvComment module you have three layouts for the 'List of Comments" view. As I see, you need some combination of them.
To do this, you have to create your custom layout as some combination of existing... (read more about 'template override'... in the forum and on the homepage).

_________________
Text of all my messages is available under the terms of the GNU Free Documentation License: http://www.gnu.org/copyleft/fdl.html


Top
 Profile  
 
PostPosted: Wed Nov 05, 2008 6:48 am 
User avatar
Joomla! Guru
Joomla! Guru

Joined: Thu Jun 01, 2006 1:52 pm
Posts: 978
Location: Moscow, Russia
malinaboy wrote:
Could you add a button Report abouse - like they have : http://www.azrul.com/articles/happy_hal ... l#comments

with box: "Comment reported to site administrator " [x]

I don't know, if Joomla! has such API...
Maybe we should use Joomla!'s existing 'rating' (voting) feature (plugin)? Lowest rating may mean 'abuse'?!
Please, investigate this: this may work out of the box already (just enable yvComment to execute content plugins...)?!

_________________
Text of all my messages is available under the terms of the GNU Free Documentation License: http://www.gnu.org/copyleft/fdl.html


Top
 Profile  
 
PostPosted: Thu Nov 06, 2008 8:48 am 
Joomla! Fledgling
Joomla! Fledgling

Joined: Sun Nov 02, 2008 9:29 pm
Posts: 1
I had the same problem, like Chris: "The comment was not found.: ArticleID=0; (Child ArticleID=125)". Yuri sent me a solution. I had to say special thanks for this GREAT SUPPORT!!

Mike from Hungary


Top
 Profile  
 
PostPosted: Thu Nov 06, 2008 11:30 am 
Joomla! Fledgling
Joomla! Fledgling

Joined: Tue Nov 04, 2008 12:35 pm
Posts: 2
no , It's meas when somebody find a "BAD" command he can very quickly add info to admin to del this post!


Top
 Profile  
 
PostPosted: Thu Nov 06, 2008 2:25 pm 
Joomla! Intern
Joomla! Intern

Joined: Tue Feb 19, 2008 6:22 pm
Posts: 58
This plugin is AWESOME! Thank you, thank you, thank you!


Top
 Profile  
 
PostPosted: Fri Nov 07, 2008 3:17 pm 
Joomla! Enthusiast
Joomla! Enthusiast

Joined: Fri Dec 16, 2005 12:33 am
Posts: 150
I've installed this component on my Joomla 1.5.7 site, however, at the bottom of each article, I get this:

Quote:
The comment was not found.: ArticleID=0; (Child ArticleID=382)


see this url

I wonder how to make it work again, because it used to work fine after a fresh install. I've enabled guest commenting though


Top
 Profile  
 
PostPosted: Sat Nov 08, 2008 7:20 am 
User avatar
Joomla! Guru
Joomla! Guru

Joined: Thu Jun 01, 2006 1:52 pm
Posts: 978
Location: Moscow, Russia
mikehu wrote:
I had the same problem, like Chris: "The comment was not found.: ArticleID=0; (Child ArticleID=125)". Yuri sent me a solution. I had to say special thanks for this GREAT SUPPORT!!

Mike from Hungary

I want to add, that this bug is for those, who don't "Use content table". The fix will be included in the next release.

I'm attaching patched files for v.1.19.002 only:
1. 'components/com_yvcomment/helpers.php'
2. 'components/com_yvcomment/models/comment.php'


You do not have the required permissions to view the files attached to this post.


Top
 Profile  
 
PostPosted: Sat Nov 08, 2008 3:48 pm 
Joomla! Intern
Joomla! Intern

Joined: Wed Sep 10, 2008 6:08 am
Posts: 57
Location: Sweden
Hi,

I searched the thread but didn't come up with anything.

Is it possible (with some modifications?), to get the comments visible in the category blog view, not just the article view? I've been browsing the code, but I'm only getting dizzy. :p

If so, I would be able to place the comments in hidden divs, and use a "collapse" javascript (show/hide-button) to show the comments "in-line" after each article.

Thanks,
Floddy

_________________
www.irry.com


Top
 Profile  
 
PostPosted: Sat Nov 08, 2008 6:11 pm 
Joomla! Enthusiast
Joomla! Enthusiast

Joined: Fri Dec 16, 2005 12:33 am
Posts: 150
yvolk wrote:
mikehu wrote:
I had the same problem, like Chris: "The comment was not found.: ArticleID=0; (Child ArticleID=125)". Yuri sent me a solution. I had to say special thanks for this GREAT SUPPORT!!

Mike from Hungary

I want to add, that this bug is for those, who don't "Use content table". The fix will be included in the next release.

I'm attaching patched files for v.1.19.002 only:
1. 'components/com_yvcomment/helpers.php'
2. 'components/com_yvcomment/models/comment.php'


Have used the patched files to overwrite existing files, however, this doesn't solve my problem. I do enable the 'Use content table' option though.

the error message is:
Quote:
The comment was not found.: ArticleID=0; (Child ArticleID=382)


see http://www.panda-greatwall.com/everythi ... group.html

Thanks for the wonderful component & plugin!! I wish I could figure out how to make it fully functional for me.


Top
 Profile  
 
PostPosted: Sat Nov 08, 2008 6:34 pm 
Joomla! Apprentice
Joomla! Apprentice

Joined: Wed Sep 19, 2007 2:03 pm
Posts: 46
hi! any chance to have a "notify me for reply" option in a new version?? :-[


Top
 Profile  
 
PostPosted: Sat Nov 08, 2008 8:48 pm 
User avatar
Joomla! Guru
Joomla! Guru

Joined: Thu Jun 01, 2006 1:52 pm
Posts: 978
Location: Moscow, Russia
Floddy wrote:
Is it possible (with some modifications?), to get the comments visible in the category blog view, not just the article view? I've been browsing the code, but I'm only getting dizzy. :p

If so, I would be able to place the comments in hidden divs, and use a "collapse" javascript (show/hide-button) to show the comments "in-line" after each article.

Hi, Floddy!
Maybe, some time this will be an option, but now you may try to hack the code:
see the file 'components/com_yvcomment/views/comment/view.html.php'.

Just a clue:
1) These lines switch on/off display of 'Comments (N)'
Code:
&& $yvComment->ParentView() != 'article'
...
    $ShowNumberOfCommentsAlone = ( ($nCommentsTotal > 0) || $MayAdd);


2) These lines restrict display list of comments to 'article' view only:
Code:
if ( $yvComment->ParentView() == 'article') {
  $ShowComments = true;
}

Good luck!

_________________
Text of all my messages is available under the terms of the GNU Free Documentation License: http://www.gnu.org/copyleft/fdl.html


Top
 Profile  
 
PostPosted: Sat Nov 08, 2008 8:59 pm 
User avatar
Joomla! Guru
Joomla! Guru

Joined: Thu Jun 01, 2006 1:52 pm
Posts: 978
Location: Moscow, Russia
Lambas wrote:
hi! any chance to have a "notify me for reply" option in a new version?? :-[

Hi, Lambas!
I can do this in yvComment, but I think this is a wrong way.
Please see Create content subscription extension 'challenge' for those, who want to contribute this function for the whole Joomla! CMS, not for yvComment alone.

Accept the challenge!

_________________
Text of all my messages is available under the terms of the GNU Free Documentation License: http://www.gnu.org/copyleft/fdl.html


Top
 Profile  
 
PostPosted: Sat Nov 08, 2008 9:13 pm 
User avatar
Joomla! Guru
Joomla! Guru

Joined: Thu Jun 01, 2006 1:52 pm
Posts: 978
Location: Moscow, Russia
malinaboy wrote:
no , It's meas when somebody find a "BAD" command he can very quickly add info to admin to del this post!

I mean, that this is You - site Admin/Developer, who defines 'semantics' (meaning), who decides, what 'lowest rating' etc. means in your site. Why don't have both 'rating' and 'abuse reporting' in one 'dimension' (one field of the table...) ?!

yvolk wrote:
malinaboy wrote:
Could you add a button Report abouse - like they have : http://www.azrul.com/articles/happy_hal ... l#comments

with box: "Comment reported to site administrator " [x]

I don't know, if Joomla! has such API...
Maybe we should use Joomla!'s existing 'rating' (voting) feature (plugin)? Lowest rating may mean 'abuse'?!
Please, investigate this: this may work out of the box already (just enable yvComment to execute content plugins...)?!

_________________
Text of all my messages is available under the terms of the GNU Free Documentation License: http://www.gnu.org/copyleft/fdl.html


Top
 Profile  
 
PostPosted: Sun Nov 09, 2008 12:22 am 
Joomla! Intern
Joomla! Intern

Joined: Wed Sep 10, 2008 6:08 am
Posts: 57
Location: Sweden
yvolk wrote:
Hi, Floddy!
Maybe, some time this will be an option, but now you may try to hack the code:
see the file 'components/com_yvcomment/views/comment/view.html.php'.

Just a clue:
1) These lines switch on/off display of 'Comments (N)'
Code:
&& $yvComment->ParentView() != 'article'
...
    $ShowNumberOfCommentsAlone = ( ($nCommentsTotal > 0) || $MayAdd);


2) These lines restrict display list of comments to 'article' view only:
Code:
if ( $yvComment->ParentView() == 'article') {
  $ShowComments = true;
}

Good luck!


Hi!

I got the "Comments (N)" hidden by just setting it in the plugin preferences, and then made the comments visible by commenting out the "if" part in 2).

Then, with a template override and some JavaScript, I've managed to get the "show/hide" work. Now I just have some styling to do, and I also have to think about what approach I should use to make the comments hidden by default, but also accessible on non-JavaScript browsers.

Thanks a lot!

Regards,
Floddy

_________________
www.irry.com


Top
 Profile  
 
PostPosted: Sun Nov 09, 2008 10:06 am 
Joomla! Apprentice
Joomla! Apprentice

Joined: Sun Nov 09, 2008 9:46 am
Posts: 6
Location: Poland
Hello

i've uninstalled older ver. of yvComent because I had problem with Bigo captcha (no picture). Other compatible captcha solutions failed. So i decided to reinstall both Captha and yvComment extensions. New 1.19.2 yvComment was available. Now its installed but ... and here goes my question: "Add new comment" form is missing. All comments are visible but no form to add new ones. What to do to fix this.
Additional info:
- J! 1.5.7
- Guest account created as Author
- Guest can add comments set to YES

Link to page with example (no Add New Comment form) - http://mlodytata.pl/index.php?option=co ... &Itemid=68

Thank you in advance for you help
Tomasz


Top
 Profile  
 
PostPosted: Sun Nov 09, 2008 1:17 pm 
User avatar
Joomla! Guru
Joomla! Guru

Joined: Thu Jun 01, 2006 1:52 pm
Posts: 978
Location: Moscow, Russia
tomzio wrote:
"Add new comment" form is missing. All comments are visible but no form to add new ones. What to do to fix this.
Additional info:
- J! 1.5.7
- Guest account created as Author
- Guest can add comments set to YES

Hi, Tomasz! There may be very many reasons, why the form is not shown...
These reasons fall into two groups:
- Current user is not allowed to add comments
- Current Article is not allowed to be commented on...

To figure out, what is a reason in your case, you may insert some 'trace messages' into 'components/com_yvcomment/views/comment/view.html.php' file.
Debugging this part of code (and inside functions, that are being called from it...) will give all answers:
Code:
   $MayAdd = false;
   $MayUpdate = false;
   $AddEnabledForArticle = false;
   $CommentsAreClosed = false;
   switch ($task) {
     case 'deletedisplay':
     case 'editdisplay':
         $MayUpdate = $yvComment->EditEnabled($this->get('yvCommentID'));
         break;
      default:
         $AddEnabledForArticle = $yvComment->AddEnabledForArticle($ArticleID);
         $CommentsAreClosed = $yvComment->CommentsAreClosed($ArticleID);
         if ($AddEnabledForArticle) {
            $MayAdd = $yvComment->AddEnabledForUser();
         }
         //$message[] = 'MayAdd="' . $MayAdd . '"; AddEnabledForArticle="' . $AddEnabledForArticle . '"';
   }

_________________
Text of all my messages is available under the terms of the GNU Free Documentation License: http://www.gnu.org/copyleft/fdl.html


Top
 Profile  
 
PostPosted: Sun Nov 09, 2008 8:04 pm 
Joomla! Apprentice
Joomla! Apprentice

Joined: Sun Nov 09, 2008 9:46 am
Posts: 6
Location: Poland
Hi once again! :)

Problem solved. Thx. Just inverted meaning of fields with section ID's for which adding comments was prohibited :)

But unforunatly have other problem - Bigo Captcha.

For yvComment I have the following settings:
Use Captcha: Yes
Delay Captha Image : NO

The problem is that captcha image shows from time to time so rarely that it is hard for me to say more about when captcha image shows and when it doesn't (I can only see the text).

Can you help me with that ?

BR
Tomasz

P.S. I know that it is not the topic about Bigo Captcha but you have so much experience that maybe you will be able to help me :)

[SOLVED]


Last edited by tomzio on Tue Nov 11, 2008 9:27 pm, edited 1 time in total.

Top
 Profile  
 
PostPosted: Mon Nov 10, 2008 1:46 am 
Joomla! Enthusiast
Joomla! Enthusiast

Joined: Fri Dec 16, 2005 12:33 am
Posts: 150
hi yvolk,

can you look into my problem?
Quote:
Section is not set. Please configure Section for yvComments (in Plugin Manager for yvComment Plugin).


http://www.panda-greatwall.com/everythi ... s-day.html

what is going wrong? thanks

I've left the section list empty in the plugin configuration.


Top
 Profile  
 
PostPosted: Mon Nov 10, 2008 6:42 am 
User avatar
Joomla! Guru
Joomla! Guru

Joined: Thu Jun 01, 2006 1:52 pm
Posts: 978
Location: Moscow, Russia
tomzio wrote:
Hi once again! :)

Problem solved... But unforunatly have other problem - Bigo Captcha.

Hi, Tomasz! I answered you in Bigo Captcha forum


Top
 Profile  
 
PostPosted: Mon Nov 10, 2008 6:45 am 
User avatar
Joomla! Guru
Joomla! Guru

Joined: Thu Jun 01, 2006 1:52 pm
Posts: 978
Location: Moscow, Russia
ivytony wrote:
hi yvolk,

can you look into my problem?
Quote:
Section is not set. Please configure Section for yvComments (in Plugin Manager for yvComment Plugin).


http://www.panda-greatwall.com/everythi ... s-day.html

what is going wrong? thanks

I've left the section list empty in the plugin configuration.

Hi! You MUST set 'Section for comments' and 'Category fo comments' options. Please read instructions on the Homepage


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 1800 posts ]  Go to page Previous  1 ... 22, 23, 24, 25, 26, 27, 28 ... 60  Next



Who is online

Users browsing this forum: No registered users and 28 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Jump to:  
Powered by phpBB® Forum Software © phpBB Group