Characters?

General questions regarding the use of languages in Joomla! 1.5.

Moderator: General Support Moderators

hlcno
Joomla! Apprentice
Joomla! Apprentice
Posts: 9
Joined: Fri Jul 20, 2007 8:09 pm

 Characters?

Postby hlcno » Sun Jun 22, 2008 9:44 pm

Anyone know what these  characters are? I keep running into them on my Joomla 1.5 site, i'm running the normal install using english.

What's weird is my main page which is running azrul blog, it's fine, but if you go to the real article page it makes ' to  and turns spaces to Â

I did a search on here but didn't see anything that really relates.

hlcno
Joomla! Apprentice
Joomla! Apprentice
Posts: 9
Joined: Fri Jul 20, 2007 8:09 pm

Re: Â Characters?

Postby hlcno » Thu Jun 26, 2008 1:24 am

anyone? anyone? Beuller?

cwk
Joomla! Apprentice
Joomla! Apprentice
Posts: 27
Joined: Wed Jun 28, 2006 2:27 pm

Re: Â Characters?

Postby cwk » Sat Nov 15, 2008 6:46 am

Bump! I'm seeing the same thing. The stray  characters are there if you aren't logged in. Nearly a vanilla installation. They disappear when you log in. This site is for a charity bone marrow registry drive and so it isn't something that will have a long life, but if I'm seeing this, I hesitate to migrate my primary site to 1.5.x.

PHP Built on: Linux web4 2.6.18-6-amd64 #1 SMP Mon Jun 16 22:30:01 UTC 2008 x86_64
Database Version: 5.0.32-Debian_7etch6-log
Database Collation: utf8_general_ci
PHP Version: 4.4.6
Web Server: Apache
Web Server to PHP interface: cgi
Joomla! Version: Joomla! 1.5.7 Production/Stable [ Wovusani ] 9-September-2008 23:00 GMT
User Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.16) Gecko/20080702 (CK-IBM) Firefox/2.0.0.16 Mnenhy/0.7.5.0

Template is
JA_Purity Default 1.2.0 12/26/07 JoomlArt.com

User avatar
infograf768
Joomla! Master
Joomla! Master
Posts: 18017
Joined: Fri Aug 12, 2005 3:47 pm
Location: **Translation Matters**

Re: Â Characters?

Postby infograf768 » Sat Nov 15, 2008 7:50 am

What is the exact character/glyph that should display?
Could you post a link to the place where it shows on your site if the site is online?
Jean-Marie Simonet / infograf · http://www.info-graf.fr
Multilanguage in 2.5: http://help.joomla.org/files/EN-GB_multilang_tutorial.pdf
---------------------------------
ex-Joomla Translation Coordination Team • ex-Joomla! Production Working Group

cwk
Joomla! Apprentice
Joomla! Apprentice
Posts: 27
Joined: Wed Jun 28, 2006 2:27 pm

Re: Â Characters?

Postby cwk » Sun Nov 16, 2008 3:33 am

infograf768 wrote:What is the exact character/glyph that should display?
Could you post a link to the place where it shows on your site if the site is online?

http://www.knoxcomm.com/saulo/

Not logged in:
Once again! VOLUNTEERS! PLEASE PARK OFF-CAMPUS!

Code: Select all

<p style="font-size: large">Once again!  VOLUNTEERS!  PLEASE PARK OFF-CAMPUS!</p>


Logged in:
Once again! VOLUNTEERS! PLEASE PARK OFF-CAMPUS!

Code: Select all

<p style="font-size: large">Once again!  VOLUNTEERS!  PLEASE PARK OFF-CAMPUS!</p>

Hesitated to display the link due to security concerns, but the site will soon be static as the event is over (quite successful, by the way, and I suggest everyone rush out to register for the bone marrow registry at http://www.marrow.org/).

User avatar
infograf768
Joomla! Master
Joomla! Master
Posts: 18017
Joined: Fri Aug 12, 2005 3:47 pm
Location: **Translation Matters**

Re: Â Characters?

Postby infograf768 » Sun Nov 16, 2008 7:13 am

Except for the fact that your text abuses of non breaking spaces next to normal spaces, I do not understand this behavior.

Code: Select all

Once again!&nbsp; VOLUNTEERS!&nbsp; PLEASE PARK OFF-CAMPUS!</p>


Could you clean-up your code and take of one of the spaces where they are together?
Which version of Joomla?
Which text editor?
Is your database full utf8?
Jean-Marie Simonet / infograf · http://www.info-graf.fr
Multilanguage in 2.5: http://help.joomla.org/files/EN-GB_multilang_tutorial.pdf
---------------------------------
ex-Joomla Translation Coordination Team • ex-Joomla! Production Working Group

cwk
Joomla! Apprentice
Joomla! Apprentice
Posts: 27
Joined: Wed Jun 28, 2006 2:27 pm

Re: Â Characters?

Postby cwk » Sun Nov 16, 2008 10:40 pm

The text is generated by the default editor, TinyMCE 2.0. The odd characters are not visible either from the editor screen or from the HTML view (you're logged in when editing). Version information appears in my first post which is a dump from the control panel System Information link.

I did find that two consecutive spaces make the funny character appear. I edited this particular piece to get rid of the two spaces following punctuation (a convention in American typing classes at one point) and the extra characters went away.

User avatar
infograf768
Joomla! Master
Joomla! Master
Posts: 18017
Joined: Fri Aug 12, 2005 3:47 pm
Location: **Translation Matters**

Re: Â Characters?

Postby infograf768 » Mon Nov 17, 2008 10:15 am

I suggest you use JCE insted of Tiny MCE.
Jean-Marie Simonet / infograf · http://www.info-graf.fr
Multilanguage in 2.5: http://help.joomla.org/files/EN-GB_multilang_tutorial.pdf
---------------------------------
ex-Joomla Translation Coordination Team • ex-Joomla! Production Working Group

cwk
Joomla! Apprentice
Joomla! Apprentice
Posts: 27
Joined: Wed Jun 28, 2006 2:27 pm

Re: Â Characters?

Postby cwk » Mon Nov 17, 2008 2:30 pm

Thanks for the suggestions. As I said at the outset, this was a quick site set up to support a specific event. I find it very interesting that the user's logged-in status would affect how the characters are displayed, which also makes me wonder whether the behavior is an artifact of the editor or of Joomla! itself. In any case, I think it qualifies as a bug.

Regards,

Chris

n1gh7r4v3n
Joomla! Apprentice
Joomla! Apprentice
Posts: 10
Joined: Sat Feb 28, 2009 5:04 pm

Re: Â Characters?

Postby n1gh7r4v3n » Sat Feb 28, 2009 8:09 pm

infograf768 wrote:I suggest you use JCE insted of Tiny MCE.

Hi, i am having the same problem. the sign  is showing up in the content regulary. And yes only when not logged in. pretty weird! When i clean the cache it is gone but that is no real solution either. Cause i like the cache to be on.

Also signs like for exemple ' or ë turn into  € or tm signs.

I am using JCE editor and not the tiny editor. I googled around and found a lot of other joomla websites with the same problem. I figured maybe it has something to do with other components i am using so i removed joomfish en artio joomsef put my language back to enhlish and my templates back to ja purity and ruck milkyway and that didnt solve the problem either.

I am using Joomla! 1.5.9 Production/Stable [ Vatani ] 9-January-2009 23:00 GMT

i didnt have this problem on an other site of mine (joomla 1.5.6) so i think it might be a bug in the 1.5.9 version. I am getting really annoyed with this problem. I just keep on searching where the problem is.

I am going to make a fresh install of joomla on an other webserver. So i can see wether this problem occurs directly after the install. I will let you know if i find a solution. Let me know if you found one to.
Thanks anyway ;)

cwk
Joomla! Apprentice
Joomla! Apprentice
Posts: 27
Joined: Wed Jun 28, 2006 2:27 pm

Re: Â Characters?

Postby cwk » Sat Feb 28, 2009 8:55 pm

I suspect you'll find that the odd characters appear when you have a period followed by two spaces. Those of us who learned our keyboard skills in high school typing class tend to automatically follow a period with two spaces.

I still think it's a bug. Good luck!

n1gh7r4v3n
Joomla! Apprentice
Joomla! Apprentice
Posts: 10
Joined: Sat Feb 28, 2009 5:04 pm

Re: Â Characters?

Postby n1gh7r4v3n » Sat Feb 28, 2009 9:32 pm

cwk wrote:I suspect you'll find that the odd characters appear when you have a period followed by two spaces. Those of us who learned our keyboard skills in high school typing class tend to automatically follow a period with two spaces.

I still think it's a bug. Good luck!


It is true double spaces make this happen, but there is more to it then that! because sometimes there is no double space at all and it still happens!

The signs ë didnt work because i needed to use &euml; instead. But when i open the code editor and replace all ë with &euml; and save it it doesnt seem to work either!! When i open it again in the code editor the &euml; are all changed back in ë. (but that is an other subject)

I am gonna keep looking maybe ill find it. But one thing is sure. When you clean the cache the problem is solved. So i figure it has something to do with the cache function. Ill get back to you if i find the problem. One thing is sure there are a lot of webmasters with the ssame problem! Try googling this http://www.google.be/search?hl=nl&safe= ... eken&meta=

n1gh7r4v3n
Joomla! Apprentice
Joomla! Apprentice
Posts: 10
Joined: Sat Feb 28, 2009 5:04 pm

Re: Â Characters?

Postby n1gh7r4v3n » Sat Mar 07, 2009 4:00 am

I found a solution, just unpublisch the plugin "system cache". But not the cache in global configuration. ;)

FoodMODE
Joomla! Apprentice
Joomla! Apprentice
Posts: 7
Joined: Tue Mar 03, 2009 7:26 pm

Re: Â Characters?

Postby FoodMODE » Sat Mar 07, 2009 6:40 am

I have tried everything in this blog but there has been no effect.

n1gh7r4v3n
Joomla! Apprentice
Joomla! Apprentice
Posts: 10
Joined: Sat Feb 28, 2009 5:04 pm

Re: Â Characters?

Postby n1gh7r4v3n » Sat Mar 07, 2009 11:50 am

FoodMODE wrote:I have tried everything in this blog but there has been no effect.


Did you empty the old cache before testing? also? which version of joomla are you using? ???

FoodMODE
Joomla! Apprentice
Joomla! Apprentice
Posts: 7
Joined: Tue Mar 03, 2009 7:26 pm

Re: Â Characters?

Postby FoodMODE » Sat Mar 07, 2009 5:21 pm

Yes ... cleared cache and everything. I am using Joomla 1.5.9

FoodMODE
Joomla! Apprentice
Joomla! Apprentice
Posts: 7
Joined: Tue Mar 03, 2009 7:26 pm

Re: Â Characters?

Postby FoodMODE » Sat Mar 07, 2009 5:26 pm


cwk
Joomla! Apprentice
Joomla! Apprentice
Posts: 27
Joined: Wed Jun 28, 2006 2:27 pm

Re: Â Characters?

Postby cwk » Sun Mar 08, 2009 8:06 am

Yup, there they are. From my quick glance, it appears that many of the  characters are originating from double spaces, but the  things appear to be directional quotation marks. Is that a product of your editor? Or is it rendering correctly in another browser?

Do yours disappear when you log in?

Has anyone on the Joomla! dev team commented on these  things?

User avatar
infograf768
Joomla! Master
Joomla! Master
Posts: 18017
Joined: Fri Aug 12, 2005 3:47 pm
Location: **Translation Matters**

Re: Â Characters?

Postby infograf768 » Sun Mar 08, 2009 8:41 am


Some of these are definitely due to wrong database encoding.

Check database collation, tables collation and table fields collations. All these should be UTF-8
Jean-Marie Simonet / infograf · http://www.info-graf.fr
Multilanguage in 2.5: http://help.joomla.org/files/EN-GB_multilang_tutorial.pdf
---------------------------------
ex-Joomla Translation Coordination Team • ex-Joomla! Production Working Group

n1gh7r4v3n
Joomla! Apprentice
Joomla! Apprentice
Posts: 10
Joined: Sat Feb 28, 2009 5:04 pm

Re: Â Characters?

Postby n1gh7r4v3n » Sun Mar 08, 2009 9:06 am

FoodMODE wrote:Yes ... cleared cache and everything. I am using Joomla 1.5.9


Hi, too bad. Must be something else then, probably the encoding of your database like infograf said under here. Or maybe you are forgetting someting. I had the same weird a characters in my articles. But they dissapeared onze you logged in. They also completely disapeared when i turned the cache off. I fixed it by turning the system cache plugin off in the plugin manager and putting the cache back on anyway. This seems to work without a problem now. Does anyone know what this System cache mambot does exactly? And wheter it is wise to turn it off? Do i really need this mambot?

FoodMODE
Joomla! Apprentice
Joomla! Apprentice
Posts: 7
Joined: Tue Mar 03, 2009 7:26 pm

Re: Â Characters?

Postby FoodMODE » Mon Mar 09, 2009 5:18 am

I have fixed my problem. I had iJoomla Magazine installed and the "Enable UTF-8 Functionality:" was on. I turned it off and everything cleared up. YEAH ... but after I waisted a beautiful weekend ... LOL

n1gh7r4v3n
Joomla! Apprentice
Joomla! Apprentice
Posts: 10
Joined: Sat Feb 28, 2009 5:04 pm

Re: Â Characters?

Postby n1gh7r4v3n » Mon Mar 09, 2009 10:15 am

FoodMODE wrote:I have fixed my problem. I had iJoomla Magazine installed and the "Enable UTF-8 Functionality:" was on. I turned it off and everything cleared up. YEAH ... but after I waisted a beautiful weekend ... LOL


Ok. but it is fixed ;) . Me too i wasted a lot of time with this problem, i uninstalled all my components one by one and at the end the problem was not gone. :D

cwk
Joomla! Apprentice
Joomla! Apprentice
Posts: 27
Joined: Wed Jun 28, 2006 2:27 pm

Re: Â Characters?

Postby cwk » Mon Mar 09, 2009 2:23 pm

n1gh7r4v3n wrote:
FoodMODE wrote:Yes ... cleared cache and everything. I am using Joomla 1.5.9


Hi, too bad. Must be something else then, probably the encoding of your database like infograf said under here. Or maybe you are forgetting someting. I had the same weird a characters in my articles. But they dissapeared onze you logged in. They also completely disapeared when i turned the cache off. I fixed it by turning the system cache plugin off in the plugin manager and putting the cache back on anyway. This seems to work without a problem now. Does anyone know what this System cache mambot does exactly? And wheter it is wise to turn it off? Do i really need this mambot?


So where's that leave it? n1gh7r4v3n's solution is at best a workaround, but what does it actually change? Is the cache doing anything without the cache mambot? Turning it off and then leaving the cache on seems a bit cargo cultishto me.

Has this been reported as a bug?

User avatar
infograf768
Joomla! Master
Joomla! Master
Posts: 18017
Joined: Fri Aug 12, 2005 3:47 pm
Location: **Translation Matters**

Re: Â Characters?

Postby infograf768 » Mon Mar 09, 2009 2:46 pm

It has not been reported.
I can't reproduce the error here. Cache or no cache.
Jean-Marie Simonet / infograf · http://www.info-graf.fr
Multilanguage in 2.5: http://help.joomla.org/files/EN-GB_multilang_tutorial.pdf
---------------------------------
ex-Joomla Translation Coordination Team • ex-Joomla! Production Working Group

n1gh7r4v3n
Joomla! Apprentice
Joomla! Apprentice
Posts: 10
Joined: Sat Feb 28, 2009 5:04 pm

Re: Â Characters?

Postby n1gh7r4v3n » Tue Mar 10, 2009 9:57 am

cwk wrote:
n1gh7r4v3n wrote:
FoodMODE wrote:Yes ... cleared cache and everything. I am using Joomla 1.5.9


Hi, too bad. Must be something else then, probably the encoding of your database like infograf said under here. Or maybe you are forgetting someting. I had the same weird a characters in my articles. But they dissapeared onze you logged in. They also completely disapeared when i turned the cache off. I fixed it by turning the system cache plugin off in the plugin manager and putting the cache back on anyway. This seems to work without a problem now. Does anyone know what this System cache mambot does exactly? And wheter it is wise to turn it off? Do i really need this mambot?


So where's that leave it? n1gh7r4v3n's solution is at best a workaround, but what does it actually change? Is the cache doing anything without the cache mambot? Turning it off and then leaving the cache on seems a bit cargo cultishto me.

Has this been reported as a bug?


Yeah it is. But it works. I cant solve it like i should. I am not a real good programmer. And this is stuff is really weird also. Why doesnt it show these weird characters when logged in? What does that change to the proces of caching? There seems to be no logic behind it.

chloregy
Joomla! Apprentice
Joomla! Apprentice
Posts: 13
Joined: Wed Mar 11, 2009 3:18 am
Location: San Francisco, CA
Contact:

Re: Â

Postby chloregy » Fri Mar 13, 2009 10:01 am

i get the same issue.

when system-cache enabled, if user is not logged in and goes to a page the second time, some characters like apostrophe and spaces (but not all) are mangled.

I also get broken images

and yes my db collation is set to UTF8...

smuggers
Joomla! Fledgling
Joomla! Fledgling
Posts: 3
Joined: Wed Feb 25, 2009 1:54 am

Re: Â Characters?

Postby smuggers » Fri Mar 27, 2009 4:25 am

Hi

I had this problem but it was becasue I didn't have the HTML metatag that told the browser which character set to accept, in the head section of your HTML.

Code: Select all

<head>
      <meta http-equiv="content-type" content="text/html; charset=utf-8" />
</head>


Goodluck :D

n1gh7r4v3n
Joomla! Apprentice
Joomla! Apprentice
Posts: 10
Joined: Sat Feb 28, 2009 5:04 pm

Re: Â Characters?

Postby n1gh7r4v3n » Fri Mar 27, 2009 2:36 pm

smuggers wrote:Hi

I had this problem but it was becasue I didn't have the HTML metatag that told the browser which character set to accept, in the head section of your HTML.

Code: Select all

<head>
      <meta http-equiv="content-type" content="text/html; charset=utf-8" />
</head>


Goodluck :D


Nope doesnt work for me. I already have this in my template:
<?php echo '<?xml version="1.0" encoding="utf-8"?'.'>'; ?>
So normally the encoding is set.

smuggers
Joomla! Fledgling
Joomla! Fledgling
Posts: 3
Joined: Wed Feb 25, 2009 1:54 am

Re: Â Characters?

Postby smuggers » Sat Mar 28, 2009 2:31 am

Yeah, I'd taken mine out because I was creating a Newsletter template.

Works fine if System Cache is turned off but you already know that.

Sorry, out of ideas

User avatar
infograf768
Joomla! Master
Joomla! Master
Posts: 18017
Joined: Fri Aug 12, 2005 3:47 pm
Location: **Translation Matters**

Re: Â Characters?

Postby infograf768 » Sat Mar 28, 2009 7:29 am

Folks,
if one of you give me full access to a site which has that type of problem, I could have a look.
By full access, I mean ftp, PHPMyadmin and superadmin.
Send infos by pm please.
Jean-Marie Simonet / infograf · http://www.info-graf.fr
Multilanguage in 2.5: http://help.joomla.org/files/EN-GB_multilang_tutorial.pdf
---------------------------------
ex-Joomla Translation Coordination Team • ex-Joomla! Production Working Group


Return to “Language - Joomla! 1.5”

Who is online

Users browsing this forum: No registered users and 5 guests