Joomla and Mediawiki

Discuss the integration of Joomla! with other products. ie SMF, phpbb etc etc

Moderator: General Support Moderators

Forum rules
Forum Rules
Absolute Beginner's Guide to Joomla! <-- please read before posting, this means YOU.
Forum Post Assistant - If you are serious about wanting help, you will use this tool to help you post.
fvt
Joomla! Fledgling
Joomla! Fledgling
Posts: 3
Joined: Sun Sep 17, 2006 12:41 pm

Joomla and Mediawiki

Postby fvt » Sat Nov 15, 2008 9:53 pm

I'm running Joomla and MediaWiki in parallell.
Now I have installed the bridge Mambowiki.

If have created a menu to connect to the wiki.

When I'm logged in the Joomla front end and click the menu
I'll end up at the login page to MediaWiki.

Just hitting Login I recieve the following:

SingleSignOn: Hash verification failed:271e5243f2a4714421174d49005fe2e7->6cae3057fb226778087b0826520d00dc->anne12267858964397fef3a576853a0fee0c1de2d19178b82ceb1342f6d44a35583299850d9

Backtrace:

#0 E:\VastraSaltsjon.se\tiedepedia\extensions\MamboLogin.php(76): wfDebugDieBacktrace('SingleSignOn: H...')
#1 E:\VastraSaltsjon.se\tiedepedia\includes\User.php(2131): MamboLogin->authenticate('Anne', '1226785896-271e...')
#2 E:\VastraSaltsjon.se\tiedepedia\includes\SpecialUserlogin.php(363): User->checkPassword('1226785896-271e...')
#3 E:\VastraSaltsjon.se\tiedepedia\includes\SpecialUserlogin.php(407): LoginForm->authenticateUserData()
#4 E:\VastraSaltsjon.se\tiedepedia\includes\SpecialUserlogin.php(103): LoginForm->processLogin()
#5 E:\VastraSaltsjon.se\tiedepedia\includes\SpecialUserlogin.php(19): LoginForm->execute()
#6 E:\VastraSaltsjon.se\tiedepedia\includes\SpecialPage.php(625): wfSpecialUserlogin(NULL, Object(SpecialPage))
#7 E:\VastraSaltsjon.se\tiedepedia\includes\SpecialPage.php(431): SpecialPage->execute(NULL)
#8 E:\VastraSaltsjon.se\tiedepedia\includes\Wiki.php(182): SpecialPage::executePath(Object(Title))
#9 E:\VastraSaltsjon.se\tiedepedia\includes\Wiki.php(47): MediaWiki->initializeSpecialCases(Object(Title), Object(OutputPage), Object(WebRequest))
#10 E:\VastraSaltsjon.se\tiedepedia\index.php(52): MediaWiki->initialize(Object(Title), Object(OutputPage), Object(User), Object(WebRequest))
#11 {main}


Can anyone help

Taikonaut
Joomla! Enthusiast
Joomla! Enthusiast
Posts: 213
Joined: Wed Sep 28, 2005 1:52 pm

Re: Joomla and Mediawiki

Postby Taikonaut » Thu Mar 12, 2009 11:04 am

Mambowiki sucks!

After a lot of trouble bridging Joomla! with Mediawiki with existing components (not JFusion), me and other developers built our own bridges, syncronising user tables and enabling simultan logins/logouts with Joomla! Works great! :)

ashlessburn
Joomla! Fledgling
Joomla! Fledgling
Posts: 2
Joined: Fri May 15, 2009 7:33 am

Re: Joomla and Mediawiki

Postby ashlessburn » Tue May 19, 2009 3:50 pm

yea thank you for the help glad this was able to get my mediwiki online thanks..

sarcastic of course

Taikonaut
Joomla! Enthusiast
Joomla! Enthusiast
Posts: 213
Joined: Wed Sep 28, 2005 1:52 pm

Re: Joomla and Mediawiki

Postby Taikonaut » Tue May 19, 2009 7:45 pm

Well, I wanted to advise you not to use Mambowiki at all...

But ok, this sounds like you installed each system (Joomla, MW) by itself and afterwards tried to merge both with Mambowiki, writing into the same database.

Is that correct?

Taiko

fvt
Joomla! Fledgling
Joomla! Fledgling
Posts: 3
Joined: Sun Sep 17, 2006 12:41 pm

Re: Joomla and Mediawiki

Postby fvt » Tue May 26, 2009 5:53 pm

Taikonaut wrote:Mambowiki sucks!

After a lot of trouble bridging Joomla! with Mediawiki with existing components (not JFusion), me and other developers built our own bridges, syncronising user tables and enabling simultan logins/logouts with Joomla! Works great! :)


I have MediaWiki and Joomla 1.5 installed side by side. Now I want to call MediaWiki from Joomla
(wrapper?) and do not want the user to log in again. Have done it with jfusion and phpBB.
Even managed to find a way to do it with PHPGedView but got stuck with MediaWiki.
I only allow registered users to use MW. So any tips are welcome to get the username/password problem solved.

Taikonaut
Joomla! Enthusiast
Joomla! Enthusiast
Posts: 213
Joined: Wed Sep 28, 2005 1:52 pm

Re: Joomla and Mediawiki

Postby Taikonaut » Wed May 27, 2009 6:24 am


User avatar
RustyJoomla
Joomla! Explorer
Joomla! Explorer
Posts: 389
Joined: Wed Aug 01, 2007 12:08 am
Location: UK

Re: Joomla and Mediawiki

Postby RustyJoomla » Tue Jul 14, 2009 1:38 pm

Have just installed MediaWiki Auto-Login - works great, the only downside however is when logging in, I can't edit or create any new pages in wiki... I think I must be missing a setting somewhere as everything else works great on it!
Follow me on Twitter - http://twitter.com/RustyJoomla

Taikonaut
Joomla! Enthusiast
Joomla! Enthusiast
Posts: 213
Joined: Wed Sep 28, 2005 1:52 pm

Re: Joomla and Mediawiki

Postby Taikonaut » Mon Aug 24, 2009 9:10 am

Hi stormit,

maybe you need to adjust your LocalSettings.php in MW's root folder to allow users to create or edit articles.

If you show me your LocalSettings.php I could help you, if that is the cause for your problem!

flatmattj
Joomla! Apprentice
Joomla! Apprentice
Posts: 9
Joined: Wed Sep 22, 2010 10:21 pm

Re: Joomla and Mediawiki

Postby flatmattj » Thu Sep 23, 2010 3:31 pm

Hi
I just downloaded this plugin and cannot for the life of me find the authjoomla plugin for mediawiki. I follow this link (and have googled a ton for it as well. Does anyone know if it stopped working with a new version of Joomla? (I have 1.5.20) or does anybody have a working link to the file?
Thanks!

aluizn
Joomla! Apprentice
Joomla! Apprentice
Posts: 7
Joined: Tue Feb 15, 2011 10:30 am

Re: Joomla and Mediawiki

Postby aluizn » Thu Mar 03, 2011 2:16 pm

I'm using JWiki and got the same problem.
Can I use MediaWiki Auto-login as well?

capeinfo
Joomla! Intern
Joomla! Intern
Posts: 62
Joined: Wed Mar 14, 2007 11:01 am

Re: Joomla and Mediawiki

Postby capeinfo » Mon Jun 06, 2011 10:37 am

The MediaWiki Auto-login developer's website ( http://www.haroldprins.nl ) doesn't seem to work any more. I managed to download the plugin from Joomla downloads but is there anybody who can help with getting it set up? Does it in fact still work?

Thanks


Return to “Integration & Bridges - 1.0.x”

Who is online

Users browsing this forum: No registered users and 4 guests