Translation Manager - Problem with this extension

A place to discuss Joomla! translation matters.

Moderator: infograf768

wasp2
Joomla! Apprentice
Joomla! Apprentice
Posts: 15
Joined: Wed Dec 23, 2009 10:27 am

Translation Manager - Problem with this extension

Postby wasp2 » Wed Dec 23, 2009 10:45 am

Hi,
I am developping a training portal using Joomla as a CMS.

I am working with, an extension called "TRANSLATION MANAGER". (see here http://extensions.joomla.org/extensions/languages/multi-lingual-content/1776)

The idea of this extension is absolutely fabulous and I mean it really. Since it dramatically ease the important translation work to be carried out on other components as well as in joomla core.

Hence I am posting here as I am facing a major blocking bug that I couldn't worklaround despite many efforts. I hope to get some help from here if possible. Or at least to see if other persons are facing the same issue.

The problem is the following. I am using an extension called "Event Registration Pro" and I am wanting to translate its .ini file create a french and dutch .ini file using translation manager.

Everything seems to work fine up to the moment you press the"Apply" or "Save" button. from that moment there are no error generated, but ALL fields in the file are considered as "Extra Phrases" that are advised to be deleted. Plus that the left part of the translation area now show the KEYS in place of the source language phrases. Back to the main language screen. you can see that indeed all the field -1 ( 403 ) have to moved to the "Extra Phrase" Area and that the main field of the .ini file are now empty ( 0 / 404);

Here is below what I have done to try to locate the problem (Before each trial I have erased all file to start the test from the original situation)

I first thought it had to deal with en ini file encoding and I made sure it was UTF-8 (I tried with and without BOM) I didn't worked.
I tried to reduce the amount of filed in the file which was not a better solution.
I tried to scrap and create manually a source ini file and ... it still didn't worked, even with a source ini file made of one single parameter.
I thought it might be due to joomla version and I tried on 1.5.9, 1.5.14 and 1.5.15 versions. It still didn't worked. same issue.
I have tried on an online web hosting as weel as on local webserver using Wamp still not working.

The ODD thing is that the extension seems to works work like a charm for other core components I gave a trial.

In that way I have created a dummy .ini file in the source en-GB folder for a component that did not existed on the system. I made the translation but I faced the same issue as the one described here above.

Would the problem have something to deal with the components used, I really have no idea now.

I am joining some screen captures for you to better visualize the issue. see attached files.
Before the Apply button is pressed
before applying translation 1.JPG

After the Apply buttons is pressed
After Apply.jpg

And when pressing the SAve button (actually the results in backend is the same as when pressing apply)
After Save .jpg


I don't know if anyone in the joomla community has experienced the same issue but I just can hope to get some help from you on this issue,

I think your component REALLY REALLY worth it for Joomla to keep growing in an enthusiastic way


Best regards

Wasp2
You do not have the required permissions to view the files attached to this post.

User avatar
mandville
Joomla! Master
Joomla! Master
Posts: 13630
Joined: Mon Mar 20, 2006 1:56 am
Location: The Girly Side of Joomla in Sussex

Re: Translation Manager - Problem with this extension

Postby mandville » Thu Dec 24, 2009 2:37 am

have you checked the developers forums?
HU2HY- Poor questions = Poor answer
Un requested Help PM's will be added to the foe list and possibly just deleted
{Community.Connect Administrator }{ Showcase & Security forums Moderator}

wasp2
Joomla! Apprentice
Joomla! Apprentice
Posts: 15
Joined: Wed Dec 23, 2009 10:27 am

Re: Translation Manager - Problem with this extension

Postby wasp2 » Sun Dec 27, 2009 11:51 pm

Hi Mandville,

Thanks for you reaction here.

Yes I've been browsing this forum and the web looking for a possible similar case but could not find anything serious about the subjet.

The only significant post related to Translation Manager is this one http://forum.joomla.org/viewtopic.php?p=1116298. Perhaps that for more visibility I'd better join my post to the one here above.

I've dropped an email to the developper end of last week but didn't got a reaction so far (... it's the end of the year for everyone in the end :)

As far as I've seen from the membership status of the forum the developper has not logged in here since 21th November 2009. I just can hope he'll pass by one of these days.

I'm still looking for the root cause of what I expect to be a particular bug, but would be happy to share similar experience with other peoples on that great component.

Wasp

User avatar
mandville
Joomla! Master
Joomla! Master
Posts: 13630
Joined: Mon Mar 20, 2006 1:56 am
Location: The Girly Side of Joomla in Sussex

Re: Translation Manager - Problem with this extension

Postby mandville » Mon Dec 28, 2009 1:04 am

no problem, did you ask the event_manager developer if they knew aof any issues or had a prepared copy?
HU2HY- Poor questions = Poor answer
Un requested Help PM's will be added to the foe list and possibly just deleted
{Community.Connect Administrator }{ Showcase & Security forums Moderator}

Joomlabox
Joomla! Intern
Joomla! Intern
Posts: 50
Joined: Tue Nov 01, 2005 9:19 am

Re: Translation Manager - Problem with this extension

Postby Joomlabox » Mon Dec 28, 2009 7:12 am

mandville wrote:have you checked the developers forums?


You may look either here: http://groups.google.com/group/joomla-dev-general
or here: http://groups.google.com/group/joomla-dev-cms

User avatar
infograf768
Joomla! Master
Joomla! Master
Posts: 17981
Joined: Fri Aug 12, 2005 3:47 pm
Location: **Translation Matters**

Re: Translation Manager - Problem with this extension

Postby infograf768 » Mon Dec 28, 2009 7:43 am

It is useless to post on these lists.
This is a third-party extension which will not be updated.

Translation Teams use it since it was released without any issue.
Therefore the issue is certainly with your settings/installation.

Can you attach here your original en-GB ini file and I will test locally.
Jean-Marie Simonet / infograf · http://www.info-graf.fr
Multilanguage in 2.5: http://help.joomla.org/files/EN-GB_multilang_tutorial.pdf
---------------------------------
ex-Joomla Translation Coordination Team • ex-Joomla! Production Working Group

User avatar
mandville
Joomla! Master
Joomla! Master
Posts: 13630
Joined: Mon Mar 20, 2006 1:56 am
Location: The Girly Side of Joomla in Sussex

Re: Translation Manager - Problem with this extension

Postby mandville » Mon Dec 28, 2009 1:50 pm


by developers forums, i meant the original creator, not the WG forums.

and thanks infograf768 for the offer
HU2HY- Poor questions = Poor answer
Un requested Help PM's will be added to the foe list and possibly just deleted
{Community.Connect Administrator }{ Showcase & Security forums Moderator}

wasp2
Joomla! Apprentice
Joomla! Apprentice
Posts: 15
Joined: Wed Dec 23, 2009 10:27 am

Re: Translation Manager - Problem with this extension

Postby wasp2 » Mon Dec 28, 2009 11:48 pm

Hi Mandville, JoomlaBox and Infograf768,

Again thanks for you assistance here ( I am a newbie on the forum and I am happy to see that really there is a community here. for sure I'll start sharing and supporting others here based on the joomla knowledge I have so far. Ideally I'd like to start recording a series of video training (at least in french and possibly in english as well) for unusual things like how to use some quite popular or rather unknown but useful extensions, I thinks this might help promoting the usage of Joomla... anyway that's not the point of the discussion here.

Back to what were are talking about here,
Dear Mandville, I've tried to look for a forum on developper's site but could not find it (I have send an email to the developper anyway).
Dear Infograf768, you'll find attached the .ini file
en-GB.com_registrationpro.ini
I am trying to use. As I have mentionned earlier I have the same problem on at least 2 different configuration (1 running on a web hosting server and thus life) and the other on a fresh joomla installation running on my notebook and WAMP powered. The issues is the same.
The attached file is the frontend language file of the extension Event Registration Pro that I am using on the life website.
If you happen to test this .ini file on your translation manager installation I'd be happy to know the results (I'am trying to genererate a customized french and a dutch translation file for the frontend of this component)

I'll keep you informed If I find any other relevant piece of information for this problem.

Cheers
You do not have the required permissions to view the files attached to this post.

User avatar
infograf768
Joomla! Master
Joomla! Master
Posts: 17981
Joined: Fri Aug 12, 2005 3:47 pm
Location: **Translation Matters**

Re: Translation Manager - Problem with this extension

Postby infograf768 » Tue Dec 29, 2009 7:50 am

This original en-GB ini file is wrongly formatted.
I wonder how it can work.
1. bad encoding. Should be utf8.
2. spaces before the "="
3. Indesirable #end tags

I do not know the original extension but I can't believe this is a commercial extension...
This is a corrected file as a sample.
en-GB.com_registrationpro.ini

Don't know if it will work with the original code though.
I suggest you contact the developer who sold this to you.

EDIT: Please read here http://docs.joomla.org/Tutorial:Templat ... ition_file
You do not have the required permissions to view the files attached to this post.
Jean-Marie Simonet / infograf · http://www.info-graf.fr
Multilanguage in 2.5: http://help.joomla.org/files/EN-GB_multilang_tutorial.pdf
---------------------------------
ex-Joomla Translation Coordination Team • ex-Joomla! Production Working Group

wasp2
Joomla! Apprentice
Joomla! Apprentice
Posts: 15
Joined: Wed Dec 23, 2009 10:27 am

Re: Translation Manager - Problem with this extension

Postby wasp2 » Tue Dec 29, 2009 10:27 pm

Hi Infograf768,

Great now it work , you've found the root cause. I had already tried to change the file to UTF-8 but I didn't solved the problem, the #end tag plus the missing spaces were there the issue on top of the wrong file coding.

The component is sold by www.joomlashowroom.com I'll warn theses guys about their faulty file.

Again thanks a lot for you support here.

Jean-Luc

PS: Merci beaucoup pour ton aide. :)

wasp2
Joomla! Apprentice
Joomla! Apprentice
Posts: 15
Joined: Wed Dec 23, 2009 10:27 am

Re: Translation Manager - Problem with this extension

Postby wasp2 » Wed Jan 06, 2010 9:20 am

Hi,

Apparently the problem in this case is not completly solved since apparently everythings seems to work after the file encoding correction to UTF-8 and the removal of the spaces on both sides of the = sign.
Now the editing the french translation file here attached
You do not have the required permissions to view the files attached to this post.

wasp2
Joomla! Apprentice
Joomla! Apprentice
Posts: 15
Joined: Wed Dec 23, 2009 10:27 am

Re: Translation Manager - Problem with this extension

Postby wasp2 » Wed Jan 06, 2010 9:35 am

Ooops wrong button accidentally pressed.

Ok then when editing this french file. everything seems to work fine and I don't have the odd behaviour described a few posts above.
Now the issue is that for some reasons the from line 237 the content is being striped out after a save or apply command on translation manager

namely
(...)
# add/edit location
ADMIN_EVENTS_CLUBSTREET_LO=Street:
ADMIN_EVENTS_CLUBPLZ_LO=ZIP:

EVENTS_REGISTRA_HEAD=Registered Users:
EVENTS_REGISTRA_NUMERIC= has to be a number.');
EVENTS_REGISTRA_ALLRE=are already registered for this Event.
EVENTS_EMAIL_DUPLICATE_ENTRY=email id entered by more then one time, email id must be unique.
EVENTS_SELECT_EVENT_TICKET=Please select registration option.
EVENTS_IS_PAID_SELECT_PAYMENT_METHOD=Please select payment method.
EVENTS_SELECT_PAYMENT_OPTION=-- Select Payment Option --
EVENTS_REGISTRA_MAX_ATTN=The maximum attendance limit is exceeded for this event.
EVENTS_REGISTRA_DISABLED=Registration for this event is currently disabled.
(...)

Turns to after a SAVE action:
(...)
# add/edit location
ADMIN_EVENTS_CLUBSTREET_LO=Street:
ADMIN_EVENTS_CLUBPLZ_LO=ZIP:

EVENTS_REGISTRA_HEAD=Registered Users:
EVENTS_REGISTRA_NUMERIC= has to be a number.');
EVENTS_REGISTRA_ALLRE=are already registered for this Event.
EVENTS_EMAIL_DUPLICATE_ENTRY=email id entered by more then one time, email id must be unique.
EVENTS_SELECT_EVENT_TICKET=Please select registration option.
EVENTS_IS_PAID_SELECT_PAYMENT_METHOD=Please select payment method.

Only the comments are left in place afterwards.
I've been checking again for odd characters but could not find anything weard.
I thought that the dashed lines --- comming right after the = sign might be wrongly interpreted. but it doesn"t seems to be the case, since even if I strip them out in the the french file the problem is still there. Plus above in the file (around line 207 and 223) there are other lines with -- that don't give that problem.
I have been looking the page adviced by Infograf768 to check the language file formatting but couldn' find any incompliency beside the " that are included into some xHTML tags in the value field

If you have a chance to give a try and let me know if you face the same problem ?
How to reporduce
1 - Copy the en and fr files in the language folders
2 - Edit any field in the french file
3 - press save
4- the french file will pass from 376/404 to 181/404 meaning 195 lines have be removed...

Does anyone have an idea on that ?

nanukumar
Joomla! Fledgling
Joomla! Fledgling
Posts: 1
Joined: Sat Jan 30, 2010 4:20 am

Re: Translation Manager - Problem with this extension

Postby nanukumar » Sat Jan 30, 2010 4:25 am

Hello,

Please remove the "');" from en-GB.com_registrationpro.ini file. The line number is 233 and try again.

I am sure your issue will be resolve.

Thanks


Return to “Translations”

Who is online

Users browsing this forum: No registered users and 7 guests