The Joomla! Forum ™



Forum rules


Forum Rules
Absolute Beginner's Guide to Joomla! <-- please read before posting, this means YOU.
Forum Post Assistant - If you are serious about wanting help, you will use this tool to help you post.



Post new topic Reply to topic  [ 164 posts ]  Go to page Previous  1, 2, 3, 4, 5, 6  Next
Author Message
PostPosted: Wed Jun 17, 2009 7:42 pm 
Joomla! Fledgling
Joomla! Fledgling

Joined: Wed Jun 17, 2009 7:16 pm
Posts: 2
Hello first time Joomla user and I had this problem right out of the gate after install.
I tried most if not all of the "fixes" above with no luck. After some outside reasearch I found my answer. This solution only applies to *nix based servers with php running as apache. Php running as CGI should not have this problem anyway.

I have a dedicated server so making changes on the box is not a problem for me. My server company compiled php to run as apache. What this means is my php setup did not have permissions to create folders etc under my domain name. This can get a little technical, so to spare everyone the details, basically joomla was trying to tell php to create a folder and php did not have permissions to create anything since it did not belong to the same group as Joomla.

My solution was to change the ownership on all files and folders to my site's user and apache as the group. In this case chown -Rf admin(mysite).apache *. Unless you have ssh access and a host that gives you this control, you will not be able to use this. I also do not recommend doing this unless you know what you are doing with that command.

If everything fails check with your host to make sure php has permissions to run as the same group as your site. I did not see this posted anywhere and thought I should pass it along.


Top
 Profile  
 
PostPosted: Thu Jun 18, 2009 5:42 pm 
Joomla! Fledgling
Joomla! Fledgling

Joined: Fri May 29, 2009 10:38 am
Posts: 4
i had the same problem for so long... but i think i can resolve this for you.

1st of all, i've done my website on a certain domain, like http://www.example.com but along the process i feel a certain need to do a splash page and to do so, i move my website to other folder like... http://www.example.com/test/ and some time after that, like 3 months later i needed to install a component, and i've started to receive this same error... so opened my configuration.php and change my ftp configuration and it work out just fine...

i hope this maybe helping someone... ;-)


Top
 Profile  
 
PostPosted: Tue Jul 14, 2009 9:58 am 
Joomla! Apprentice
Joomla! Apprentice

Joined: Fri Aug 03, 2007 10:08 pm
Posts: 8
I disabled the ftp access layer in the config file and its now working again (both installing and uploading images). Does this have any security implications?

Thanks
Ola


Top
 Profile  
 
PostPosted: Tue Aug 04, 2009 3:45 pm 
Joomla! Apprentice
Joomla! Apprentice

Joined: Wed Jun 07, 2006 11:54 pm
Posts: 47
HI I have just installed Joomla 1.5.14 and I am having the same JFTP problem. WOuld you be able to tell me what you did to your configuration.php file to resolve this issue?

Many thanks.

Ollie


Top
 Profile  
 
PostPosted: Tue Aug 11, 2009 9:49 pm 
User avatar
Joomla! Intern
Joomla! Intern

Joined: Mon Oct 02, 2006 8:21 pm
Posts: 86
Location: Colombia
Please remember
Quote:
Folders that have permissions higher than 755 may compromise your Joomla!, leaving the "door" open for an attacker to read/write or even upload his own shell files, thus taking control over your site.
Quote:
Leaving files with permissions higher than 644 can make life easier for hackers trying to access your website. Once they're in, they can easily modify files with permissions higher than 644.
Source: http://blog.rsjoomla.com/bid/20490/10-s ... a-Part-One
Sometimes this error (JFTP::store: Bad response Warning! - Failed to move file) is caused by a misconfiguration of the TMP path in configuration.php file:
Code:
var $tmp_path = '/home/webuser/public_html/tmp';

_________________
Ernesto Patarroyo - Consultor Web - http://ernestopatarroyo.com
Twitter: @openwebsoft


Top
 Profile  
 
PostPosted: Wed Aug 12, 2009 12:59 am 
Joomla! Enthusiast
Joomla! Enthusiast

Joined: Wed Aug 05, 2009 4:03 am
Posts: 244
2 references

1), make full path to the "logs" and "tmp" in configuration.php
2), sufficient permission to the directory which is mentioned in the error.

_________________
www.webhostpark.com
Get quality web hosting with latest promotion


Top
 Profile  
 
PostPosted: Wed Aug 19, 2009 1:15 am 
Joomla! Fledgling
Joomla! Fledgling

Joined: Thu Nov 23, 2006 2:11 pm
Posts: 2
Ok, read all the responses, tried all the fixes and somehow nothing worked for me...

So, as a last resource I looked with FTP inside the TMP and CACHE folder and saw a lot of stuff inside... so just decided to DELETE everything inside these 2 folders (except the index.html files) and than tried again and suddenly my installs work again... with FTP enable and no other changes...

It worled for me, hope it helps someone else too.


Top
 Profile  
 
PostPosted: Mon Sep 07, 2009 8:35 am 
Joomla! Fledgling
Joomla! Fledgling

Joined: Mon Sep 07, 2009 8:29 am
Posts: 1
Location: Netherlands
To anyone.

Don't really want to break into this conversation, but perhaps it does help someone?? It sure did work for me.

I had an .ftpaccess file in my user directory of my shared webhosting account. This is an extra safety measure to allow FTP access only from certain IP addresses.)

This resulted in the error messages as mentioned in this thread.
I had to add the localhost address (127.0.0.1) to be allowed, to make it work again:

<Limit ALL>
Allow 127.0.0.1
Allow (other ip address)
DenyAll
</Limit>

Perhaps you have this sort of FTP restrictions?
Might want to check it out?


Top
 Profile  
 
PostPosted: Sat Oct 17, 2009 2:13 am 
Joomla! Intern
Joomla! Intern

Joined: Tue Oct 13, 2009 1:19 am
Posts: 70
Location: Mexico
I was in this post looking for a solution, unfortunately did not find it, however I found what worked for me and hope it will also work for some other people.

I dont really know whos problem is it, the host, joomla or the extensions

my problem started so i decided to install the extension manually, then is when i figured i could not send files via ftp to my host, was getting a permission denied so I tought well then the host is the problem, however the hopst blames jommla´s extensions, anyway i dont care whos fault is it but the good thing is they had a solution in their control panel they have this toll named Fix File
Ownership and another Fix File permissions in the first one the explanation of the feature is

"This feature is useful when you have any files created by PHP (for example if you installed Joomla or used some file upload script), ownership of these files usually changes to "99" or "nobody" and you are not be able to delete or modify such files by FTP or File Manager, you will get "Permission denied" errors (such files can be deleted by PHP script only).

This tool fixes ownership for all files inside of your account, so you can edit or delete without problems."

note that they specifically mention joomla so i would say yes the problem is joomla, but there most be a problem with some extensions

anyway after clicking on those 2 fixes it took me less than a minute and was able again to install extensions

my web host is [url banned] i dont know if other hosts have this feature but you can check

Attachment:
Untitled.png


You do not have the required permissions to view the files attached to this post.

_________________
You can view my free Joomla! extensions and templates at:http://www.tlacaelelrl.com/


Top
 Profile  
 
PostPosted: Wed Dec 02, 2009 3:42 am 
User avatar
Joomla! Enthusiast
Joomla! Enthusiast

Joined: Sun Oct 16, 2005 2:26 am
Posts: 119
Location: Honolulu, Hawaii
Not sure if this will work for you, but it did for me. We are using 1.5.14. The error started this morning after uploading an 100k .gif image.

I tried everything and it didn't work...then I noticed a disk quota note while trying to upload via FTP and sure enough I was out of disk space.

So after increasing my disk space to an additional 100mb everything works fine again. ...if the cms error had just inlcuded "disk quota warning" or something like that instead of:

* JFTP::store: Bad response
* Warning! Failed to move file.
* JFTP::mkdir: Bad response
* JFTP::chmod: Bad response
* Unable to create destination

It would have saved me two hours today. :) Good luck everyone and Aloha! :)

_________________
Please read forum rules regarding signatures: viewtopic.php?t=65


Top
 Profile  
 
PostPosted: Mon Dec 07, 2009 3:30 pm 
Joomla! Fledgling
Joomla! Fledgling

Joined: Mon Dec 07, 2009 3:26 pm
Posts: 1
Just wanted to pass along I am running version 1.5.14 and had JFTP::store: Bad response Warning! - Failed to move file issues as well. I did not disable my ftp but in the server setting I had the host set to localhost. I changed it to the domain name that I am using for the site and then I could upload plugins and modules without error.

Hope this helps


Top
 Profile  
 
PostPosted: Mon Jan 11, 2010 3:46 am 
Joomla! Apprentice
Joomla! Apprentice

Joined: Thu Jan 07, 2010 5:36 pm
Posts: 5
Scoffers wrote:
Ok, I am resolved now. What I did was disable the FTP settings in Global Config, and now it works a treat !!

I'll try the option above and then turn FTP back on, and see what happens!


Man I was fighting with this for hours... Tried the CHMOD's to 777 across the board, verified my FTP settings. Got nothing. Read this, gave it a shot, and it worked. Thanks


Top
 Profile  
 
PostPosted: Fri Jan 15, 2010 7:12 pm 
Joomla! Apprentice
Joomla! Apprentice

Joined: Sat Aug 01, 2009 6:59 am
Posts: 11
Typically in cpanel or your server configuration manager you need to setup an ftp account to enable joomla to access your website server. It may look like this

Manual Settings
FTP Username: joomla@yourwebsite.com
FTP Server: ftp.yourwebsie.com
FTP Server Port: 21
SFTP Server Port: 22
Directory home/yourwebsite/public_html

Now in the joomla configuration file in the root directory you should have

var $ftp_enable = '1';
var $ftp_host = 'localhost';
var $ftp_port = '21';
var $ftp_user = 'joomla@yourwebsite.com';
var $ftp_pass = 'yourftppasswordhere';
var $ftp_root = ' ';

If you set ftp_root in the config file as home/yourwebsite/public_html then you will get an error as joomla will think the ftp path is

home/yourwebsite/public_html/home/yourwebsite/public_html

Hope this helps


Top
 Profile  
 
PostPosted: Mon Jan 18, 2010 11:17 am 
Joomla! Intern
Joomla! Intern

Joined: Sun Oct 22, 2006 2:26 pm
Posts: 96
I had this issue... I had the FTP Path wrong (even though when connecting in a FTP client you usually specify a path relative to the user root rather than server root).

It should not be:-
var $ftp_root = '/public_html';

But should be the full path on the server:-
var $ftp_root = '/home/myuser/public_html';

This fixed it for me.


Top
 Profile  
 
PostPosted: Tue Apr 20, 2010 12:53 am 
Joomla! Fledgling
Joomla! Fledgling

Joined: Mon Apr 19, 2010 6:34 am
Posts: 2
New to Joomla. Installed via host 1click. When first installed, could not install any extensions - was getting the "JFTP::store: Bad response Warning! - Failed to move file" error.

After many frustrating days, here is what resolved it:

1. Fixed Permissions on server - I was able to use a host tool called Permissions fixer. This took 1 click and 1 minute.

2. Disabled FTP - in Joomla admin -> Site -> Global Configuration, set Enable FTP as No

After this, worked perfectly with no probs.
Thanks to the suggestions above.


Top
 Profile  
 
PostPosted: Tue Jun 01, 2010 5:58 am 
Joomla! Intern
Joomla! Intern

Joined: Wed Apr 23, 2008 4:45 am
Posts: 81
So a few hours at this is proving frustrating because I thought I knew Joomla >:( After uploading a backup of both the files and db and getting the copied site running, I wanted to install an extension and of course that's why I'm at this thread. I've gotten the:

Quote:
* JFTP::write: Bad response
* Warning! Failed to move file.

* JFTP::store: Bad response
* Warning! Failed to move file.

* JFTP::login: Unable to login
* JFTP::store: Unable to use passive mode
* Warning! Failed to move file.

... with variations of fixes everyone else has come up with in this and that thread ;) My Hsphere now Parallels hosting cp does have the "File Ownership" which turns the ownership back to your user:group and it also allows you to set all file/folder permissions to 644/755 respectively. I checked in the media manager and tried to create a folder and got "JFTP::mkdir: Bad response". With other similar problems like this I was able to add a folder in the image folder like M_images that wasn't there as the stock Joomla install usually does and wahla, problem was gone. I've tried without ftp_enabled and I am able to create a folder in Media Manager without the error message, but then while trying to install an extension I get
Quote:
* JFolder::create: Could not create directory
* Component Install: Failed to create directory.: "/hsphere/local/home/champ/mydomain.com/new/components/com_mtwmigrator"
Message

* Install Component Error

... if I give 777 permissions to the components (a security risk and an indication that Joomla isn't working as it should) then I get
Quote:
* JFolder::create: Could not create directory
* Component Install: Failed to create directory.: "/hsphere/local/home/champ/mydomain.com/new/administrator/components/com_mtwmigrator"

so of course I give 777 to administrator/components/ and then GET
Quote:
INSTALL COMPONENT SUCCESS

Doesn't feel successful since I know this isn't how Joomla 1.5.18 works. Can anyone who KNOWS JOOMLA please help?

_________________
Regards,
Scott


Last edited by dss on Wed Jun 02, 2010 12:37 am, edited 1 time in total.

Top
 Profile  
 
PostPosted: Tue Jun 01, 2010 7:56 pm 
User avatar
Joomla! Enthusiast
Joomla! Enthusiast

Joined: Sun Oct 16, 2005 2:26 am
Posts: 119
Location: Honolulu, Hawaii
Did you take a look at your disk space? i.e. How much disk space do you have available on your server?

_________________
Please read forum rules regarding signatures: viewtopic.php?t=65


Top
 Profile  
 
PostPosted: Wed Jun 02, 2010 12:25 am 
Joomla! Intern
Joomla! Intern

Joined: Wed Apr 23, 2008 4:45 am
Posts: 81
norman kaui wrote:
Did you take a look at your disk space?

Thanks, but this isn't an issue at 47% quota.

Anyone have a clue for something apparently way out of the ordinary :eek: >:(

_________________
Regards,
Scott


Top
 Profile  
 
PostPosted: Wed Jun 02, 2010 1:06 am 
Joomla! Intern
Joomla! Intern

Joined: Wed Apr 23, 2008 4:45 am
Posts: 81
Just figured it out finally after reading carefully Swettling's post here: viewtopic.php?p=1591143#p1591143

Since I'm migrating a site from a 1.0 site to 1.5.18 I've created a 2nd db and put the site into a subfolder (new) which required the opening and trailing / backslash to ftp into the subfolder. So the winning antidote and knowing it took was when "apply" in global setting of "yes to enable ftp" and putting /mysite.com/new/ into the ftp root field; this actually saved the "yes" state of the radio button whereas anything else that was an incorrect ftp setting would "apply" it and it would go back to "no" by itself. This was by design from the Joomla team and I tried reinventing the wheel through thinking my uploaded files went wrong, even though the site worked when viewing mysite.com/new :-[

Hope this will help those who like to try and second guess the creators :)

_________________
Regards,
Scott


Top
 Profile  
 
PostPosted: Tue Sep 07, 2010 4:51 pm 
Joomla! Apprentice
Joomla! Apprentice

Joined: Tue Sep 30, 2008 12:44 am
Posts: 6
I know this is an old thread, but is still very valuable. I just ran across the same problem as the original poster. My solution was ultimately because I had re-tasked the logs/ and tmp/ directories to the home directory. I believe the permissions were set incorrectly for those directories when I set them up. To get a quick fix, I just put the tmp/ and logs/ directories back inside the web root directory. Once I did that, I was able to install extensions.
You can find more information on why this error may pop up Here
(Note: I believe the tmp/ directory was the cause. I'm not sure we even have logging turned on). Anyway, I had re-tasked those directories based on the Joomla Security FAQ, which can be found Here)
I will go back later and take another look at what I did wrong, but I think it's an important step to secure your site.
I have seen many solutions posted that set directory and file permissions to 777. I would strongly advise against that. If you are telling yourself that you will go back and change them later to proper permissions, think again. Only a very small percentage of us will actually do that. Take it from me, I was one of the ones in the majority who didn't go back and re-permission things. The result was a trojan left on our server. Proper ownership and permissions would have prevented that.
Also, unless you are using PHPsuExec, I would also strongly discourage your from turning off the FTP Layer. If you do that, then it leaves you only the option of making the web server process (nobody, www-data, apache, etc) as the owner of the files in your web root. That makes your server more vulnerable if you don't have the permissions set up correctly. Please give yourself some time to look over the security documentation at The Joomla Documentation Site. If nothing else, Start Here

Good luck.


Top
 Profile  
 
PostPosted: Wed Sep 08, 2010 1:52 am 
Joomla! Fledgling
Joomla! Fledgling

Joined: Wed Sep 08, 2010 1:43 am
Posts: 1
too much information to help me thanks a lot verdiginiz'd share our friend

_________________
http://www.dizimix.net

http://www.kemalsunalfilmleri.tk


Top
 Profile  
 
PostPosted: Tue Sep 21, 2010 2:06 pm 
Joomla! Fledgling
Joomla! Fledgling

Joined: Tue Sep 21, 2010 2:04 pm
Posts: 1
I was experiencing this issue on a 1and.com server. For my the problem was I based my install on a copy of another site, so my log_path and tmp_path in the configuration.php file were incorrect.


Top
 Profile  
 
PostPosted: Wed Sep 22, 2010 9:57 pm 
Joomla! Fledgling
Joomla! Fledgling

Joined: Wed Sep 22, 2010 9:54 pm
Posts: 1
I tried everything above... only to realise I'd reached my disk quota :-(
Deleted some old files and everything's back to normal. After all that *sigh*


Top
 Profile  
 
PostPosted: Sun Nov 07, 2010 3:30 pm 
User avatar
Joomla! Explorer
Joomla! Explorer

Joined: Mon Feb 27, 2006 7:52 pm
Posts: 264
In my case, I had just installed Joomla v 1.5.21 and migrated my site to a new server when I got the above error.
I found that disabling FTP feature in Global Configuration/Server tab fixed the issue. I am now able to upload through both the Media Manager and JCE Utilities Upload button.

Best,
railer


Top
 Profile  
 
PostPosted: Mon Jan 17, 2011 8:03 am 
Joomla! Fledgling
Joomla! Fledgling

Joined: Thu Dec 17, 2009 11:04 pm
Posts: 1
I had the same problem with Joomla 1.6 on my Fedora 14. It takes me all sunday but finally it seems to work and I want to share my solution.
Permissions chmod were set in 777 in the directory. PHP safe_mode was disabled. Then I change booleans in SELinux about FTP anf HTTP, searching with commands #getsebool -a |grep ftp, #getsebool -a |grep http, and turning on the most of them. Despite this, Joomla continued showing me the error message. The last thing I did was to disable FTP in Global Configuration - Server in Joomla Administrator and then re-enable the feature FTP but leaving blank the space for the route and just putting the server, port, username and password.

After that, I managed to install extensions. As to which of the booleans are to be activated, I'm still not completely sure.

Regards. ;)


Top
 Profile  
 
PostPosted: Tue Feb 22, 2011 8:03 pm 
Joomla! Fledgling
Joomla! Fledgling

Joined: Thu Jan 07, 2010 2:53 pm
Posts: 4
After pulling my hair for hours, i happened to read somewhere(sorry, missed that link) that setting
Code:
var $ftp_enable = '0';

in configuration.php would solve this issue. It did work for me.

I were installing mobile joomla., after disabling ftp in configuration.php, though it showed a -install successfull- message, I had other errors;

It was not possible to copy the selected file.
JInstaller::install: Failed to copy file: /home/.../sitedir/tmp/install_4d640b3a8c9a2/en-GB.tpl_mobile_iphone.ini to /home/.../sitedir/language/en-GB/en-GB.tpl_mobile_iphone.ini
It was not possible to copy the selected file.
JInstaller::install: Failed to copy file: /home/.../sitedir/tmp/install_4d640b3a8c9a2/en-GB.com_mobilejoomla.ini to /home/.../sitedir/administrator/language/en-GB/en-GB.com_mobilejoomla.ini


That was I guess because those directories mentioned in the error didn't have enough write permissions., the mobile joomla site's installation instructions doesn't say anything about the permission of those /language directories.

So I just copied those files manually into those directories and things seem to work fine so far. Hope that is of use to someone.


Top
 Profile  
 
PostPosted: Sat Mar 26, 2011 4:40 pm 
Joomla! Fledgling
Joomla! Fledgling

Joined: Fri Sep 19, 2008 3:45 pm
Posts: 1
EDIT configuration.php file as below:

Find a few of line below and edit:
Code:
   public $ftp_host = '127.0.0.1';
   public $ftp_port = '21';
   public $ftp_user = '******@lmkhangsd.co.cc';
   public $ftp_pass = '****1';
   public $ftp_root = '/home/YOUR_USER/public_html/';
   public $ftp_enable = '0';


Good luck to you.

p/s: 100% working.


Top
 Profile  
 
PostPosted: Sun Mar 27, 2011 10:30 am 
Joomla! Fledgling
Joomla! Fledgling

Joined: Wed Mar 23, 2011 3:17 pm
Posts: 3
mulligankm wrote:
I, like many of you, also encountered this problem and wasted an inordinate amount of time trying to solve it.

I solved it by doing two things:

1. Changed Global Configuration-->Server-->Path to temp-folder: to /tmp
2. Changed "Enabled FTP" to No

I hope this helps.


Thanx a lot, the quote above solved my problem!!! :p


Top
 Profile  
 
PostPosted: Thu Jun 16, 2011 6:33 pm 
Joomla! Fledgling
Joomla! Fledgling

Joined: Thu Jun 16, 2011 6:23 pm
Posts: 2
I had a similar problem not long ago. It's been only a few months I started to work with joomla and it amazes me how some little errors have no logical explanation yet, at least to me. I read in some blog, after having spent an hour or so looking for the answer, that you could replace in the ftp port field, over global configuration, 21 by standard. I did that and my problem was gone. I hope that someone that knows more about this would have a proper explanation considering the lack of clarity in my answer.

the error that was stopping me from making any installations over the extensions manager was:
JFTP: :connect: Could not connect to host ' myhost.com ' on port ' 21 '.

This error was relatively new because few days ago I installed a few components and nothing happened then. Again, hope someone recognizes this and is able to explain me why exactly did that solve my problem.


Top
 Profile  
 
PostPosted: Thu Jul 21, 2011 9:03 am 
Joomla! Fledgling
Joomla! Fledgling

Joined: Fri May 06, 2011 2:39 pm
Posts: 3
Solved!

1. Fixed typo in ftp settings.
I was also getting these "JFTP::store: Bad response" errors when trying to upgrade Joomla or install modules. So I read through the posts and came across a post saying they had found a typo in the FTP path. So I went and checked and Yes! I also had a typo! But I couldn't change it in the Admin interface so I downloaded configuration.php, and edited it's settings. Tried to upload it but didn't have the permission to overwrite the current file, so I deleted the current file and uploaded the new one.

2. Uninstalling first helps!
My problems were related to upgrading Akeeba Admin Tools and Akeeba Backup so I tried uninstalling and this gave partly some success upon reinstalling. The new errors that occurred were related to parts of the extensions that I had missed to uninstall. There were some modules and plugins that also needed to be uninstalled. After that I could reinstall the extensions without any errors displaying.

Cheers,
--peter


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 164 posts ]  Go to page Previous  1, 2, 3, 4, 5, 6  Next



Who is online

Users browsing this forum: No registered users and 19 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Jump to:  
Powered by phpBB® Forum Software © phpBB Group