The Joomla! Forum ™



Forum rules


Forum Rules
Absolute Beginner's Guide to Joomla! <-- please read before posting, this means YOU.
Forum Post Assistant - If you are serious about wanting help, you will use this tool to help you post.



Post new topic Reply to topic  [ 30 posts ] 
Author Message
PostPosted: Wed Apr 09, 2008 9:22 pm 
Joomla! Fledgling
Joomla! Fledgling

Joined: Wed Apr 09, 2008 9:16 pm
Posts: 3
Hi, every time I try to install any plugin i get the same error message

* JFolder::create: Infinite loop detected
* Warning! - Failed to move file

The directory permission for all directories are set to writable, if you are wondering...

Do you guys have any idea how I can fix this?


Thanx


Top
 Profile  
 
PostPosted: Thu Jul 17, 2008 7:53 pm 
Joomla! Fledgling
Joomla! Fledgling

Joined: Fri Dec 14, 2007 6:43 pm
Posts: 1
Ok, for anyone else who stumbles on this thread, the problem is an incorrectly set tmp file.

viewtopic.php?f=470&t=266930

Make sure the path to your 'log' and 'tmp' folders are set correctly in the global configuration.


Top
 Profile  
 
PostPosted: Thu Dec 04, 2008 10:16 am 
Joomla! Apprentice
Joomla! Apprentice

Joined: Tue Oct 28, 2008 10:04 am
Posts: 7
Problem solved, and I think I know why this problem is so common... To find the path to my tmp directory, in the backend I clicked help -> system info -> php info, then i search the page for the letters "tmp".

I locate the following line:

open_basedir /var/www/vhosts/mysite.com/httpdocs:/tmp

I then went to my global configuration, clicked on the server tab and entered the following line:

"/var/www/vhosts/mysite.com/httpdocs:/tmp"

The error continued and i noticed when looking at the path which came from the php info file that it included a ":" right before "/tmp". I confirmed that path does not exist on my server but "/var/www/vhosts/mysite.com/httpdocs/tmp" does so i removed the ":", saved it, and tried to install a component again and it worked.

My point is, the path that you get out of the php info file may be slightly off so simply use your ftp client to browse through your sites directories to confirm that every character in that path is legitimate.

im not sure if this helps, but thats why I was getting that error.


Top
 Profile  
 
PostPosted: Thu Dec 04, 2008 10:17 am 
Joomla! Apprentice
Joomla! Apprentice

Joined: Tue Oct 28, 2008 10:04 am
Posts: 7
Problem solved, and I think I know why this problem is so common... To find the path to my tmp directory, in the backend I clicked help -> system info -> php info, then i search the page for the letters "tmp".

I locate the following line:

open_basedir /var/www/vhosts/mysite.com/httpdocs:/tmp

I then went to my global configuration, clicked on the server tab and entered the following line:

"/var/www/vhosts/mysite.com/httpdocs:/tmp"

The error continued and i noticed when looking at the path which came from the php info file that it included a ":" right before "/tmp". I confirmed that path does not exist on my server but "/var/www/vhosts/mysite.com/httpdocs/tmp" does so i removed the ":", saved it, and tried to install a component again and it worked.

My point is, the path that you get out of the php info file may be slightly off so simply use your ftp client to browse through your sites directories to confirm that every character in that path is legitimate.

im not sure if this helps, but thats why I was getting that error.


Top
 Profile  
 
PostPosted: Mon Mar 23, 2009 8:53 am 
Joomla! Intern
Joomla! Intern

Joined: Thu Mar 12, 2009 1:30 am
Posts: 62
what you said is alright

I have the same problem and now it solved because of your post

set the tmp directory right and the message gone away

Thank you

:p


Top
 Profile  
 
PostPosted: Sat Apr 11, 2009 4:33 pm 
Joomla! Apprentice
Joomla! Apprentice

Joined: Thu Sep 18, 2008 3:31 pm
Posts: 27
Location: Chicago, IL
Azazriel wrote:
Ok, for anyone else who stumbles on this thread, the problem is an incorrectly set tmp file.

viewtopic.php?f=470&t=266930

Make sure the path to your 'log' and 'tmp' folders are set correctly in the global configuration.

Problem solved! Thanks Azazriel.

_________________
Web Design Chicago - http://www.varsys.com
SEO Chicago - http://www.varsys.com/seo-company-chicago.html


Top
 Profile  
 
PostPosted: Fri Jun 26, 2009 9:08 pm 
Joomla! Apprentice
Joomla! Apprentice

Joined: Tue Aug 05, 2008 9:09 pm
Posts: 6
This fixed my problem too! Thanks a Million!


Top
 Profile  
 
PostPosted: Mon Jul 06, 2009 5:36 pm 
Joomla! Apprentice
Joomla! Apprentice

Joined: Tue Jun 09, 2009 2:46 pm
Posts: 14
Where do you change this "open_basedir /var/www/vhosts/mysite.com/httpdocs:/tmp" at? Which file is that under?


Top
 Profile  
 
PostPosted: Tue Jul 07, 2009 9:50 pm 
Joomla! Apprentice
Joomla! Apprentice

Joined: Tue Aug 05, 2008 9:09 pm
Posts: 6
Log in to the Administrator back end. In the Control Panel click on Global Configuration. Once you are in the Global Configuration area, click on Server. Here you will change the path to the Temp_folder under Server Settings. Hope this helps.


Image


Top
 Profile  
 
PostPosted: Wed Jul 08, 2009 1:26 pm 
Joomla! Apprentice
Joomla! Apprentice

Joined: Tue Jun 09, 2009 2:46 pm
Posts: 14
I knew where that was. I was looking for the Open Basedir location. Doesn't matter. Fixed the issue.


Top
 Profile  
 
PostPosted: Sun Jan 03, 2010 8:40 pm 
Joomla! Apprentice
Joomla! Apprentice

Joined: Mon Dec 28, 2009 9:01 am
Posts: 44
prestonascott wrote:
The error continued and i noticed when looking at the path which came from the php info file that it included a ":" right before "/tmp". I confirmed that path does not exist on my server but "/var/www/vhosts/mysite.com/httpdocs/tmp" does so i removed the ":", saved it, and tried to install a component again and it worked.


Sounds promising.
But where do I find that 'php info file'?
Is that its name?
In which directory can I find it?


Top
 Profile  
 
PostPosted: Wed Apr 07, 2010 10:06 pm 
Joomla! Fledgling
Joomla! Fledgling

Joined: Wed Apr 07, 2010 10:01 pm
Posts: 1
Hi Lads, now this is the 3rd evening what I have been struggling with my joomla extension errors.

HERE IS MY ENVIRONMENT:
-----------------------------------------------------------------------------------
PHP Built on: Linux albatros 2.6.18-6-vserver-686 #1 SMP Sat Dec 27 11:44:04 UTC 2008 i686
Database Version: 5.0.32-Debian_7etch10-log
Database Collation: utf8_general_ci
PHP Version: 5.2.0-8+etch13
Web Server: Apache
Web Server to PHP interface: apache2handler
Joomla! Version: Joomla! 1.5.15 Stable [ Wojmamni Ama Mamni ] 05-November-2009 04:00 GMT
User Agent: Mozilla/5.0 (Windows; U; Windows NT 6.1; sk; rv:1.9.2.3) Gecko/20100401 Firefox/3.6.3
-----------------------------------------------------------------------------------
Firstly I recommend to read these threads to get a better feel with this issue:
http://docs.joomla.org/Why_can%27t_you_ ... ensions%3F
http://docs.joomla.org/How_to_solve_Ins ... on_Manager
http://www.jfoobar.org/blog/258-quickgu ... layer.html

Firstly I had to enable my FTP Settings to:
-------------------------------------------
var $ftp_enable = '1';
var $ftp_host = 'YOURHOST.com';
var $ftp_port = '21';
var $ftp_user = 'USERNAME';
var $ftp_pass = 'PASSWORD';
var $ftp_root = '/web/';
-------------------------------------------
(take it easy with configuration.php file, I did all from File-Global Configuration, it's more confy)
Now, make sure you hit the right var $ftp_root: /www, or /web, or /anything else (check your website's structure)
If you dont catch the right var $ftp_root, you're gonna get an error, something about cannot saving the configuration file.

As soon as I have hit the right var $ftp_root, the global configuration has successfully saved and I moved on to the next step.
I have modified permissions of my entire website to '777' (temporarily for testing purposes) using my FILEZILLA software.


IF
var $ftp_enable = '1'; <---- OK
var $ftp_host = 'YOURHOST.COM'; <---- OK
var $ftp_port = '21'; <---- OK
var $ftp_user = 'USERNAME'; <---- OK
var $ftp_pass = 'PASSWORD'; <---- OK
var $ftp_root = '/vap/www/web129/web/'; <- WRONG (one subfolder was missing)

I GOT THIS ERROR:
* JFTP::store: Bad response
* Warning! Failed to move file.
-----------------------------------------------------------

IF
var $ftp_enable = '1'; <---- OK
var $ftp_host = 'YOURHOST.COM'; <---- OK
var $ftp_port = '21'; <---- OK
var $ftp_user = 'USERNAME'; <---- OK
var $ftp_pass = 'PASSWORD'; <---- OK
var $ftp_root = '/vap/'; <- MADE IT A SHORT VERSION LOOKED THE SAME LIKE WRONG 'var $ftp_root'

I GOT THIS ERROR: JFolder::create: Infinite loop detected
-----------------------------------------------------------

FINALLY I CAUGHT THE RIGHT var '$ftp_root', when I have created a path.php and used in from this guide:
http://docs.joomla.org/How_to_solve_Ins ... on_Manager


This means that there are some server settings which are wrong. You have to go to your global configuration and click on server. The first field is Path to Temp-folder and that's most likely the local path of you local install. You have to give in your live server path.

There are multiple ways to find that path. The easy one is to create a path.php file that has the following code in it:

<?php
echo getcwd();
?>

Go to example.com/path.php and this will give you the right directory. Put /tmp behind it, place it in Path to Temp-folder and your done.
The path.php showed me the right path, in my case /vap/www/web129/web/tmp, which I have just put into var '$ftp_root' and a wonder happened. Thx god I've guit smoking otherwise I
would have been smoking my ar.e right now!


IF

var $ftp_enable = '1'; <---- OK
var $ftp_host = 'YOURHOST.COM'; <---- OK
var $ftp_port = '21'; <---- OK
var $ftp_user = 'USERNAME'; <---- OK
var $ftp_pass = 'PASSWORD'; <---- OK
var $ftp_root = '/vap/www/web129/web/tmp' <---- ok


RESOURCES:
http://docs.joomla.org/Why_can%27t_you_ ... ensions%3F
http://docs.joomla.org/How_to_solve_Ins ... on_Manager
http://www.jfoobar.org/blog/258-quickgu ... layer.html
AND ALL JOOMLA FORUMS.


Top
 Profile  
 
PostPosted: Thu May 20, 2010 10:14 am 
Joomla! Apprentice
Joomla! Apprentice

Joined: Fri Feb 05, 2010 8:33 am
Posts: 22
I face this problem. I tryed all of the way, but still can't install module/com.

Linux hosting no problem (/home/gnet2u/public_html/mysite.com/logs)

Windos hosting I try to locate (/var/www/vhosts/myste.com/httpdocs:/logs/)

I think windows hosting location is problem.


Help-->System Info--> Director Permision

1. administrator/backups/ Writable
2. administrator/components/ Writable
3. administrator/language/ Unwritable
4. administrator/language/en-GB/ Unwritable
5. administrator/modules/ Unwritable
6. administrator/templates/ Unwritable
7 components/ Writable
8. images/ Unwritable
9. images/banners/ Unwritable
10. images/stories/ Unwritable
11. language/ Unwritable
12. language/en-GB/ Unwritable
13. language/pdf_fonts/ Unwritable
14. media/ Unwritable
15. modules/ Writable
16. plugins/ Writable
17. plugins/content/ Writable
18. plugins/editors/ Writable
19. plugins/editors-xtd/ Unwritable
20. plugins/search/ Unwritable
21. plugins/system/ Unwritable
22. plugins/user/ Unwritable
23. plugins/xmlrpc/ Unwritable
24. templates/ Unwritable
25. Cache Directory /var/www/vhosts/mysite.com/httpdocs/cache/ Unwritable
26. Cache Directory /var/www/vhosts/mysite.com/httpdocs/administrator/cache/ Writable
27. Log Directory ($log_path) /var/www/vhosts/mysie.com/httpdocs:/logs/ Unwritable
28. Temp Directory ($tmp_path) /var/www/vhosts/mysite.com/httpdocs:/tmp/ Unwritable


Please advice me.


Top
 Profile  
 
PostPosted: Tue Jul 06, 2010 10:49 am 
Joomla! Intern
Joomla! Intern

Joined: Mon Jul 31, 2006 4:53 pm
Posts: 90
I'm also coming up against this problem, but can't get to the bottom of it. I'm pretty sure I have the right tmp and logs paths set, but there seems to be an issue with file permissions. If I go into Help/System Info/Directory Permissions, I get this list:

administrator/backups/ Unwritable
administrator/components/ Unwritable
administrator/language/ Unwritable
administrator/language/de-DE/ Unwritable
administrator/language/en-GB/ Unwritable
administrator/language/nl-NL/ Unwritable
administrator/modules/ Unwritable
administrator/templates/ Unwritable
components/ Unwritable
images/ Unwritable
images/banners/ Unwritable
images/stories/ Unwritable
language/ Unwritable
language/en-GB/ Unwritable
language/pdf_fonts/ Unwritable
media/ Unwritable
modules/ Unwritable
plugins/ Unwritable
plugins/content/ Unwritable
plugins/editors/ Unwritable
plugins/editors-xtd/ Unwritable
plugins/search/ Unwritable
plugins/system/ Unwritable
plugins/user/ Unwritable
plugins/xmlrpc/ Unwritable
templates/ Unwritable
Cache Directory /usr/local/pem/vhosts/103103/webspace/httpdocs/cache/ Unwritable
Cache Directory /usr/local/pem/vhosts/103103/webspace/httpdocs/administrator/cache/ Unwritable
Log Directory ($log_path) /webspace/httpdocs/logs// Unwritable
Temp Directory ($tmp_path) /webspace/httpdocs/tmp// Unwritable

I used FileZilla to check the permissions on tmp and logs and found that they are set to 755. But when I try to change them to 777, FileZilla confirms the change, but it doesn't actually happen and they stay set at 755.

I'm assuming that this is the cause of the "JFolder::create: Infinite loop detected" error. Am I right, and if so, how can I change the permissions?


Top
 Profile  
 
PostPosted: Wed Jul 07, 2010 9:42 pm 
Joomla! Intern
Joomla! Intern

Joined: Mon Jul 31, 2006 4:53 pm
Posts: 90
Anybody able to help me on this one? Seems to be a topic that gets an awful lot of reads.


Top
 Profile  
 
PostPosted: Sun Jul 11, 2010 9:17 am 
Joomla! Intern
Joomla! Intern

Joined: Mon Jul 31, 2006 4:53 pm
Posts: 90
Finally tracked down the problem to the hosting company. It seems that they recently moved a lot of sites to new servers. In doing so, it seems that they screwed up the directory ownership settings. Once I convinced them to check this out, they were able to rectify the fault in seconds.


Top
 Profile  
 
PostPosted: Mon Aug 09, 2010 3:58 am 
Joomla! Fledgling
Joomla! Fledgling

Joined: Mon Aug 09, 2010 3:25 am
Posts: 3
Azazriel wrote:
Ok, for anyone else who stumbles on this thread, the problem is an incorrectly set tmp file.

viewtopic.php?f=470&t=266930

Make sure the path to your 'log' and 'tmp' folders are set correctly in the global configuration.


Thank you. I had solved the problem as well. I changed my Global Configuration Settings:
Path to Local Folder - log
Path to Temp Folder - tmp

_________________
My online shopping:http://egarden.com.my


Top
 Profile  
 
PostPosted: Fri Oct 22, 2010 6:01 pm 
Joomla! Apprentice
Joomla! Apprentice

Joined: Wed Jan 17, 2007 3:44 pm
Posts: 11
Location: Michigan,USA
I couldn't get anything to work until I stumbled upon a post on a cakePHP site suggesting changing the variable via your .htaccess file to something like:

php_value include_path "./insert/path/to/your/website:/tmp"

That worked for me.

-Brent


Top
 Profile  
 
PostPosted: Sun Dec 12, 2010 3:23 am 
Joomla! Fledgling
Joomla! Fledgling

Joined: Sun Dec 12, 2010 3:18 am
Posts: 1
Thanks, prestonascott!

Your post helped me to solve this problem even it was a post more than 2 years ago.
I searched in Google and I found your post.

In order to thank you I registered this forum... :D

Well Done, hope you read this post, Merry X'mas!


Top
 Profile  
 
PostPosted: Thu Jan 06, 2011 7:36 am 
Joomla! Fledgling
Joomla! Fledgling

Joined: Mon Nov 29, 2010 4:21 am
Posts: 1
For my site www.gecwyd.ac.in, Tmp setting is /www/hosted_sites/gecwyd.ac.in/www/tmp. I changed last www to httpdocs n tried. Still i am getting the same error. Can someone help me in this regard.

SREEJITH V P


Top
 Profile  
 
PostPosted: Wed Apr 06, 2011 9:28 pm 
Joomla! Apprentice
Joomla! Apprentice

Joined: Thu Aug 09, 2007 4:46 pm
Posts: 30
I had this same error and the correct fix for me was a code change to tar.php documented here...

http://sammoffatt.com.au/os/forum/2-upd ... p-detected

Note that the current version puts tar.php in a different location so the path to the file will be different, however the change to the "Make sure the destination folder exists" condition is the same.


Top
 Profile  
 
PostPosted: Tue Jun 21, 2011 9:25 am 
Joomla! Fledgling
Joomla! Fledgling

Joined: Wed Mar 09, 2011 2:23 pm
Posts: 2
Problem solved thanks to your post!

Thank you!


Top
 Profile  
 
PostPosted: Mon Sep 26, 2011 5:37 am 
Joomla! Intern
Joomla! Intern

Joined: Tue Apr 28, 2009 7:37 am
Posts: 50
Location: pune
hi i was getting the same problem,

please check the following link as well

http://docs.joomla.org/Infinite_loop_de ... Joomla_1.7

if your problem are not solved by above solution

_________________
Thanks
Kind Regards


Top
 Profile  
 
PostPosted: Tue Jul 03, 2012 11:26 am 
Joomla! Fledgling
Joomla! Fledgling

Joined: Mon Feb 06, 2012 9:10 am
Posts: 3
In Joomla after installing an extension (component, template, plugin, etc) the following error may appear:
* JFolder::create: Infinite loop detected
* Warning! Failed to move file.
The cause of this error is usually a bad path to the Joomla tmp folder and can be fixed within the Joomla configuration.php file by modifying the $tmp_path variable. For sites hosted on Linux servers the following line will usually fix the problem (change domain-name.com to your site’s domain name):
var $tmp_path = '/var/www/vhosts/domain-name.com/httpdocs/tmp';
The path above may need to be modified if your web server hosts multiple sites per IP address and if the site is hosted on a sub domain.
Tip: The website’s media manager can help identify the correct path. Navigate to Site → Media Managerfrom the Joomla admin menu, and copy the path under the “Files” text/legend and, replace the last word (images) to tmp.
Once the Joomla website’s tmp path has been changed, the log path ($log_path) will also need to be changed.
taken from another website, but it works :)


Top
 Profile  
 
PostPosted: Thu Dec 06, 2012 4:39 pm 
Joomla! Apprentice
Joomla! Apprentice

Joined: Mon Dec 05, 2011 12:07 pm
Posts: 20
I copied my site from one website to another and then had this problem :JFolder::create: Infinite loop detected when trying to install a module

Even though I changed the configuration.php files to point to the correct temp directory it still didnt work.

I also checked the permissions and they were correct and it still didn't work.

Finally in Global Configuration -> Server -> Path to Temp Folder in Joomla, I deleted the entry and clicked saved . I then put the path to the tmp folder in again, saved it and it worked!


Top
 Profile  
 
PostPosted: Wed Dec 26, 2012 12:36 pm 
Joomla! Fledgling
Joomla! Fledgling

Joined: Wed Dec 26, 2012 12:24 pm
Posts: 1
Hi guys,
I am not a IT guy, but in this case I luckely find a solution. I use a free hosting place and in global configuration I add those!
SOLVED:
/home/MY_username in hosting place/domains/my_domain.fi/public_html/tmp
/home/MY_username in hosting place/domains/my_domain.fi/public_html/logs

I hope it will help somebody!


Top
 Profile  
 
PostPosted: Thu Jan 31, 2013 10:56 am 
Joomla! Fledgling
Joomla! Fledgling

Joined: Thu Jan 31, 2013 10:31 am
Posts: 1
Location: Paarl, South Africa
Hi have the same problem but the solution did not work in my case - unless I am REALLY missing something

Can anyone help me out? This is the outline of the problem:

Action: Trying to install - anything
Error: JFolder::create: Infinite loop detected / Warning: Failed to move file!

The weird: Changing the permissions of tmp and logs does absolutely NOTHING - when checking the properties of the folders they are set on 777 (that's as writable as it gets) BUT it shows up as unwritable on the Joomla system check

What are we missing and how can this be fixed - login details available on request


PLEASE HELP


You do not have the required permissions to view the files attached to this post.


Top
 Profile  
 
PostPosted: Wed Jun 19, 2013 6:02 pm 
Joomla! Fledgling
Joomla! Fledgling

Joined: Fri Jan 08, 2010 2:49 pm
Posts: 2
I've had the same problem with JFolder::create: Infinite loop detected and I've fixed like this:

Go to Site>System Information>Directory Permissions and find Log directory. Copy the path (mine was something like this: /home/*****/public_html/****/logs). Then go to Site>Global Configuration>Server an paste the copied path to Path to Temp Folder. Change logs with tmp, save and then go to your hosting cpanel. Use File Manager under Files section. In left, click on public_html, then clik on the subfolder in which the site (mine was a subdomain) is installed or look in the right side and see the folder structure. Right click on tmp folder and change permission to 777. Then try to reinstall the plugin, module, language pack or whatever you wanted to before this, when you got the error.

Note: For me, this worked.


Top
 Profile  
 
PostPosted: Mon Jul 15, 2013 4:16 pm 
User avatar
Joomla! Apprentice
Joomla! Apprentice

Joined: Sat Mar 25, 2006 2:43 am
Posts: 28
Location: Malaysia
Thanks prestonascott. You've save my day. Ran into the same error and the method posted by prestonascott happen to have solved for my problems too. Thanks a million!

_________________
~Engrave the Creativity~


Top
 Profile  
 
PostPosted: Tue Oct 29, 2013 3:41 pm 
User avatar
Joomla! Enthusiast
Joomla! Enthusiast

Joined: Tue Nov 20, 2007 11:05 am
Posts: 152
Location: Greece
Azazriel wrote:
...Make sure the path to your 'log' and 'tmp' folders are set correctly in the global configuration.


That was really very beautiful! :pop

_________________
My love is music :-)
Free server monitor at:
http://www.serverdesk.eu


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 30 posts ] 



Who is online

Users browsing this forum: No registered users and 12 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Jump to:  
Powered by phpBB® Forum Software © phpBB Group