The Joomla! Forum ™



Forum rules


Forum Rules
Absolute Beginner's Guide to Joomla! <-- please read before posting, this means YOU.
Forum Post Assistant - If you are serious about wanting help, you will use this tool to help you post.



Post new topic Reply to topic  [ 20 posts ] 
Author Message
PostPosted: Thu Sep 11, 2008 4:27 pm 
Joomla! Apprentice
Joomla! Apprentice

Joined: Wed May 30, 2007 8:39 pm
Posts: 5
where put this line?

php_value mbstring.language neutra


in wich file wich location?


thanks


Top
 Profile  
 
PostPosted: Fri Sep 12, 2008 11:40 am 
User avatar
Joomla! Master
Joomla! Master

Joined: Wed Aug 17, 2005 10:27 pm
Posts: 14715
Location: Kent, England
Please explain what it is you are trying to achieve.


Top
 Profile  
 
PostPosted: Mon Sep 15, 2008 2:44 pm 
Joomla! Apprentice
Joomla! Apprentice

Joined: Wed May 30, 2007 8:39 pm
Posts: 5
PHP Version >= 4.3.10 Yes
- Zlib Compression Support Yes
- XML Support Yes
- MySQL Support Yes
MB Language is Default No PHP mbstring language is not set to neutral. This can be
set locally by entering php_value mbstring.language neutral in your .htaccess file.

MB String Overload Off Yes
configuration.php Writable No You can still continue the installation as the
configuration settings will be displayed at the end. You will have to manually
upload the code.

Click in the text area to highlight all of the code and then paste
into a new text file. Name this file 'configuration.php' and upload it to your site
root folder.

how solve the first problem? the second i can solve, but the first? thanks


Top
 Profile  
 
PostPosted: Mon Sep 15, 2008 2:55 pm 
User avatar
Joomla! Master
Joomla! Master

Joined: Wed Aug 17, 2005 10:27 pm
Posts: 14715
Location: Kent, England
Please run the phpinfo() script from your web_root/ directory

Add the following code to a new file and save as info.php (name is unimportant call it what-you-like)
Code:
<?php
phpinfo();
?>

Upload this file to your web_root/ directory and then call it from your Web browser as http://yourdomain.com/info.php.

Save the HTML output and zip it up and add that file to your forum post using the upload attachment function to the bottom left of the Post Editor screen.

Andy


Top
 Profile  
 
PostPosted: Tue Sep 16, 2008 11:27 am 
Joomla! Fledgling
Joomla! Fledgling

Joined: Tue Sep 16, 2008 11:19 am
Posts: 1
Hi Andy,

I too am having this same problem. I am attaching the info.php results in zip format.


You do not have the required permissions to view the files attached to this post.


Top
 Profile  
 
PostPosted: Wed Sep 17, 2008 5:24 pm 
Joomla! Apprentice
Joomla! Apprentice

Joined: Wed May 30, 2007 8:39 pm
Posts: 5
here my phpinfo


thanks


You do not have the required permissions to view the files attached to this post.


Top
 Profile  
 
PostPosted: Thu Sep 25, 2008 12:27 pm 
Joomla! Fledgling
Joomla! Fledgling

Joined: Wed Aug 29, 2007 6:51 pm
Posts: 4
I'm having the same issue can anyone help me on this?


You do not have the required permissions to view the files attached to this post.


Top
 Profile  
 
PostPosted: Fri Oct 17, 2008 9:42 am 
Joomla! Apprentice
Joomla! Apprentice

Joined: Fri Oct 17, 2008 9:34 am
Posts: 5
I to have this exact problem and also

Register Globals is set to On when Joomla recommends it should be OFF!

Any help would be much appreciated.

Thanks


You do not have the required permissions to view the files attached to this post.


Top
 Profile  
 
PostPosted: Mon Nov 10, 2008 10:07 pm 
Joomla! Fledgling
Joomla! Fledgling

Joined: Mon Nov 10, 2008 9:03 pm
Posts: 1
Installation problemwith MB Language is Default No

have tried changing :
.htaccess
php.ini

PHP Version >= 4.3.10 Yes
- Zlib Compression Support Yes
- XML Support Yes
- MySQL Support Yes
MB Language is Default No PHP mbstring language is not set to neutral. This can be set locally by entering php_value mbstring.language neutral in your .htaccess file.
MB String Overload Off Yes
configuration.php Writable Yes


You do not have the required permissions to view the files attached to this post.


Top
 Profile  
 
PostPosted: Thu Dec 25, 2008 9:17 am 
Joomla! Fledgling
Joomla! Fledgling

Joined: Thu Dec 25, 2008 9:12 am
Posts: 1
I met same problem. Attached file is info.php as requested.

Thanks for kindly help.


You do not have the required permissions to view the files attached to this post.


Top
 Profile  
 
PostPosted: Wed Dec 31, 2008 6:38 pm 
Joomla! Fledgling
Joomla! Fledgling

Joined: Wed Dec 31, 2008 6:32 pm
Posts: 1
I got the same problem, and I've tried adding the string to htaccess but my website keeps giving me an error 500. Does this means that my webhost is restricting me?

php info attached...


You do not have the required permissions to view the files attached to this post.


Top
 Profile  
 
PostPosted: Fri Jan 16, 2009 9:07 am 
User avatar
Joomla! Explorer
Joomla! Explorer

Joined: Wed Jun 07, 2006 10:56 am
Posts: 321
Location: Malaysia
Hi,

I have the same problem too. Attached with the zip file. How to solve it?

Thanks!


You do not have the required permissions to view the files attached to this post.

_________________
Internet Marketing Consultant and Web Developer
http://humanwebsite.com.my
http://worldwebcreator.com


Top
 Profile  
 
PostPosted: Sat Feb 21, 2009 8:00 pm 
Joomla! Fledgling
Joomla! Fledgling

Joined: Sat Feb 21, 2009 7:54 pm
Posts: 4
Anyone have found a solution on this yet? i really need to have this solved!!!!!!!!!!!!!!!!!


Top
 Profile  
 
PostPosted: Sun Feb 22, 2009 1:45 am 
User avatar
Joomla! Explorer
Joomla! Explorer

Joined: Wed Jun 07, 2006 10:56 am
Posts: 321
Location: Malaysia
Hi,

You can contact your hosting provider and ask them to solve for you. I did that.

_________________
Internet Marketing Consultant and Web Developer
http://humanwebsite.com.my
http://worldwebcreator.com


Top
 Profile  
 
PostPosted: Sun Mar 01, 2009 4:21 pm 
Joomla! Fledgling
Joomla! Fledgling

Joined: Sat Feb 21, 2009 7:54 pm
Posts: 4
sfpkent wrote:
Hi,

You can contact your hosting provider and ask them to solve for you. I did that.


I tried that and got an reply that just stated the same as the joomla install, i had to put some code into a .access file and it should be corrected, but it didn't. I sent a new service ticket to my provider, but have not heard anything from them in 4-5 days now... are ther eany way i can fix this other than with the .htaccess file? or what will happen if i go forward with the install without fixing this? (added phpinfo file in the post)


You do not have the required permissions to view the files attached to this post.


Top
 Profile  
 
PostPosted: Fri Aug 06, 2010 7:44 am 
Joomla! Fledgling
Joomla! Fledgling

Joined: Fri Aug 06, 2010 7:31 am
Posts: 2
Hi guys,

To solve this without contacting your service provider is actually quite simple.

If it does not already exist create a file in the root of your website (Where your index.php file is) called ".htaccess" (without the quotes). Then simply place the following line in the file:

php_value mbstring.language neutral

Save and close and that error should disappear.

For the other error. Go to the root of your webserver again and make a copy of configuration.php-dist and call it configuration.php. Now after you have done that you need to temporarily change the permissions on that file so that the webserver can write your configuration to it.

If you are using ssh to connect to your webserver simply use the chmod command:
chmod 777 configuration.php

Otherwise if you are using a graphical program, ensure that you change its file permissions to read write and execute for all users.

Warning: After you have installed Joomla remember to switch back the file permissions, otherwise it is a security hole.

Hope that solves both the problems,

Callaghan001.


Top
 Profile  
 
PostPosted: Wed Sep 01, 2010 6:26 pm 
Joomla! Fledgling
Joomla! Fledgling

Joined: Wed Sep 01, 2010 6:18 pm
Posts: 4
I´m having the same problem, not solving either of them!!!

The php_value mbstring.language neutra is givin´me the 500 internal error and the global config is not changin

@callaghan001

What can I do?
Please Help, my Hosting Administrator can´t do it!


Top
 Profile  
 
PostPosted: Sat May 14, 2011 11:14 am 
Joomla! Apprentice
Joomla! Apprentice

Joined: Thu Oct 07, 2010 10:44 am
Posts: 32
Location: Cambridge, UK
Hello guys, appreciate this is an old post but I'm having exactly the same problem as sjorkode - I add the .htaccess file and get a 500 internal error. Did anyone manage to sort this?

Cheers

John

_________________
Please read forum rules regarding signatures: viewtopic.php?t=65


Top
 Profile  
 
PostPosted: Fri Jun 17, 2011 10:03 am 
Joomla! Apprentice
Joomla! Apprentice

Joined: Thu Oct 07, 2010 10:44 am
Posts: 32
Location: Cambridge, UK
OK, found a couple of solutions to this depending on what you're doing:

For basic install issues add the following to your php.ini file (located in your root folder - or make a new one):

mbstring.language = Neutral

That should override the server settings and reset the site to neutral.

If you're running an Akeeba back up and have the same problem (the issue I was experiencing) then follow this thread and edit the installation/includes/logic/index.php as described: https://www.akeebabackup.com/support/fo ... lt-no.html

Worked a treat for me.

Cheers

John

_________________
Please read forum rules regarding signatures: viewtopic.php?t=65


Top
 Profile  
 
PostPosted: Sun Mar 18, 2012 5:34 pm 
Joomla! Fledgling
Joomla! Fledgling

Joined: Fri Mar 16, 2012 8:46 pm
Posts: 1
Location: Galway, Ireland
Hi to everyone,
I have common installation problems with:

MB Language is Default No;
Register Globals: On

I have tried changing
.htaccess
php.ini
by adding these commands in one of them and both of them.
register_globals = 0
php_value mbstring.language neutral

That didn’t help. Is there another solution? Is MB Language is Default important? Could somebody help me in this situation please? I also attached my info.php file.


You do not have the required permissions to view the files attached to this post.


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 20 posts ] 



Who is online

Users browsing this forum: No registered users and 16 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Jump to:  
Powered by phpBB® Forum Software © phpBB Group