The Joomla! Forum ™



Forum rules


Forum Rules
Absolute Beginner's Guide to Joomla! <-- please read before posting, this means YOU.
Forum Post Assistant - If you are serious about wanting help, you will use this tool to help you post.



Post new topic Reply to topic  [ 16 posts ] 
Author Message
PostPosted: Fri Aug 06, 2010 12:06 pm 
Joomla! Apprentice
Joomla! Apprentice

Joined: Fri Aug 06, 2010 11:49 am
Posts: 42
Hey

I've installed the Module "Random Background" but don't quite understand the whole setup process. I have installed and configured the module settings with appropriate folder URL etc.

Here are the instructions i don't understand:

"Step 2:
Place a module tag in your template, for example:
<jdoc:include type="modules" name="user1" style="xhtml"/> "

The bit i don't understand is the module tag you have to insert. It's not very clear where i put this. I have experience in using dreamweaver to modify my templates so i know it shouldn't be hard! Does it go in index.php or template.css or somewhere else??

Thanks


Top
 Profile  
 
PostPosted: Fri Aug 06, 2010 12:40 pm 
User avatar
Joomla! Master
Joomla! Master

Joined: Wed Aug 13, 2008 2:57 am
Posts: 22103
Location: Chennai, India
Are you creating a new template? The instructions you are referencing is applicable only if you are building a new template.

If you are already using a template, create the Random Image Module and publish it using the appropriate module position that is valid for your template. The module should show in your site in the module position you selected.

_________________
- Ilagnayeru (MIG) Manickam
http://www.eegan.org - helping the poor and underprivileged
educate. empower. enrich.
Support the poor and underprivileged


Top
 Profile  
 
PostPosted: Fri Aug 06, 2010 12:50 pm 
Joomla! Apprentice
Joomla! Apprentice

Joined: Fri Aug 06, 2010 11:49 am
Posts: 42
I created the template using Artisteer and I'm pretty sure I've got all the settings right, but it still doesn't seem to be working, here's a screen shot of the settings ive used...


You do not have the required permissions to view the files attached to this post.


Top
 Profile  
 
PostPosted: Fri Aug 06, 2010 2:27 pm 
User avatar
Joomla! Master
Joomla! Master

Joined: Wed Aug 13, 2008 2:57 am
Posts: 22103
Location: Chennai, India
Remove the semi-colon (;) after repeat in Additional CSS.

If this does not work, test this module with the default templates such as Beez and see how things work.

_________________
- Ilagnayeru (MIG) Manickam
http://www.eegan.org - helping the poor and underprivileged
educate. empower. enrich.
Support the poor and underprivileged


Top
 Profile  
 
PostPosted: Mon Aug 09, 2010 8:04 am 
Joomla! Apprentice
Joomla! Apprentice

Joined: Fri Aug 06, 2010 11:49 am
Posts: 42
neither worked, Could some help me with this??? If i can't get the module to work, is there another solution? all i want is to have a different background picture of every page. Thanks


Top
 Profile  
 
PostPosted: Mon Aug 09, 2010 9:27 am 
User avatar
Joomla! Master
Joomla! Master

Joined: Wed Aug 13, 2008 2:57 am
Posts: 22103
Location: Chennai, India
I tested this module in the template Beez and it worked.

What is your site URL so that others can see what is happening?

_________________
- Ilagnayeru (MIG) Manickam
http://www.eegan.org - helping the poor and underprivileged
educate. empower. enrich.
Support the poor and underprivileged


Top
 Profile  
 
PostPosted: Mon Aug 09, 2010 10:16 am 
Joomla! Apprentice
Joomla! Apprentice

Joined: Fri Aug 06, 2010 11:49 am
Posts: 42
I'm sure the module works fine as i have heard alot of people who are happy with the results but i cant seem to get it working.
Here is the URL:

www.cp-hosting.net/henrysmith

Thanks


Top
 Profile  
 
PostPosted: Wed Aug 25, 2010 6:48 pm 
Joomla! Fledgling
Joomla! Fledgling

Joined: Wed Aug 25, 2010 12:25 pm
Posts: 1
Hi!

I'm having the same problem. I have the Ja_Purity template, and, I don't know why, I can't make the RB work. As I see in your page, Laura, that it actually works now for you, may I ask how did you did it?

Place a module tag in your template, for example:
<jdoc:include type="modules" name="user1" style="xhtml"/> "

This is too the part of the instructions were I think I'm splitting down...

Can anyone hep me please? :(

Thanks to all!


Top
 Profile  
 
PostPosted: Wed Feb 02, 2011 11:12 am 
Joomla! Fledgling
Joomla! Fledgling

Joined: Thu Dec 09, 2010 7:29 pm
Posts: 1
TheJollyJoker wrote:
Hi!

I'm having the same problem. I have the Ja_Purity template, and, I don't know why, I can't make the RB work. As I see in your page, Laura, that it actually works now for you, may I ask how did you did it?

Place a module tag in your template, for example:
<jdoc:include type="modules" name="user1" style="xhtml"/> "

This is too the part of the instructions were I think I'm splitting down...

Can anyone hep me please? :(

Thanks to all!


You do not have to:
Place a module tag in your template, for example:
<jdoc:include type="modules" name="user1" style="xhtml"/> "

Just install the module, then enable it (in module manager click on the red icon in the Enabled column). Then enter into the backround module and choose a position from the position list (Details - Position) then select the Select Menu Item(s) from the List radiobutton (Menu assignement) and choose the desired menu item and then choose a background image in Parameters. Save and you're ready to go!


Top
 Profile  
 
PostPosted: Sat Oct 08, 2011 1:45 pm 
Joomla! Apprentice
Joomla! Apprentice

Joined: Sat Aug 06, 2011 9:45 pm
Posts: 6
Dear imanickam,

I have the same problem with the backgrounds as Laura. Also used artisteer to make a template but the backgrounds won't appear at all.

Can you please check the code for me

_________________
Joomla 1.7 Rocks, it is the best Software out there and for FREE. I didn't saw a CMS that was so extended. I hope Joomla will keep this up for eva. Looking [spam] forward to all my sites to Joomla 1.7 and beyond. [spam] amsterdam


Top
 Profile  
 
PostPosted: Thu Dec 15, 2011 1:51 am 
Joomla! Apprentice
Joomla! Apprentice

Joined: Fri Sep 25, 2009 7:51 pm
Posts: 15
How do i stop the image from being tiled?


Top
 Profile  
 
PostPosted: Thu Dec 15, 2011 2:40 am 
User avatar
Joomla! Master
Joomla! Master

Joined: Wed Aug 13, 2008 2:57 am
Posts: 22103
Location: Chennai, India
elleclouds:

Use the value no-repeat for the background-repeat attribute.

Review of the site http://www.w3schools.com/cssref/pr_background-repeat.asp would be of help.

_________________
- Ilagnayeru (MIG) Manickam
http://www.eegan.org - helping the poor and underprivileged
educate. empower. enrich.
Support the poor and underprivileged


Top
 Profile  
 
PostPosted: Sun Jan 15, 2012 7:10 am 
Joomla! Fledgling
Joomla! Fledgling

Joined: Sun Jan 15, 2012 6:57 am
Posts: 4
Hi,

After all those review it looks like I still have problem to run background module. For easier to understand what I am probably doing wrong I did screenshot on this link: https://docs.google.com/document/d/12pr ... VVvFs/edit

First: confusion what I had it was about:
Step 2
Place a module tag in your template, for example:
<jdoc:include type="modules" name="user1" style="xhtml"/>

So from review I realize there is a no need for this to be add in anywhere if I am using already some template (in my case this one: http://demo.cloudaccess.net/?template=fitness

Second: I didn't know that I should chose any position in module since this should be a background picture. However I am not sure if I understand well but this is background for modules? (if is not for module!? Why I should select module position??

Third is there anything that I should add in CSS? It looks like that by default I have already everything set up in module: background-repeat:no-repeat !important;
I believe I don't need to touch anything there?

Should I do anything in regard background color?

And last concern can I have static picture background what is follow when you scroll mouse up/down.

Thank you in advance for your time to respond on this issue,
Branko


You do not have the required permissions to view the files attached to this post.


Top
 Profile  
 
PostPosted: Thu May 10, 2012 5:38 am 
Joomla! Fledgling
Joomla! Fledgling

Joined: Thu May 10, 2012 5:31 am
Posts: 1
Hi,
I am struggling big time with this. Doesnt help i have limited CSS knowledge lol.

I simple want to apply a photo/picture behind all of the main content - I would call this the background.

However the background module wont work for me.

It either does nothing or changes the whole background white.

I am not even too sure what 'position' to place the module in.

Some specific guidance from any brains out there would be truely appreciated.

Thanks


Top
 Profile  
 
PostPosted: Thu May 10, 2012 7:06 am 
User avatar
Joomla! Master
Joomla! Master

Joined: Wed Aug 13, 2008 2:57 am
Posts: 22103
Location: Chennai, India
CricketCI: what is your sites URL so that others can review and offer suggestions?

_________________
- Ilagnayeru (MIG) Manickam
http://www.eegan.org - helping the poor and underprivileged
educate. empower. enrich.
Support the poor and underprivileged


Top
 Profile  
 
PostPosted: Fri Jun 29, 2012 7:21 am 
Joomla! Fledgling
Joomla! Fledgling

Joined: Fri Jun 29, 2012 7:01 am
Posts: 1
Dear Imanickam,
seems like I'm having the same troubles...

...the URL where you can find my site is:

www . faqtotumwebdesignermilano . it / armj

the module is now published in position-7 (under the breadcrumbs) as you can see for the title I left ON.

No matter what I try...the image is set as a background of the whole page and not of the position where I set it...

...and Chrome Elements analysis shown me an error such as:

Uncaught TypeError: Cannot call method 'set' of null md_stylechanger.js:66
addControls md_stylechanger.js:66
(anonymous function) mootools-core.js:375
h mootools-core.js:33
Array.implement.each mootools-core.js:40
invoke.fireEvent mootools-core.js:374
g mootools-core.js:514

that was not shown before the use of mod_background....

...can you help?

Thank you very much

Matteo


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 16 posts ] 



Who is online

Users browsing this forum: No registered users and 3 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Jump to:  
Powered by phpBB® Forum Software © phpBB Group