The Joomla! Forum ™



Forum rules


Forumregler



Post new topic Reply to topic  [ 20 posts ] 
Author Message
PostPosted: Tue Aug 10, 2010 11:15 am 
Joomla! Enthusiast
Joomla! Enthusiast

Joined: Sun Oct 18, 2009 12:48 pm
Posts: 108
Hej!
När jag är inne i Joomleague får jag följande felmeddelande..

Warning: fopen(/home/fotboll4/public_html/components/com_joomleague/frontend_config/english/show_report.tpl.jml) [function.fopen]: failed to open stream: No such file or directory in /home/fotboll4/public_html/administrator/components/com_joomleague/classes/xml.class.php on line 129

Linje: 129 är: $fop = fopen($src, 'r');

Warning: filesize() [function.filesize]: stat failed for /home/fotboll4/public_html/components/com_joomleague/frontend_config/english/show_report.tpl.jml in /home/fotboll4/public_html/administrator/components/com_joomleague/classes/xml.class.php on line 130

Linje 130 är: $data = fread($fop, filesize($src));

Warning: fread(): supplied argument is not a valid stream resource in /home/fotboll4/public_html/administrator/components/com_joomleague/classes/xml.class.php on line 130

Warning: fclose(): supplied argument is not a valid stream resource in /home/fotboll4/public_html/administrator/components/com_joomleague/classes/xml.class.php on line 131

Linje 131 är: fclose($fop);

Warning: key() [function.key]: Passed variable is not an array or object in /home/fotboll4/public_html/administrator/components/com_joomleague/classes/xml.class.php on line 157

Linje 157 är: return $this->pOut[0][key($this->pOut[0])];


Någon som vet hur man löser detta ?

Tack! ;)


Top
 Profile  
 
PostPosted: Tue Aug 10, 2010 12:22 pm 
User avatar
Joomla! Ace
Joomla! Ace

Joined: Thu Nov 15, 2007 4:12 pm
Posts: 1701
Location: Oxie, Sweden
Finns två orsaker som jag tror det är fel på.

1. Komponenten har inte blivit ordentlig installerad.
2. Komponenten stödjer inte det webbhotell som du har.

Vissa webbhotell har problem med vissa komponenter.

_________________
Mvh / Regards
Andreas Lindvall - Moderator Swedish forum
http://www.oxiepagen.se


Top
 Profile  
 
PostPosted: Tue Aug 10, 2010 12:37 pm 
Joomla! Enthusiast
Joomla! Enthusiast

Joined: Sun Oct 18, 2009 12:48 pm
Posts: 108
Med tanke på att komponenten annars fungerar utmärkt så tror jag dock att webbhotellet stödjer komponenten..

Så hm..


Top
 Profile  
 
PostPosted: Tue Aug 10, 2010 2:02 pm 
Joomla! Enthusiast
Joomla! Enthusiast

Joined: Sun Oct 18, 2009 12:48 pm
Posts: 108
Testade att ladda upp filen igen och har fortfarande samma problem...

Någon som vet något?

Har för mig nåt om att när där står foreach så är det nåt man ska lägga till, array eller nåt eller är jag helt fel ute?


Top
 Profile  
 
PostPosted: Tue Aug 10, 2010 5:47 pm 
User avatar
Joomla! Virtuoso
Joomla! Virtuoso

Joined: Wed Jan 10, 2007 11:23 am
Posts: 3866
Location: Västerås
"Har för mig nåt om att när där står foreach så är det nåt man ska lägga till, array eller nåt eller är jag helt fel ute?"

foreach('this do that')
{
...
}

array[]

Dessa är programkod. PHP-kod i detta fall.
Det är inget som du ska eller kan påverka.

_________________
Olle Zettergren
Moderator Swedish forum


Top
 Profile  
 
PostPosted: Tue Aug 10, 2010 7:31 pm 
Joomla! Enthusiast
Joomla! Enthusiast

Joined: Sun Oct 18, 2009 12:48 pm
Posts: 108
Så då är där inget jag kan göra ? ...


Top
 Profile  
 
PostPosted: Tue Aug 10, 2010 8:28 pm 
User avatar
Joomla! Virtuoso
Joomla! Virtuoso

Joined: Wed Jan 10, 2007 11:23 am
Posts: 3866
Location: Västerås
Jo, det går alltid att göra nåt.
Har den fungerat tidigare?
I så fall...
- Vad har ändrats?
- Var har det ändrats? Hos dig eller hosten?
- Går det att ta tillbaka en tidigare backup?

o.s.v.

Jag har inte använt detta tillägg så jag kan inte felsöka detta.
Men felsökning handlar om systematiskt detektivarbete :)
Om du inte har ett kanonminne så dokumentera under tiden vad du gör så att du kan backa tillbaka i "felsökningen".

Det viktigaste är att inte direkt säga. Nej, inget har ändrats! För i så fall skulle det ju fungera. Eller hur? ;)

_________________
Olle Zettergren
Moderator Swedish forum


Top
 Profile  
 
PostPosted: Wed Aug 11, 2010 8:11 am 
User avatar
Joomla! Ace
Joomla! Ace

Joined: Thu Nov 15, 2007 4:12 pm
Posts: 1701
Location: Oxie, Sweden
Jag har också denna komponent, men det fungerar felfritt hos mig.

_________________
Mvh / Regards
Andreas Lindvall - Moderator Swedish forum
http://www.oxiepagen.se


Top
 Profile  
 
PostPosted: Wed Aug 11, 2010 8:32 am 
Joomla! Enthusiast
Joomla! Enthusiast

Joined: Sun Oct 18, 2009 12:48 pm
Posts: 108
hmm.. tack zello :)

Andy: skulle du kunna skicka över din xml.class.php-fil så skulle jag kunna ta en titt och se om där är nåt som skiljer. ;)


Top
 Profile  
 
PostPosted: Wed Aug 11, 2010 4:02 pm 
User avatar
Joomla! Ace
Joomla! Ace

Joined: Thu Nov 15, 2007 4:12 pm
Posts: 1701
Location: Oxie, Sweden
anyone252 wrote:
Andy: skulle du kunna skicka över din xml.class.php-fil så skulle jag kunna ta en titt och se om där är nåt som skiljer. ;)


Javisst, det kan jag göra, men det får bli senare ikväll. Befinner mig nämligen ute i stan och svarar just nu via mobilen.

_________________
Mvh / Regards
Andreas Lindvall - Moderator Swedish forum
http://www.oxiepagen.se


Top
 Profile  
 
PostPosted: Wed Aug 11, 2010 9:19 pm 
User avatar
Joomla! Ace
Joomla! Ace

Joined: Thu Nov 15, 2007 4:12 pm
Posts: 1701
Location: Oxie, Sweden
Alltså, jag kan inte hitta den filen i min installation...
Verken i admin eller component.

_________________
Mvh / Regards
Andreas Lindvall - Moderator Swedish forum
http://www.oxiepagen.se


Top
 Profile  
 
PostPosted: Thu Aug 12, 2010 12:44 pm 
Joomla! Enthusiast
Joomla! Enthusiast

Joined: Sun Oct 18, 2009 12:48 pm
Posts: 108
xml.class.php borde ju finnas i admin.. Konstigt..


Top
 Profile  
 
PostPosted: Thu Aug 12, 2010 1:12 pm 
User avatar
Joomla! Ace
Joomla! Ace

Joined: Thu Nov 15, 2007 4:12 pm
Posts: 1701
Location: Oxie, Sweden
Ligger den i en mapp eller direkt i admin under komponenten?

_________________
Mvh / Regards
Andreas Lindvall - Moderator Swedish forum
http://www.oxiepagen.se


Top
 Profile  
 
PostPosted: Thu Aug 12, 2010 1:21 pm 
Joomla! Enthusiast
Joomla! Enthusiast

Joined: Sun Oct 18, 2009 12:48 pm
Posts: 108
Sökvägen till den ska vara administrator/components/com_joomleague/classes/xml.class.php

Har du tid får du gärna skicka över denna också components/com_joomleague/frontend_config/english/show_report.tpl.jml

Tack ;)


Top
 Profile  
 
PostPosted: Thu Aug 12, 2010 1:39 pm 
User avatar
Joomla! Ace
Joomla! Ace

Joined: Thu Nov 15, 2007 4:12 pm
Posts: 1701
Location: Oxie, Sweden
anyone252 wrote:
Sökvägen till den ska vara administrator/components/com_joomleague/classes/xml.class.php

Har du tid får du gärna skicka över denna också components/com_joomleague/frontend_config/english/show_report.tpl.jml

Tack ;)


Jag kollar så fort jag har tillgång till min dator. :)

_________________
Mvh / Regards
Andreas Lindvall - Moderator Swedish forum
http://www.oxiepagen.se


Top
 Profile  
 
PostPosted: Thu Aug 12, 2010 2:40 pm 
Joomla! Enthusiast
Joomla! Enthusiast

Joined: Sun Oct 18, 2009 12:48 pm
Posts: 108
Kanon :D


Top
 Profile  
 
PostPosted: Sat Aug 14, 2010 9:53 am 
User avatar
Joomla! Ace
Joomla! Ace

Joined: Thu Nov 15, 2007 4:12 pm
Posts: 1701
Location: Oxie, Sweden
Här är filen.
Du får ta och packa upp den

components/com_joomleague/frontend_config/english/show_report.tpl.jml
Den filen har jag inte.

Har du den senaste versionen??


You do not have the required permissions to view the files attached to this post.

_________________
Mvh / Regards
Andreas Lindvall - Moderator Swedish forum
http://www.oxiepagen.se


Top
 Profile  
 
PostPosted: Sat Aug 14, 2010 8:28 pm 
Joomla! Enthusiast
Joomla! Enthusiast

Joined: Sun Oct 18, 2009 12:48 pm
Posts: 108
Tack :)

Allt löst nu! ;)


Top
 Profile  
 
PostPosted: Sat Aug 14, 2010 9:22 pm 
User avatar
Joomla! Ace
Joomla! Ace

Joined: Thu Nov 15, 2007 4:12 pm
Posts: 1701
Location: Oxie, Sweden
Kanon, kul att man kom till nytta!

Du kan gärna dela med dig vad som var fel..

_________________
Mvh / Regards
Andreas Lindvall - Moderator Swedish forum
http://www.oxiepagen.se


Top
 Profile  
 
PostPosted: Sun Aug 15, 2010 8:01 am 
Joomla! Enthusiast
Joomla! Enthusiast

Joined: Sun Oct 18, 2009 12:48 pm
Posts: 108
Det var nog något fel i xml.class..
Ersatte din med min, samt att jag laddade upp report filen igen. :)


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 20 posts ] 



Who is online

Users browsing this forum: No registered users and 2 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Jump to:  
Powered by phpBB® Forum Software © phpBB Group