Joomla and php 5.3.3

Need help installing Joomla! 1.5? For all Joomla! 1.5 installation issues please use this forum.

Moderator: General Support Moderators

Forum rules
Forum Rules
Absolute Beginner's Guide to Joomla! <-- please read before posting, this means YOU.
Forum Post Assistant - If you are serious about wanting help, you will use this tool to help you post.
gonzela2006
Joomla! Intern
Joomla! Intern
Posts: 50
Joined: Thu Jan 14, 2010 2:06 am

Joomla and php 5.3.3

Postby gonzela2006 » Tue Oct 05, 2010 1:43 pm

Hello,
my site was working well until my hosting provider upgraded to php 5.3.3 as I can see a lot of errors on the home page like this:

Code: Select all

Warning: Parameter 1 to plugin_get_module_output() expected to be a reference, value given in /home/*******/public_html/libraries/joomla/event/dispatcher.php on line 136
Warning: Parameter 1 to plgContentJumi::onPrepareContent() expected to be a reference, value given in /home/*******/public_html/libraries/joomla/event/event.php on line 67
Warning: Parameter 1 to plgContentEmailCloak() expected to be a reference, value given in /home/*******/public_html/libraries/joomla/event/dispatcher.php on line 136
Warning: Parameter 1 to plgContentLoadModule() expected to be a reference, value given in /home/*******/public_html/libraries/joomla/event/dispatcher.php on line 136

so What can I do???

Thanks

gonzela2006
Joomla! Intern
Joomla! Intern
Posts: 50
Joined: Thu Jan 14, 2010 2:06 am

Re: Joomla and php 5.3.3

Postby gonzela2006 » Tue Oct 05, 2010 2:13 pm

Joomla installation manual says:

Code: Select all

Note: There are currently ongoing discussions as to whether there are additional issues with the whole 4.3.x. series of releases of PHP and it has been found that the best and most consistent results are achieved with the PHP 5.x series.


Does it mean that Joomla not compatible with 5.3+??

User avatar
Per Yngve Berg
Joomla! Master
Joomla! Master
Posts: 21834
Joined: Mon Oct 27, 2008 9:27 pm
Location: Akershus, Norway

Re: Joomla and php 5.3.3

Postby Per Yngve Berg » Tue Oct 05, 2010 2:54 pm

Joomla 1.5.20 is compatible with php 5.3 (before 1.5.15 is not)

There can also be extensions that is not compatible.

If you have not upgraded to the latest 1.5.20 release, do so.

gonzela2006
Joomla! Intern
Joomla! Intern
Posts: 50
Joined: Thu Jan 14, 2010 2:06 am

Re: Joomla and php 5.3.3

Postby gonzela2006 » Mon Oct 18, 2010 1:54 pm

Per Yngve Berg wrote:Joomla 1.5.20 is compatible with php 5.3 (before 1.5.15 is not)

There can also be extensions that is not compatible.

If you have not upgraded to the latest 1.5.20 release, do so.

I have upgraded to 1.5.21 and the error still appear.
Any help please

User avatar
Per Yngve Berg
Joomla! Master
Joomla! Master
Posts: 21834
Joined: Mon Oct 27, 2008 9:27 pm
Location: Akershus, Norway

Re: Joomla and php 5.3.3

Postby Per Yngve Berg » Mon Oct 18, 2010 2:32 pm

Jumi is mentioned in the error message. Have you checked that it is the latest version?

gonzela2006
Joomla! Intern
Joomla! Intern
Posts: 50
Joined: Thu Jan 14, 2010 2:06 am

Re: Joomla and php 5.3.3

Postby gonzela2006 » Mon Oct 18, 2010 2:45 pm

Per Yngve Berg wrote:Jumi is mentioned in the error message. Have you checked that it is the latest version?

Yes, I have Jumi version 2.0.6

User avatar
dhuelsmann
Joomla! Master
Joomla! Master
Posts: 19226
Joined: Sun Oct 02, 2005 12:50 am
Location: Omaha, NE
Contact:

Re: Joomla and php 5.3.3

Postby dhuelsmann » Wed Oct 20, 2010 11:19 am

You say you upgraded to 1.5.21. Please check on the info tab in the Joomla backend and see if it agrees that you have upgraded to that version.
Regards, Dave
Past Treasurer Open Source Matters, Inc.
http://www.kiwaniswest.org

gonzela2006
Joomla! Intern
Joomla! Intern
Posts: 50
Joined: Thu Jan 14, 2010 2:06 am

Re: Joomla and php 5.3.3

Postby gonzela2006 » Wed Oct 20, 2010 11:59 am

dhuelsmann wrote:You say you upgraded to 1.5.21. Please check on the info tab in the Joomla backend and see if it agrees that you have upgraded to that version.

all info tab:

Code: Select all

PHP Built on:       Linux (server name) 2.6.18-53.el5PAE #1 SMP Mon Nov 12 02:55:09 EST 2007 i686
Database Version:    5.0.91-community
Database Collation:    latin1_swedish_ci
PHP Version:    5.3.3
Web Server:    Apache/2.2.16 (Unix) mod_ssl/2.2.16 OpenSSL/0.9.8e-fips-rhel5 mod_auth_passthrough/2.1 mod_bwlimited/1.4 FrontPage/5.0.2.2635 PHP/5.3.3
Web Server to PHP interface:    apache2handler
Joomla! Version:    Joomla! 1.5.21 Stable [ senu takaa ama wepulai ] 08-October-2010 18:00 GMT
User Agent:    Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.2.10) Gecko/20100914 Firefox/3.6.10 ( .NET CLR 3.5.30729)

User avatar
mark_up
Joomla! Guru
Joomla! Guru
Posts: 849
Joined: Sun Oct 29, 2006 10:51 am
Location: Fiji
Contact:

Re: Joomla and php 5.3.3

Postby mark_up » Wed Oct 20, 2010 12:17 pm

Try turning off error reporting in Joomla global configuration :)

A temporary solution anyway.
http://twitter.com/mark_up.
Opinions expressed are mine alone and don't necessarily represent the views of any organisation I am associated with.

gonzela2006
Joomla! Intern
Joomla! Intern
Posts: 50
Joined: Thu Jan 14, 2010 2:06 am

Re: Joomla and php 5.3.3

Postby gonzela2006 » Wed Oct 20, 2010 1:21 pm

mark_up wrote:Try turning off error reporting in Joomla global configuration :)

A temporary solution anyway.

I made Error Reporting : none and the error still exist ??? ??? ???

gonzela2006
Joomla! Intern
Joomla! Intern
Posts: 50
Joined: Thu Jan 14, 2010 2:06 am

Re: Joomla and php 5.3.3

Postby gonzela2006 » Wed Oct 20, 2010 1:34 pm

I have noticed some things
If I disabled those plugins
-module
-Content - Email Cloaking
-Content - Load Module
-Content - Pagebreak
everything will work well
So how can I fix that problem????????????

amzro
Joomla! Apprentice
Joomla! Apprentice
Posts: 17
Joined: Sat Sep 26, 2009 7:12 pm

Re: Joomla and php 5.3.3

Postby amzro » Sat Jan 08, 2011 5:14 pm

I have the same problem and I don'find anyware a solution. :(

rkubera
Joomla! Apprentice
Joomla! Apprentice
Posts: 26
Joined: Thu Jan 05, 2006 3:37 pm
Contact:

Re: Joomla and php 5.3.3

Postby rkubera » Fri Jun 03, 2011 5:08 pm

WORKGROUND :::
In file:
libraries/joomla/event/dispatcher.php on line 136
replace [line 136]:
$result[] = call_user_func_array($observer['handler'], $args);
with:
$result[] = @call_user_func_array($observer['handler'], $args);

and in file:
/libraries/joomla/event/event.php
replace [line 67]:
return call_user_func_array ( array($this, $event), $args );
with:
return @call_user_func_array ( array($this, $event), $args );

Regards, Radek.
SEF Service Map for J 1.5 - http://www.sefservicemap.com

User avatar
cbahiana
Joomla! Enthusiast
Joomla! Enthusiast
Posts: 174
Joined: Wed Aug 24, 2005 2:03 pm
Location: Rio de Janeiro
Contact:

Re: Joomla and php 5.3.3

Postby cbahiana » Thu Dec 01, 2011 12:51 pm

Thanks, Radek, that did the trick!
Carlos Bahiana
Designer, Ergonomist, MSc Production Engineering
http://www.softdesign.eti.br

majstormisa
Joomla! Fledgling
Joomla! Fledgling
Posts: 1
Joined: Thu Dec 08, 2011 9:28 am
Contact:

Re: Joomla and php 5.3.3

Postby majstormisa » Thu Dec 08, 2011 9:41 am

I had compatibility trouble with perl and awstats(geo ip plugin) and i spent 3 days solving it.Can someone confirm that i can use latest php,or what version to use to be able to use Jomla ?


Return to “Installation 1.5”

Who is online

Users browsing this forum: No registered users and 4 guests