The Joomla! Forum ™



Forum rules


Forum Rules
Absolute Beginner's Guide to Joomla! <-- please read before posting.
Forum Post Assistant - If you are serious about wanting help, you should use this tool to help you post.



Post new topic Reply to topic  [ 9 posts ] 
Author Message
PostPosted: Tue Oct 19, 2010 3:32 am 
Joomla! Apprentice
Joomla! Apprentice

Joined: Mon Mar 22, 2010 3:19 am
Posts: 7
Hello!
I have searched the forum and seen that many people have this issue but for different reasons.
Here is mine (or, at least, this is my guess):

This is a website I am working on. http://ruidonaranja.com/nosotros

The current state in the top menu does not work.
The code for active menu items shows as follows:
Code:
<ul class="menutop"><li class="item7"><a href="/nosotros"><span>Nosotros</span></a></li>

With no current id
When I disable the SEF URLS from the joomla global configuration, it works properly.
I have cleaned the cache many times, the module has no cache saving and the full active higlighting is set to Yes.

Has anyone solved a problem like this one?
Thanks a lot!
Angeles


Top
 Profile  
 
PostPosted: Tue Oct 19, 2010 8:10 am 
Joomla! Apprentice
Joomla! Apprentice

Joined: Sun Oct 10, 2010 2:48 pm
Posts: 27
I don't see any problem to me it's working fine.


Top
 Profile  
 
PostPosted: Tue Oct 19, 2010 1:05 pm 
Joomla! Apprentice
Joomla! Apprentice

Joined: Mon Mar 22, 2010 3:19 am
Posts: 7
Hi! Thanks for your reply! ;)
You mean you see
Code:
id="current"

in the code for the first item on that top menu?


Top
 Profile  
 
PostPosted: Thu Oct 21, 2010 2:58 am 
Joomla! Apprentice
Joomla! Apprentice

Joined: Mon Mar 22, 2010 3:19 am
Posts: 7
I think the problem is the SEF URL activation. I´m using ARTIO SEF.


Top
 Profile  
 
PostPosted: Tue Nov 16, 2010 11:50 pm 
User avatar
Joomla! Enthusiast
Joomla! Enthusiast

Joined: Wed Aug 24, 2005 12:51 am
Posts: 235
Location: Melbourne, Australia
I'm having exactly the same issue. Anyone found a solution for this?

_________________
thinksync  ::  corporate  creative  media  http://www.thinksync.com.au


Top
 Profile  
 
PostPosted: Mon Nov 29, 2010 11:54 am 
Joomla! Apprentice
Joomla! Apprentice

Joined: Mon Mar 22, 2010 3:19 am
Posts: 7
I found where the problem was!
My top menu was not my joomla main menu. It was not the menu with the default link (hompeage link) so it was not declaring the current state for any of my links.
It would be good to have that state in all menus, not just the main one!!


Top
 Profile  
 
PostPosted: Mon Nov 29, 2010 7:09 pm 
User avatar
Joomla! Enthusiast
Joomla! Enthusiast

Joined: Wed Aug 24, 2005 12:51 am
Posts: 235
Location: Melbourne, Australia
I've also found the solution - sorry for not posting sooner, only the notification from angelesb's post reminded me.

It's not just to do with it being the main menu, but that for active menu highlighting to work there can only be ONE menu item across all menus pointing to the article/component/etc you're linking to.

That doesn't mean that you can't have several menu items that take you to the same place, however.

For example, let's say you have the 'about' menu item in both the main and footer menus. If you link directly to your about article in both menus, active menu highlighting will not work.

But, you can link to the article in your main menu and then use the 'link to menu item' option for the footer menu and it will work. The footer menu doesn't link to the article, you're just telling it to use the same link as the 'about' in the main menu.

This solved my problem.

_________________
thinksync  ::  corporate  creative  media  http://www.thinksync.com.au


Top
 Profile  
 
PostPosted: Tue Nov 30, 2010 11:28 am 
Joomla! Apprentice
Joomla! Apprentice

Joined: Mon Mar 22, 2010 3:19 am
Posts: 7
Thanks!!! Really helpful!


Top
 Profile  
 
PostPosted: Wed Oct 19, 2011 2:38 pm 
Joomla! Apprentice
Joomla! Apprentice

Joined: Fri Sep 25, 2009 1:51 pm
Posts: 7
Location: Ireland
Thanks Troubadour. I've been working around this issue for a long time. Nice to finally have it solved using the Alias menu item type, and so simply too :)


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 9 posts ] 



Who is online

Users browsing this forum: No registered users and 43 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Jump to:  
Powered by phpBB® Forum Software © phpBB Group