The Joomla! Forum ™



Forum rules


Please use the Forum Post Assistant to give your server setting details which are necessary to determine the problem.



Forum locked This topic is locked, you cannot edit posts or make further replies.  [ 9 posts ] 
Author Message
PostPosted: Sun Aug 08, 2010 12:43 am 
Joomla! Fledgling
Joomla! Fledgling

Joined: Thu Aug 05, 2010 6:33 am
Posts: 3
Location: singapore
hi, sir
I face one issued of migration of website:
if my configuration is already in one domain name under one diractory and one database name, when I migrate to any other server, or cahnge diractory name, or change the database name also cause the wesite become not workable, how to solve the problem?

when I install in one server is working, I backup the database when I restore this database in another server will come out error, what is the problem ? the error as following:
SQL query:

CREATE TABLE IF NOT EXISTS `jml_usergroups` (

`id` int( 10 ) unsigned NOT NULL AUTO_INCREMENT COMMENT 'Primary Key',
`parent_id` int( 10 ) unsigned NOT NULL DEFAULT '0' COMMENT 'Adjacency List Reference Id',
`lft` int( 11 ) NOT NULL DEFAULT '0' COMMENT 'Nested set lft.',
`rgt` int( 11 ) NOT NULL DEFAULT '0' COMMENT 'Nested set rgt.',
`title` varchar( 100 ) NOT NULL DEFAULT '',
PRIMARY KEY ( `id` ) ,
UNIQUE KEY `idx_usergroup_title_lookup` ( `title` ) ,
KEY `idx_usergroup_adjacency_lookup` ( `parent_id` ) ,
KEY `idx_usergroup_nested_set_lookup` ( `lft` , `rgt` ) USING BTREE) ENGINE = MYISAM DEFAULT CHARSET = utf8 AUTO_INCREMENT =13;

MySQL said:

#1064 - You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near 'USING BTREE
) ENGINE=MyISAM DEFAULT CHARSET=utf8 AUTO_INCREMENT=13' at line 10

What is the problem ,
how to solve this probem?
Thanks from David


Top
 Profile  
 
PostPosted: Mon Aug 09, 2010 4:40 pm 
User avatar
Joomla! Ace
Joomla! Ace

Joined: Sat Oct 28, 2006 11:16 pm
Posts: 1242
Location: Texas
There is a known problem with MySQL 5.1 you can read about here:
http://bugs.mysql.com/bug.php?id=25162

The "USING BTREE" portion of the query might be what is causing your issue.

Remove it from all queries and try again.

_________________
My extensions: http://extensions.joomla.org/extensions/owner/stutteringp0et
Honk if this signature offends you.


Top
 Profile  
 
PostPosted: Thu Jan 13, 2011 8:42 am 
Joomla! Apprentice
Joomla! Apprentice

Joined: Sat Oct 30, 2010 6:48 pm
Posts: 15
Hi. Can you please explain how to remove "USING BTREE" from a query? I am having the same issue and I have (I am sure thousands of others neither) no idea how to do it to make joomla migration work. Thanx for your understanding.


Top
 Profile  
 
PostPosted: Thu Jan 13, 2011 5:52 pm 
User avatar
Joomla! Ace
Joomla! Ace

Joined: Sat Oct 28, 2006 11:16 pm
Posts: 1242
Location: Texas
edit the query file, remove the text "USING BTREE" anywhere you find it.

Take care to not disturb the surrounding text.

Code:
CREATE TABLE IF NOT EXISTS `#__usergroups` (

`id` int( 10 ) unsigned NOT NULL AUTO_INCREMENT COMMENT 'Primary Key',
`parent_id` int( 10 ) unsigned NOT NULL DEFAULT '0' COMMENT 'Adjacency List Reference Id',
`lft` int( 11 ) NOT NULL DEFAULT '0' COMMENT 'Nested set lft.',
`rgt` int( 11 ) NOT NULL DEFAULT '0' COMMENT 'Nested set rgt.',
`title` varchar( 100 ) NOT NULL DEFAULT '',
PRIMARY KEY ( `id` ) ,
UNIQUE KEY `idx_usergroup_title_lookup` ( `title` ) ,
KEY `idx_usergroup_adjacency_lookup` ( `parent_id` ) ,
KEY `idx_usergroup_nested_set_lookup` ( `lft` , `rgt` ) USING BTREE) ENGINE = MYISAM DEFAULT CHARSET = utf8 AUTO_INCREMENT =13;

becomes (notice the 2nd to last line in both)
Code:
CREATE TABLE IF NOT EXISTS `#__usergroups` (

`id` int( 10 ) unsigned NOT NULL AUTO_INCREMENT COMMENT 'Primary Key',
`parent_id` int( 10 ) unsigned NOT NULL DEFAULT '0' COMMENT 'Adjacency List Reference Id',
`lft` int( 11 ) NOT NULL DEFAULT '0' COMMENT 'Nested set lft.',
`rgt` int( 11 ) NOT NULL DEFAULT '0' COMMENT 'Nested set rgt.',
`title` varchar( 100 ) NOT NULL DEFAULT '',
PRIMARY KEY ( `id` ) ,
UNIQUE KEY `idx_usergroup_title_lookup` ( `title` ) ,
KEY `idx_usergroup_adjacency_lookup` ( `parent_id` ) ,
KEY `idx_usergroup_nested_set_lookup` ( `lft` , `rgt` ) ) ENGINE = MYISAM DEFAULT CHARSET = utf8 AUTO_INCREMENT =13;

_________________
My extensions: http://extensions.joomla.org/extensions/owner/stutteringp0et
Honk if this signature offends you.


Top
 Profile  
 
PostPosted: Thu Jan 13, 2011 5:59 pm 
Joomla! Apprentice
Joomla! Apprentice

Joined: Sat Oct 30, 2010 6:48 pm
Posts: 15
Thank you very much for your help, but how do I edit the query file?


Top
 Profile  
 
PostPosted: Thu Jan 13, 2011 8:00 pm 
User avatar
Joomla! Ace
Joomla! Ace

Joined: Sat Oct 28, 2006 11:16 pm
Posts: 1242
Location: Texas
Really?

It's a text file, edit it just like any other text/php/html file on your system. If you're on windows you can use something like notepad. On Mac I like TextMate and in Linux I like Kate or Nano.

_________________
My extensions: http://extensions.joomla.org/extensions/owner/stutteringp0et
Honk if this signature offends you.


Top
 Profile  
 
PostPosted: Thu Jan 13, 2011 8:58 pm 
Joomla! Apprentice
Joomla! Apprentice

Joined: Sat Oct 30, 2010 6:48 pm
Posts: 15
Thank you very much.


Top
 Profile  
 
PostPosted: Mon Feb 07, 2011 6:48 pm 
Joomla! Fledgling
Joomla! Fledgling

Joined: Mon Feb 07, 2011 6:42 pm
Posts: 1
Thank you stutteringp0et.
Your information was very useful !


Top
 Profile  
 
PostPosted: Fri Apr 08, 2011 8:45 am 
Joomla! Enthusiast
Joomla! Enthusiast

Joined: Sun Apr 30, 2006 11:35 am
Posts: 211
Location: UK
stutteringp0et wrote:
edit the query file, remove the text "USING BTREE" anywhere you find it.

I was having problems transferring a local copy of J 1.6 from XAMPP to a live server. I searched the database for the above text, deleted it and tried again and now it's working fine. Thanks so much for the tip.

_________________
http://www.nationalcasinos.co.uk/ http://www.funcasino-hire.co.uk/


Top
 Profile  
 
Display posts from previous:  Sort by  
Forum locked This topic is locked, you cannot edit posts or make further replies.  [ 9 posts ] 



Who is online

Users browsing this forum: No registered users and 2 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Jump to:  
Powered by phpBB® Forum Software © phpBB Group