Problem with PHP Version 6.0.0-dev

Need help installing Joomla! 2.5? For all Joomla! 2.5 installation issues please use this forum. Note: All 1.6 and 1.7 releases have reached end of life and should be updated to 2.5.

Moderator: General Support Moderators

Forum rules
Forum Rules
Absolute Beginner's Guide to Joomla! <-- please read before posting, this means YOU.
Forum Post Assistant - If you are serious about wanting help, you will use this tool to help you post.
JeDuke
Joomla! Apprentice
Joomla! Apprentice
Posts: 6
Joined: Sat Jan 24, 2009 10:35 am

Problem with PHP Version 6.0.0-dev

Postby JeDuke » Wed Jan 12, 2011 4:15 pm

Hello everybody,
I'm installing 1.6, a fresh install. My ISP 1and1 has PHP4, so I edited .htaccess to include PHP5. Now I realize the version of 5 they're running is PHP Version 5.2.17. Not enough. So I updated .htaccess to include the line AddType x-mapp-php6 .php .php3 .php4 .htm .html. Pretty standard so far.

Now Joomla gives me error messages aplenty, what do I need to do? Thanks!!

Strict Standards: Declaration of JInstallation::initialise() should be compatible with that of JApplication::initialise() in /homepages/42/d259270560/htdocs/web2csv/installation/includes/application.php on line 276

Strict Standards: Declaration of JInstallation::_createConfiguration() should be compatible with that of JApplication::_createConfiguration() in /homepages/42/d259270560/htdocs/web2csv/installation/includes/application.php on line 276

Strict Standards: Declaration of JInstallation::_createSession() should be compatible with that of JApplication::_createSession() in /homepages/42/d259270560/htdocs/web2csv/installation/includes/application.php on line 276

Warning: session_start() [function.session-start]: Cannot send session cookie - headers already sent by (output started at /homepages/42/d259270560/htdocs/web2csv/installation/includes/application.php:276) in /homepages/42/d259270560/htdocs/web2csv/libraries/joomla/session/session.php on line 411

Warning: session_start() [function.session-start]: Cannot send session cache limiter - headers already sent (output started at /homepages/42/d259270560/htdocs/web2csv/installation/includes/application.php:276) in /homepages/42/d259270560/htdocs/web2csv/libraries/joomla/session/session.php on line 411

Warning: parse_url(https:////) [function.parse-url]: Unable to parse URL in /homepages/42/d259270560/htdocs/web2csv/libraries/joomla/utilities/string.php on line 708

Warning: Invalid argument supplied for foreach() in /homepages/42/d259270560/htdocs/web2csv/libraries/joomla/utilities/string.php on line 710

Strict Standards: urlencode() [function.urlencode]: expecting binary parameter, received Unicode parameter was converted to UTF-8 in /homepages/42/d259270560/htdocs/web2csv/libraries/joomla/utilities/string.php on line 706

Fatal error: Cannot use object of type JLanguage as array in /homepages/42/d259270560/htdocs/web2csv/libraries/joomla/environment/request.php on line 132

User avatar
jmuehleisen
Joomla! Virtuoso
Joomla! Virtuoso
Posts: 4874
Joined: Thu Nov 09, 2006 2:46 pm
Location: Kampala, Uganda
Contact:

Re: Problem with PHP Version 6.0.0-dev

Postby jmuehleisen » Fri Jan 14, 2011 2:14 pm

php 5.2.17 should be OK to install Joomla 1.6 (at least, according to the docs).

What kind of errors did you get when trying to install with 5.2.17?
John Muehleisen
Visit my "Getting Started with Joomla" site, now with videos, tips, and new user tutorials:  http://welcometojoomla.com

JeDuke
Joomla! Apprentice
Joomla! Apprentice
Posts: 6
Joined: Sat Jan 24, 2009 10:35 am

Re: Problem with PHP Version 6.0.0-dev

Postby JeDuke » Fri Jan 14, 2011 4:31 pm

jmuehleisen wrote:php 5.2.17 should be OK to install Joomla 1.6 (at least, according to the docs).

What kind of errors did you get when trying to install with 5.2.17?


No, alas, 5.2.17 is not enough. I got this message: 5.2.24 necessary.

But, o, marvel of all marvels, it is working today!!! Thanks. I wouldn't have tried again without you!!!

User avatar
jmuehleisen
Joomla! Virtuoso
Joomla! Virtuoso
Posts: 4874
Joined: Thu Nov 09, 2006 2:46 pm
Location: Kampala, Uganda
Contact:

Re: Problem with PHP Version 6.0.0-dev

Postby jmuehleisen » Fri Jan 14, 2011 4:48 pm

No, alas, 5.2.17 is not enough. I got this message: 5.2.24 necessary.

Interesting. That's good to know.
But, o, marvel of all marvels, it is working today!
Wonderful! We take victory any way we can!
John Muehleisen
Visit my "Getting Started with Joomla" site, now with videos, tips, and new user tutorials:  http://welcometojoomla.com

JeDuke
Joomla! Apprentice
Joomla! Apprentice
Posts: 6
Joined: Sat Jan 24, 2009 10:35 am

Re: Problem with PHP Version 6.0.0-dev

Postby JeDuke » Fri Jan 14, 2011 5:43 pm

Something tells me it could have to do with the fact that I complained to my ISP (1and1.com) yesterday. That was quick!!!

User avatar
mbabker
Joomla! Ace
Joomla! Ace
Posts: 1588
Joined: Sun Feb 28, 2010 8:26 pm
Location: White Bear Lake, MN, USA
Contact:

Re: Problem with PHP Version 6.0.0-dev

Postby mbabker » Fri Jan 14, 2011 8:39 pm

jmuehleisen wrote:
No, alas, 5.2.17 is not enough. I got this message: 5.2.24 necessary.

Interesting. That's good to know.


Umm... There is no PHP 5.2.24. The installer lists PHP 5.2.4 as the minimum requirement. I've run locally on 5.2.13 without issue.
Past: Release Lead, CMS Maintainer
Present: Framework Maintainer, Security Team Member, .org System Administrator, Bug Squad Member

Manually updating Joomla? See https://gist.github.com/mbabker/d7bfb4e1e2fbc6b7815a733607f89281

User avatar
jmuehleisen
Joomla! Virtuoso
Joomla! Virtuoso
Posts: 4874
Joined: Thu Nov 09, 2006 2:46 pm
Location: Kampala, Uganda
Contact:

Re: Problem with PHP Version 6.0.0-dev

Postby jmuehleisen » Fri Jan 14, 2011 9:13 pm

Interesting. One of the technical requirements pages says that PHP 5.2+ is necessary, so that should probably be updated.

http://www.joomla.org/technical-requirements.html

(see the Joomla 1.6 section of this page).

But, another page definitely says 5.2.4 is required (and this page is more specifically for 1.6):

http://docs.joomla.org/Joomla_1.6_technical_requirements

So, PHP 5.2.4 is correct and my earlier posting was inaccurate.
ss-technical-requirements.jpg
You do not have the required permissions to view the files attached to this post.
John Muehleisen
Visit my "Getting Started with Joomla" site, now with videos, tips, and new user tutorials:  http://welcometojoomla.com

JeDuke
Joomla! Apprentice
Joomla! Apprentice
Posts: 6
Joined: Sat Jan 24, 2009 10:35 am

Re: Problem with PHP Version 6.0.0-dev

Postby JeDuke » Fri Jan 14, 2011 9:33 pm

mbabker wrote:
jmuehleisen wrote:
No, alas, 5.2.17 is not enough. I got this message: 5.2.24 necessary.

Interesting. That's good to know.


Umm... There is no PHP 5.2.24. The installer lists PHP 5.2.4 as the minimum requirement. I've run locally on 5.2.13 without issue.


Right, 5.2.4, this was a typo. Sorry.

aaanativearts
Joomla! Enthusiast
Joomla! Enthusiast
Posts: 201
Joined: Fri Aug 04, 2006 12:38 pm

Re: Problem with PHP Version 6.0.0-dev

Postby aaanativearts » Sun Apr 17, 2011 1:30 am

I'm running Joomla 1.6.2 on PHP 5.2.17 Not receiving any error messages. It also worked with 1.6.0 and 1.6.1


Return to “Installation Joomla! 2.5”

Who is online

Users browsing this forum: No registered users and 5 guests