The Joomla! Forum ™



Forum rules


Forum Rules
Absolute Beginner's Guide to Joomla! <-- please read before posting, this means YOU.
Forum Post Assistant - If you are serious about wanting help, you will use this tool to help you post.



Post new topic Reply to topic  [ 14 posts ] 
Author Message
 Post subject: How to remove template
PostPosted: Thu Jan 27, 2011 9:30 am 
User avatar
Joomla! Ace
Joomla! Ace

Joined: Thu Aug 18, 2005 5:50 am
Posts: 1177
Location: Amsterdam
Since we need to install templates in 1.6 (in 1.0 and 1.5 I uploaded them with FTP), I expect I can uninstall a template. How can I do this?

_________________
http://www.tastymouse.com/


Top
 Profile  
 
PostPosted: Thu Jan 27, 2011 12:06 pm 
Joomla! Hero
Joomla! Hero

Joined: Sun Jun 25, 2006 12:12 am
Posts: 2855
Location: Salisbury, NC/USA (N. of Charlotte)
Go to template manager and make sure the template to be removed in NOT the default.

Select the template and hit the delete icon, to right.

_________________
http://www.200mphMedia.net
Author: Joomla 1.6 Picture Yourself Series book @ Amazon.com
Book also covers Version 1.7, 2.5, which had no notable/major user-side changes.


Top
 Profile  
 
PostPosted: Thu Jan 27, 2011 12:39 pm 
User avatar
Joomla! Ace
Joomla! Ace

Joined: Thu Aug 18, 2005 5:50 am
Posts: 1177
Location: Amsterdam
That gives the error: Cannot delete last style of a template. The delete button only shows with the Styles tab, not with the Template tab

_________________
http://www.tastymouse.com/


Top
 Profile  
 
PostPosted: Thu Jan 27, 2011 1:13 pm 
User avatar
I've been banned!

Joined: Sun Dec 19, 2010 1:26 am
Posts: 602
Location: Slovakia, Bratislava
you need to make default another template default style, then you go to extension manager - manage and you can uninstall template like in 1.5 ... but you need another one to set as default style

_________________
I m Rebel ...


Top
 Profile  
 
PostPosted: Thu Jan 27, 2011 1:38 pm 
User avatar
Joomla! Ace
Joomla! Ace

Joined: Thu Aug 18, 2005 5:50 am
Posts: 1177
Location: Amsterdam
I understand how it should work, but it doesn't. It may be a bug, I'll try it another time. For now I have removed the Style with phpMyAdmin.

Thanks, Tom

_________________
http://www.tastymouse.com/


Top
 Profile  
 
PostPosted: Thu Jan 27, 2011 1:42 pm 
User avatar
I've been banned!

Joined: Sun Dec 19, 2010 1:26 am
Posts: 602
Location: Slovakia, Bratislava
what is your problem ? that when you want to uninstall it says ... you can not delete last style ? Do you have another style there makred '' default '' ? check it again

_________________
I m Rebel ...


Top
 Profile  
 
PostPosted: Thu Jan 27, 2011 2:59 pm 
User avatar
Joomla! Ace
Joomla! Ace

Joined: Thu Aug 18, 2005 5:50 am
Posts: 1177
Location: Amsterdam
Yes I had another Style marked Default (Atomic).

_________________
http://www.tastymouse.com/


Top
 Profile  
 
PostPosted: Thu Jan 27, 2011 3:05 pm 
Joomla! Apprentice
Joomla! Apprentice

Joined: Thu Jan 13, 2011 8:08 pm
Posts: 30
Go to extension manager ... click "manage Extensions" ... you will see ALL of your various templates, plugins, extensions, etc. listed.

Tick your template - then in the upper right click 'Uninstall'


Top
 Profile  
 
PostPosted: Thu Jan 27, 2011 3:25 pm 
User avatar
Joomla! Ace
Joomla! Ace

Joined: Thu Aug 18, 2005 5:50 am
Posts: 1177
Location: Amsterdam
Yes, that's the way it works :).

Thanks, Tom
(being a beginner again feels somewhat strange, but I do like 1.6 :))

_________________
http://www.tastymouse.com/


Top
 Profile  
 
PostPosted: Sun Jan 30, 2011 3:17 pm 
Joomla! Apprentice
Joomla! Apprentice

Joined: Tue Apr 24, 2007 5:29 pm
Posts: 23
Also found your tip helpful, BUT, they still show up in the template manager. They are all called 'Default" in the title but I have only one set as the site default. I REALLY don't want a bunch of templates that I will not be using to be taking up space in my template manager page. They are useless junk at this point. Thanks.


Top
 Profile  
 
PostPosted: Sun Jan 30, 2011 8:24 pm 
Joomla! Fledgling
Joomla! Fledgling

Joined: Sun Jan 30, 2011 8:17 pm
Posts: 4
Location: Near Geneva
Well,

I did exactly like you , and everyithing is fine.
I still think we should be able to remove them from the 'manage templates' location, but, as long as it works...
Best regards,
Franck


Top
 Profile  
 
PostPosted: Mon Jan 31, 2011 1:34 am 
User avatar
Joomla! Intern
Joomla! Intern

Joined: Thu Oct 14, 2010 5:10 am
Posts: 52
Location: Rangpur,Bangladesh
thanks for share.

_________________
http://www.jotiprokash.com << JotiProkash.com
http://RangpurLive.com << RangpurLive.com


Top
 Profile  
 
PostPosted: Mon Jan 31, 2011 10:32 am 
Joomla! Apprentice
Joomla! Apprentice

Joined: Mon Feb 02, 2009 8:19 pm
Posts: 45
Thank you, I have had the same problem and finally I can solve it!!!


Top
 Profile  
 
PostPosted: Sun Feb 13, 2011 2:57 am 
Joomla! Fledgling
Joomla! Fledgling

Joined: Sun Feb 13, 2011 2:52 am
Posts: 1
TomT wrote:
I understand how it should work, but it doesn't. It may be a bug, I'll try it another time. For now I have removed the Style with phpMyAdmin.

Thanks, Tom



Hey Tom! Thanks for the tip. While this may be a workaround for 1.6 it works, and that's what matters to me!


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 14 posts ] 



Who is online

Users browsing this forum: No registered users and 36 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Jump to:  
Powered by phpBB® Forum Software © phpBB Group