The Joomla! Forum ™






Post new topic Reply to topic  [ 56 posts ]  Go to page Previous  1, 2
Author Message
PostPosted: Mon Aug 23, 2010 4:44 pm 
Joomla! Apprentice
Joomla! Apprentice

Joined: Sun Nov 15, 2009 9:14 pm
Posts: 31
I'm not good at this at all, but I can remember something about changing in the site settings so that the site engine understands that the site is located in a subfolder....


Top
 Profile  
 
PostPosted: Thu Nov 25, 2010 1:12 am 
Joomla! Apprentice
Joomla! Apprentice

Joined: Fri Aug 01, 2008 2:37 am
Posts: 5
After many trial and error I had no luck with most suggestions in here. I got it mine to work with SEF URL ON and Apache Rewrite OFF. Then I renamed the htaccess.txt to .htaccess and mine worked fine after that.


Top
 Profile  
 
PostPosted: Sat Dec 04, 2010 11:24 am 
Joomla! Fledgling
Joomla! Fledgling

Joined: Fri Dec 03, 2010 10:00 am
Posts: 2
Even i have installed the component for Search Engine Friendly URL but its still not working its open the link but template don't work except for main page.
my site is http://startyourbiblecollege.com


Top
 Profile  
 
PostPosted: Tue Dec 07, 2010 6:17 am 
Joomla! Apprentice
Joomla! Apprentice

Joined: Fri Aug 01, 2008 2:37 am
Posts: 5
I managed to get this to work. On some servers the default is correct. But for some, you have to do a few things (apache and some versions of xampp, for example). Depending on your version of Apache you just have to change the htaccess file to .htaccess only, on some you have to turn on apache rewrite only, and on the rest you have to do both. Just make sure if you rename your htaccess, make sure no other file that has it in the name (rename, delete, or move to a folder if you want to keep a backup)


Top
 Profile  
 
PostPosted: Thu Dec 23, 2010 4:24 am 
Joomla! Fledgling
Joomla! Fledgling

Joined: Thu Dec 23, 2010 4:13 am
Posts: 1
I installed my Joomla site in a subfolder and finally managed to get the SEO search engine friendly URL feature work. Here's what I did.

In the global configuration:

Search Engine Friendly URL -> YES
Use Apache mod_rewrite -> YES

Suppose I have installed my site in "www/foo" where "www" is the web root.
I renamed htaccess.txt to .htacces. It is www/foo/.htaccess. And editted .htacces:

Comment out following line
#Options +FollowSymLinks

Uncomment following line and add your subfolder name like this
RewriteBase /foo

That's all there is to it. Now I get clean URLs :D

yoshi


Top
 Profile  
 
PostPosted: Fri Jan 14, 2011 3:24 pm 
Joomla! Apprentice
Joomla! Apprentice

Joined: Sat Sep 26, 2009 2:05 pm
Posts: 23
I am having this problem too. When Apache mod_rewrite & Search Engine Friendly URLs are both checked as on, I get a Not found 404 message.

I went and renamed the htaccess.txt file to .htaccess... I did this thru the C-Panel file manager (was that right?)

But still having this problem.
Have no idea how to re-write any insider files, like the htacces file... what do I do?

Funny thing is I had this problem with my first website, and in the end gave up trying to sort it out. But then somehow it changed all by itself at some stage to accept the SEF URLs.. and I have no idea how that happened.


Top
 Profile  
 
PostPosted: Fri Jan 14, 2011 8:22 pm 
Joomla! Apprentice
Joomla! Apprentice

Joined: Wed Nov 24, 2010 8:04 pm
Posts: 21
davetanguay wrote:
Turn on "Use Apache mod_rewrite" within the Joomla Global Config. Then rename the htaccess.txt file in your web directory to .htaccess


I have done this but it makes no difference. (of course I am also selecting Search Engine Friendly URLs).

People speak of the plugin but which plugin? I have just taken over management of my site so I'm not sure what might or might not be installed. I have found http://www.artio.net/joomla-extensions/joomsef but when you get to the download section there are 35 different programs to load all called joomsef. Which ones do I need? Is this even the right plugin?

Thanks for any help.


Top
 Profile  
 
PostPosted: Sat Jan 15, 2011 6:26 am 
Joomla! Fledgling
Joomla! Fledgling

Joined: Sat Jan 15, 2011 6:15 am
Posts: 2
I used it and my site was in a subfolder I acticated the three options for search friendly urls in the joomla admin global config and then changed the name of the htaccess file from htaccess.txt to .htaccess this file is perhaps inactive until changed.


info:

PHP Built on: Linux 2010 i686
Database Version: 5.0.91-log
PHP Version: 5.2.14
Web Server: Apache
Web Server to PHP interface: cgi-fcgi
Joomla! Version: Joomla! 1.5.22 Stable [ senu takaa ama woi ] 04-November-2010 18:00 GMT
User Agent: Mozilla/4.0 (compatible; MSIE 8.0; Windows NT 5.1; Trident/4.0; .NET CLR 1.1.4322; .NET CLR 2.0.50727; .NET CLR 3.0.4506.2152; .NET CLR 3.5.30729; .NET4.0C; .NET4.0E)


Top
 Profile  
 
PostPosted: Sat Jan 15, 2011 6:29 am 
Joomla! Fledgling
Joomla! Fledgling

Joined: Sat Jan 15, 2011 6:15 am
Posts: 2
http://www.scribd.com/doc/2300167/Jooml ... t-SEF-URLs


Top
 Profile  
 
PostPosted: Sun Jan 16, 2011 3:07 am 
Joomla! Apprentice
Joomla! Apprentice

Joined: Sat Sep 26, 2009 2:05 pm
Posts: 23
lukechrisco wrote:
http://www.scribd.com/doc/2300167/Joomla-v-15-Configure-and-troubleshoot-SEF-URLs


Thank you for that link, it looks informative but I can't completely load their page and there is no template (LOL). Have been trying to load it now since yesterday.
When it gets to here <<<If you get “404 page not found” or “Error 500 – Internal Server Error” errors, read on for additional configuration and troubleshooting information.>>> ...
which is the part I need - I can't make anything out after that.

But there must be a simple answer for this problem. Because with my first website it drove me crazy, changing all sorts of things but I couldn't get SEF to work and I finally gave up. Then at some stage it changed and SEF works perfectly when turned on... and I have no idea why.

I did not change anything inside the htaccess.txt file as I don't have enough knowledge to do that, and I never changed the name, it is still named htaccess.txt and now the SEF works. I have no idea what changed.

Is there anywhere that has REALLY easy step-by-step instructions on how to change the text inside the htaccess file? All of what I have found goes way over my head, and I don't even know where to go to make the changes recommended.


Top
 Profile  
 
PostPosted: Wed Jan 26, 2011 7:56 am 
Joomla! Apprentice
Joomla! Apprentice

Joined: Sat Sep 26, 2009 2:05 pm
Posts: 23
renaming htaccess.file???
Hi, I am pretty much a newbie and really struggling with my Joomla site and SEF URL's.
So to get the apache rewrite to work, apparently I need to change the name of the htaccess.txt file to .htaccess.
OK, I did this thru cPanel, by clicking on the file and choosing rename.
But a file is still there named as the original htaccess.txt and I can’t see the new .htaccess... so I tried to rename it again and it said there was already a file with this name... but I cannot see it.
And now in the ACE SEF extension, it now tells me there is a problem with my .htaccess file.
Am I not actually able to rename this file thru cPanel?
And if not, exactly how do I go about it please?


Top
 Profile  
 
PostPosted: Thu Feb 03, 2011 1:21 pm 
Joomla! Apprentice
Joomla! Apprentice

Joined: Fri Nov 21, 2008 8:17 pm
Posts: 24
Location: MarylandUSA
thanks it worked perfectly, it took a minute to kick in.


Top
 Profile  
 
PostPosted: Thu Feb 10, 2011 6:07 am 
Joomla! Apprentice
Joomla! Apprentice

Joined: Wed Mar 03, 2010 1:16 am
Posts: 8
i have done all the above and i get this near the menu bar
Warning: implode() [function.implode]: Invalid arguments passed in /home/mychatne/public_html/includes/router.php on line 325

why is that happening?


Top
 Profile  
 
PostPosted: Fri Mar 25, 2011 5:37 am 
Joomla! Fledgling
Joomla! Fledgling

Joined: Fri Mar 25, 2011 5:31 am
Posts: 3
One thing I have not seen here. If you created your Joomla in a subfolder and then copied it to the main folder, change the htaccess.txt in the subfolder you originally created it in to .htaccess AND before you change it upload it into your public_html folder as well. THEN change that one to .htacess as well. Before doing that I changed the existing one to htaccessold.txt

This was driving me nuts but it worked out in the end


Top
 Profile  
 
PostPosted: Fri Apr 15, 2011 4:18 am 
Joomla! Fledgling
Joomla! Fledgling

Joined: Fri Dec 24, 2010 8:27 pm
Posts: 2
Hello Guys,
I'm getting a blank page when I go to my webpage www.curriculumpanama.com when TURN ON the SEF ON.
I've also change the .htaccess.txt to .htaccess
I've also uncommented this line from the .htaccess file "RewriteBase /"

With all these changes, I'm still getting a blank page.

What do you recommend?

_________________
Regards,
angel110785


Top
 Profile  
 
PostPosted: Thu May 26, 2011 10:56 pm 
Joomla! Apprentice
Joomla! Apprentice

Joined: Thu Mar 24, 2011 10:42 am
Posts: 10
I am using: Joomla 1.6.3

Hi all, I am having problems with my google analytics so I thought that the problem was that I didn´t have enabled the "Search engine friendly URL´s", am I correct? I mean, this could be a reason for google analytics not working?. On my google analytics overviw page It is shown the warning message meaning that it have not been correctly implemented.

Well, the thing is that after I enabled "Search engine friendly URL´s" all my page links were broken (the main page still works) and this message was shown:
Not Found

The requested URL /nuestras-bases was not found on this server.

Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.

Apache Server at piruletascanarias.com Port 80


This is how my global configuration is set:

Search Engine Friendly URLs - Yes
Use URL rewriting - Yes
Adds Suffix to URL - No

I´ve looked over the internet and followed this steps: http://docs.joomla.org/How_to_check_if_ ... our_server
(after I renamed the file to .htaccess the file disappeared on my ftp, is this normal?)

I made the example test and it redirected me to joomla.org, so I figured that it was working OK.

But I am still having problems and getting the error mentioned at the beginning, so hope you can help me figured this out.

Thanks!

Juan


Top
 Profile  
 
PostPosted: Wed Jun 15, 2011 2:30 pm 
Joomla! Fledgling
Joomla! Fledgling

Joined: Sun Dec 20, 2009 4:48 pm
Posts: 3
this fix worked perfect for my site as well. thanks!


Top
 Profile  
 
PostPosted: Tue Sep 27, 2011 3:45 pm 
Joomla! Apprentice
Joomla! Apprentice

Joined: Wed Jul 15, 2009 3:48 pm
Posts: 6
Location: Salt Lake City, Utah
[deleted double post]


Last edited by utahdiabetes on Tue Sep 27, 2011 3:47 pm, edited 1 time in total.

Top
 Profile  
 
PostPosted: Tue Sep 27, 2011 3:46 pm 
Joomla! Apprentice
Joomla! Apprentice

Joined: Wed Jul 15, 2009 3:48 pm
Posts: 6
Location: Salt Lake City, Utah
nodayoshikazu wrote:
I installed my Joomla site in a subfolder and finally managed to get the SEO search engine friendly URL feature work. Here's what I did.

In the global configuration:

Search Engine Friendly URL -> YES
Use Apache mod_rewrite -> YES

Suppose I have installed my site in "www/foo" where "www" is the web root.
I renamed htaccess.txt to .htacces. It is www/foo/.htaccess. And editted .htacces:

Comment out following line
#Options +FollowSymLinks

Uncomment following line and add your subfolder name like this
RewriteBase /foo

That's all there is to it. Now I get clean URLs :D

yoshi


My joomla site is in a subfolder, and I was very glad to see you had success. So far I've tried your method and it's not working. I've tried different combinations of these steps too.


Top
 Profile  
 
PostPosted: Thu Oct 20, 2011 10:34 pm 
Joomla! Apprentice
Joomla! Apprentice

Joined: Tue Apr 21, 2009 6:37 am
Posts: 12
I also have my joomla installed in a subfolder, have followed the advice in this thread and cannot get my SEF URLs working correctly. Other than the homepage, all my pages return a 500 error.


Top
 Profile  
 
PostPosted: Thu Oct 20, 2011 11:29 pm 
Joomla! Apprentice
Joomla! Apprentice

Joined: Tue Apr 21, 2009 6:37 am
Posts: 12
bashmentyard wrote:
this htaccess.txt code below worked for me, just copy and paste, save as htaccess.txt, upload to server, rename to .htaccess, THEN go into global config in Joomla and turn the THREE SEO settings on. hope it provides an option for someone.





##
# @version $Id: htaccess.txt 423 2005-10-09 18:23:50Z stingrey $
# @package Joomla
# @copyright Copyright (C) 2005 Open Source Matters. All rights reserved.
# @license http://www.gnu.org/copyleft/gpl.html GNU/GPL
# Joomla! is Free Software
##

#
# mod_rewrite in use
#

RewriteEngine On

# Uncomment following line if your webserver's URL
# is not directly related to physical file paths.
# Update YourJoomlaDirectory (just / for root)

RewriteBase /

#
# Rules
#

RewriteCond %{REQUEST_FILENAME} !\.(jpg|jpeg|gif|png|css|js|pl|txt)$
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule ^(.*) index.php


That did it. Victory! Thank you so much. The Joomla community rocks.


Top
 Profile  
 
PostPosted: Thu Apr 12, 2012 3:40 pm 
Joomla! Apprentice
Joomla! Apprentice

Joined: Tue Jun 09, 2009 9:16 am
Posts: 21
bashmentyard wrote:
this htaccess.txt code below worked for me, just copy and paste, save as htaccess.txt, upload to server, rename to .htaccess, THEN go into global config in Joomla and turn the THREE SEO settings on. hope it provides an option for someone.





##
# @version $Id: htaccess.txt 423 2005-10-09 18:23:50Z stingrey $
# @package Joomla
# @copyright Copyright (C) 2005 Open Source Matters. All rights reserved.
# @license http://www.gnu.org/copyleft/gpl.html GNU/GPL
# Joomla! is Free Software
##

#
# mod_rewrite in use
#

RewriteEngine On

# Uncomment following line if your webserver's URL
# is not directly related to physical file paths.
# Update YourJoomlaDirectory (just / for root)

RewriteBase /

#
# Rules
#

RewriteCond %{REQUEST_FILENAME} !\.(jpg|jpeg|gif|png|css|js|pl|txt)$
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule ^(.*) index.php


Working. Great post. Should be a sticky :)

Thank you very much.


Top
 Profile  
 
PostPosted: Tue Dec 18, 2012 10:42 pm 
Joomla! Apprentice
Joomla! Apprentice

Joined: Sun Dec 12, 2010 12:07 am
Posts: 19
Hello All!

Thanks in advance for your assistance on this issue.

A client of mine has a Joomla 2.5 website and I am trying to enable the SEF URL structure. I followed the suggestion by renaming my file from htaccess.txt -> .htaccess, upon renaming the file I went to the back end and toggled the 3 settings to Yes under the global configuration:
- Search Engine Friendly URLs
- Use URL rewriting
- Adds Suffix to URL

This did not work. Then I noticed the clients site is setup as follows, http://www.polygonhomes.com/polygon/ so I inputted the '/polygon/' into the htaccess.txt file in the RewriteBase /polygon/. Reuploaded the .txt file and renamed to .htaccess and still the SEF URLs were a no go.

I am not sure what the problem is, however, I also have a component, iProperty, that will need their URLs to be SEF as well.

Stuck and don't know what to do.

Attached is the .txt file for your reference.

Any help would be greatly appreciated, cheers Andrew.


You do not have the required permissions to view the files attached to this post.


Top
 Profile  
 
PostPosted: Wed Dec 19, 2012 8:59 am 
Joomla! Apprentice
Joomla! Apprentice

Joined: Mon Jan 24, 2011 5:48 pm
Posts: 28
Check your web server if is apache or iis ?
.htaccess working on apache web servers

_________________
ParsMizban http://parsmizban.com


Top
 Profile  
 
PostPosted: Wed Dec 19, 2012 4:56 pm 
Joomla! Apprentice
Joomla! Apprentice

Joined: Sun Dec 12, 2010 12:07 am
Posts: 19
Thanks pars_mizban for the reply, the server is Apache.


Top
 Profile  
 
PostPosted: Sat Mar 30, 2013 11:08 pm 
Joomla! Fledgling
Joomla! Fledgling

Joined: Sat Mar 30, 2013 11:01 pm
Posts: 1
Following codes worked for me in .htaccess
I have tried all but nothing was working. Also called godaddy and they told me the mod_rewrite is on by default. Anyway, i am happy and just like to confirm others that just paste these codes into new text file, name it .htaccess, upload to your server and you will be happy one like me. see the site working with good keywords in url at http://www.labaiktours.com. Thanks bashmentyard for your help.

##
# @version $Id: htaccess.txt 423 2005-10-09 18:23:50Z stingrey $
# @package Joomla
# @copyright Copyright (C) 2005 Open Source Matters. All rights reserved.
# @license http://www.gnu.org/copyleft/gpl.html GNU/GPL
# Joomla! is Free Software
##

#
# mod_rewrite in use
#

RewriteEngine On

# Uncomment following line if your webserver's URL
# is not directly related to physical file paths.
# Update YourJoomlaDirectory (just / for root)

RewriteBase /

#
# Rules
#

RewriteCond %{REQUEST_FILENAME} !\.(jpg|jpeg|gif|png|css|js|pl|txt)$
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule ^(.*) index.php


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 56 posts ]  Go to page Previous  1, 2



Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Jump to:  
Powered by phpBB® Forum Software © phpBB Group