TinyMCE and JCE Editors Not Showing Toolbar Icons

This forum is for general questions about extensions for Joomla! version 1.5.x.

Moderator: General Support Moderators

Forum rules
Forum Rules
Absolute Beginner's Guide to Joomla! <-- please read before posting, this means YOU.
Forum Post Assistant - If you are serious about wanting help, you will use this tool to help you post.
Bassman1956
Joomla! Fledgling
Joomla! Fledgling
Posts: 4
Joined: Thu Oct 29, 2009 9:45 pm

TinyMCE and JCE Editors Not Showing Toolbar Icons

Postby Bassman1956 » Fri Oct 30, 2009 2:00 pm

I recently developed a Joomla 1.5 site for a client who is unable to edit her articles in WYSIWYG view. This is true not only for TinyMCE, but also for the JCE editor. When I log in to the back-end control panel and pull up her articles to edit from my computer at my office, all the icons are there. Everything works smoothly.

I actually went to her office with my laptop to troubleshoot the problem, thinking it might be a network or firewall issue, or that she simply was doing something wrong. I hooked up to their internet connection and brought up their web site. Lo and behold, I was not able to view the WYSIWYG buttons either. I tried both editors (JCE and TinyMCE).

Next I tried bringing up two other other Joomla web sites I've developed on their internet connection. The text editors worked flawlessly.

Any ideas on what could be wrong?

Rick

mbarefield
Joomla! Apprentice
Joomla! Apprentice
Posts: 14
Joined: Sat Oct 27, 2007 8:14 pm

Re: TinyMCE and JCE Editors Not Showing Toolbar Icons

Postby mbarefield » Sun Nov 01, 2009 4:10 pm

I awoke this morning to find exactly the same problem. I hope someone can address is quickly. None of the editors work and html code is displayed in the window. You cannot save or apply any changes, either.

cms_newb
Joomla! Apprentice
Joomla! Apprentice
Posts: 13
Joined: Wed Sep 24, 2008 11:42 pm

Re: TinyMCE and JCE Editors Not Showing Toolbar Icons

Postby cms_newb » Sat Nov 07, 2009 2:49 am

I just noticed something similar...see this post
viewtopic.php?f=428&t=458141

TinyMCE chosen as editor but icons disappeared. I had to go to Extensions > plugin manager > editor - tinymce 2.0 > THEN I changed functionality from 'advanced' to 'extended' to get the toolbars back esp. font color.

:(

User avatar
Drible
Joomla! Apprentice
Joomla! Apprentice
Posts: 22
Joined: Wed May 31, 2006 7:18 pm
Location: Northernmost town in the world

Re: TinyMCE and JCE Editors Not Showing Toolbar Icons

Postby Drible » Mon Nov 09, 2009 10:02 am

I just did that after an upgrading to 1.5.15 , and no the "read more" and "image" button is not working anymore...

I`m using Tiny MCE 2.0

Anyone know how to fix, please?
Nowadays most people die of a sort of creeping common sense, and discover only when it is too late that the only things you will never regret, it's your own errors.

pajata
Joomla! Fledgling
Joomla! Fledgling
Posts: 1
Joined: Fri Apr 09, 2010 9:28 pm

Re: TinyMCE and JCE Editors Not Showing Toolbar Icons

Postby pajata » Fri Apr 09, 2010 10:04 pm

cms_newb wrote:I just noticed something similar...see this post
viewtopic.php?f=428&t=458141

TinyMCE chosen as editor but icons disappeared. I had to go to Extensions > plugin manager > editor - tinymce 2.0 > THEN I changed functionality from 'advanced' to 'extended' to get the toolbars back esp. font color.

:(


Thank you, thank you, thank you .... saved me posting a question and waiting for the answer ;D

ptran38
Joomla! Fledgling
Joomla! Fledgling
Posts: 1
Joined: Fri Dec 08, 2006 10:23 pm

Re: TinyMCE and JCE Editors Not Showing Toolbar Icons

Postby ptran38 » Mon May 31, 2010 5:06 pm

Try turning off TinyMCE. It works for me.

nruber
Joomla! Apprentice
Joomla! Apprentice
Posts: 10
Joined: Mon Jul 05, 2010 7:59 am

Re: TinyMCE and JCE Editors Not Showing Toolbar Icons

Postby nruber » Mon Jul 05, 2010 8:08 am

I have same issue but I don't have the extended option. How do I get that to come up?

User avatar
cryogen
Joomla! Apprentice
Joomla! Apprentice
Posts: 18
Joined: Tue Jun 12, 2007 2:48 pm
Contact:

Re: TinyMCE and JCE Editors Not Showing Toolbar Icons

Postby cryogen » Thu Jul 08, 2010 2:02 am

Check what you have in configuration.php file for the live site path param. If it has www prefix, you should use the http://WWW.yousite.com/administrator/ calls.
http://www.eximdesign.com - Web design and graphic design services in New York | Portland | Seattle | Toronto

nruber
Joomla! Apprentice
Joomla! Apprentice
Posts: 10
Joined: Mon Jul 05, 2010 7:59 am

Re: TinyMCE and JCE Editors Not Showing Toolbar Icons

Postby nruber » Thu Jul 08, 2010 10:50 am

I have modified the configuration.php file as you suggested and it still isn't showing the extended.
I am just trying to get the tinyMCE editor to show up it used to work and from some reason it stopped working. Any other ideas woudl reinstalling it work and if yes what is the best way of doing it.

Onglai
Joomla! Apprentice
Joomla! Apprentice
Posts: 7
Joined: Thu Jul 08, 2010 4:44 am

Re: TinyMCE and JCE Editors Not Showing Toolbar Icons

Postby Onglai » Sat Jul 10, 2010 7:17 pm

Hi,

Try refreshing the page.

In Chrome, I press and hold the Shift button and click the reload button on the browser, or just reload the page. And all those extra buttons appear! I need to do this every time. It is an issue with Chrome.

No issue with Firefox or IE.

Thank you

Onglai

nruber
Joomla! Apprentice
Joomla! Apprentice
Posts: 10
Joined: Mon Jul 05, 2010 7:59 am

Re: TinyMCE and JCE Editors Not Showing Toolbar Icons

Postby nruber » Sun Jul 11, 2010 4:30 am

Thanks, but that didn't work either. I have noticed that I get this error message on the article edit page whenever I am trying to save. Webpage error details

User Agent: Mozilla/4.0 (compatible; MSIE 8.0; Windows NT 6.1; WOW64; Trident/4.0; GTB6.5; SLCC2; .NET CLR 2.0.50727; Media Center PC 6.0; OfficeLiveConnector.1.5; OfficeLivePatch.1.3; .NET4.0C; .NET CLR 3.5.30729; .NET CLR 3.0.30729)
Timestamp: Sun, 11 Jul 2010 04:28:33 UTC

Message: Expected '}'
Line: 1
Char: 15493
Code: 0
URI: http://www.achievenow.com.au/plugins/ed ... iny_mce.js


Message: 'tinyMCE' is undefined
Line: 102
Char: 4
Code: 0
URI: http://www.achievenow.com.au/administra ... k=edit&cid []=18


Message: 'tinyMCE' is undefined
Line: 307
Char: 4
Code: 0
URI: http://www.achievenow.com.au/administra ... k=edit&cid []=18

Onglai
Joomla! Apprentice
Joomla! Apprentice
Posts: 7
Joined: Thu Jul 08, 2010 4:44 am

Re: TinyMCE and JCE Editors Not Showing Toolbar Icons

Postby Onglai » Sun Jul 11, 2010 5:17 am

Hi,

Attached image shows my setting for the TinyMCE, and all options in the Advance Parameters are either turn to On or Show, except for the template option.

And I have Joomla 1.5.18 installed.

With the above set up, TinyMCE is working fine or me. If you are using Chrome browser , than you need to refresh the page (the Wysiwyg Editor page) to see the extra buttons.

Thank you
You do not have the required permissions to view the files attached to this post.

nruber
Joomla! Apprentice
Joomla! Apprentice
Posts: 10
Joined: Mon Jul 05, 2010 7:59 am

Re: TinyMCE and JCE Editors Not Showing Toolbar Icons

Postby nruber » Tue Jul 20, 2010 1:43 am

Thanks for that. I tried a couple of things including installing on a test location version 1.5.18 of Joomla, with that version I am getting the toolbars and I noticed that the difference is that I am using TinyMCE 2.0 in the version that doesn't work and I think that is why I am not seeing the extended option. Does anyone know what is the difference between tinyMCE and tinyMCE 2.0? HOw can I switch to tinyMCE?

william07
Joomla! Fledgling
Joomla! Fledgling
Posts: 2
Joined: Fri Feb 19, 2010 11:32 am
Location: 3 Locust Street, Suite A Assonet, MA 02702
Contact:

Re: TinyMCE and JCE Editors Not Showing Toolbar Icons

Postby william07 » Thu Jul 22, 2010 1:23 pm

Well I also have the same kind of problem in my recent designs . I think its a big problem & needs to be resolved as soon as possible . Any kind suggestions are welcome
See Signature rules: viewtopic.php?f=8&t=65

everfree
Joomla! Fledgling
Joomla! Fledgling
Posts: 1
Joined: Tue Jan 12, 2010 5:36 am

Re: TinyMCE and JCE Editors Not Showing Toolbar Icons

Postby everfree » Sat Jul 24, 2010 1:09 pm

Under the editing box there should be a Toggle editor button.

User avatar
ageofknowledge
Joomla! Apprentice
Joomla! Apprentice
Posts: 12
Joined: Sun Oct 24, 2010 5:11 am

Re: TinyMCE and JCE Editors Not Showing Toolbar Icons

Postby ageofknowledge » Sat Nov 06, 2010 5:57 pm

I have the exact same problem. Here's what it looks like:

http://i255.[spam].com/albums/hh14 ... joomla.jpg

Go Daddy support said they can see all the icons in the editor fine. We tried different computers with different browsers on my end, clearing all cache and settings in browsers, etc... but nothing worked.

I've uninstalled and reinstalled. They said all the files are correct. Nothing is corrupt. Anyone propose a solution?
The glass is always 1/2 empty.

User avatar
ageofknowledge
Joomla! Apprentice
Joomla! Apprentice
Posts: 12
Joined: Sun Oct 24, 2010 5:11 am

Re: TinyMCE and JCE Editors Not Showing Toolbar Icons

Postby ageofknowledge » Sat Nov 06, 2010 6:48 pm

After installing JCE it looks like this:

http://i255.[spam].com/albums/hh14 ... owing1.jpg

Here's the default group layout. Looks fine!

http://i255.[spam].com/albums/hh14 ... layout.jpg

So why is everything configured right but the JCE or Tinymce plugins not showing up in the editor interface in article manager?
The glass is always 1/2 empty.

User avatar
ageofknowledge
Joomla! Apprentice
Joomla! Apprentice
Posts: 12
Joined: Sun Oct 24, 2010 5:11 am

Re: TinyMCE and JCE Editors Not Showing Toolbar Icons

Postby ageofknowledge » Sat Nov 06, 2010 7:18 pm

I FOUND the problem. The problem, and you'll want to make a note of this one, was that OPEN DNS's Family Shield was screening them out somehow. As soon as I went into my firewall and stopped blocking keywords and set it to pull DNS servers from my ISP instead of OPEN DNS the JCE and Tinymce plugin icons showed up on the interface under Article Manager just fine. So it was either the Open DNS blocking configurations I had set or one of the keywords.
The glass is always 1/2 empty.

Jack Viljoen
Joomla! Fledgling
Joomla! Fledgling
Posts: 1
Joined: Thu Nov 11, 2010 3:23 pm

Re: TinyMCE and JCE Editors Not Showing Toolbar Icons

Postby Jack Viljoen » Thu Nov 11, 2010 3:38 pm

Hi there ageofknowledge,

Glad you found the problem with JCE. I am pulling my hair out. I am new to Joomla! so please could you explain want you did in layman's terms.

Thanks,

Jack.

User avatar
StJohnsLutheran
Joomla! Fledgling
Joomla! Fledgling
Posts: 2
Joined: Mon May 24, 2010 7:31 pm

Re: TinyMCE and JCE Editors Not Showing Toolbar Icons

Postby StJohnsLutheran » Thu Nov 11, 2010 3:46 pm

Same problem on front end only (it started happening after the last Joomla Update). Tried all the fixes suggest, nothing.
Finally I removed JCE and TinyMCE toolbar came up on the front end. Reinstalled JCE with the updated version and the toolbar disappeared again. Argh...

Joomla 1.5.22
JCE 1.5.7.5

MtnHermit
Joomla! Enthusiast
Joomla! Enthusiast
Posts: 205
Joined: Tue Oct 12, 2010 5:05 pm
Location: Colorado

Re: TinyMCE and JCE Editors Not Showing Toolbar Icons

Postby MtnHermit » Tue Nov 30, 2010 7:20 pm

cms_newb wrote:I just noticed something similar...see this post
viewtopic.php?f=428&t=458141

TinyMCE chosen as editor but icons disappeared. I had to go to Extensions > plugin manager > editor - tinymce 2.0 > THEN I changed functionality from 'advanced' to 'extended' to get the toolbars back esp. font color. :(

Just installed the JCE editor and it wouldn't display, changing TinyMCE from advanced to extended seems to fix the problem.

Who'd thunk? :)

Thanks

jikanv
Joomla! Apprentice
Joomla! Apprentice
Posts: 15
Joined: Sat Oct 30, 2010 6:48 pm

Re: TinyMCE and JCE Editors Not Showing Toolbar Icons

Postby jikanv » Fri Jan 14, 2011 6:55 pm

I have the same issue. TinyMCE was working for a while but than stopped showing the toolbar altogether in any mode, (advanced or extended or basic) So I've installed JCE and that was working for about two tries and stopped showing the toolbar altogether. Installed JCK and worked for about a minute than stopped showing the toolbar all together.

None of them are showing the toolbar at all. No front end and no back end.
I am using Joomla 1.5.22 which is the newest before 1.6. I am also using the Rhuk_milkyway template. I am on localhost right now.

I had uninstalled and re-installed them again but no success. I had cleaned the Joomla cache and the browser cache.

TinyMCE basic shows the toggle button at the bottom left corner and when I click on that it brings up the 6 basic icons below the editor window. That's the only one that has any kinds of response.

Did anyone else had this thing? Thanx for the help if someone know the answer.

Cemoy
Joomla! Fledgling
Joomla! Fledgling
Posts: 1
Joined: Thu Feb 17, 2011 2:43 pm

Re: TinyMCE and JCE Editors Not Showing Toolbar Icons

Postby Cemoy » Thu Feb 17, 2011 3:39 pm

I have the same issue, I installed joomla 1.5.22 and JCE because i have Authors registered and they need to load files on server.

Concerning JCE, I have no toggle and a javascript error: tinyMCE IS UNDEFINED.

I have no toggle with others editors too.

Only tinyMCE works.

SandN
Joomla! Apprentice
Joomla! Apprentice
Posts: 21
Joined: Tue Sep 14, 2010 6:26 pm

Re: TinyMCE and JCE Editors Not Showing Toolbar Icons

Postby SandN » Sat Feb 19, 2011 8:48 pm

OH MY GOSH!!! So much jargon! Does anyone out there speak simple layman's language. So many potential solutions. I don't know what to do. Just a realtor trying to update my own website.

SandN
Joomla! Apprentice
Joomla! Apprentice
Posts: 21
Joined: Tue Sep 14, 2010 6:26 pm

Re: TinyMCE and JCE Editors Not Showing Toolbar Icons

Postby SandN » Mon Feb 21, 2011 2:31 pm

Help....... Cannot figure this one out. Not even sure how to get to some of the places the techie minds in this thread have gone one their sites. Sorry to be so lame, just frustrated!

pymoo
Joomla! Fledgling
Joomla! Fledgling
Posts: 1
Joined: Sun May 01, 2011 9:31 am

Re: TinyMCE and JCE Editors Not Showing Toolbar Icons

Postby pymoo » Sun May 01, 2011 9:46 am

Exactly the same. jce and tinymce don't work. I changed the settings from extended to simple and still not working. What I can do, someone who has found a solution?

brazmus
Joomla! Intern
Joomla! Intern
Posts: 70
Joined: Thu Nov 05, 2009 4:54 am

Re: TinyMCE and JCE Editors Not Showing Toolbar Icons

Postby brazmus » Mon May 30, 2011 12:42 am

Just spent an hour on this one. The only thing that worked for me to get JCE working again was the url that I used to access the joomla backend. when I had oceaneye.com.au/administrator it didn't work. As soon as I changed it to www.oceaneye.com.au/administrator it worked! Had to re-login as well.

Hope this helps someone

B

wywj82
Joomla! Fledgling
Joomla! Fledgling
Posts: 4
Joined: Tue Sep 28, 2010 2:02 pm

Re: TinyMCE and JCE Editors Not Showing Toolbar Icons

Postby wywj82 » Wed Jun 01, 2011 4:42 pm

brazmus wrote:Just spent an hour on this one. The only thing that worked for me to get JCE working again was the url that I used to access the joomla backend. when I had oceaneye.com.au/administrator it didn't work. As soon as I changed it to http://www.oceaneye.com.au/administrator it worked! Had to re-login as well.

Hope this helps someone

B


Thanks! but it's not work!!
i have the same problem !!Please help!!!
3th party editor.... i can't use too....
why ???
is the joomla have the big bugs ?
please joomla Development team ...help!!!

brazmus
Joomla! Intern
Joomla! Intern
Posts: 70
Joined: Thu Nov 05, 2009 4:54 am

Re: TinyMCE and JCE Editors Not Showing Toolbar Icons

Postby brazmus » Wed Jun 01, 2011 9:59 pm

1.5.22 has been giving me lots of problems too. Artcile save button hasn't been working in IE9, the article text doesn't show in Chrome or Safari, just HTML, dropdown menus not working in Article Manager mode etc...

Sorry my fix above didn't work for you.

clon74
Joomla! Fledgling
Joomla! Fledgling
Posts: 1
Joined: Tue Jun 14, 2011 5:53 pm

Re: TinyMCE and JCE Editors Not Showing Toolbar Icons

Postby clon74 » Tue Jun 14, 2011 6:50 pm

I had the same problem and my site is finally working again but I did two thing at the same time so I don't know what solve the problem:

Enter to the admin area not using www, log out, enter to the admin area using www and made the following changes:

Intall JCE editor.
Set TinyMCE to the simple functionality, coode cleanup off and never.
Set JCE as default editor.

voilá! the editor is fully functional in both front and backend.


Return to “Extensions for Joomla! 1.5”

Who is online

Users browsing this forum: No registered users and 12 guests