The Joomla! Forum ™



Forum rules


Forum Rules
Absolute Beginner's Guide to Joomla! <-- please read before posting, this means YOU.



Post new topic Reply to topic  [ 74 posts ]  Go to page Previous  1, 2, 3
Author Message
 Post subject: Re: Joomla IE8 problem
PostPosted: Sat Sep 18, 2010 11:50 am 
Joomla! Fledgling
Joomla! Fledgling

Joined: Sat Sep 18, 2010 11:41 am
Posts: 1
Hello,

Here is a new variation on the IE8 problem theme….

I run two sites based on the JA_purity template. Both work perfectly well in IE8, IE7, Firefox, Chome etc etc. – except for one thing…..

I put in a weblink from one site to the other. The child site opens fine PROVIDED that I launch it in the parent window (not nice). But, if I launch the child site in a new window the first view is all messed up because the font size in the main component area is incorrectly rendered (too large) and everything in the left side of the site is displaced to the bottom of the window (grrrrr !). But then, the first time you navigate around in the child site everything corrects itself and is fine thereafter.

I checked what happens when I weblinked to other sites that I could find which were also clearly built with Joomla! and using variants of the JA_purity template. Same thing ! So, its not just me (phew).

I checked the trick of removing the gte from <!--[if gte IE 7.0]> in the index.php file, and it was not there in the version of my_japurity that I started out with, so I guess this has been attended to “at source” by the Joomla! Admin.

So, anyone got any ideas? I’ve rummaged through the template code for some time and not coming up with any solutions. Its such a specific set of conditions under which the problem occurs that it ought to be traceable, but I can’t find it.

This ONLY happens with IE8 – not with Firefox, Chrome, Safari. I despair of IE8. Don’t like using it myself, but 80% of the visitors to my sites do, so I have to accommodate it. Do you think MS do this on purpose ?

Parent site using Joomla 1.5.20
Child site using Joomla 1.5.15
(but the problem is just the same when parent and child are inverted)

Parent page…. http://www.mirrorsailingscotland.org/index.php?option=com_weblinks&view=category&id=3&Itemid=6

Click on the “ASYC…” weblink to open in the parent window. Shift-click to open in a new window and see the problem.

Hope to hear from someone out there.


Top
 Profile  
 
 Post subject: Re: Joomla IE8 problem
PostPosted: Mon Oct 04, 2010 6:25 am 
Joomla! Enthusiast
Joomla! Enthusiast

Joined: Wed Mar 17, 2010 7:46 am
Posts: 125
should i leave this as it is in my template?
Code:
<!--[if IE 7.0]>
<style type="text/css">
.clearfix {display: inline-block;}
</style>
<![endif]-->
<?php if ($tmpTools->isIE6()): ?>
<!--[if lte IE 6]>
<script type="text/javascript">
var siteurl = '<?php echo $tmpTools->baseurl();?>';

window.addEvent ('load', makeTransBG);
function makeTransBG() {
   fixIEPNG($E('.ja-headermask'), '', '', 1);
   fixIEPNG($E('h1.logo a'));
   fixIEPNG($$('img'));
   fixIEPNG ($$('#ja-mainnav ul.menu li ul'), '', 'scale', 0, 2);
}
</script>
<style type="text/css">
.ja-headermask, h1.logo a, #ja-cssmenu li ul { background-position: -1000px; }
#ja-cssmenu li ul li, #ja-cssmenu li a { background:transparent url(<?php echo $tmpTools->templateurl(); ?>/images/blank.png) no-repeat right;}
.clearfix {height: 1%;}
</style>
<![endif]-->
<?php endif; ?>

_________________
Buy Medical Supplies, Medical Equipment and Home Health Care products


Top
 Profile  
 
 Post subject: Re: Joomla IE8 problem
PostPosted: Tue Nov 09, 2010 9:59 am 
Joomla! Apprentice
Joomla! Apprentice

Joined: Thu Mar 30, 2006 7:28 pm
Posts: 22
maranate wrote:
We have the same problem, IE 8 shows the PDA template instead of the regular template. We don't want to delete the PDA template because we do have a lot of mobile users. So how do we force it to display the correct template with IE8? It displays fine on other browsers, and we let people know that it works better with Firefox, but still have the majority using IE. We also want it to display properly for people who are new, or who just happen upon our site and are using IE8.

I also want to note that even in compatibility mode, it displays the PDA template, not the correct, default, template.


i have this very same problem. the mobile version appears by default on ie8. and only on ie8, chrome and ff are fine. the site runs on joomla 1.5.20, and the plugin is mobile joomla.

http://www.riversideclinic.sg/cms/

however, this doesn't happen on all PC's. 3 of my friends can view the standard website immediately upon entering the url on ie8 on their pc. following another member's advice, i'd deleted all templates that i was not using, but the problem persists on my pc.

please help.


Top
 Profile  
 
 Post subject: Re: Joomla IE8 problem
PostPosted: Tue Nov 09, 2010 5:49 pm 
User avatar
Joomla! Enthusiast
Joomla! Enthusiast

Joined: Sat Apr 14, 2007 9:16 am
Posts: 108
Location: Russia
What is the User-Agent string of that PC with IE8 (as IE plugins may alter tthis string and break correct determination of browser type)?

_________________
Visit my blog — Interesting about Joomla! http://joomup.com/blog/.


Top
 Profile  
 
 Post subject: Re: Joomla IE8 problem
PostPosted: Wed Nov 10, 2010 6:00 am 
Joomla! Apprentice
Joomla! Apprentice

Joined: Thu Mar 30, 2006 7:28 pm
Posts: 22
thanks for responding. the user agent info is:

Mozilla/4.0 (compatible; MSIE 8.0; Windows NT 6.0; Trident/4.0; Ant.com Toolbar 1.6; GTB6.6; SLCC1; .NET CLR 2.0.50727; .NET CLR 3.5.30729; .NET CLR 3.0.30729; .NET4.0C)

is this what you meant?


Top
 Profile  
 
 Post subject: Re: Joomla IE8 problem
PostPosted: Wed Nov 10, 2010 6:35 am 
Joomla! Apprentice
Joomla! Apprentice

Joined: Thu Mar 30, 2006 7:28 pm
Posts: 22
i realized that Ant.com Toolbar wasn't supposed to be there, cos i disabled it sometime ago. i couldn't uninstall it on ie8, however i managed to do it at the control panel.

having done so, i ran my ie8 and accessed that website again, and it worked. thanks very much, physicist. that solved my problem. :D


Top
 Profile  
 
 Post subject: Re: Joomla IE8 problem
PostPosted: Sat Jan 15, 2011 11:27 pm 
Joomla! Apprentice
Joomla! Apprentice

Joined: Sun Mar 01, 2009 7:54 pm
Posts: 8
I busted my butt on this one endlessly. IE 8 was not displaying right side of website and lower nav on ANY template. I tried the compatability plugin and index.php header tag, but what worked was.....................drumroll please..... I had 4 articles that must've had some crap in them. It didn't appear to visually, but here is how I solved it. It was isolated to a section of articles, so I unpublished all of the articles, and the display problem was solved. Then I turned on one article at a time and viewed the site. I finally narrowed it down to 4 offending articles and I cut and pasted them to a text editor and re-published them and deleted the old.

All good now.

http://www.speakfreaks.com


Top
 Profile  
 
 Post subject: Re: Joomla IE8 problem
PostPosted: Sat Mar 05, 2011 11:26 am 
Joomla! Fledgling
Joomla! Fledgling

Joined: Sat Mar 05, 2011 11:23 am
Posts: 2
shibu wrote:
Hi,

I have solved by using this plugin.
Link : http://extensions.joomla.org/extensions ... 23/details.

And also we can use following code to fix the IE8 issue.
This tag needs to be first in the <head> (before any css):

<meta http-equiv="X-UA-Compatible" content="IE=7" />

Please try.

Thanks and regards


YOU my friend are a LEGEND !!!!!

I have tried all options (thanks guys) but your help finally did the trick '

THAAAAAAAAAAAAANK YOU !!!!


Top
 Profile  
 
 Post subject: Re: Joomla IE8 problem
PostPosted: Sat Mar 05, 2011 3:10 pm 
Joomla! Fledgling
Joomla! Fledgling

Joined: Sat Mar 05, 2011 11:23 am
Posts: 2
dontak wrote:
gbnam wrote:
shibu wrote:
Hi,

I have solved by using this plugin.
Link : http://extensions.joomla.org/extensions ... 23/details.

And also we can use following code to fix the IE8 issue.
This tag needs to be first in the <head> (before any css):

<meta http-equiv="X-UA-Compatible" content="IE=7" />

Please try.

Thanks and regards


YOU my friend are a LEGEND !!!!!

I have tried all options (thanks guys) but your help finally did the trick '

THAAAAAAAAAAAAANK YOU !!!!

gbnam , can you explain more, i do it but i have error yet.


Howzit bud !

I start from top of this tread, tried every setting that people mentioned, until I tried this one, and this one finally worked.


Top
 Profile  
 
 Post subject: Re: Joomla IE8 problem
PostPosted: Wed Jun 22, 2011 10:05 pm 
Joomla! Apprentice
Joomla! Apprentice

Joined: Thu May 28, 2009 2:42 pm
Posts: 15
Thanks for the help


Top
 Profile  
 
 Post subject: Re: Joomla IE8 problem
PostPosted: Fri Nov 18, 2011 6:45 pm 
Joomla! Apprentice
Joomla! Apprentice

Joined: Fri Nov 11, 2011 2:47 pm
Posts: 6
My template didn't have that line of code in the PHP...I was having problems getting my banner to show up in IE8. I re-saved it as a PNG in RGB color mode and it works fine now!


Top
 Profile  
 
 Post subject: Re: Joomla IE8 problem
PostPosted: Mon Jan 23, 2012 9:36 am 
Joomla! Apprentice
Joomla! Apprentice

Joined: Thu Dec 15, 2011 7:32 am
Posts: 10
The code below fixed my problem. Many, many thanks.

Use following code to fix the IE8 issue.
This tag needs to be first in the <head> (before any css):

<meta http-equiv="X-UA-Compatible" content="IE=7" />


Top
 Profile  
 
 Post subject: Re: Joomla IE8 problem
PostPosted: Thu Mar 22, 2012 5:09 am 
Joomla! Fledgling
Joomla! Fledgling

Joined: Thu Mar 22, 2012 5:03 am
Posts: 1
Hi friends,

I am getting problem in IE8. I am using defalut template ja-purity when i open my site on firefox, IE7, IE6, its perfectly ok. But when i open my site on IE8 then my top logo section, top menu, and at the down the latest news section aligning on left i am using 780 width my website is in center. Can any tell me how to compitable my site on IE8.


Top
 Profile  
 
 Post subject: Re: Joomla IE8 problem
PostPosted: Fri Apr 27, 2012 6:25 pm 
Joomla! Apprentice
Joomla! Apprentice

Joined: Fri Jan 07, 2011 3:27 am
Posts: 9
Hey all, I've been up and down this thread and many others out there regarding IE compatability with some Joomla templates.

www.itmiradio.com/home

For me, I am seeing the alignment issues on ALL Internet Explorer versions, yet everything is fine on Chrome and Firefox. My center and right columns line up to the left and downward from there.

I've tried every suggestion from this thread and other with the exception of some of the plug in's I've seen referenced. I am weary of adding additional modules and plug in's to fix things. Seems like it can only lead to trouble ;) I have tried adding the <meta> tags lists, no effect, I have deactivated all usesless articles and modules, I've tried messing with the left and right module widths in the template CSS.

Nothing seems to work. Would anyone be able to take a look at my site and offer some insight on why this is happening in IE for me? I'm all ears and I'd love to understand the "why" of this issue.

Thanks


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 74 posts ]  Go to page Previous  1, 2, 3



Who is online

Users browsing this forum: Google [Bot], Google Feedfetcher and 21 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Jump to:  
Powered by phpBB® Forum Software © phpBB Group