TIP: I can't display my language correctly in Joomla

General questions regarding the use of languages in Joomla! 2.5.

Moderators: infograf768, General Support Moderators

Forum rules
Forum Rules
Absolute Beginner's Guide to Joomla! <-- please read before posting, this means YOU.
Forum Post Assistant - If you are serious about wanting help, you will use this tool to help you post.
User avatar
infograf768
Joomla! Master
Joomla! Master
Posts: 18038
Joined: Fri Aug 12, 2005 3:47 pm
Location: **Translation Matters**

TIP: I can't display my language correctly in Joomla

Postby infograf768 » Wed Mar 23, 2011 8:00 am

1. The database should be collated UTF8.
Not only the db itself, but also the tables and fields !!!

On some hosts, the db is automatically created as Swedish latin.

2 solutions to this:

A. You do NOT have much stuff already saved in your site
Delete the database tables, set the db collation to UTF8, and reinstall.
This can be done via PhpMyAdmin

B. You need to keep what you already entered in the db
You can correct this by using this script.
http://www.phoca.cz/download/category/1 ... ation-tool

2. Your host has disabled some PHP functions.

ini_set is very often the issue. Contact your host
Jean-Marie Simonet / infograf · http://www.info-graf.fr
Multilanguage in 2.5: http://help.joomla.org/files/EN-GB_multilang_tutorial.pdf
---------------------------------
ex-Joomla Translation Coordination Team • ex-Joomla! Production Working Group

Return to “Language - Joomla! 2.5”

Who is online

Users browsing this forum: No registered users and 1 guest