The Joomla! Forum ™



Forum rules


Forum Rules
Absolute Beginner's Guide to Joomla! <-- please read before posting.
Forum Post Assistant - If you are serious about wanting help, you should use this tool to help you post.



Post new topic Reply to topic  [ 16 posts ] 
Author Message
PostPosted: Wed Mar 30, 2011 9:00 pm 
Joomla! Apprentice
Joomla! Apprentice

Joined: Thu Feb 24, 2011 11:26 pm
Posts: 11
Hey,

I am running Joomla 1.5

When I attempt to go to https://www.mydomain.com it automatically redirects to http://www.mydomain.com

If I force SSL on the menu items (though add-on modules) or even the entire site I get the following browser errors: Firefox has detected that the server is redirecting the request for this address in a way that will never complete. I get the same error in Google Chrome and Internet Explorer.

I've manually set the .htaccess file to set the server to HTTPS, and it still resets to HTTP.

Funny thing is, the admin area works fine in SSL, and certain pages will actually do HTTPS fine.

Is there anything you guys can think of that might be preventing my site able to do the HTTPS on the pages that I need? I am trying to get it working for a payment processor to accept registrations and it just won't take.

Have disabled random modules and nothing seems to work.


Top
 Profile  
 
PostPosted: Wed Mar 30, 2011 9:17 pm 
User avatar
Joomla! Master
Joomla! Master
Online

Joined: Sat Apr 05, 2008 9:58 pm
Posts: 25338
Location: @Webdongle
Do you own an SSL certificate ?

_________________
'When I'm right nobody remembers when I'm wrong nobody forgets.'

http://weblinksonline.co.uk/joomla-faq.html
http://www.weblinksonline.co.uk/updating-joomla.html


Top
 Profile  
 
PostPosted: Tue Apr 05, 2011 6:52 pm 
Joomla! Apprentice
Joomla! Apprentice

Joined: Thu Feb 24, 2011 11:26 pm
Posts: 11
Webdongle wrote:
Do you own an SSL certificate ?



Yes the SSL, is working fine on other parts of the site.


Top
 Profile  
 
PostPosted: Tue Apr 05, 2011 7:11 pm 
User avatar
Joomla! Master
Joomla! Master
Online

Joined: Sat Apr 05, 2008 9:58 pm
Posts: 25338
Location: @Webdongle
On the Joomla pages is there anywhere that htttps works or is it failing on all Joomla links ?

Do you have mod_rewrite active in .htaccess ?

Do you have a 3rd party SEF Component that needs the SEF url's Purged ?

Perhaps http://extensions.joomla.org/extensions ... tion/11326 may help ?

https works on my site (but I don't use it as it's a shared ssl cert it throws warnings on the Browser).

_________________
'When I'm right nobody remembers when I'm wrong nobody forgets.'

http://weblinksonline.co.uk/joomla-faq.html
http://www.weblinksonline.co.uk/updating-joomla.html


Top
 Profile  
 
PostPosted: Tue Apr 05, 2011 7:39 pm 
Joomla! Apprentice
Joomla! Apprentice

Joined: Thu Feb 24, 2011 11:26 pm
Posts: 11
If i go to https://www.domain.com/test.php it properly goes to the address. going to https://www.domain.com will change it to http://www.domain.com


Top
 Profile  
 
PostPosted: Tue Apr 05, 2011 7:45 pm 
Joomla! Apprentice
Joomla! Apprentice

Joined: Thu Feb 24, 2011 11:26 pm
Posts: 11
Only SEF addon that I know of is the system SEF.

Plugin: System - SEF

Checked .htaccess

########## Begin - Rewrite rules to block out some common exploits
## If you experience problems on your site block out the operations listed below
## This attempts to block the most common type of exploit `attempts` to Joomla!
#
# Block out any script trying to set a mosConfig value through the URL
RewriteCond %{QUERY_STRING} mosConfig_[a-zA-Z_]{1,21}(=|\%3D) [OR]
# Block out any script trying to base64_encode crap to send via URL
RewriteCond %{QUERY_STRING} base64_encode.*\(.*\) [OR]
# Block out any script that includes a <script> tag in URL
RewriteCond %{QUERY_STRING} (\<|%3C).*script.*(\>|%3E) [NC,OR]
# Block out any script trying to set a PHP GLOBALS variable via URL
RewriteCond %{QUERY_STRING} GLOBALS(=|\[|\%[0-9A-Z]{0,2}) [OR]
# Block out any script trying to modify a _REQUEST variable via URL
RewriteCond %{QUERY_STRING} _REQUEST(=|\[|\%[0-9A-Z]{0,2})
# Send all blocked request to homepage with 403 Forbidden error!
RewriteRule ^(.*)$ index.php [F,L]
#
########## End - Rewrite rules to block out some common exploits

# Uncomment following line if your webserver's URL
# is not directly related to physical file paths.
# Update Your Joomla! Directory (just / for root)

# RewriteBase /


########## Begin - Joomla! core SEF Section
#
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteCond %{REQUEST_URI} !^/index.php
RewriteCond %{REQUEST_URI} (/|\.php|\.html|\.htm|\.feed|\.pdf|\.raw|/[^.]*)$ [NC]
RewriteRule (.*) index.php
RewriteRule .* - [E=HTTP_AUTHORIZATION:%{HTTP:Authorization},L]
#

Could it be that last line in the .htaccess????? HTTP authorization etc

If that's not it, it has to be some Addon, it used to work fine before. I can't for the life of me find out what it is.


Top
 Profile  
 
PostPosted: Tue Apr 05, 2011 7:47 pm 
Joomla! Apprentice
Joomla! Apprentice

Joined: Thu Feb 24, 2011 11:26 pm
Posts: 11
Nevermind, that last line just changes anything to index.php


Top
 Profile  
 
PostPosted: Tue Apr 05, 2011 7:58 pm 
User avatar
Joomla! Master
Joomla! Master
Online

Joined: Sat Apr 05, 2008 9:58 pm
Posts: 25338
Location: @Webdongle
Try
# RewriteBase /
to
RewriteBase /

_________________
'When I'm right nobody remembers when I'm wrong nobody forgets.'

http://weblinksonline.co.uk/joomla-faq.html
http://www.weblinksonline.co.uk/updating-joomla.html


Top
 Profile  
 
PostPosted: Tue Apr 05, 2011 8:17 pm 
Joomla! Apprentice
Joomla! Apprentice

Joined: Thu Feb 24, 2011 11:26 pm
Posts: 11
I tried that and nothing changed...

here is my full .htaccess file.


# Use PHP5 Single php.ini as default
AddHandler application/x-httpd-php5s .php
##
# @version $Id: htaccess.txt 10492 2008-07-02 06:38:28Z ircmaxell $
# @package Joomla
# @copyright Copyright (C) 2005 - 2008 Open Source Matters. All rights reserved.
# @license http://www.gnu.org/copyleft/gpl.html GNU/GPL
# Joomla! is Free Software
##


#####################################################
# READ THIS COMPLETELY IF YOU CHOOSE TO USE THIS FILE
#
# The line just below this section: 'Options +FollowSymLinks' may cause problems
# with some server configurations. It is required for use of mod_rewrite, but may already
# be set by your server administrator in a way that dissallows changing it in
# your .htaccess file. If using it causes your server to error out, comment it out (add # to
# beginning of line), reload your site in your browser and test your sef url's. If they work,
# it has been set by your server administrator and you do not need it set here.
#
#####################################################

## Can be commented out if causes errors, see notes above.
# For security reasons, Option followsymlinks cannot be overridden.
#Options +FollowSymLinks
Options +SymLinksIfOwnerMatch
#
# mod_rewrite in use

RewriteEngine On
#
########## Begin - Rewrite rules to block out some common exploits
## If you experience problems on your site block out the operations listed below
## This attempts to block the most common type of exploit `attempts` to Joomla!
#
# Block out any script trying to set a mosConfig value through the URL
RewriteCond %{QUERY_STRING} mosConfig_[a-zA-Z_]{1,21}(=|\%3D) [OR]
# Block out any script trying to base64_encode crap to send via URL
RewriteCond %{QUERY_STRING} base64_encode.*\(.*\) [OR]
# Block out any script that includes a <script> tag in URL
RewriteCond %{QUERY_STRING} (\<|%3C).*script.*(\>|%3E) [NC,OR]
# Block out any script trying to set a PHP GLOBALS variable via URL
RewriteCond %{QUERY_STRING} GLOBALS(=|\[|\%[0-9A-Z]{0,2}) [OR]
# Block out any script trying to modify a _REQUEST variable via URL
RewriteCond %{QUERY_STRING} _REQUEST(=|\[|\%[0-9A-Z]{0,2})
# Send all blocked request to homepage with 403 Forbidden error!
RewriteRule ^(.*)$ index.php [F,L]
#
########## End - Rewrite rules to block out some common exploits

# Uncomment following line if your webserver's URL
# is not directly related to physical file paths.
# Update Your Joomla! Directory (just / for root)

RewriteBase /


########## Begin - Joomla! core SEF Section
#
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteCond %{REQUEST_URI} !^/index.php
RewriteCond %{REQUEST_URI} (/|\.php|\.html|\.htm|\.feed|\.pdf|\.raw|/[^.]*)$ [NC]
RewriteRule (.*) index.php
RewriteRule .* - [E=HTTP_AUTHORIZATION:%{HTTP:Authorization},L]
#
########## End - Joomla! core SEF Section


Top
 Profile  
 
PostPosted: Tue Apr 05, 2011 8:22 pm 
Joomla! Apprentice
Joomla! Apprentice

Joined: Thu Feb 24, 2011 11:26 pm
Posts: 11
What's weird is, I used to run the site HTTPS only and it worked, now when setting SSL in the admin to Entire site I get the weird HTTP redirect on any HTTPS request but only on the main site, some pages work fine, especially in the DT Register Module, the HTTPS is fine..

Everything used to work fine.. Nothing really changed but updating some JEvents Modules and DT Register.

I don't understand how this could have happened.


Top
 Profile  
 
PostPosted: Tue Apr 05, 2011 8:29 pm 
User avatar
Joomla! Master
Joomla! Master
Online

Joined: Sat Apr 05, 2008 9:58 pm
Posts: 25338
Location: @Webdongle
Have you tried that extension I gave the link to ?

Perhaps you should set the https by menu item and not site wide ?

_________________
'When I'm right nobody remembers when I'm wrong nobody forgets.'

http://weblinksonline.co.uk/joomla-faq.html
http://www.weblinksonline.co.uk/updating-joomla.html


Top
 Profile  
 
PostPosted: Tue Apr 05, 2011 8:32 pm 
Joomla! Apprentice
Joomla! Apprentice

Joined: Thu Feb 24, 2011 11:26 pm
Posts: 11
I tried that Yireo, it does the same thing, When I set the menu Item to HTTPS I get the following error:

"Firefox has detected that the server is redirecting the request for this address in a way that will never complete.
The browser has stopped trying to retrieve the requested item. The site is redirecting the request in a way that will never complete.
* Have you disabled or blocked cookies required by this site?
* NOTE: If accepting the site's cookies does not resolve the problem, it is likely a server configuration issue and not your computer."


Top
 Profile  
 
PostPosted: Tue Apr 05, 2011 8:32 pm 
Joomla! Apprentice
Joomla! Apprentice

Joined: Thu Feb 24, 2011 11:26 pm
Posts: 11
Something is forcing the server to go back to HTTP on any HTTPS request.


Top
 Profile  
 
PostPosted: Wed Apr 06, 2011 4:01 am 
Joomla! Apprentice
Joomla! Apprentice

Joined: Thu Feb 24, 2011 11:26 pm
Posts: 11
Started just disabling everything.......... found out it was a Plugin System - DT Register SSL

WOW.

Ok i'm done. hopefully this post will help someone in the future. thanks all for your help.


Top
 Profile  
 
PostPosted: Sun Feb 05, 2012 12:54 am 
Joomla! Apprentice
Joomla! Apprentice

Joined: Wed Nov 26, 2008 11:17 pm
Posts: 5
You have totally saved my life! I've been looking for this answer forever. So important to post your solutions on these forums... Thanks!


Top
 Profile  
 
PostPosted: Sat Feb 22, 2014 12:08 am 
Joomla! Fledgling
Joomla! Fledgling

Joined: Thu Oct 04, 2012 5:19 pm
Posts: 2
You're a lifesaver!!!! I registered just to thank-you dvfd7!!!


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 16 posts ] 



Who is online

Users browsing this forum: No registered users and 15 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Jump to:  
Powered by phpBB® Forum Software © phpBB Group