The Joomla! Forum ™



Forum rules


Global Rules
Additional Rules for this forum <------- Please read before posting



Post new topic Reply to topic  [ 6 posts ] 
Author Message
PostPosted: Tue Apr 19, 2011 9:46 am 
Joomla! Apprentice
Joomla! Apprentice

Joined: Mon Aug 02, 2010 11:21 am
Posts: 13
Hi,
as explain in subject, i have installed servicepack plugin it-IT but i you try to add comment, language remain en-EN.
www.lari-ce.it

someone can help me.


I use joomla 1.6.2


Top
 Profile  
 
PostPosted: Wed Apr 20, 2011 5:52 am 
User avatar
Joomla! Guru
Joomla! Guru

Joined: Thu Jun 01, 2006 1:52 pm
Posts: 979
Location: Moscow, Russia
Hi, this package is not updated for Joomla! 1.6
You may look e.g. Russian language pack v.2.xx to see the difference (or better compare v.1.25.003 with v.2.xx)
In short, Joomla! v.1.6 doesn't load language file (*.ini) in case it violates any formatting rules, which changed for Joomla! v.1.6 (quoting of values is required now etc...)

_________________
Text of all my messages is available under the terms of the GNU Free Documentation License: http://www.gnu.org/copyleft/fdl.html


Top
 Profile  
 
PostPosted: Wed Apr 20, 2011 2:14 pm 
User avatar
Joomla! Guru
Joomla! Guru

Joined: Thu Jun 01, 2006 1:52 pm
Posts: 979
Location: Moscow, Russia
You're lucky, Italian Language Pack was just updated:
http://joomlacode.org/gf/project/yvcomm ... ge_id=3520

_________________
Text of all my messages is available under the terms of the GNU Free Documentation License: http://www.gnu.org/copyleft/fdl.html


Top
 Profile  
 
PostPosted: Thu Jun 23, 2011 9:20 am 
User avatar
Joomla! Apprentice
Joomla! Apprentice

Joined: Wed Aug 18, 2010 6:31 am
Posts: 11
Location: Berlin, Germany
yvolk wrote:
Hi, this package is not updated for Joomla! 1.6
You may look e.g. Russian language pack v.2.xx to see the difference (or better compare v.1.25.003 with v.2.xx)
In short, Joomla! v.1.6 doesn't load language file (*.ini) in case it violates any formatting rules, which changed for Joomla! v.1.6 (quoting of values is required now etc...)


Hi Yuri

I've updated German language files, but still they don't work out :'(
..even tried to put another de-DE.com_yvcomment.ini additionallly in
'language/de-DE/..' but this didn't help either. Files for download here:
http://media.1a-sales.de/yvcomment_de-DE.zip

Working on http://co.starthilfe-gmdh.de/, Comments only for registered users (for now),
Joomla 1.6.3, Component and Plugin N°1 installed (to keep it simple in the beginning),
PLUS the CB-Plugin

I have some more issues (Module didn't show up in the first round, CB-Tab doesn't appear...), so this is the second try (re-installed yvcomments yesterday) - and I've followed the Joomla/yvComment/index_en.html guide step by step, I swear!

Please advice me what to do, thanks!

Mathias
Attachment:
screen.png


You do not have the required permissions to view the files attached to this post.

_________________
Web, Business, Berlin, World, Politik..
Jetzt lesen unter www.strassen-030.de


Top
 Profile  
 
PostPosted: Thu Jun 23, 2011 9:56 am 
User avatar
Joomla! Guru
Joomla! Guru

Joined: Thu Jun 01, 2006 1:52 pm
Posts: 979
Location: Moscow, Russia
Hi Mathias,

1. You may start from setting yvComment's 'Debug' option to 'Yes'
I've just tried this for 'Russian' language and got this message on the frontpage:
'yvComment plugin type=1 is loaded
Language strings for 'ru-RU' were loaded.'
Then I introduced single (!) error in the 'administrator\language\ru-RU\ru-RU.com_yvcomment.ini' (I added extra quote to one line...) and I got this message:
'yvComment plugin type=1 is loaded
Language strings for 'ru-RU' were NOT loaded.'

2. In order to find the bug in the language file I propose that you translate the 'administrator\language\de-DE\de-DE.com_yvcomment.ini' step by step:
2.1. Start from copying 'administrator\language\en-GB\en-GB.com_yvcomment.ini' into 'administrator\language\de-DE\de-DE.com_yvcomment.ini'
and get 'Language strings for 'de-DE' were loaded.' message from yvComment.
2.2. Change only ONE line so you can see the difference (e.g. ADD_YOUR_COMMENT="Translated string")
2.3. Change MORE lines...

Did this help?

_________________
Text of all my messages is available under the terms of the GNU Free Documentation License: http://www.gnu.org/copyleft/fdl.html


Top
 Profile  
 
PostPosted: Thu Jun 23, 2011 10:15 am 
User avatar
Joomla! Apprentice
Joomla! Apprentice

Joined: Wed Aug 18, 2010 6:31 am
Posts: 11
Location: Berlin, Germany
The right way, debug gives me the ability to see what's happening, thnks!!

>I've tried to avoid to do this string by string, and there was no obvious error displayed (Notpad++, saved as Ressource file) ... now I will do it line by line.

:eek: The russian .ini contains uncommented quotes in <a href, the original is using single quotes - and my '\"' didn't work. In addition, there MUST NOT be any additional or missing line...


http://media.1a-sales.de/yvcomment_de-DE.zip = Now Up2Date,
including the German formal / Non formal version 8)

Juice By Yv'comment

_________________
Web, Business, Berlin, World, Politik..
Jetzt lesen unter www.strassen-030.de


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 6 posts ] 



Who is online

Users browsing this forum: No registered users and 10 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Jump to:  
Powered by phpBB® Forum Software © phpBB Group