The Joomla! Forum ™



Forum rules


Forum Rules
Absolute Beginner's Guide to Joomla! <-- please read before posting, this means YOU.
Forum Post Assistant - If you are serious about wanting help, you will use this tool to help you post.



Post new topic Reply to topic  [ 9 posts ] 
Author Message
PostPosted: Tue Jul 10, 2007 12:15 am 
Joomla! Apprentice
Joomla! Apprentice

Joined: Sun Jul 08, 2007 11:03 pm
Posts: 6
How do I set JCE to left align by default? Everytime I create a new article, it's always center aligned by default instead of being left aligned. Another question, how can I have JCE paste as plain text by default (while maintaining line breaks).

Any help is very much appreciated.


Last edited by Wardrop on Tue Jul 10, 2007 12:57 am, edited 1 time in total.

Top
 Profile  
 
PostPosted: Tue Jul 24, 2007 11:25 pm 
Joomla! Ace
Joomla! Ace

Joined: Sat Feb 10, 2007 8:26 pm
Posts: 1618
I think the left align thing is probably in your template. You probably have to go add a align tag to fix it.

_________________
-Matt H
http://ninjaforge.com


Top
 Profile  
 
PostPosted: Wed Jul 25, 2007 12:15 am 
Joomla! Apprentice
Joomla! Apprentice

Joined: Sun Jul 08, 2007 11:03 pm
Posts: 6
I've managed to fix it by creating my own little editor .css and making JCE use that instead of the template.css file which i think is used by default. It's good to know someone's viewing these old topics and still willing to give some assistance.

Thanks!


Top
 Profile  
 
PostPosted: Wed Jul 25, 2007 3:04 am 
Joomla! Ace
Joomla! Ace

Joined: Sat Feb 10, 2007 8:26 pm
Posts: 1618
Your welcome.

_________________
-Matt H
http://ninjaforge.com


Top
 Profile  
 
PostPosted: Thu May 15, 2008 12:12 am 
Joomla! Apprentice
Joomla! Apprentice

Joined: Fri Feb 22, 2008 12:15 am
Posts: 5
Location: Dawson Creek, BC
I've been trying to solve the same issue. I've utilized my own "editor_content.css" stylesheet for JCE to use instead of the template (template.css) stylesheet. But I'm still wondering if there's a way to prevent users from pasting dynamic text into the editor that usually adds style="" and other attributes. Is there a way other than using the special Paste Plain Text button to force the code to be pasted as clean with only line-breaks?

That would simplify my life quite a bit. Thanks.


Top
 Profile  
 
PostPosted: Tue Jun 16, 2009 3:37 pm 
Joomla! Apprentice
Joomla! Apprentice

Joined: Tue Feb 24, 2009 9:38 am
Posts: 26
Hello, I have left align everything in my template.css and the editor_template.css but my icons are still centering. Is there anything specific I should pin point to get them to left align?


Top
 Profile  
 
PostPosted: Tue Sep 15, 2009 1:02 pm 
Joomla! Apprentice
Joomla! Apprentice

Joined: Fri Apr 24, 2009 9:24 am
Posts: 5
Hi there: I've just had a similar problem. To verify which part is causing the problems do the following tests:
1. Tried a different WYSIWIG editor: see if the problem persists.
2. Try a different template (one of the default ones): does the problem goes away?

Using this method I was able to establish that the problem was not the editor (the problem persisted even when this was changed).

I contacted the Template providers and explained the problem. They instructed me to remove a CSS style that was being applied to the body.

In this case.... text-align:center;

I hope this helps you sort out the problem


Top
 Profile  
 
PostPosted: Sun Jul 10, 2011 11:41 pm 
Joomla! Fledgling
Joomla! Fledgling

Joined: Sun Jul 10, 2011 11:37 pm
Posts: 1
Simplest fix:

Hit up JCE Administration in the Components menu.
Go to Global Configuration.
Find setting called Editor Style Reset and change it to Yes.

This "forces left aligned, black text on a white background," in other words, case closed for 99% of users.

Best,
Jaimeji


Top
 Profile  
 
PostPosted: Thu Nov 10, 2011 9:04 pm 
Joomla! Apprentice
Joomla! Apprentice

Joined: Fri Apr 01, 2011 9:40 pm
Posts: 17
Jaimeji wrote:
Simplest fix:

Hit up JCE Administration in the Components menu.
Go to Global Configuration.
Find setting called Editor Style Reset and change it to Yes.

This "forces left aligned, black text on a white background," in other words, case closed for 99% of users.

Best,
Jaimeji


Great! Thanks for the tip.


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 9 posts ] 



Who is online

Users browsing this forum: No registered users and 6 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Jump to:  
Powered by phpBB® Forum Software © phpBB Group