Help with set-up error messages

General questions relating to Joomla! 1.5 There are other boards for more specific help on Joomla! features and extensions.

Moderator: General Support Moderators

Forum rules
Forum Rules
Absolute Beginner's Guide to Joomla! <-- please read before posting.
Forum Post Assistant - If you are serious about wanting help, you should use this tool to help you post.
ruby2000
Joomla! Fledgling
Joomla! Fledgling
Posts: 1
Joined: Wed Jul 20, 2011 6:47 am

Help with set-up error messages

Postby ruby2000 » Wed Jul 20, 2011 6:58 am

Hello,
I've just installed Joomla 1.7 and XAMPP and the installtion went well until I clicked on 'site' to view the site and recived lines of error messages along the lines of:

[b]Strict Standards: Static function JDatabase::test() should not be abstract in C:\xampp\htdocs\joomla17\libraries\joomla\database\database.php on line 350

Strict Standards: Accessing static property JCache::$_handler as non static in C:\xampp\htdocs\joomla17\libraries\joomla\cache\cache.php on line 394
[/b]

Does anyone have any idea what I did wrong?

Thanks for any help you can provide...
Rick

monir_asian
Joomla! Intern
Joomla! Intern
Posts: 82
Joined: Wed Jul 20, 2011 8:20 am

Re: Help with set-up error messages

Postby monir_asian » Wed Jul 20, 2011 8:41 am

Strict Standards: Accessing static property JCache::$_handler as non static in D:\xampp\htdocs\Joomla\libraries\joomla\cache\cache.php on line 394

Strict Standards: Accessing static property JCache::$_handler as non static in D:\xampp\htdocs\Joomla\libraries\joomla\cache\cache.php on line 396

Strict Standards: Accessing static property JCache::$_handler as non static in D:\xampp\htdocs\Joomla\libraries\joomla\cache\cache.php on line 396

Strict Standards: Accessing static property JCache::$_handler as non static in D:\xampp\htdocs\Joomla\libraries\joomla\cache\cache.php on line 396

Strict Standards: Accessing static property JCache::$_handler as non static in D:\xampp\htdocs\Joomla\libraries\joomla\cache\cache.php on line 396

Strict Standards: Accessing static property JCache::$_handler as non static in D:\xampp\htdocs\Joomla\libraries\joomla\cache\cache.php on line 394

Strict Standards: Accessing static property JCache::$_handler as non static in D:\xampp\htdocs\Joomla\libraries\joomla\cache\cache.php on line 396

Strict Standards: Accessing static property JCache::$_handler as non static in D:\xampp\htdocs\Joomla\libraries\joomla\cache\cache.php on line 396

Strict Standards: Accessing static property JCache::$_handler as non static in D:\xampp\htdocs\Joomla\libraries\joomla\cache\cache.php on line 396

Strict Standards: Accessing static property JCache::$_handler as non static in D:\xampp\htdocs\Joomla\libraries\joomla\cache\cache.php on line 396

Strict Standards: Accessing static property JCache::$_handler as non static in D:\xampp\htdocs\Joomla\libraries\joomla\cache\cache.php on line 396

Strict Standards: Accessing static property JCache::$_handler as non static in D:\xampp\htdocs\Joomla\libraries\joomla\cache\cache.php on line 396

Strict Standards: Accessing static property JCache::$_handler as non static in D:\xampp\htdocs\Joomla\libraries\joomla\cache\cache.php on line 396

Strict Standards: Accessing static property JCache::$_handler as non static in D:\xampp\htdocs\Joomla\libraries\joomla\cache\cache.php on line 396
Administration


I also got this above error . please give the suggestion.

pallavi_t
Joomla! Enthusiast
Joomla! Enthusiast
Posts: 150
Joined: Sat Jun 04, 2011 9:24 am

Re: Help with set-up error messages

Postby pallavi_t » Wed Jul 20, 2011 9:23 am

Hi ruby2000,

Keep error reporting off.
It may because of you are using the latest version of xampp.It works fine with 1.7.3.

Best Regards,

monir_asian
Joomla! Intern
Joomla! Intern
Posts: 82
Joined: Wed Jul 20, 2011 8:20 am

Re: Help with set-up error messages

Postby monir_asian » Wed Jul 20, 2011 10:47 am

i have a joomla cms and i want to setup this cms in IIS server.

will it work for IIS?

pallavi_t
Joomla! Enthusiast
Joomla! Enthusiast
Posts: 150
Joined: Sat Jun 04, 2011 9:24 am

Re: Help with set-up error messages

Postby pallavi_t » Wed Jul 20, 2011 11:17 am

Hi monir_asian,

PHP can run on IIS, so a Joomla! web site also can run on IIS.
See the documentation : http://docs.joomla.org/IIS .

Best Regards,

monir_asian
Joomla! Intern
Joomla! Intern
Posts: 82
Joined: Wed Jul 20, 2011 8:20 am

Re: Help with set-up error messages

Postby monir_asian » Wed Jul 20, 2011 11:45 am

visit this. http://www.bit.ge/phpinfo.php . my server current version is PHP Version 5.2.17.
I want to update this version to php 5.3.6. how can i update?

if I update my php version, will it work for joomla 1.5 and 1.7. I have another website also which is running from this server. do you think it will not conflict ?


please add me to your skypee list. skypee id-- monir_asp.net
yahoo id- [email protected]
bye
monir

User avatar
Overcast451
Joomla! Apprentice
Joomla! Apprentice
Posts: 13
Joined: Wed Aug 10, 2011 2:36 pm

Re: Help with set-up error messages

Postby Overcast451 » Sun Aug 14, 2011 3:34 pm

pallavi_t wrote:Hi ruby2000,

Keep error reporting off.
It may because of you are using the latest version of xampp.It works fine with 1.7.3.

Best Regards,


Hey, I'm running into this too. I'm using the newest version of XAMPP - so it's likely that, Joomla is working now (this is Ubuntu 10.04-LTS)

How can I turn of the error reporting? You mean within Joomla or within MYSQL?

User avatar
Overcast451
Joomla! Apprentice
Joomla! Apprentice
Posts: 13
Joined: Wed Aug 10, 2011 2:36 pm

Re: Help with set-up error messages

Postby Overcast451 » Sun Aug 14, 2011 3:41 pm

Here's an example - and I turned off error reporting in Joomla (at least one of the settings I found)

http://imageshack.us/photo/my-images/853/examplei.jpg/

Notice how it spits out error text above the Joomla site administrator.

User avatar
Overcast451
Joomla! Apprentice
Joomla! Apprentice
Posts: 13
Joined: Wed Aug 10, 2011 2:36 pm

Re: Help with set-up error messages

Postby Overcast451 » Sun Aug 14, 2011 3:54 pm

I found it - if anyone else hits this thread with these errors, you need to change the PHP.INI file to suppress the errors.

viewtopic.php?p=2443155#p2443155


You have "Strict Standards: Non-static method" errors, this is because of the error reporting settings in your Xampp php.ini file. In the php.ini file make these changes and then restart Apache;

error_reporting = E_ALL & ~E_NOTICE

display_errors = Off

You must restart Apache before these changes take effect. If you are unsure where you php.ini file is try running this file on your server and look for the "Loaded Configuration File" line.


In a default Ubuntu install, I found it in: /opt/lampp/etc/php.ini

Thanks to the above and dpacadmin!

User avatar
Sudhir_Dixit
Joomla! Apprentice
Joomla! Apprentice
Posts: 14
Joined: Fri Aug 13, 2010 8:24 am

Re: Help with set-up error messages

Postby Sudhir_Dixit » Fri Aug 19, 2011 1:48 pm

Overcast451 wrote:Here's an example - and I turned off error reporting in Joomla (at least one of the settings I found)

http://imageshack.us/photo/my-images/853/examplei.jpg/

Notice how it spits out error text above the Joomla site administrator.


Instead of Error Reporting = Simple instead of None
it worked for me

bobc2001
Joomla! Fledgling
Joomla! Fledgling
Posts: 3
Joined: Thu Sep 22, 2011 9:06 pm

Re: Help with set-up error messages

Postby bobc2001 » Thu Sep 22, 2011 9:13 pm

I give up Xampp 1.77 gives the same error. Nobody has attempted to solve the problem. I have worked with xampp 1.71 for several weeks and do not understand why no body has an answer.


Yes I am frustrated. It's tough enough being a learner but this is too much. maybe I'll wait till 1.8 but then nobodys templates work. T3 framework won't work with modules anywhere and they are all pointing at each other.

turning error reporting off is like removing the check engine lite. the idea is rediculus

sorry for the rant
bobc

eric49er
Joomla! Fledgling
Joomla! Fledgling
Posts: 1
Joined: Fri Oct 28, 2011 12:53 pm

Re: Help with set-up error messages

Postby eric49er » Fri Oct 28, 2011 12:57 pm

Thanks Overcast451

My setup is on windows 7, so my php.ini file was located in c:\xampp\php

I set the display_errors = Off and restarted - worked great - I am using XAMPP 1.7.7, btw
Overcast451 wrote:I found it - if anyone else hits this thread with these errors, you need to change the PHP.INI file to suppress the errors.

viewtopic.php?p=2443155#p2443155


You have "Strict Standards: Non-static method" errors, this is because of the error reporting settings in your Xampp php.ini file. In the php.ini file make these changes and then restart Apache;

error_reporting = E_ALL & ~E_NOTICE

display_errors = Off

You must restart Apache before these changes take effect. If you are unsure where you php.ini file is try running this file on your server and look for the "Loaded Configuration File" line.


In a default Ubuntu install, I found it in: /opt/lampp/etc/php.ini

Thanks to the above and dpacadmin!


Return to “General Questions/New to Joomla! 1.5”

Who is online

Users browsing this forum: No registered users and 10 guests