The Joomla! Forum ™






Post new topic Reply to topic  [ 30 posts ] 
Author Message
PostPosted: Thu Jul 21, 2011 11:08 pm 
Joomla! Apprentice
Joomla! Apprentice

Joined: Sat Mar 19, 2011 10:29 pm
Posts: 21
Please assist me with hiding the parent title "Articles" in my page titles/headings.

I have already set the parameters in both the menu items and the article itself to display "hide", but the top parent title, Articles, still appears on some pages.

Here's a sample link: http://www.lordisthere.com/index.php?op ... yer-center

Thanks for your help!


Top
 Profile  
 
PostPosted: Thu Jul 21, 2011 11:29 pm 
User avatar
Joomla! Explorer
Joomla! Explorer

Joined: Fri Jul 10, 2009 4:00 am
Posts: 359
Location: Ratanakiri Cambodia
In article set dispay to "hide"
In menu items:: Article Options :: Show title to "Use Article Settings".

_________________
Sovann Heng ហេង សុវណ្ណ km-kh.com
អរគុណ"​អាច​ជួយ​ជំរុញ​អ្នក​ដទៃ​​មាន​កម្លាំង​ចិត្ត​ក្នុង​ការ​ចែក​រំលែក
Khmer (Cambodia) Translation Team Coordinator អ្នក​សម្របសម្រួល​ក្រុម​បកប្រែ​ភាសា​ខ្មែរ​(កម្ពុជា)


Top
 Profile  
 
PostPosted: Fri Jul 22, 2011 4:50 am 
Joomla! Apprentice
Joomla! Apprentice

Joined: Sat Mar 19, 2011 10:29 pm
Posts: 21
Thanks, however, that doesn't work for me. I'm using a module, not a menu, to link to the article.

Here's the home page:

http://www.lordisthere.com/

All of the 5 middle icons link properly (removes the "Article" title), except the praying hands. When a user clicks on the praying hands the "Article" title shows. I'm puzzled and have tried many various settings.


Top
 Profile  
 
PostPosted: Wed Aug 03, 2011 2:41 pm 
Joomla! Apprentice
Joomla! Apprentice

Joined: Sat Mar 19, 2011 10:29 pm
Posts: 21
Still waiting. Perhaps someone can direct me elsewhere?

Thanks.


Top
 Profile  
 
PostPosted: Wed Dec 21, 2011 7:08 pm 
Joomla! Fledgling
Joomla! Fledgling

Joined: Mon Jul 14, 2008 12:07 am
Posts: 2
I also have the same problem! Hope this can be solved!


Top
 Profile  
 
PostPosted: Sun Feb 19, 2012 12:07 pm 
Joomla! Apprentice
Joomla! Apprentice

Joined: Sat Nov 03, 2007 8:06 am
Posts: 18
I have flagged this problem in this post
http://forum.joomla.org/viewtopic.php?f=624&t=697131

To fix you need ftp into your files.
- Copy \components\com_content\views\article\tmpl\default.php
- And paste the file into \templates\**your template**\html\com_content\article
- Open it/download it to edit it and look for <?php if ($this->params->get('show_page_heading', 1)) : ?>
- Change the 1 to a 0 save and upload if necessary


Top
 Profile  
 
PostPosted: Thu Feb 23, 2012 10:15 am 
Joomla! Fledgling
Joomla! Fledgling

Joined: Thu Feb 23, 2012 9:57 am
Posts: 2
I also have the save problem but thank you saraheagle for your help. I solve it.


Top
 Profile  
 
PostPosted: Thu Feb 23, 2012 5:45 pm 
Joomla! Apprentice
Joomla! Apprentice

Joined: Thu Feb 23, 2012 5:08 pm
Posts: 11
- Open it/download it to edit it and look for <?php if ($this->params->get('show_page_heading', 1)) : ?>
- Change the 1 to a 0 save and upload if necessary

It works, thank you saraheagle!


Top
 Profile  
 
PostPosted: Fri Feb 24, 2012 12:47 pm 
Joomla! Apprentice
Joomla! Apprentice

Joined: Thu Feb 23, 2012 5:08 pm
Posts: 11
Looked ttillman's site, I think use module is better then use a menu, very smarter choice, I'm trying to do the same change.


Top
 Profile  
 
PostPosted: Mon Feb 27, 2012 12:48 am 
Joomla! Apprentice
Joomla! Apprentice

Joined: Fri Aug 19, 2011 12:43 am
Posts: 20
I have this problem, but I don't understand the instructions given to solve it. Can someone kindly explain them more fully to me?

"To fix you need ftp into your files.
- Copy \components\com_content\views\article\tmpl\default.php
- And paste the file into \templates\**your template**\html\com_content\article
- Open it/download it to edit it and look for <?php if ($this->params->get('show_page_heading', 1)) : ?>
- Change the 1 to a 0 save and upload if necessary"

Why do I need to ftp something and where to as I usually edit from the backend online. And where do I fined these things eg it says paste the file into ........ where do I find the file?

Thanks if you can help, although I successfully did websites in Joomla 1.6, now I'm using 1.7 and the parent titles are appearing. I can't find an easy way to fix this. And I don't understand this fix! I am about to do another page and don't want this to happen again. I tried a fix I found elsewhere to do with making a NoMenuArticles category but that didn't work.

Here is a link to show what is happening http://www.hamilton-field-naturalists-c ... icle&id=70
The other two pages look fine, no extra unwanted title!
I've posted in one or two forums but don't seem to get answers. This thread is very recent so I'm hoping for better luck.

Cheers
Chris


Top
 Profile  
 
PostPosted: Mon Feb 27, 2012 8:53 am 
Joomla! Apprentice
Joomla! Apprentice

Joined: Sat Nov 03, 2007 8:06 am
Posts: 18
Unfortunately, you cannot fix this issue from the backend, you have to edit the code in the actual files themselves.

FTP stands for File Transfer Protocol and I recommend you use http://filezilla-project.org to transfer/edit files on the live server. You need to find out from your hosting company your login details to access them. The file paths like '\components\com_content\views\article\tmpl\default.php' show which file in which folder you need to change. You may need to first enter the 'public_html' folder or similar first.

However be very careful doing this as you sound like a novice at editing files :)


Top
 Profile  
 
PostPosted: Sat Mar 31, 2012 1:42 am 
Joomla! Fledgling
Joomla! Fledgling

Joined: Sat Mar 31, 2012 1:40 am
Posts: 1
This article saved my day.. Thank you so much.. Hope there is a lot of people like you to help us newbie here in Joomla.


Top
 Profile  
 
PostPosted: Sat Mar 31, 2012 6:15 am 
Joomla! Fledgling
Joomla! Fledgling

Joined: Sun Feb 27, 2011 6:02 am
Posts: 1
I didn't use Sarah's method in the end as somehow I found that when I actually linked my article to a menu button/item the offending text disappeared! It was only there before the linking.
Maybe this will help someone else and thank you Sarah, I as going to give your advice a go and then the miracle happened :-)


Top
 Profile  
 
PostPosted: Thu Apr 05, 2012 3:09 pm 
User avatar
Joomla! Intern
Joomla! Intern

Joined: Thu Aug 17, 2006 9:27 am
Posts: 85
Location: United Kingdom
ttillman wrote:
Thanks, however, that doesn't work for me. I'm using a module, not a menu, to link to the article.

Here's the home page:

http://www.lordisthere.com/

All of the 5 middle icons link properly (removes the "Article" title), except the praying hands. When a user clicks on the praying hands the "Article" title shows. I'm puzzled and have tried many various settings.


Here's a solution that does not use a core hack, which should always be avoided if possible:

Create a 'Hidden Menu' (which is simply a menu that is not published) then add a menu item to this menu which links to the article. Save this then copy the url of this menu item (from the Link field in Edit Menu Item) and use this url for the link to the article in the module but add onto the end
Code:
&Itemid=
and then the number of the hidden menu item you have created.

'Article' will now not be displayed above the article title.

_________________
http://www.starfishwebsites.com
In need of some loving... https://www.facebook.com/starfishwebsites


Top
 Profile  
 
PostPosted: Wed Apr 18, 2012 6:24 pm 
User avatar
Joomla! Enthusiast
Joomla! Enthusiast

Joined: Thu Sep 18, 2008 6:05 pm
Posts: 131
Location: Vancouver Island, Canada
Thanks erickas! I created a hidden menu item and tried copying the link, but "Articles" was still dislpaying... Then I found your tip re: adding the ItemID to the URL and it worked like a charm.

Chris

_________________
Digital Bloom
Web development powered by Joomla!

Web: www.digitalbloom.ca
Twitter: http://www.twitter.com/digitalbloom_ca


Top
 Profile  
 
PostPosted: Tue Jun 05, 2012 1:57 am 
Joomla! Apprentice
Joomla! Apprentice

Joined: Tue Oct 07, 2008 12:56 pm
Posts: 5
For those of you looking for the official patch for this issue for both 2.5.4 & 1.7.3 you can find it here:

http://joomlacode.org/gf/project/joomla ... m_id=27779

cheers,
Bianca


Top
 Profile  
 
PostPosted: Wed Jun 06, 2012 4:47 am 
Joomla! Apprentice
Joomla! Apprentice

Joined: Fri Aug 19, 2011 12:43 am
Posts: 20
Thank you for that Bianca :)


Top
 Profile  
 
PostPosted: Wed Jun 13, 2012 1:20 pm 
Joomla! Apprentice
Joomla! Apprentice

Joined: Fri Feb 18, 2011 3:10 am
Posts: 11
saraheagle wrote:
I have flagged this problem in this post
http://forum.joomla.org/viewtopic.php?f=624&t=697131

To fix you need ftp into your files.
- Copy \components\com_content\views\article\tmpl\default.php
- And paste the file into \templates\**your template**\html\com_content\article
- Open it/download it to edit it and look for <?php if ($this->params->get('show_page_heading', 1)) : ?>
- Change the 1 to a 0 save and upload if necessary


This worked for me. Thank you so much! My article was showing category "articles" in bold at the top of my article which is not attached to either a menu item or module. What a relief to find a solution. Thanks again! :)


Top
 Profile  
 
PostPosted: Sat Jun 16, 2012 10:07 pm 
Joomla! Apprentice
Joomla! Apprentice

Joined: Sat May 19, 2012 7:39 pm
Posts: 20
OK of the 4 solutions that ive seen posted the best/easiest is this:

Go to : Extensions->Language Manager , then click on the Overrides tab, then select a language on the right e.g. ” English (UK) site ” and click on new and set the “Language Constant” to “JGLOBAL_ARTICLES” and leave the “text” field empty, and save&close. Do this for the remaining languages(if there are any) problem solved.


Top
 Profile  
 
PostPosted: Tue Jun 19, 2012 7:52 am 
Joomla! Apprentice
Joomla! Apprentice

Joined: Sat Nov 03, 2007 8:06 am
Posts: 18
Good News,
You can now choose by default whether to show the Page Heading or not. Works on J 2.5.4.

Go to Menus > Menu Manager > Options button (top right) > Page Display Options and set set to No.

Big thanks to the Joomla team for implementing this :)


Top
 Profile  
 
PostPosted: Wed Jul 11, 2012 7:04 pm 
Joomla! Fledgling
Joomla! Fledgling

Joined: Fri Aug 07, 2009 2:18 pm
Posts: 4
Finally something that works !!!!
thanks to merc911


Top
 Profile  
 
PostPosted: Mon Aug 06, 2012 8:22 pm 
User avatar
Joomla! Intern
Joomla! Intern

Joined: Sat Dec 08, 2007 8:23 pm
Posts: 99
saraheagle wrote:
Good News,
You can now choose by default whether to show the Page Heading or not. Works on J 2.5.4.

Go to Menus > Menu Manager > Options button (top right) > Page Display Options and set set to No.

Big thanks to the Joomla team for implementing this :)


This does not resolve the issue with this post which is the displaying of the 'Articles' title at the top of any page that is linked to from a module. You must use a 'hidden' menu and make your changes there. It works very well.


Top
 Profile  
 
PostPosted: Sat Dec 08, 2012 3:21 am 
Joomla! Intern
Joomla! Intern

Joined: Sun May 31, 2009 11:55 pm
Posts: 68
Location: Toronto, Ontario
Sarah is correct about changing it from the backend. She said

Go to Menus > Menu Manager > Options button (top right) > Page Display Options and set set to No.

I had the same prob. Even though the Page Display Option was already yet to NO, you must still click on SAVE which triggers the option so that the ARTICLES title disappears.. So dont be fooled by the fact that Page Display Option was already yet to NO. Still click on save. And the ARTICLE title will disappear form the page in question. No need to hack joomla.


Top
 Profile  
 
PostPosted: Fri Jan 04, 2013 10:04 pm 
Joomla! Fledgling
Joomla! Fledgling

Joined: Fri Aug 22, 2008 3:25 pm
Posts: 3
Hmmm.. Press SAVE even though you did nothing.. There might be a life lesson here. Anyway, thanks. That fixed it.

~Dysier

dannycool wrote:
I had the same prob. Even though the Page Display Option was already yet to NO, you must still click on SAVE which triggers the option so that the ARTICLES title disappears.. So dont be fooled by the fact that Page Display Option was already yet to NO. Still click on save. And the ARTICLE title will disappear form the page in question. No need to hack joomla.


Top
 Profile  
 
PostPosted: Tue Feb 12, 2013 10:37 am 
Joomla! Apprentice
Joomla! Apprentice

Joined: Tue Oct 19, 2010 2:37 pm
Posts: 12
This did it for me:

http://www.mountainvistatech.com/2012/0 ... oomla-2-5/


Top
 Profile  
 
PostPosted: Fri Apr 26, 2013 7:38 pm 
User avatar
Joomla! Apprentice
Joomla! Apprentice

Joined: Wed Jul 29, 2009 11:50 am
Posts: 10
merc911 wrote:
OK of the 4 solutions that ive seen posted the best/easiest is this:

Go to : Extensions->Language Manager , then click on the Overrides tab, then select a language on the right e.g. ” English (UK) site ” and click on new and set the “Language Constant” to “JGLOBAL_ARTICLES” and leave the “text” field empty, and save&close. Do this for the remaining languages(if there are any) problem solved.


None of the suggestions worked. Thanks merc911 I just saw your suggestion and I was about to quote the same. I found the same solution at http://askjoomla.com/3240/looking-to-re ... -h1-header

Cheers..


Top
 Profile  
 
PostPosted: Fri Jun 07, 2013 4:01 am 
Joomla! Apprentice
Joomla! Apprentice

Joined: Tue Feb 03, 2009 12:04 am
Posts: 17
Location: Sydney, Australia
dannycool wrote:
Sarah is correct about changing it from the backend. She said

Go to Menus > Menu Manager > Options button (top right) > Page Display Options and set set to No.

I had the same prob. Even though the Page Display Option was already yet to NO, you must still click on SAVE which triggers the option so that the ARTICLES title disappears.. So dont be fooled by the fact that Page Display Option was already yet to NO. Still click on save. And the ARTICLE title will disappear form the page in question. No need to hack joomla.


Yep...I can confirm this also worked for me when I had the original problem in this thread, that is, linking to a page from a module.

Bizarre...!


Top
 Profile  
 
PostPosted: Thu Dec 19, 2013 9:01 pm 
Joomla! Fledgling
Joomla! Fledgling

Joined: Wed Sep 26, 2012 6:22 am
Posts: 1
A strange thing worked for me in Joomla 3.2.1. In Menu Manger option, " Show Page Heading" was set to "No" by default and page title was still showing. I set it to 'Yes', saved it once and then set to to 'No' back again and saved for the 2nd time. Walla! the page heading is gone.


Top
 Profile  
 
PostPosted: Tue Jan 28, 2014 7:29 pm 
Joomla! Fledgling
Joomla! Fledgling

Joined: Tue Jan 28, 2014 7:25 pm
Posts: 1
PLEASE HEEEEEEEEEEEEEEEELP! i was trying to hide the title of articles in the way you wrote..i coundn't find the exact words "Heading, 0 " (something like that) so i wrote my my self "0" i put a zero.... and now my page isn't working i can't see it helppppppppppp :( deleted the zero and nothing...... :'(


Top
 Profile  
 
PostPosted: Tue Feb 04, 2014 10:14 am 
Joomla! Apprentice
Joomla! Apprentice

Joined: Sat Jun 08, 2013 8:25 am
Posts: 47
Go to Menu > Menu Manager
Select Options.
Make sure Show Page Heading is set to No.
For Page Heading enter 1 space.
Save.

_________________
Toutes les informations sur le rachat de crédit, RachatCrédit.info : www.RachatCrédit.info, ou RachatCrédit.org : www.RachatCrédit.org


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 30 posts ] 



Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Jump to:  
Powered by phpBB® Forum Software © phpBB Group